Build with OpenSSL 1.1.x. While here, wrap long line in MESSAGE.
This commit is contained in:
parent
fcebffdaaa
commit
65fd92e30d
5 changed files with 537 additions and 11 deletions
|
@ -1,9 +1,10 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1 2008/08/15 16:51:59 schmonz Exp $
|
||||
$NetBSD: MESSAGE,v 1.2 2020/07/02 08:50:09 schmonz Exp $
|
||||
|
||||
To enable spamdyke, set:
|
||||
|
||||
qmailsmtpd_presmtpd="${PREFIX}/bin/spamdyke --config-file ${PKG_SYSCONFDIR}/spamdyke.conf"
|
||||
qmailsmtpd_presmtpd=\
|
||||
"${PREFIX}/bin/spamdyke --config-file ${PKG_SYSCONFDIR}/spamdyke.conf"
|
||||
|
||||
in /etc/rc.conf, then restart qmail-smtpd.
|
||||
|
||||
|
|
|
@ -1,11 +1,12 @@
|
|||
$NetBSD: distinfo,v 1.34 2018/12/25 16:24:26 schmonz Exp $
|
||||
$NetBSD: distinfo,v 1.35 2020/07/02 08:50:09 schmonz Exp $
|
||||
|
||||
SHA1 (spamdyke-5.0.1.tgz) = 4de76158a98b3ee33e7002160446ae36de7c96d2
|
||||
RMD160 (spamdyke-5.0.1.tgz) = 7237108ebf0ff2a5c02b7e305985a11e93720f8d
|
||||
SHA512 (spamdyke-5.0.1.tgz) = a022c8a8d4a8d74f5249f8e2d901d3de423ee853bbaffaf7e86cece1d19880d9039135892ef6ccb8a2a0fb11532c487402dc97a8dd6d89c9de431752c55f6eb9
|
||||
Size (spamdyke-5.0.1.tgz) = 383720 bytes
|
||||
SHA1 (patch-configuration.c) = 81548b8a7cc557446d3ecfca3546a129b04a2173
|
||||
SHA1 (patch-configure) = 0ff7ecd6b73445664243918001368a73186159b3
|
||||
SHA1 (patch-configure.ac) = 5b932db1992c268e80fced15d032d369d1dc40ce
|
||||
SHA1 (patch-configure) = 308cde4c9f54c30ce11c7d7c415ebe7caf51732e
|
||||
SHA1 (patch-configure.ac) = 23ed678900fbb9b9d1a2613e9267607ac59eb5b8
|
||||
SHA1 (patch-md5.c) = d30f421e28fbc6b87c4dc78f4a2e7f5048c61a45
|
||||
SHA1 (patch-spamdyke.h) = 689d4774d78b60a4dd2fbb62a99b218aca9b500b
|
||||
SHA1 (patch-tls.c) = 1cc05d30dfd3736727c6203a81ebb24c44cd2c1f
|
||||
|
|
|
@ -1,14 +1,408 @@
|
|||
$NetBSD: patch-configure,v 1.1 2018/07/29 08:41:18 schmonz Exp $
|
||||
$NetBSD: patch-configure,v 1.2 2020/07/02 08:50:09 schmonz Exp $
|
||||
|
||||
Remove anonymous inner functions to build with clang.
|
||||
Remove outdated OpenSSL check to build with 1.1.x.
|
||||
|
||||
--- configure.orig 2018-07-08 21:13:24.635573514 +0000
|
||||
--- configure.orig 2015-04-30 00:53:36.000000000 +0000
|
||||
+++ configure
|
||||
@@ -4389,105 +4389,6 @@ fi
|
||||
@@ -1,13 +1,11 @@
|
||||
#! /bin/sh
|
||||
# Guess values for system-dependent variables and create Makefiles.
|
||||
-# Generated by GNU Autoconf 2.68 for spamdyke 5.0.1.
|
||||
+# Generated by GNU Autoconf 2.69 for spamdyke 5.0.1.
|
||||
#
|
||||
# Report bugs to <samc (at) silence (dot) org>.
|
||||
#
|
||||
#
|
||||
-# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1998, 1999, 2000, 2001,
|
||||
-# 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010 Free Software
|
||||
-# Foundation, Inc.
|
||||
+# Copyright (C) 1992-1996, 1998-2012 Free Software Foundation, Inc.
|
||||
#
|
||||
#
|
||||
# This configure script is free software; the Free Software Foundation
|
||||
@@ -136,6 +134,31 @@ export LANGUAGE
|
||||
# CDPATH.
|
||||
(unset CDPATH) >/dev/null 2>&1 && unset CDPATH
|
||||
|
||||
+# Use a proper internal environment variable to ensure we don't fall
|
||||
+ # into an infinite loop, continuously re-executing ourselves.
|
||||
+ if test x"${_as_can_reexec}" != xno && test "x$CONFIG_SHELL" != x; then
|
||||
+ _as_can_reexec=no; export _as_can_reexec;
|
||||
+ # We cannot yet assume a decent shell, so we have to provide a
|
||||
+# neutralization value for shells without unset; and this also
|
||||
+# works around shells that cannot unset nonexistent variables.
|
||||
+# Preserve -v and -x to the replacement shell.
|
||||
+BASH_ENV=/dev/null
|
||||
+ENV=/dev/null
|
||||
+(unset BASH_ENV) >/dev/null 2>&1 && unset BASH_ENV ENV
|
||||
+case $- in # ((((
|
||||
+ *v*x* | *x*v* ) as_opts=-vx ;;
|
||||
+ *v* ) as_opts=-v ;;
|
||||
+ *x* ) as_opts=-x ;;
|
||||
+ * ) as_opts= ;;
|
||||
+esac
|
||||
+exec $CONFIG_SHELL $as_opts "$as_myself" ${1+"$@"}
|
||||
+# Admittedly, this is quite paranoid, since all the known shells bail
|
||||
+# out after a failed `exec'.
|
||||
+$as_echo "$0: could not re-execute with $CONFIG_SHELL" >&2
|
||||
+as_fn_exit 255
|
||||
+ fi
|
||||
+ # We don't want this to propagate to other subprocesses.
|
||||
+ { _as_can_reexec=; unset _as_can_reexec;}
|
||||
if test "x$CONFIG_SHELL" = x; then
|
||||
as_bourne_compatible="if test -n \"\${ZSH_VERSION+set}\" && (emulate sh) >/dev/null 2>&1; then :
|
||||
emulate sh
|
||||
@@ -169,7 +192,8 @@ if ( set x; as_fn_ret_success y && test
|
||||
else
|
||||
exitcode=1; echo positional parameters were not saved.
|
||||
fi
|
||||
-test x\$exitcode = x0 || exit 1"
|
||||
+test x\$exitcode = x0 || exit 1
|
||||
+test -x / || exit 1"
|
||||
as_suggested=" as_lineno_1=";as_suggested=$as_suggested$LINENO;as_suggested=$as_suggested" as_lineno_1a=\$LINENO
|
||||
as_lineno_2=";as_suggested=$as_suggested$LINENO;as_suggested=$as_suggested" as_lineno_2a=\$LINENO
|
||||
eval 'test \"x\$as_lineno_1'\$as_run'\" != \"x\$as_lineno_2'\$as_run'\" &&
|
||||
@@ -214,21 +238,25 @@ IFS=$as_save_IFS
|
||||
|
||||
|
||||
if test "x$CONFIG_SHELL" != x; then :
|
||||
- # We cannot yet assume a decent shell, so we have to provide a
|
||||
- # neutralization value for shells without unset; and this also
|
||||
- # works around shells that cannot unset nonexistent variables.
|
||||
- # Preserve -v and -x to the replacement shell.
|
||||
- BASH_ENV=/dev/null
|
||||
- ENV=/dev/null
|
||||
- (unset BASH_ENV) >/dev/null 2>&1 && unset BASH_ENV ENV
|
||||
- export CONFIG_SHELL
|
||||
- case $- in # ((((
|
||||
- *v*x* | *x*v* ) as_opts=-vx ;;
|
||||
- *v* ) as_opts=-v ;;
|
||||
- *x* ) as_opts=-x ;;
|
||||
- * ) as_opts= ;;
|
||||
- esac
|
||||
- exec "$CONFIG_SHELL" $as_opts "$as_myself" ${1+"$@"}
|
||||
+ export CONFIG_SHELL
|
||||
+ # We cannot yet assume a decent shell, so we have to provide a
|
||||
+# neutralization value for shells without unset; and this also
|
||||
+# works around shells that cannot unset nonexistent variables.
|
||||
+# Preserve -v and -x to the replacement shell.
|
||||
+BASH_ENV=/dev/null
|
||||
+ENV=/dev/null
|
||||
+(unset BASH_ENV) >/dev/null 2>&1 && unset BASH_ENV ENV
|
||||
+case $- in # ((((
|
||||
+ *v*x* | *x*v* ) as_opts=-vx ;;
|
||||
+ *v* ) as_opts=-v ;;
|
||||
+ *x* ) as_opts=-x ;;
|
||||
+ * ) as_opts= ;;
|
||||
+esac
|
||||
+exec $CONFIG_SHELL $as_opts "$as_myself" ${1+"$@"}
|
||||
+# Admittedly, this is quite paranoid, since all the known shells bail
|
||||
+# out after a failed `exec'.
|
||||
+$as_echo "$0: could not re-execute with $CONFIG_SHELL" >&2
|
||||
+exit 255
|
||||
fi
|
||||
|
||||
if test x$as_have_required = xno; then :
|
||||
@@ -331,6 +359,14 @@ $as_echo X"$as_dir" |
|
||||
|
||||
|
||||
} # as_fn_mkdir_p
|
||||
+
|
||||
+# as_fn_executable_p FILE
|
||||
+# -----------------------
|
||||
+# Test if FILE is an executable regular file.
|
||||
+as_fn_executable_p ()
|
||||
+{
|
||||
+ test -f "$1" && test -x "$1"
|
||||
+} # as_fn_executable_p
|
||||
# as_fn_append VAR VALUE
|
||||
# ----------------------
|
||||
# Append the text in VALUE to the end of the definition contained in VAR. Take
|
||||
@@ -452,6 +488,10 @@ as_cr_alnum=$as_cr_Letters$as_cr_digits
|
||||
chmod +x "$as_me.lineno" ||
|
||||
{ $as_echo "$as_me: error: cannot create $as_me.lineno; rerun with a POSIX shell" >&2; as_fn_exit 1; }
|
||||
|
||||
+ # If we had to re-execute with $CONFIG_SHELL, we're ensured to have
|
||||
+ # already done that, so ensure we don't try to do so again and fall
|
||||
+ # in an infinite loop. This has already happened in practice.
|
||||
+ _as_can_reexec=no; export _as_can_reexec
|
||||
# Don't try to exec as it changes $[0], causing all sort of problems
|
||||
# (the dirname of $[0] is not the place where we might find the
|
||||
# original and so on. Autoconf is especially sensitive to this).
|
||||
@@ -486,16 +526,16 @@ if (echo >conf$$.file) 2>/dev/null; then
|
||||
# ... but there are two gotchas:
|
||||
# 1) On MSYS, both `ln -s file dir' and `ln file dir' fail.
|
||||
# 2) DJGPP < 2.04 has no symlinks; `ln -s' creates a wrapper executable.
|
||||
- # In both cases, we have to default to `cp -p'.
|
||||
+ # In both cases, we have to default to `cp -pR'.
|
||||
ln -s conf$$.file conf$$.dir 2>/dev/null && test ! -f conf$$.exe ||
|
||||
- as_ln_s='cp -p'
|
||||
+ as_ln_s='cp -pR'
|
||||
elif ln conf$$.file conf$$ 2>/dev/null; then
|
||||
as_ln_s=ln
|
||||
else
|
||||
- as_ln_s='cp -p'
|
||||
+ as_ln_s='cp -pR'
|
||||
fi
|
||||
else
|
||||
- as_ln_s='cp -p'
|
||||
+ as_ln_s='cp -pR'
|
||||
fi
|
||||
rm -f conf$$ conf$$.exe conf$$.dir/conf$$.file conf$$.file
|
||||
rmdir conf$$.dir 2>/dev/null
|
||||
@@ -507,28 +547,8 @@ else
|
||||
as_mkdir_p=false
|
||||
fi
|
||||
|
||||
-if test -x / >/dev/null 2>&1; then
|
||||
- as_test_x='test -x'
|
||||
-else
|
||||
- if ls -dL / >/dev/null 2>&1; then
|
||||
- as_ls_L_option=L
|
||||
- else
|
||||
- as_ls_L_option=
|
||||
- fi
|
||||
- as_test_x='
|
||||
- eval sh -c '\''
|
||||
- if test -d "$1"; then
|
||||
- test -d "$1/.";
|
||||
- else
|
||||
- case $1 in #(
|
||||
- -*)set "./$1";;
|
||||
- esac;
|
||||
- case `ls -ld'$as_ls_L_option' "$1" 2>/dev/null` in #((
|
||||
- ???[sx]*):;;*)false;;esac;fi
|
||||
- '\'' sh
|
||||
- '
|
||||
-fi
|
||||
-as_executable_p=$as_test_x
|
||||
+as_test_x='test -x'
|
||||
+as_executable_p=as_fn_executable_p
|
||||
|
||||
# Sed expression to map a string onto a valid CPP name.
|
||||
as_tr_cpp="eval sed 'y%*$as_cr_letters%P$as_cr_LETTERS%;s%[^_$as_cr_alnum]%_%g'"
|
||||
@@ -1128,8 +1148,6 @@ target=$target_alias
|
||||
if test "x$host_alias" != x; then
|
||||
if test "x$build_alias" = x; then
|
||||
cross_compiling=maybe
|
||||
- $as_echo "$as_me: WARNING: if you wanted to set the --build type, don't use --host.
|
||||
- If a cross compiler is detected then cross compile mode will be used" >&2
|
||||
elif test "x$build_alias" != "x$host_alias"; then
|
||||
cross_compiling=yes
|
||||
fi
|
||||
@@ -1377,9 +1395,9 @@ test -n "$ac_init_help" && exit $ac_stat
|
||||
if $ac_init_version; then
|
||||
cat <<\_ACEOF
|
||||
spamdyke configure 5.0.1
|
||||
-generated by GNU Autoconf 2.68
|
||||
+generated by GNU Autoconf 2.69
|
||||
|
||||
-Copyright (C) 2010 Free Software Foundation, Inc.
|
||||
+Copyright (C) 2012 Free Software Foundation, Inc.
|
||||
This configure script is free software; the Free Software Foundation
|
||||
gives unlimited permission to copy, distribute and modify it.
|
||||
_ACEOF
|
||||
@@ -1654,7 +1672,8 @@ int
|
||||
main ()
|
||||
{
|
||||
static int test_array [1 - 2 * !(0 < ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1))];
|
||||
-test_array [0] = 0
|
||||
+test_array [0] = 0;
|
||||
+return test_array [0];
|
||||
|
||||
;
|
||||
return 0;
|
||||
@@ -1670,7 +1689,8 @@ main ()
|
||||
{
|
||||
static int test_array [1 - 2 * !(($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 1)
|
||||
< ($ac_type) ((((($ac_type) 1 << N) << N) - 1) * 2 + 2))];
|
||||
-test_array [0] = 0
|
||||
+test_array [0] = 0;
|
||||
+return test_array [0];
|
||||
|
||||
;
|
||||
return 0;
|
||||
@@ -1727,7 +1747,8 @@ int
|
||||
main ()
|
||||
{
|
||||
static int test_array [1 - 2 * !((($ac_type) -1 >> ($2 / 2 - 1)) >> ($2 / 2 - 1) == 3)];
|
||||
-test_array [0] = 0
|
||||
+test_array [0] = 0;
|
||||
+return test_array [0];
|
||||
|
||||
;
|
||||
return 0;
|
||||
@@ -1783,7 +1804,7 @@ $as_echo "$ac_try_echo"; } >&5
|
||||
test ! -s conftest.err
|
||||
} && test -s conftest$ac_exeext && {
|
||||
test "$cross_compiling" = yes ||
|
||||
- $as_test_x conftest$ac_exeext
|
||||
+ test -x conftest$ac_exeext
|
||||
}; then :
|
||||
ac_retval=0
|
||||
else
|
||||
@@ -1909,7 +1930,7 @@ This file contains any messages produced
|
||||
running configure, to aid debugging if configure makes a mistake.
|
||||
|
||||
It was created by spamdyke $as_me 5.0.1, which was
|
||||
-generated by GNU Autoconf 2.68. Invocation command line was
|
||||
+generated by GNU Autoconf 2.69. Invocation command line was
|
||||
|
||||
$ $0 $@
|
||||
|
||||
@@ -2289,7 +2310,7 @@ do
|
||||
IFS=$as_save_IFS
|
||||
test -z "$as_dir" && as_dir=.
|
||||
for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
|
||||
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||
ac_cv_prog_CC="$ac_tool_prefix$ac_prog"
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
break 2
|
||||
@@ -2333,7 +2354,7 @@ do
|
||||
IFS=$as_save_IFS
|
||||
test -z "$as_dir" && as_dir=.
|
||||
for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
|
||||
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||
ac_cv_prog_ac_ct_CC="$ac_prog"
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
break 2
|
||||
@@ -2777,8 +2798,7 @@ cat confdefs.h - <<_ACEOF >conftest.$ac_
|
||||
/* end confdefs.h. */
|
||||
#include <stdarg.h>
|
||||
#include <stdio.h>
|
||||
-#include <sys/types.h>
|
||||
-#include <sys/stat.h>
|
||||
+struct stat;
|
||||
/* Most of the following tests are stolen from RCS 5.7's src/conf.sh. */
|
||||
struct buf { int x; };
|
||||
FILE * (*rcsopen) (struct buf *, struct stat *, int);
|
||||
@@ -3019,7 +3039,7 @@ do
|
||||
for ac_prog in grep ggrep; do
|
||||
for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
ac_path_GREP="$as_dir/$ac_prog$ac_exec_ext"
|
||||
- { test -f "$ac_path_GREP" && $as_test_x "$ac_path_GREP"; } || continue
|
||||
+ as_fn_executable_p "$ac_path_GREP" || continue
|
||||
# Check for GNU ac_path_GREP and select it if it is found.
|
||||
# Check for GNU $ac_path_GREP
|
||||
case `"$ac_path_GREP" --version 2>&1` in
|
||||
@@ -3085,7 +3105,7 @@ do
|
||||
for ac_prog in egrep; do
|
||||
for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
ac_path_EGREP="$as_dir/$ac_prog$ac_exec_ext"
|
||||
- { test -f "$ac_path_EGREP" && $as_test_x "$ac_path_EGREP"; } || continue
|
||||
+ as_fn_executable_p "$ac_path_EGREP" || continue
|
||||
# Check for GNU ac_path_EGREP and select it if it is found.
|
||||
# Check for GNU $ac_path_EGREP
|
||||
case `"$ac_path_EGREP" --version 2>&1` in
|
||||
@@ -3699,7 +3719,7 @@ do
|
||||
IFS=$as_save_IFS
|
||||
test -z "$as_dir" && as_dir=.
|
||||
for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
|
||||
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||
ac_cv_prog_STRIP_CMD="strip spamdyke"
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
break 2
|
||||
@@ -3743,7 +3763,7 @@ do
|
||||
IFS=$as_save_IFS
|
||||
test -z "$as_dir" && as_dir=.
|
||||
for ac_exec_ext in '' $ac_executable_extensions; do
|
||||
- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
|
||||
+ if as_fn_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
|
||||
ac_cv_prog_STRIP_CMD="strip spamdyke"
|
||||
$as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
|
||||
break 2
|
||||
@@ -3988,83 +4008,6 @@ as_fn_error $? "--enable-tls was given b
|
||||
See \`config.log' for more details" "$LINENO" 5; }
|
||||
fi
|
||||
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing SSL_library_init" >&5
|
||||
-$as_echo_n "checking for library containing SSL_library_init... " >&6; }
|
||||
-if ${ac_cv_search_SSL_library_init+:} false; then :
|
||||
- $as_echo_n "(cached) " >&6
|
||||
-else
|
||||
- ac_func_search_save_LIBS=$LIBS
|
||||
-cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
-/* end confdefs.h. */
|
||||
-
|
||||
-/* Override any GCC internal prototype to avoid an error.
|
||||
- Use char because int might match the return type of a GCC
|
||||
- builtin and then its argument prototype would still apply. */
|
||||
-#ifdef __cplusplus
|
||||
-extern "C"
|
||||
-#endif
|
||||
-char SSL_library_init ();
|
||||
-int
|
||||
-main ()
|
||||
-{
|
||||
-return SSL_library_init ();
|
||||
- ;
|
||||
- return 0;
|
||||
-}
|
||||
-_ACEOF
|
||||
-for ac_lib in '' ssl crypto; do
|
||||
- if test -z "$ac_lib"; then
|
||||
- ac_res="none required"
|
||||
- else
|
||||
- ac_res=-l$ac_lib
|
||||
- LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
||||
- fi
|
||||
- if ac_fn_c_try_link "$LINENO"; then :
|
||||
- ac_cv_search_SSL_library_init=$ac_res
|
||||
-fi
|
||||
-rm -f core conftest.err conftest.$ac_objext \
|
||||
- conftest$ac_exeext
|
||||
- if ${ac_cv_search_SSL_library_init+:} false; then :
|
||||
- break
|
||||
-fi
|
||||
-done
|
||||
-if ${ac_cv_search_SSL_library_init+:} false; then :
|
||||
-
|
||||
-else
|
||||
- ac_cv_search_SSL_library_init=no
|
||||
-fi
|
||||
-rm conftest.$ac_ext
|
||||
-LIBS=$ac_func_search_save_LIBS
|
||||
-fi
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_SSL_library_init" >&5
|
||||
-$as_echo "$ac_cv_search_SSL_library_init" >&6; }
|
||||
-ac_res=$ac_cv_search_SSL_library_init
|
||||
-if test "$ac_res" != no; then :
|
||||
- test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
|
||||
- LIBS="$LIBS -lssl"
|
||||
- $as_echo "#define HAVE_LIBSSL 1" >>confdefs.h
|
||||
-
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for OpenSSL libraries (for TLS support)" >&5
|
||||
-$as_echo_n "checking for OpenSSL libraries (for TLS support)... " >&6; }
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
|
||||
-$as_echo "yes" >&6; }
|
||||
-
|
||||
-else
|
||||
- if test "x$enable_tls" = "xcheck" ; then :
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for OpenSSL libraries (for TLS support)" >&5
|
||||
-$as_echo_n "checking for OpenSSL libraries (for TLS support)... " >&6; }
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no, TLS disabled" >&5
|
||||
-$as_echo "no, TLS disabled" >&6; }
|
||||
-else
|
||||
- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
|
||||
-$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
|
||||
-as_fn_error $? "--enable-tls was given but OpenSSL was not found
|
||||
-See \`config.log' for more details" "$LINENO" 5; }
|
||||
-
|
||||
-fi
|
||||
-
|
||||
-fi
|
||||
-
|
||||
|
||||
else
|
||||
|
||||
@@ -4390,104 +4333,6 @@ fi
|
||||
fi
|
||||
|
||||
|
||||
-# Checks for the flag to compile anonymous inner functions.
|
||||
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether anonymous inner functions are supported by default" >&5
|
||||
-$as_echo_n "checking whether anonymous inner functions are supported by default... " >&6; }
|
||||
|
@ -110,3 +504,94 @@ Remove anonymous inner functions to build with clang.
|
|||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether struct option is defined in getopt.h" >&5
|
||||
$as_echo_n "checking whether struct option is defined in getopt.h... " >&6; }
|
||||
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
@@ -5407,16 +5252,16 @@ if (echo >conf$$.file) 2>/dev/null; then
|
||||
# ... but there are two gotchas:
|
||||
# 1) On MSYS, both `ln -s file dir' and `ln file dir' fail.
|
||||
# 2) DJGPP < 2.04 has no symlinks; `ln -s' creates a wrapper executable.
|
||||
- # In both cases, we have to default to `cp -p'.
|
||||
+ # In both cases, we have to default to `cp -pR'.
|
||||
ln -s conf$$.file conf$$.dir 2>/dev/null && test ! -f conf$$.exe ||
|
||||
- as_ln_s='cp -p'
|
||||
+ as_ln_s='cp -pR'
|
||||
elif ln conf$$.file conf$$ 2>/dev/null; then
|
||||
as_ln_s=ln
|
||||
else
|
||||
- as_ln_s='cp -p'
|
||||
+ as_ln_s='cp -pR'
|
||||
fi
|
||||
else
|
||||
- as_ln_s='cp -p'
|
||||
+ as_ln_s='cp -pR'
|
||||
fi
|
||||
rm -f conf$$ conf$$.exe conf$$.dir/conf$$.file conf$$.file
|
||||
rmdir conf$$.dir 2>/dev/null
|
||||
@@ -5476,28 +5321,16 @@ else
|
||||
as_mkdir_p=false
|
||||
fi
|
||||
|
||||
-if test -x / >/dev/null 2>&1; then
|
||||
- as_test_x='test -x'
|
||||
-else
|
||||
- if ls -dL / >/dev/null 2>&1; then
|
||||
- as_ls_L_option=L
|
||||
- else
|
||||
- as_ls_L_option=
|
||||
- fi
|
||||
- as_test_x='
|
||||
- eval sh -c '\''
|
||||
- if test -d "$1"; then
|
||||
- test -d "$1/.";
|
||||
- else
|
||||
- case $1 in #(
|
||||
- -*)set "./$1";;
|
||||
- esac;
|
||||
- case `ls -ld'$as_ls_L_option' "$1" 2>/dev/null` in #((
|
||||
- ???[sx]*):;;*)false;;esac;fi
|
||||
- '\'' sh
|
||||
- '
|
||||
-fi
|
||||
-as_executable_p=$as_test_x
|
||||
+
|
||||
+# as_fn_executable_p FILE
|
||||
+# -----------------------
|
||||
+# Test if FILE is an executable regular file.
|
||||
+as_fn_executable_p ()
|
||||
+{
|
||||
+ test -f "$1" && test -x "$1"
|
||||
+} # as_fn_executable_p
|
||||
+as_test_x='test -x'
|
||||
+as_executable_p=as_fn_executable_p
|
||||
|
||||
# Sed expression to map a string onto a valid CPP name.
|
||||
as_tr_cpp="eval sed 'y%*$as_cr_letters%P$as_cr_LETTERS%;s%[^_$as_cr_alnum]%_%g'"
|
||||
@@ -5519,7 +5352,7 @@ cat >>$CONFIG_STATUS <<\_ACEOF || ac_wri
|
||||
# values after options handling.
|
||||
ac_log="
|
||||
This file was extended by spamdyke $as_me 5.0.1, which was
|
||||
-generated by GNU Autoconf 2.68. Invocation command line was
|
||||
+generated by GNU Autoconf 2.69. Invocation command line was
|
||||
|
||||
CONFIG_FILES = $CONFIG_FILES
|
||||
CONFIG_HEADERS = $CONFIG_HEADERS
|
||||
@@ -5581,10 +5414,10 @@ cat >>$CONFIG_STATUS <<_ACEOF || ac_writ
|
||||
ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
|
||||
ac_cs_version="\\
|
||||
spamdyke config.status 5.0.1
|
||||
-configured by $0, generated by GNU Autoconf 2.68,
|
||||
+configured by $0, generated by GNU Autoconf 2.69,
|
||||
with options \\"\$ac_cs_config\\"
|
||||
|
||||
-Copyright (C) 2010 Free Software Foundation, Inc.
|
||||
+Copyright (C) 2012 Free Software Foundation, Inc.
|
||||
This config.status script is free software; the Free Software Foundation
|
||||
gives unlimited permission to copy, distribute and modify it."
|
||||
|
||||
@@ -5672,7 +5505,7 @@ fi
|
||||
_ACEOF
|
||||
cat >>$CONFIG_STATUS <<_ACEOF || ac_write_fail=1
|
||||
if \$ac_cs_recheck; then
|
||||
- set X '$SHELL' '$0' $ac_configure_args \$ac_configure_extra_args --no-create --no-recursion
|
||||
+ set X $SHELL '$0' $ac_configure_args \$ac_configure_extra_args --no-create --no-recursion
|
||||
shift
|
||||
\$as_echo "running CONFIG_SHELL=$SHELL \$*" >&6
|
||||
CONFIG_SHELL='$SHELL'
|
||||
|
|
|
@ -1,10 +1,31 @@
|
|||
$NetBSD: patch-configure.ac,v 1.1 2018/07/29 08:41:18 schmonz Exp $
|
||||
$NetBSD: patch-configure.ac,v 1.2 2020/07/02 08:50:09 schmonz Exp $
|
||||
|
||||
Remove anonymous inner functions to build with clang.
|
||||
Remove outdated OpenSSL check to build with 1.1.x.
|
||||
|
||||
--- configure.ac.orig 2018-07-08 21:13:05.924307278 +0000
|
||||
--- configure.ac.orig 2015-04-30 00:53:36.000000000 +0000
|
||||
+++ configure.ac
|
||||
@@ -188,37 +188,6 @@ AC_SEARCH_LIBS([getopt_long],
|
||||
@@ -149,19 +149,6 @@ AS_IF([ test "x$enable_tls" != "xno" ],
|
||||
[
|
||||
AC_MSG_RESULT([yes])
|
||||
AC_SEARCH_LIBS([RSA_sign], [ssl crypto], [], [ AC_MSG_FAILURE([--enable-tls was given but OpenSSL was not found]) ])
|
||||
- AC_SEARCH_LIBS([SSL_library_init],
|
||||
- [ssl crypto],
|
||||
- [ LIBS="$LIBS -lssl"
|
||||
- AC_DEFINE([HAVE_LIBSSL], [1])
|
||||
- AC_MSG_CHECKING([for OpenSSL libraries (for TLS support)])
|
||||
- AC_MSG_RESULT([yes])
|
||||
- ],
|
||||
- [ AS_IF([ test "x$enable_tls" = "xcheck" ],
|
||||
- [ AC_MSG_CHECKING([for OpenSSL libraries (for TLS support)])
|
||||
- AC_MSG_RESULT([no, TLS disabled]) ],
|
||||
- [ AC_MSG_FAILURE([--enable-tls was given but OpenSSL was not found])
|
||||
- ])
|
||||
- ])
|
||||
],
|
||||
[
|
||||
AC_MSG_RESULT([no])
|
||||
@@ -188,37 +175,6 @@ AC_SEARCH_LIBS([getopt_long],
|
||||
[ AC_MSG_FAILURE([unable to compile without getopt_long(), you may need to install the libgnugetopt package/port]) ])
|
||||
])
|
||||
|
||||
|
|
18
mail/spamdyke/patches/patch-tls.c
Normal file
18
mail/spamdyke/patches/patch-tls.c
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-tls.c,v 1.1 2020/07/02 08:50:09 schmonz Exp $
|
||||
|
||||
Support OpenSSL 1.1.x.
|
||||
|
||||
--- tls.c.orig 2015-04-30 00:53:36.000000000 +0000
|
||||
+++ tls.c
|
||||
@@ -186,7 +186,11 @@ int tls_init_inner(struct filter_setting
|
||||
|
||||
if (!initialized)
|
||||
{
|
||||
+#if OPENSSL_VERSION_NUMBER < 0x10100000L
|
||||
SSL_library_init();
|
||||
+#else
|
||||
+ OPENSSL_init_ssl(0, NULL);
|
||||
+#endif
|
||||
|
||||
if (!RAND_status())
|
||||
{
|
Loading…
Reference in a new issue