Make this build with a post-ISO C compiler. Add DESTDIR support.
Likely still broken on LP64...
This commit is contained in:
parent
92b4b348d2
commit
660e95458e
9 changed files with 255 additions and 22 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.26 2007/01/07 09:14:06 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.27 2009/02/08 00:16:00 joerg Exp $
|
||||
#
|
||||
|
||||
DISTNAME= export.socks.cstc.4.2.2
|
||||
|
@ -14,6 +14,7 @@ COMMENT= Old library, server and client for using proxy firewall software
|
|||
CONFLICTS= socks5-[0-9]* dante*
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
WRKSRC= ${WRKDIR}/socks.cstc.4.2
|
||||
MAKE_ENV+= OPTIMIZE=${CFLAGS:M*:Q}
|
||||
|
@ -21,7 +22,8 @@ MAKE_ENV+= OPTIMIZE=${CFLAGS:M*:Q}
|
|||
EGDIR= ${PREFIX}/share/examples/socks4
|
||||
CONF_FILES= ${EGDIR}/socks.conf ${PKG_SYSCONFDIR}/socks.conf
|
||||
|
||||
INSTALLATION_DIRS= bin lib libexec ${PKGMANDIR}/man1 ${PKGMANDIR}/man5 ${PKGMANDIR}/man8
|
||||
INSTALLATION_DIRS= bin lib libexec ${PKGMANDIR}/man1 \
|
||||
${PKGMANDIR}/man5 ${PKGMANDIR}/man8 ${EGDIR}
|
||||
|
||||
post-patch:
|
||||
@cd ${WRKSRC}; \
|
||||
|
@ -31,7 +33,4 @@ post-patch:
|
|||
${MV} include/socks.h.new include/socks.h
|
||||
@${ECHO} "sockd 0.0.0.0 0.0.0.0" >> ${WRKSRC}/socks.conf
|
||||
|
||||
pre-install:
|
||||
${INSTALL_DATA_DIR} ${EGDIR}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,15 +1,15 @@
|
|||
$NetBSD: distinfo,v 1.7 2005/12/27 13:48:56 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.8 2009/02/08 00:16:00 joerg Exp $
|
||||
|
||||
SHA1 (export.socks.cstc.4.2.2.tar.gz) = 7d8d041c82213f9fd60f64aadf9c1ade418e15db
|
||||
RMD160 (export.socks.cstc.4.2.2.tar.gz) = 03dc72b80f2223c7462ecf168a0fbbf3effd5223
|
||||
Size (export.socks.cstc.4.2.2.tar.gz) = 278805 bytes
|
||||
SHA1 (patch-aa) = 0ec9255cf3e9a04da5cb035f85e3fbd1ac1c5e45
|
||||
SHA1 (patch-aa) = 252ef19fa1c255e4aeaad30162869269716c7e98
|
||||
SHA1 (patch-ab) = fd3f119add1144b24eb2cec578c011bcb397e875
|
||||
SHA1 (patch-ac) = d3988d7ae5103bd7849305bb555d7cf3b1574ddc
|
||||
SHA1 (patch-ad) = 321d88cf5863f8c3f0b5b3623a1af2c4753f5eb3
|
||||
SHA1 (patch-ae) = 6bb9ffb57bb45f3a427059ddeee1f8cfd5489ab4
|
||||
SHA1 (patch-af) = fc08b324b19be9ea35d8f7c0f59073ac6c0349b7
|
||||
SHA1 (patch-ag) = 859f310ba8e699c4ac568d1d672f54261f500557
|
||||
SHA1 (patch-ag) = 805ba908664d23c774acec0bb80c0169e5b2731e
|
||||
SHA1 (patch-ah) = 71af7c7706f60f02b7b2fe936cdb7163b0054220
|
||||
SHA1 (patch-ai) = 31ab5443177a211f34afebb7c110a5c45a307c25
|
||||
SHA1 (patch-aj) = 277772e951c26ad1ff7f767e3a0943b8cad84982
|
||||
|
@ -17,3 +17,8 @@ SHA1 (patch-ak) = a36dea113c30fa951b9eb96e49eb00667a63a868
|
|||
SHA1 (patch-al) = d955ca99b0d73b47281144776c09d4380b5d939e
|
||||
SHA1 (patch-am) = 712ccb9bdc0bebc40e5fa752e6a25944275b33e0
|
||||
SHA1 (patch-an) = 23b930373ecc06711cdcb869e5e4b6c8bdb410b4
|
||||
SHA1 (patch-ao) = 23e9ad01762f280ab169990cba657637ed45a058
|
||||
SHA1 (patch-ap) = f8a20f8301083e4a679766febdfb5c646c4cf8c9
|
||||
SHA1 (patch-aq) = 0359ed3ee095fb2844f998a3c00a61fc1685c8e8
|
||||
SHA1 (patch-ar) = 45d49f6f1be44ce3422e51abe6bfccdb419de6d0
|
||||
SHA1 (patch-as) = 90c12847eabb72273e7ef7172cdc5c4a8c97c43f
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.8 2005/12/27 13:48:56 joerg Exp $
|
||||
$NetBSD: patch-aa,v 1.9 2009/02/08 00:16:00 joerg Exp $
|
||||
|
||||
--- Makefile.orig 1995-09-07 02:24:02.000000000 +0000
|
||||
--- Makefile.orig 1995-09-07 04:24:02.000000000 +0200
|
||||
+++ Makefile
|
||||
@@ -3,9 +3,11 @@
|
||||
|
||||
|
@ -48,15 +48,15 @@ $NetBSD: patch-aa,v 1.8 2005/12/27 13:48:56 joerg Exp $
|
|||
|
||||
# Directory into which to install the man pages
|
||||
-MAN_DEST_DIR = /usr/local/man
|
||||
+MAN_DEST_DIR = ${PREFIX}/man
|
||||
+MAN_DEST_DIR = ${DESTDIR}${PREFIX}/man
|
||||
|
||||
# Directory into which the SOCKS server should be installed
|
||||
-SERVER_BIN_DIR = /usr/etc
|
||||
+SERVER_BIN_DIR = ${PREFIX}/libexec
|
||||
+SERVER_BIN_DIR = ${DESTDIR}${PREFIX}/libexec
|
||||
|
||||
# Directory into the client programs should be installed
|
||||
-CLIENTS_BIN_DIR = /usr/local/bin
|
||||
+CLIENTS_BIN_DIR = ${PREFIX}/bin
|
||||
+CLIENTS_BIN_DIR = ${DESTDIR}${PREFIX}/bin
|
||||
|
||||
# SunOS 4.1.x should use
|
||||
#CC=cc
|
||||
|
@ -131,10 +131,10 @@ $NetBSD: patch-aa,v 1.8 2005/12/27 13:48:56 joerg Exp $
|
|||
|
||||
|
||||
+install.conf:
|
||||
+ ${INSTALL} -m 0644 socks.conf ${PREFIX}/share/examples/socks4
|
||||
+ ${INSTALL} -m 0644 socks.conf ${DESTDIR}${PREFIX}/share/examples/socks4
|
||||
+
|
||||
+install.lib:
|
||||
+ ${INSTALL} -m 0644 lib/libsocks.a ${PREFIX}/lib/libsocks4.a
|
||||
+ ${RANLIB} ${PREFIX}/lib/libsocks4.a
|
||||
+ ${INSTALL} -m 0644 lib/libsocks.a ${DESTDIR}${PREFIX}/lib/libsocks4.a
|
||||
+ ${RANLIB} ${DESTDIR}${PREFIX}/lib/libsocks4.a
|
||||
+
|
||||
+install: install.server install.clients install.man install.conf install.lib
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ag,v 1.1 2004/09/08 15:03:15 sketch Exp $
|
||||
$NetBSD: patch-ag,v 1.2 2009/02/08 00:16:00 joerg Exp $
|
||||
|
||||
--- rtelnet/telnet/commands.c.orig 1995-02-25 00:36:16.000000000 +0000
|
||||
+++ rtelnet/telnet/commands.c 2004-09-08 15:57:55.000000000 +0100
|
||||
@@ -43,7 +43,7 @@
|
||||
--- rtelnet/telnet/commands.c.orig 1995-02-25 01:36:16.000000000 +0100
|
||||
+++ rtelnet/telnet/commands.c
|
||||
@@ -43,7 +43,7 @@ static char sccsid[] = "@(#)commands.c 5
|
||||
#include <netdb.h>
|
||||
#include <ctype.h>
|
||||
#include <pwd.h>
|
||||
|
@ -11,16 +11,102 @@ $NetBSD: patch-ag,v 1.1 2004/09/08 15:03:15 sketch Exp $
|
|||
#include <errno.h>
|
||||
#if defined(ISC)
|
||||
#include <net/errno.h>
|
||||
@@ -112,7 +112,7 @@
|
||||
@@ -112,7 +112,16 @@ extern int isprefix();
|
||||
extern char **genget();
|
||||
extern int Ambiguous();
|
||||
|
||||
-static call();
|
||||
+static int call(void *, ...);
|
||||
+static int help(int argc, char *argvp[]);
|
||||
+static int send_esc();
|
||||
+
|
||||
+#ifndef SOLARIS
|
||||
+static void send_do();
|
||||
+static void send_dont();
|
||||
+static void send_will();
|
||||
+static void send_wont();
|
||||
+#endif
|
||||
|
||||
typedef struct {
|
||||
char *name; /* command name */
|
||||
@@ -2345,17 +2345,15 @@
|
||||
@@ -265,7 +274,7 @@ struct sendlist {
|
||||
};
|
||||
|
||||
|
||||
-extern int
|
||||
+static int
|
||||
send_esc P((void)),
|
||||
send_help P((void)),
|
||||
send_docmd P((char *)),
|
||||
@@ -406,9 +415,6 @@ send_esc()
|
||||
send_docmd(name)
|
||||
char *name;
|
||||
{
|
||||
-#ifndef SOLARIS
|
||||
- void send_do();
|
||||
-#endif
|
||||
return(send_tncmd(send_do, "do", name));
|
||||
}
|
||||
|
||||
@@ -416,27 +422,18 @@ send_docmd(name)
|
||||
send_dontcmd(name)
|
||||
char *name;
|
||||
{
|
||||
-#ifndef SOLARIS
|
||||
- void send_dont();
|
||||
-#endif
|
||||
return(send_tncmd(send_dont, "dont", name));
|
||||
}
|
||||
static int
|
||||
send_willcmd(name)
|
||||
char *name;
|
||||
{
|
||||
-#ifndef SOLARIS
|
||||
- void send_will();
|
||||
-#endif
|
||||
return(send_tncmd(send_will, "will", name));
|
||||
}
|
||||
static int
|
||||
send_wontcmd(name)
|
||||
char *name;
|
||||
{
|
||||
-#ifndef SOLARIS
|
||||
- void send_wont();
|
||||
-#endif
|
||||
return(send_tncmd(send_wont, "wont", name));
|
||||
}
|
||||
|
||||
@@ -635,9 +632,9 @@ togxbinary(val)
|
||||
}
|
||||
|
||||
|
||||
-extern int togglehelp P((void));
|
||||
+static int togglehelp P((void));
|
||||
#if defined(AUTHENTICATE)
|
||||
-extern int auth_togdebug P((int));
|
||||
+static int auth_togdebug P((int));
|
||||
#endif
|
||||
|
||||
struct togglelist {
|
||||
@@ -1477,7 +1474,7 @@ struct slclist {
|
||||
int arg;
|
||||
};
|
||||
|
||||
-extern void slc_help();
|
||||
+static void slc_help();
|
||||
|
||||
struct slclist SlcList[] = {
|
||||
{ "export", "Use local special character definitions",
|
||||
@@ -1555,7 +1552,7 @@ struct envlist {
|
||||
|
||||
extern struct env_lst *
|
||||
env_define P((unsigned char *, unsigned char *));
|
||||
-extern void
|
||||
+static void
|
||||
env_undefine P((unsigned char *)),
|
||||
env_export P((unsigned char *)),
|
||||
env_unexport P((unsigned char *)),
|
||||
@@ -2345,17 +2342,15 @@ static Command cmdtab2[] = {
|
||||
|
||||
/*VARARGS1*/
|
||||
static
|
||||
|
|
21
net/socks4/patches/patch-ao
Normal file
21
net/socks4/patches/patch-ao
Normal file
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-ao,v 1.1 2009/02/08 00:16:00 joerg Exp $
|
||||
|
||||
--- lib/check_cconf.c.orig 1995-02-10 21:22:51.000000000 +0100
|
||||
+++ lib/check_cconf.c
|
||||
@@ -29,6 +29,7 @@ extern char *socks_serverlist;
|
||||
static struct config *confPtr, **confNtries = NULL;
|
||||
static int Ntries = 0;
|
||||
static int no_conf = 0;
|
||||
+static int read_cconf(void);
|
||||
|
||||
socks_check_cconf(src, dst)
|
||||
/* Return 0 if sockd should be used,
|
||||
@@ -84,7 +85,7 @@ GotIt:
|
||||
|
||||
}
|
||||
|
||||
-static read_cconf()
|
||||
+static read_cconf(void)
|
||||
{
|
||||
FILE *fd;
|
||||
static char buf[1024];
|
22
net/socks4/patches/patch-ap
Normal file
22
net/socks4/patches/patch-ap
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-ap,v 1.1 2009/02/08 00:16:00 joerg Exp $
|
||||
|
||||
--- lib/check_user.c.orig 2009-02-08 00:44:57.000000000 +0100
|
||||
+++ lib/check_user.c
|
||||
@@ -19,6 +19,7 @@
|
||||
#include "bstring.h"
|
||||
#endif
|
||||
|
||||
+static int check_userfile(char *userfile, char *src_user);
|
||||
|
||||
/*
|
||||
* These functions are used by both Validate (for sockd)
|
||||
@@ -147,8 +148,7 @@ char *userlist, *src_user;
|
||||
#include <string.h>
|
||||
#include <syslog.h>
|
||||
|
||||
-static int check_userfile(userfile, src_user)
|
||||
-char *userfile, *src_user;
|
||||
+static int check_userfile(char *userfile, char *src_user)
|
||||
/* return 1 if match, 0 otherwise */
|
||||
/* return -1 if cannot open file */
|
||||
{
|
20
net/socks4/patches/patch-aq
Normal file
20
net/socks4/patches/patch-aq
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-aq,v 1.1 2009/02/08 00:16:00 joerg Exp $
|
||||
|
||||
--- rftp/ruserpass.c.orig 2009-02-08 01:01:36.000000000 +0100
|
||||
+++ rftp/ruserpass.c
|
||||
@@ -65,6 +65,7 @@ static FILE *cfile;
|
||||
#define MACH 11
|
||||
|
||||
static char tokval[100];
|
||||
+static int token();
|
||||
|
||||
static struct toktab {
|
||||
char *tokstr;
|
||||
@@ -87,7 +88,6 @@ ruserpass(host, aname, apass, aacct)
|
||||
char myname[MAXHOSTNAMELEN], *mydomain;
|
||||
int t, i, c, usedefault = 0;
|
||||
struct stat stb;
|
||||
- static int token();
|
||||
|
||||
hdir = getenv("HOME");
|
||||
if (hdir == NULL)
|
67
net/socks4/patches/patch-ar
Normal file
67
net/socks4/patches/patch-ar
Normal file
|
@ -0,0 +1,67 @@
|
|||
$NetBSD: patch-ar,v 1.1 2009/02/08 00:16:00 joerg Exp $
|
||||
|
||||
--- rtelnet/telnet/sys_bsd.c.orig 1995-02-25 01:16:07.000000000 +0100
|
||||
+++ rtelnet/telnet/sys_bsd.c
|
||||
@@ -66,6 +66,8 @@ static char sccsid[] = "@(#)sys_bsd.c 5.
|
||||
#define SIG_FUNC_RET int
|
||||
#endif
|
||||
|
||||
+extern int termdata;
|
||||
+
|
||||
int
|
||||
tout, /* Output file descriptor */
|
||||
tin, /* Input file descriptor */
|
||||
@@ -121,6 +123,19 @@ struct termio old_tc = { 0 };
|
||||
|
||||
static fd_set ibits, obits, xbits;
|
||||
|
||||
+#if defined(SOLARIS) || defined(_SEQUENT_)
|
||||
+static void xmitAO(), xmitEL(), xmitEC();
|
||||
+#else
|
||||
+static void xmitAO(), xmitEL(), xmitEC(), intp(), sendbrk();
|
||||
+#endif
|
||||
+
|
||||
+#ifdef SIGTSTP
|
||||
+static SIG_FUNC_RET susp();
|
||||
+#endif /* SIGTSTP */
|
||||
+#ifdef SIGINFO
|
||||
+static SIG_FUNC_RET ayt();
|
||||
+static SIG_FUNC_RET ayt_status();
|
||||
+#endif /* SIGINFO */
|
||||
|
||||
void
|
||||
init_sys()
|
||||
@@ -187,11 +202,6 @@ extern int kludgelinemode;
|
||||
TerminalSpecialChars(c)
|
||||
int c;
|
||||
{
|
||||
-#if defined(SOLARIS) || defined(_SEQUENT_)
|
||||
- void xmitAO(), xmitEL(), xmitEC();
|
||||
-#else
|
||||
- void xmitAO(), xmitEL(), xmitEC(), intp(), sendbrk();
|
||||
-#endif
|
||||
|
||||
if (c == termIntChar) {
|
||||
intp();
|
||||
@@ -616,12 +626,6 @@ TerminalNewMode(f)
|
||||
}
|
||||
|
||||
if (f != -1) {
|
||||
-#ifdef SIGTSTP
|
||||
- static SIG_FUNC_RET susp();
|
||||
-#endif /* SIGTSTP */
|
||||
-#ifdef SIGINFO
|
||||
- static SIG_FUNC_RET ayt();
|
||||
-#endif /* SIGINFO */
|
||||
|
||||
#ifdef SIGTSTP
|
||||
(void) signal(SIGTSTP, susp);
|
||||
@@ -669,8 +673,6 @@ TerminalNewMode(f)
|
||||
#endif
|
||||
} else {
|
||||
#ifdef SIGINFO
|
||||
- SIG_FUNC_RET ayt_status();
|
||||
-
|
||||
(void) signal(SIGINFO, ayt_status);
|
||||
#endif /* SIGINFO */
|
||||
|
13
net/socks4/patches/patch-as
Normal file
13
net/socks4/patches/patch-as
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-as,v 1.1 2009/02/08 00:16:00 joerg Exp $
|
||||
|
||||
--- rtelnet/Makefile.orig 2009-02-08 01:06:41.000000000 +0100
|
||||
+++ rtelnet/Makefile
|
||||
@@ -91,7 +91,7 @@ all: echocwd
|
||||
cd telnet; ${MAKE} ${OS} CC="${CC}" OTHER_CFLAGS="$(OTHER_CFLAGS)" SOCKS="${SOCKS}" SOCKS_LIB=${SOCKS_LIB} RESOLV_LIB="${RESOLV_LIB}" OPTIMIZE="${OPTIMIZE}"
|
||||
|
||||
install: echocwd rtelnet
|
||||
- $(INSTALL) -s -o bin -g bin -m 111 rtelnet ${CLIENTS_BIN_DIR}
|
||||
+ ${INSTALL} -m 555 rtelnet ${CLIENTS_BIN_DIR}
|
||||
|
||||
install.man: echocwd
|
||||
$(INSTALL) -m 444 ../doc/socks_clients.1 $(MAN_DEST_DIR)/man1
|
Loading…
Reference in a new issue