Initial import of medusa-0.5.1, a file system indexing engine.

This commit is contained in:
rh 2001-05-14 17:13:21 +00:00
parent cdef2324e9
commit 6630a5a8fb
17 changed files with 339 additions and 0 deletions

24
sysutils/medusa/Makefile Normal file
View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
#
DISTNAME= medusa-0.5.1
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=stable/sources/medusa/} \
http://download.eazel.com/source/
MAINTAINER= rh@netbsd.org
HOMEPAGE= http://www.eazel.com/
COMMENT= file system indexing engine
DEPENDS+= psmisc-*:../../sysutils/psmisc
DEPENDS+= gnome-vfs>=1.0.1:../../sysutils/gnome-vfs
GNU_CONFIGURE= YES
USE_X11BASE= YES
USE_LIBTOOL= YES
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
.include "../../mk/bsd.pkg.mk"

14
sysutils/medusa/distinfo Normal file
View file

@ -0,0 +1,14 @@
$NetBSD: distinfo,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
SHA1 (medusa-0.5.1.tar.gz) = 8e3a1ae286c9502bceda3f3fa5f2b3559440d8d0
Size (medusa-0.5.1.tar.gz) = 384482 bytes
SHA1 (patch-aa) = 76a682d2b7e71488131037fed209a9d2144a97c9
SHA1 (patch-ab) = f19d58f14f957dff3de7de9015910d4933c1b896
SHA1 (patch-ac) = b429ce07a98f3eb48fe5922ab68dc12d4875300e
SHA1 (patch-ad) = 885715122bbe31cb582e4cc75db02296e4282b4f
SHA1 (patch-ae) = 0e93570781b68d42f9ced0b705e447c965fd611c
SHA1 (patch-af) = db1f6edb61cc9afdf0fec9f93d982dfa8214cc15
SHA1 (patch-ag) = 9c4ffb05d2108dbacfbf34704c6a81fc06fc6d37
SHA1 (patch-ah) = aabf5bbb2d0ea1872b76517b94ae65130147ff0c
SHA1 (patch-ai) = 9c63685f52e62cebd027e7dfdbbb6526b0cd7b6b
SHA1 (patch-aj) = 38cd6ebdcddf8fd956f6664df20236ec66797ae4

View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
SHA1 (medusa-0.5.0.tar.gz) = 2f4c93f980431a78ebfdc76bf4f524f9b9eeddb2

View file

@ -0,0 +1,10 @@
$NetBSD: patch-sum,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
SHA1 (patch-aa) = 76a682d2b7e71488131037fed209a9d2144a97c9
SHA1 (patch-ab) = f19d58f14f957dff3de7de9015910d4933c1b896
SHA1 (patch-ac) = b429ce07a98f3eb48fe5922ab68dc12d4875300e
SHA1 (patch-ad) = 68727ea14540c4cab3650546f42c42e4388a4223
SHA1 (patch-ae) = 0e93570781b68d42f9ced0b705e447c965fd611c
SHA1 (patch-af) = db1f6edb61cc9afdf0fec9f93d982dfa8214cc15
SHA1 (patch-ag) = c1f539eabbd1cade231a969652e74cbb5e00bf50
SHA1 (patch-ah) = 9c4ffb05d2108dbacfbf34704c6a81fc06fc6d37

View file

@ -0,0 +1,18 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
--- libmedusa/medusa-index-progress.c.orig Sun Apr 8 08:38:01 2001
+++ libmedusa/medusa-index-progress.c
@@ -54,7 +54,12 @@
#ifdef HAVE_STATVFS
# include <sys/statvfs.h>
#elif HAVE_STATFS
-# include <sys/statfs.h>
+# ifdef HAVE_STATVFS_H
+# include <sys/statfs.h>
+# else
+# include <sys/param.h>
+# include <sys/mount.h>
+# endif
#else
# warning "Medusa will not be able to record your indexing progress because you don't have either statfs or statvfs."
#endif

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ab,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
--- medusa-idled/medusa-idled-client.c.orig Sun Apr 8 08:43:28 2001
+++ medusa-idled/medusa-idled-client.c
@@ -31,9 +31,9 @@
#include <glib.h>
#include <string.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <sys/time.h>
-#include <sys/types.h>
#include <sys/un.h>
#include <unistd.h>
#include <libmedusa/medusa-service-private.h>

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
--- medusa-idled/Makefile.in.orig Sun Apr 8 08:48:34 2001
+++ medusa-idled/Makefile.in
@@ -145,7 +145,7 @@
noinst_HEADERS = x-screensaver-code.h medusa-idled-private.h $(NULL)
-INCLUDES = -I$(top_srcdir) $(X_CFLAGS) $(GLIB_CFLAGS) $(NULL)
+INCLUDES = -I$(top_srcdir) -I${X11BASE}/include $(X_CFLAGS) $(GLIB_CFLAGS) $(NULL)
medusa_idled_LDADD = $(GLIB_LIBS) $(top_builddir)/libmedusa/libmedusa.la $(XML_LIBS) $(VFS_LIBS) $(X_LIBS) $(GTK_LIBS) $(DB_LIB) -lXt $(NULL)

View file

@ -0,0 +1,32 @@
$NetBSD: patch-ad,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
--- indexer/medusa-file-index-daemon.c.orig Fri Apr 27 02:55:43 2001
+++ indexer/medusa-file-index-daemon.c
@@ -33,19 +33,26 @@
#include <libgnomevfs/gnome-vfs-types.h>
#include <libgnomevfs/gnome-vfs-uri.h>
#include <libgnomevfs/gnome-vfs-utils.h>
-#include <popt.h>
+#include <popt-gnome.h>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <sys/resource.h>
#include <sys/time.h>
#include <sys/types.h>
+#ifdef HAVE_SYS_VFS_H
#include <sys/vfs.h>
+#endif
#ifdef HAVE_STATVFS
#include <sys/statvfs.h>
#elif defined(HAVE_STATFS)
+#ifdef HAVE_STATFS_H
#include <sys/statfs.h>
+#else
+#include <sys/param.h>
+#include <sys/mount.h>
+#endif /* HAVE_STATFS_H */
#endif /* HAVE_STATVFS */
#include <time.h>

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ae,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
--- search-service/medusa-file-search-daemon.c.orig Sun Apr 8 08:54:53 2001
+++ search-service/medusa-file-search-daemon.c
@@ -271,7 +271,7 @@
/* Ignore the termination status of child processes explicitly,
so that they don't become zombies (see Stevens, "Advanced Programming
in the Unix Environment", page 280) */
- signal (SIGCLD, SIG_IGN);
+ signal (SIGCHLD, SIG_IGN);
/* Finish setting up all of the socket internals */

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
--- gnome-vfs-module/Makefile.in.orig Tue Mar 13 02:40:38 2001
+++ gnome-vfs-module/Makefile.in
@@ -137,7 +137,7 @@
INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/libmedusa $(GNOME_CFLAGS) $(VFS_CFLAGS) $(NULL)
-libvfs_search_la_LIBADD = -L$(top_builddir)/libmedusa/.libs -lmedusa $(VFS_LIBS) $(GLIB_LIBS) $(NULL)
+libvfs_search_la_LIBADD = -L`cd $(top_builddir)/libmedusa/ ; pwd` -lmedusa $(VFS_LIBS) $(GLIB_LIBS) $(NULL)
libvfs_search_la_LDFLAGS = -export_dynamic -avoid-version

View file

@ -0,0 +1,14 @@
$NetBSD: patch-ag,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
--- libmedusa/medusa-lock-file-paths.h.orig Sun Apr 8 09:19:16 2001
+++ libmedusa/medusa-lock-file-paths.h
@@ -27,7 +27,7 @@
#ifndef MEDUSA_LOCK_FILE_PATHS_H
#define MEDUSA_LOCK_FILE_PATHS_H
-#define MEDUSA_FILE_INDEX_READ_LOCK_FILE "/var/lock/medusa-db-read"
-#define MEDUSA_FILE_INDEX_WRITE_LOCK_FILE "/var/lock/medusa-db-write"
+#define MEDUSA_FILE_INDEX_READ_LOCK_FILE "/var/run/medusa-db-read.lock"
+#define MEDUSA_FILE_INDEX_WRITE_LOCK_FILE "/var/run/medusa-db-write.lock"
#endif /* MEDUSA_LOCK_FILE_PATHS_H */

View file

@ -0,0 +1,10 @@
$NetBSD: patch-ah,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
--- index-configuration/file-index-stoplist.orig Wed May 9 18:06:46 2001
+++ index-configuration/file-index-stoplist
@@ -2,4 +2,5 @@
# Adding directories to this list will prevent the directory and all of its
# contents from being indexed
file:///proc
+file:///kern
file:///dev

View file

@ -0,0 +1,71 @@
$NetBSD: patch-ai,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
--- index-configuration/Makefile.in.orig Fri May 4 08:08:32 2001
+++ index-configuration/Makefile.in
@@ -146,12 +146,12 @@
medusacronconf_DATA = medusa.cron $(NULL)
-medusaidledconfdir = $(sysconfdir)/profile.d
+medusaidledconfdir = $(sysconfdir)/medusa
medusaidledconf_DATA = medusa-idled.sh medusa-idled.csh $(NULL)
-medusainitdir = $(prefix)/tmp
+medusainitdir = $(prefix)/etc/rc.d
medusainit_DATA = medusa-init $(NULL)
@@ -316,10 +316,10 @@
@list='$(file_index_DATA)'; for p in $$list; do \
if test -f $(srcdir)/$$p; then \
echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(file_indexdir)/$$p"; \
- $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(file_indexdir)/$$p; \
+ $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(file_indexdir)/$$p.sample; \
else if test -f $$p; then \
echo " $(INSTALL_DATA) $$p $(DESTDIR)$(file_indexdir)/$$p"; \
- $(INSTALL_DATA) $$p $(DESTDIR)$(file_indexdir)/$$p; \
+ $(INSTALL_DATA) $$p $(DESTDIR)$(file_indexdir)/$$p.sample; \
fi; fi; \
done
@@ -335,10 +335,10 @@
@list='$(medusa_conf_DATA)'; for p in $$list; do \
if test -f $(srcdir)/$$p; then \
echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(medusa_confdir)/$$p"; \
- $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(medusa_confdir)/$$p; \
+ $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(medusa_confdir)/$$p.sample; \
else if test -f $$p; then \
echo " $(INSTALL_DATA) $$p $(DESTDIR)$(medusa_confdir)/$$p"; \
- $(INSTALL_DATA) $$p $(DESTDIR)$(medusa_confdir)/$$p; \
+ $(INSTALL_DATA) $$p $(DESTDIR)$(medusa_confdir)/$$p.sample; \
fi; fi; \
done
@@ -373,10 +373,10 @@
@list='$(medusaidledconf_DATA)'; for p in $$list; do \
if test -f $(srcdir)/$$p; then \
echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(medusaidledconfdir)/$$p"; \
- $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(medusaidledconfdir)/$$p; \
+ ${BSD_INSTALL_SCRIPT} $(srcdir)/$$p $(DESTDIR)$(medusaidledconfdir)/$$p; \
else if test -f $$p; then \
echo " $(INSTALL_DATA) $$p $(DESTDIR)$(medusaidledconfdir)/$$p"; \
- $(INSTALL_DATA) $$p $(DESTDIR)$(medusaidledconfdir)/$$p; \
+ ${BSD_INSTALL_SCRIPT} $$p $(DESTDIR)$(medusaidledconfdir)/$$p; \
fi; fi; \
done
@@ -392,10 +392,10 @@
@list='$(medusainit_DATA)'; for p in $$list; do \
if test -f $(srcdir)/$$p; then \
echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(medusainitdir)/$$p"; \
- $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(medusainitdir)/$$p; \
+ ${BSD_INSTALL_SCRIPT} $(srcdir)/$$p $(DESTDIR)$(medusainitdir)/medusa; \
else if test -f $$p; then \
echo " $(INSTALL_DATA) $$p $(DESTDIR)$(medusainitdir)/$$p"; \
- $(INSTALL_DATA) $$p $(DESTDIR)$(medusainitdir)/$$p; \
+ ${BSD_INSTALL_SCRIPT} $$p $(DESTDIR)$(medusainitdir)/medusa; \
fi; fi; \
done

View file

@ -0,0 +1,10 @@
$NetBSD: patch-aj,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
--- index-configuration/medusa-idled.csh.in.orig Fri Jan 19 00:53:25 2001
+++ index-configuration/medusa-idled.csh.in
@@ -6,4 +6,4 @@
# it's easier just to call the sh version than to figure out what's been
# set and what hasn't.
-/bin/sh /etc/profile.d/medusa-idled.sh
+/bin/sh @prefix@/etc/medusa/medusa-idled.sh

13
sysutils/medusa/pkg/DESCR Normal file
View file

@ -0,0 +1,13 @@
Medusa is software that allows you to quickly search your system for
particular types of files, using an index.
CAVEATS
-------
Medusa is still in its early stages. It is not yet feature complete,
and there are known bugs, some of which can take up lots of
unnecessary resources on your machine.
Please do not use this code on an afs system or over nfs volumes;
the file permissions are not compatible with medusa. Running
medusa on these systems is completely insecure.

View file

@ -0,0 +1,8 @@
$NetBSD: MESSAGE,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
==========================================================================
Medusa has now been installed on your system. To configure this
package, you need to create "medusa.conf", "file-index-stoplist", and
"mount-type-stoplist" files in ${PREFIX}/etc by copying and editing
the corresponding ".sample" files.
==========================================================================

58
sysutils/medusa/pkg/PLIST Normal file
View file

@ -0,0 +1,58 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2001/05/14 17:13:21 rh Exp $
bin/medusa-config
bin/medusa-idled
bin/medusa-indexd
bin/medusa-searchd
bin/msearch
etc/cron.daily/medusa.cron
etc/medusa/file-index-stoplist.sample
etc/medusa/medusa.conf.sample
etc/medusa/mount-type-stoplist.sample
etc/medusa/medusa-idled.csh
etc/medusa/medusa-idled.sh
etc/rc.d/medusa
etc/vfs/modules/search-methods.conf
include/libmedusa/medusa-file-info-utilities.h
include/libmedusa/medusa-idled-client.h
include/libmedusa/medusa-index-progress.h
include/libmedusa/medusa-index-service-private.h
include/libmedusa/medusa-index-service.h
include/libmedusa/medusa-indexed-search.h
include/libmedusa/medusa-lock-file-paths.h
include/libmedusa/medusa-lock.h
include/libmedusa/medusa-log.h
include/libmedusa/medusa-search-service-private.h
include/libmedusa/medusa-search-service.h
include/libmedusa/medusa-service-private.h
include/libmedusa/medusa-stdio-extensions.h
include/libmedusa/medusa-string.h
include/libmedusa/medusa-system-state.h
include/libmedusa/medusa-unindexed-search.h
include/libmedusa/medusa-unsearched-locations.h
include/libmedusa/medusa-utils.h
lib/libmedusa-index.a
lib/libmedusa-index.la
lib/libmedusa-index.so
lib/libmedusa-index.so.0
lib/libmedusa-index.so.0.0
lib/libmedusa.a
lib/libmedusa.la
lib/libmedusa.so
lib/libmedusa.so.0
lib/libmedusa.so.0.0
lib/vfs/modules/libvfs-search.a
lib/vfs/modules/libvfs-search.la
lib/vfs/modules/libvfs-search.so
man/man1/medusa-config.1
man/man1/medusa-idled.1
man/man1/msearch.1
man/man5/medusa-file-index-stoplist.5
man/man5/medusa.conf.5
man/man7/medusa-search-uri.7
man/man8/medusa-searchd.8
sbin/medusa-test-indexing-status
var/medusa/.dummy
@dirrm include/libmedusa
@dirrm var/medusa
@dirrm etc/medusa
@dirrm etc/cron.daily