Updating package for Perl5 module local::lib from CPAN in devel/p5-local-lib

from 1.8.10 to 2.000004.

pkgsrc changes:
- 1st upate done using Packager::Utils
- move homepage to MetaCPAN
- major version update allows follow upstream version scheme
- remove fix for "fixing CPAN.pm" - pretend we're cpanm >:-)

Upstream changes since 1.008010 (is 1.8.10):
2.000004 - 2014-01-03
        - fix errors in PowerShell output when clearing nonexistant variables
        - fix shell test to avoid extremely long lines
        - fix shell test to avoid testing standard Win32 shells on Cygwin
        - improved diagnostics in shell test

2.000003 - 2013-12-30
        - releasing 2.000_002 as stable

2.000_002 - 2013-12-25
        - fix CPAN setup error check in Makefile.PL
        - fix install test warnings
        - fix shell test to skip cmd/powershell startup scripts

2.000_001 - 2013-12-23
        - fix shell output for old bourne shells
        - fix various shell test issues
        - note issues/workarounds when combining with PREFIX/--prefix options

2.000_000 - 2013-12-22
        - significant refactor of internals, adding an object oriented interface
        - add --no-create option to prevent directory creation on activation
        - add support for powershell output
        - add --shelltype option to specify shell instead of auto detecting
        - document recommended use of $SHLVL
        - document limitations regarding File::Spec
        - avoid including empty path segments in output
        - fix output for csh to allow direct use in eval
        - improve taint handling test
        - fix docs for build_environment_vars, install_base_bin_path
        - use Distar instead of Module::Install for packaging

1.008026 - 2013-11-05
        - drop perl prerequisite to 5.6, since everything works there.

1.008025 - 2013-11-01  (development release, unindexed)
        - fix install test on cygwin
        - fix stackable test on win32 and when external local::lib is set
        - clarify errors in Makefile.PL about CPAN configuration
        - adjust csh output to allow use directly by eval
        - silence a possible warning in Makefile.PL
        - add additional docs about combining local::lib with lib::core::only
        - reverse order of PERL_LOCAL_LIB_ROOT.  new local::libs are now added
          to the beginning instead of the end, to match the order of other
          similar environment variables.

1.008024 - 2013-10-28  (development release, unindexed)
        - fix installation into directories with spaces or backslashes, as
          well as Win32 test failures when Capture::Tiny is installed
        - fix test breaking in some cases when an external local::lib is set
        - fix test compatibility with old versions of Exporter

1.008023 - 2013-10-19
        - stable release of 1.008022 (no code changes since 1.008012)

1.008022 - 2013-10-07 (development release, unindexed)
        - see 1.008019 through 1.008021

1.008021 - 2013-10-04 (development release, unindexed)
        - yet another attempt to overcome win32 testing issues (paths with
          spaces, backslashes)

1.008020 - 2013-10-03 (development release, unindexed)
        - yet another attempt to overcome win32 testing issues (paths with
          spaces, backslashes)

1.008019 - 2013-09-29 (development release, unindexed)
        - another attempt to overcome win32 testing issues (paths with spaces,
          backslashes)

1.008018 - 2013-09-15
        - print out actual paths in more test cases, for helping to diagnose
          mysterious failures

1.008017 - 2013-09-14
        - avoid "Unrecognized escape \s passed through" errors on win32
          (again)

1.008016 - 2013-09-13
        - avoid "Unrecognized escape \s passed through" errors on win32

1.008015 - 2013-09-12
        - re-release 1.008014 to fix broken MANIFEST

1.008014 - 2013-09-12
        - fix new test to use alternate path representations on windows, to
          handle potential space issues (regression since 1.008012)

1.008013 - 2013-09-11
        - fix undef value errors when not installing into a local::lib

1.008012 - 2013-09-11
        - now handling using -Mlocal::lib in a taintperl environment, by
          ensuring that all libs in PERL_LOCAL_LIB_ROOT are properly added to
          @INC (RT#76661, Karen Etheridge)

1.008011 - 2013-07-26
        - skip CPAN workaround if running via cpanminus  (miyagawa, RT#85731)
This commit is contained in:
sno 2014-02-16 17:56:44 +00:00
parent a93aba4942
commit 6637cfc4f3
4 changed files with 27 additions and 110 deletions

View file

@ -1,6 +1,15 @@
The Perl 5 module local::lib allows for the bootstrapping and usage
of a directory containing Perl modules outside of Perl's @INC. This
makes it easier to ship an application with an app-specific copy
of a Perl module, or collection of modules. Useful in cases like
when an upstream maintainer hasn't applied a patch to a module of
theirs that you need for your application.
This module provides a quick, convenient way of bootstrapping a user-local
Perl module library located within the user's home directory. It also
constructs and prints out for the user the list of environment variables
using the syntax appropriate for the user's current shell (as specified by
the "SHELL" environment variable), suitable for directly adding to one's
shell configuration file. More generally, local::lib allows for the
bootstrapping and usage of a directory containing Perl modules outside of
Perl's @INC. This makes it easier to ship an application with an
app-specific copy of a Perl module, or collection of modules. Useful in
cases like when an upstream maintainer hasn't applied a patch to a module
of theirs that you need for your application. On import, local::lib sets
the following environment variables to appropriate values: PERL_MB_OPT
PERL_MM_OPT PERL5LIB PATH PERL_LOCAL_LIB_ROOT When possible, these will be
appended to instead of overwritten entirely. These values are then
available for reference by any code after import.

View file

@ -1,19 +1,21 @@
# $NetBSD: Makefile,v 1.20 2013/07/13 09:37:37 wen Exp $
# $NetBSD: Makefile,v 1.21 2014/02/16 17:56:44 sno Exp $
#
DISTNAME= local-lib-1.008010
PKGNAME= p5-${DISTNAME:S/008010/8.10/}
DISTNAME= local-lib-2.000004
PKGNAME= p5-${DISTNAME}
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=lib/}
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=../../authors/id/H/HA/HAARG/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://search.cpan.org/dist/local-lib/
HOMEPAGE= https://metacpan.org/release/local-lib
COMMENT= Create and use a local lib/ for perl modules with PERL5LIB
LICENSE= ${PERL5_LICENSE}
USE_LANGUAGES= # empty
PERL5_PACKLIST= auto/local/lib/.packlist
PERL5_MODULE_TYPE= Module::Install::Bundled
MAKE_ENV+= PERL5_CPANM_IS_RUNNING=1
.include "../../lang/perl5/module.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.14 2013/07/13 09:37:37 wen Exp $
$NetBSD: distinfo,v 1.15 2014/02/16 17:56:44 sno Exp $
SHA1 (local-lib-1.008010.tar.gz) = 9cb15c5afa1d7730b739c0e05fa421e09186e770
RMD160 (local-lib-1.008010.tar.gz) = 03618e5f644a969e4a1048ef1304de19d0de6d1f
Size (local-lib-1.008010.tar.gz) = 56892 bytes
SHA1 (patch-aa) = 68232a7b89bdf1209d7c788a4afb2a2056bca85c
SHA1 (local-lib-2.000004.tar.gz) = 60d20361a4bf50d7fc73928c7685d5112f8c45d9
RMD160 (local-lib-2.000004.tar.gz) = bd1bcf07906660eadf157a3fbcc07aaa01beb841
Size (local-lib-2.000004.tar.gz) = 47624 bytes

View file

@ -1,93 +0,0 @@
$NetBSD: patch-aa,v 1.3 2011/11/05 13:30:44 hiramatsu Exp $
Prevent CPAN's interactive configuration process to take place!
--- Makefile.PL.orig 2011-11-04 19:20:21.000000000 +0000
+++ Makefile.PL
@@ -200,46 +200,46 @@ delete $ENV{PERL5_CPAN_IS_RUNNING} if $n
# and make sure that the user doesn't have any existing CPAN config that'll
# cause us problems for the next few steps.
-{
- local $@;
- eval { require CPAN::HandleConfig; };
- # Need newish CPAN.pm for this, ergo skip it if that version of CPAN isn't
- # installed yet.
- # It will already be installed by the time we reach here if bootstrapping,
- # otherwise, if we're running from CPAN then it will be installed soon
- # enough, and we'll come back here..
- if (!$@ ) {
- CPAN::HandleConfig->require_myconfig_or_config;
- if ( $CPAN::Config ) {
- for my $eumm_setting ( qw/makepl_arg make_install_arg/ ) {
- if ($CPAN::Config->{$eumm_setting} =~ /(?:PREFIX|INSTALL_BASE)/) {
- die <<"DEATH";
-WHOA THERE! It looks like you've got $CPAN::Config->{$eumm_setting} set. This is
-known to cause problems with local::lib. Please either remove this setting or
-clear out your .cpan directory.
-DEATH
- }
- }
-
- for my $mb_setting (qw/mbuild_arg mbuild_install_arg mbuildpl_arg/) {
- if ($CPAN::Config->{$mb_setting} =~ /(?:--prefix|--install_base)/) {
- die <<"DEATH";
-WHOA THERE! It looks like you've got $CPAN::Config->{$mb_setting} set. This is
-known to cause problems with local::lib. Please either remove this setting or
-clear out your .cpan directory.
-DEATH
- }
- }
- }
- }
- else {
- my $error = $@;
- require CPAN;
- # Explode if it looks like requiring CPAN::HandleConfig should
- # have worked, but didn't.
- die($error) if $CPAN::VERSION >= $required_CPAN;
- }
-}
+#{
+# local $@;
+# eval { require CPAN::HandleConfig; };
+# # Need newish CPAN.pm for this, ergo skip it if that version of CPAN isn't
+# # installed yet.
+# # It will already be installed by the time we reach here if bootstrapping,
+# # otherwise, if we're running from CPAN then it will be installed soon
+# # enough, and we'll come back here..
+# if (!$@ ) {
+# CPAN::HandleConfig->require_myconfig_or_config;
+# if ( $CPAN::Config ) {
+# for my $eumm_setting ( qw/makepl_arg make_install_arg/ ) {
+# if ($CPAN::Config->{$eumm_setting} =~ /(?:PREFIX|INSTALL_BASE)/) {
+# die <<"DEATH";
+#WHOA THERE! It looks like you've got $CPAN::Config->{$eumm_setting} set. This is
+#known to cause problems with local::lib. Please either remove this setting or
+#clear out your .cpan directory.
+#DEATH
+# }
+# }
+#
+# for my $mb_setting (qw/mbuild_arg mbuild_install_arg mbuildpl_arg/) {
+# if ($CPAN::Config->{$mb_setting} =~ /(?:--prefix|--install_base)/) {
+# die <<"DEATH";
+#WHOA THERE! It looks like you've got $CPAN::Config->{$mb_setting} set. This is
+#known to cause problems with local::lib. Please either remove this setting or
+#clear out your .cpan directory.
+#DEATH
+# }
+# }
+# }
+# }
+# else {
+# my $error = $@;
+# require CPAN;
+# # Explode if it looks like requiring CPAN::HandleConfig should
+# # have worked, but didn't.
+# die($error) if $CPAN::VERSION >= $required_CPAN;
+# }
+#}
if ($bootstrapping) {
auto_install_now;