hexchat: adapt libpci option for pciutils 3.8.0
default-off, so no PKGREVISION bump
This commit is contained in:
parent
2936c4db4e
commit
6657696a64
5 changed files with 3 additions and 50 deletions
|
@ -1,10 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.16 2022/03/04 07:48:16 nia Exp $
|
||||
$NetBSD: distinfo,v 1.17 2022/05/13 15:35:17 wiz Exp $
|
||||
|
||||
BLAKE2s (hexchat-2.16.1.tar.xz) = c4a0d6d4925f062eb6401c4764c38fdd28b261339de5d915544b424d5f30a286
|
||||
SHA512 (hexchat-2.16.1.tar.xz) = 9e6baa30ec8c3ce4fb56e2c82625da63295040eaf93a542aec8a4a18a6a3c95d69d1d4ffabc952bcdcd7b754afef234b348f296143991fafd0550342db95ce0e
|
||||
Size (hexchat-2.16.1.tar.xz) = 1349536 bytes
|
||||
SHA1 (patch-osx_launcher.sh) = 7493430921809182898aca2ebb8fd1f493dbd9d3
|
||||
SHA1 (patch-plugins_sysinfo_meson.build) = 35257a24137fe02a1ba292d7da8b627d318de0ab
|
||||
SHA1 (patch-plugins_sysinfo_unix_parse.c) = 92b882b7573cfcfc280351353a7bdcb0a7940c06
|
||||
SHA1 (patch-plugins_sysinfo_unix_pci.c) = db2d20261419bed6d6c4b716b4416d73b3386053
|
||||
SHA1 (patch-plugins_sysinfo_unix_pci.h) = 018b74796143b26d6a1f9ad821f3889b74b09cc8
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: options.mk,v 1.11 2021/12/17 20:09:34 maya Exp $
|
||||
# $NetBSD: options.mk,v 1.12 2022/05/13 15:35:17 wiz Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.hexchat
|
||||
PKG_SUPPORTED_OPTIONS= dbus gtk2 libcanberra libpci
|
||||
|
@ -38,6 +38,7 @@ MESON_ARGS+= -Dlibcanberra=disabled
|
|||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mlibpci)
|
||||
BUILDLINK_API_DEPENDS.pciutils+= pciutils>=3.8
|
||||
.include "../../sysutils/pciutils/buildlink3.mk"
|
||||
.include "../../sysutils/pciutils/libname.mk"
|
||||
LIBS+= -l${PCIUTILS_LIBNAME}
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-plugins_sysinfo_unix_parse.c,v 1.2 2018/03/17 11:56:15 tnn Exp $
|
||||
|
||||
Fix header location for pkgsrc.
|
||||
|
||||
--- plugins/sysinfo/unix/parse.c.orig 2018-03-14 02:27:13.000000000 +0000
|
||||
+++ plugins/sysinfo/unix/parse.c
|
||||
@@ -24,7 +24,7 @@
|
||||
#include <string.h>
|
||||
#include <ctype.h>
|
||||
#ifdef HAVE_LIBPCI
|
||||
- #include <pci/header.h>
|
||||
+ #include <pciutils/header.h>
|
||||
#include "pci.h"
|
||||
#endif
|
||||
#include <glib.h>
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-plugins_sysinfo_unix_pci.c,v 1.1 2016/08/16 08:30:14 tnn Exp $
|
||||
|
||||
Fix header location for pkgsrc.
|
||||
|
||||
--- plugins/sysinfo/unix/pci.c.orig 2016-03-20 01:05:19.000000000 +0000
|
||||
+++ plugins/sysinfo/unix/pci.c
|
||||
@@ -23,7 +23,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#include <ctype.h>
|
||||
-#include <pci/pci.h>
|
||||
+#include <pciutils/pci.h>
|
||||
#include <glib.h>
|
||||
|
||||
#include "sysinfo.h"
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-plugins_sysinfo_unix_pci.h,v 1.1 2016/08/16 08:30:14 tnn Exp $
|
||||
|
||||
Fix header location for pkgsrc.
|
||||
|
||||
--- plugins/sysinfo/unix/pci.h.orig 2016-03-20 01:05:19.000000000 +0000
|
||||
+++ plugins/sysinfo/unix/pci.h
|
||||
@@ -21,7 +21,7 @@
|
||||
#ifndef _PCI_H_
|
||||
#define _PCI_H_
|
||||
|
||||
-#include <pci/pci.h>
|
||||
+#include <pciutils/pci.h>
|
||||
void pci_find_fullname(char *fullname, char *vendor, char *device);
|
||||
int pci_find_by_class(u16 *class, char *vendor, char *device);
|
||||
|
Loading…
Reference in a new issue