Update to 3.4.00

* Sync with ispell-3.4.00.
* Use PATCHDIR and DISTINFO_FILE in textproc/ispell.
This commit is contained in:
ryoon 2015-03-14 08:15:51 +00:00
parent cbb8b255f0
commit 6666689f3a
7 changed files with 5 additions and 123 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.4 2013/10/15 15:54:25 roy Exp $
# $NetBSD: Makefile,v 1.5 2015/03/14 08:15:51 ryoon Exp $
#
DISTNAME= ispell-3.3.02
DISTNAME= ispell-3.4.00
PKGNAME= ${DISTNAME:S/-/-${DICT_LANG}-/1}
PKGREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://fmg-www.cs.ucla.edu/geoff/tars/
@ -14,6 +13,9 @@ COMMENT= British dictionary for interactive spelling checker
CONFLICTS+= ispell-british-[0-9]*
DEPENDS+= ispell>=3.3.02:../../textproc/ispell
PATCHDIR= ${.CURDIR}/../../textproc/ispell/patches
DISTINFO_FILE= ${.CURDIR}/../../textproc/ispell/distinfo
BUILD_TARGET= config.sh all-languages
DICT_LANG= british

View file

@ -1,10 +0,0 @@
$NetBSD: distinfo,v 1.2 2013/05/25 23:46:51 joerg Exp $
SHA1 (ispell-3.3.02.tar.gz) = c0d98e1af3afb8e0b642717c03439ff8881e3d60
RMD160 (ispell-3.3.02.tar.gz) = 12edc94ebb7c1f4040bd8f5b0dbb8f40326aa781
Size (ispell-3.3.02.tar.gz) = 619813 bytes
SHA1 (patch-aa) = cf8e0863e62103526d75ba5f0f25c760d4ee8e32
SHA1 (patch-ab) = 210d80ca55fc1d4fb5aa308205d8630a7f4bfb67
SHA1 (patch-ac) = a3474192676a326f33e10266e57ace5dfb1ba7eb
SHA1 (patch-ad) = b3edb0466b306ecf1d59cfba46ec3f74e01db6ff
SHA1 (patch-correct.c) = fccbda8d49dd52bcd1318e025d523fd366de678d

View file

@ -1,12 +0,0 @@
$NetBSD: patch-aa,v 1.1 2013/04/24 02:20:38 rodent Exp $
--- languages/english/english.2-orig Mon Jan 23 19:28:44 1995
+++ languages/english/english.2 Thu Apr 16 14:34:21 1998
@@ -1867,7 +1867,6 @@
auxotroph
auxotrophic
auxotrophy
-avaliable
avast
avatar
avaunt

View file

@ -1,19 +0,0 @@
$NetBSD: patch-ab,v 1.1 2013/04/24 02:20:38 rodent Exp $
--- languages/english/english.3.orig Tue Oct 27 22:26:48 1998
+++ languages/english/english.3 Tue Oct 27 22:27:35 1998
@@ -5202,6 +5202,7 @@
dirndl
disaccredit
disafforest
+disappear
disbranch
disbud
discalced
@@ -5236,7 +5237,6 @@
dispersoid
displayable
disproven
-dissappear
disseminule
dissentious
dissepiment

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ac,v 1.1 2013/04/24 02:20:38 rodent Exp $
Use the buildhash program from the base installation
--- languages/british/Makefile 1995/01/08 23:24:18 1.4
+++ languages/british/Makefile 2001/03/14 10:56:42
@@ -63,7 +63,7 @@
CONFIG = ../../config.sh
PATHADDER = ../..
-BUILDHASH = ../../buildhash
+BUILDHASH = ${PREFIX}/bin/buildhash
# The following variables should be set by the superior Makefile,
# based on the LANGUAGES variable in config.X.

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ad,v 1.1 2013/04/24 02:20:38 rodent Exp $
Don't build the programs - use the ones from the base system.
--- Makefile.orig 2005-05-26 01:57:02.000000000 +1200
+++ Makefile
@@ -287,7 +287,7 @@ showversion: ispell
mv y_tab.o $@; \
rm -f y_tab.c
-all-languages: munchable
+all-languages:
$(MAKE) LANGUAGE_TARGET=all SHELLDEBUG=$(SHELLDEBUG) language-subdirs
install: config.sh all install-basic install-deformatters

View file

@ -1,49 +0,0 @@
$NetBSD: patch-correct.c,v 1.1 2013/05/25 23:46:51 joerg Exp $
--- correct.c.orig 2013-05-25 18:03:03.000000000 +0000
+++ correct.c
@@ -245,7 +245,7 @@ static void save_root_cap P ((ichar_t *
struct flagent * sufent,
ichar_t savearea[MAX_CAPS][INPUTWORDLEN + MAXAFFIXLEN],
int * nsaved));
-static char * getline P ((char * buf, int bufsize));
+static char * my_getline P ((char * buf, int bufsize));
void askmode P ((void));
void copyout P ((unsigned char ** cc, int cnt));
static void lookharder P ((unsigned char * string));
@@ -571,7 +571,7 @@ checkagain:
imove (li - 1, 0);
(void) putchar ('!');
- if (getline ((char *) buf, sizeof buf) == NULL)
+ if (my_getline ((char *) buf, sizeof buf) == NULL)
{
(void) putchar (7);
ierase ();
@@ -596,7 +596,7 @@ checkagain:
(void) printf ("%s ", CORR_C_READONLY);
}
(void) printf (CORR_C_REPLACE_WITH);
- if (getline ((char *) ctok, ctokl) == NULL)
+ if (my_getline ((char *) ctok, ctokl) == NULL)
{
(void) putchar (7);
/* Put it back */
@@ -664,7 +664,7 @@ checkagain:
unsigned char buf[100];
imove (li - 1, 0);
(void) printf (CORR_C_LOOKUP_PROMPT);
- if (getline ((char *) buf, sizeof buf) == NULL)
+ if (my_getline ((char *) buf, sizeof buf) == NULL)
{
(void) putchar (7);
ierase ();
@@ -1583,7 +1583,7 @@ static void save_root_cap (word, pattern
return;
}
-static char * getline (s, len)
+static char * my_getline (s, len)
register char * s;
register int len;
{