postfix: update to 3.4.9

upstream changes:
-----------------
 Fixed in all supported stable releases:

    Bug (introduced: Postfix 3.1): smtp_dns_resolver_options were broken while adding support for negative DNS response caching in postscreen. Postfix was inadvertently changed to call res_query() instead of res_search(). Reported by Jaroslav Skarvada.

    Bug (introduced: Postfix 2.5): Postfix ignored the CONNECT macro overrides from a Milter application. Postfix now evaluates the Milter macros for an SMTP CONNECT event after the Postfix-to-Milter connection is negotiated. Problem reported by David Bürgin.

    Bug (introduced: Postfix 3.0): sanitize (remote) server responses before storing them in the verify database, to avoid Postfix warnings about malformed UTF8. Found during code maintenance.
This commit is contained in:
triaxx 2020-02-11 20:40:27 +00:00
parent 25dd95ea1e
commit 668bd34850
4 changed files with 13 additions and 14 deletions

View file

@ -1,6 +1,5 @@
# $NetBSD: Makefile,v 1.316 2020/01/28 08:16:51 triaxx Exp $
# $NetBSD: Makefile,v 1.317 2020/02/11 20:40:27 triaxx Exp $
PKGREVISION= 2
.include "../../mail/postfix/Makefile.common"
COMMENT= Fast, easy to administer, and secure mail transfer agent

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile.common,v 1.23 2020/01/28 08:16:51 triaxx Exp $
# $NetBSD: Makefile.common,v 1.24 2020/02/11 20:40:27 triaxx Exp $
# used by mail/postfix/Makefile
# used by mail/postfix/Makefile.module
DISTNAME= postfix-3.4.8
DISTNAME= postfix-3.4.9
CATEGORIES= mail
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/official/
MASTER_SITES+= http://mirrors.isc.org/pub/postfix/official/

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.182 2019/12/09 08:45:14 triaxx Exp $
$NetBSD: distinfo,v 1.183 2020/02/11 20:40:27 triaxx Exp $
SHA1 (postfix-3.4.8.tar.gz) = a6f90324fcba80eb59d4c9a6a2198421360252b7
RMD160 (postfix-3.4.8.tar.gz) = 430c5294a1fd4ca5411e13fb328897e01a03a055
SHA512 (postfix-3.4.8.tar.gz) = 782fe83e4b40c7aadfb4c55850db4c7163dd0f647f4ef133e59f7b47c993b2b4fa6c43ebbc45131caa54d968259f9c8568f47e81bfccda02ab142be52aa95d45
Size (postfix-3.4.8.tar.gz) = 4573099 bytes
SHA1 (postfix-3.4.9.tar.gz) = e2ce620f172052bb3a51e99eefe0294199163a54
RMD160 (postfix-3.4.9.tar.gz) = 45c52a186bbadfa9ab289694b8d696565a7f39b3
SHA512 (postfix-3.4.9.tar.gz) = 9038850d79bf19460d55dede2dd97e6f4bd8255363b4004704e5f0493bf9b1c0729f5bb11663ba6f6ed34177205609f72401b0f55d1d9dbce5398b4603a0a991
Size (postfix-3.4.9.tar.gz) = 4573241 bytes
SHA1 (patch-aa) = c8216f133e202a7bb37682b0dbc1448f021e7c1c
SHA1 (patch-ag) = c126c572e36bf2bcbd3f6e5d8332a3d26e704109
SHA1 (patch-ai) = 51748ccf92da543f7ff640f36906a29b5db3f6e3
SHA1 (patch-src_dns_dns__lookup.c) = 88cdda55765799d40f05fa7aad43cdbc58c4a307
SHA1 (patch-src_dns_dns__lookup.c) = 448fe38a38cb201cd09fbae35d6c5f6cdf7df8b9

View file

@ -1,8 +1,8 @@
$NetBSD: patch-src_dns_dns__lookup.c,v 1.5 2018/02/25 12:27:50 taca Exp $
$NetBSD: patch-src_dns_dns__lookup.c,v 1.6 2020/02/11 20:40:27 triaxx Exp $
Fix runtime problem when mysql PKG_OPTIONS is enabled.
--- src/dns/dns_lookup.c.orig 2017-12-21 01:53:15.000000000 +0000
--- src/dns/dns_lookup.c.orig 2019-12-15 16:13:04.000000000 +0000
+++ src/dns/dns_lookup.c
@@ -245,6 +245,8 @@
@ -52,8 +52,8 @@ Fix runtime problem when mysql PKG_OPTIONS is enabled.
if (keep_notfound)
/* Prepare for returning a null-padded server reply. */
memset(answer, 0, anslen);
- len = res_query(name, class, type, answer, anslen);
+ len = res_nquery(statp, name, class, type, answer, anslen);
- len = res_search(name, class, type, answer, anslen);
+ len = res_nsearch(statp, name, class, type, answer, anslen);
/* Begin API creep workaround. */
if (len < 0 && h_errno == 0) {
SET_H_ERRNO(TRY_AGAIN);