try to find openssl header from system inc_dirs additionally, builtin one
may be in unusual location.
This commit is contained in:
parent
8f65bf1087
commit
66a84e04ef
2 changed files with 8 additions and 6 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.58 2014/04/13 14:56:56 bsiegert Exp $
|
||||
$NetBSD: distinfo,v 1.59 2014/05/21 00:35:50 obache Exp $
|
||||
|
||||
SHA1 (Python-2.6.9.tar.xz) = 2fc159946dfcceffbe4a8638de32d0cd8059c2f8
|
||||
RMD160 (Python-2.6.9.tar.xz) = 42edf7c9f2f64b77ab173de30ea453257c2c06b3
|
||||
|
@ -17,7 +17,7 @@ SHA1 (patch-ad) = a997e39d16a8f0023125362b180d19ee97ab519b
|
|||
SHA1 (patch-ae) = a6d578b5f12eb42fbbcc11791576d2686a4807d9
|
||||
SHA1 (patch-ah) = 501d220b41e578402f3400fe88e582aa2408a147
|
||||
SHA1 (patch-al) = 45dd16af8e7a45aa323138f712c034aa79a91019
|
||||
SHA1 (patch-am) = 602726fb7f694c1cfe39691aef01fee1687befb1
|
||||
SHA1 (patch-am) = 216e4993a83b3ff1193c2ab524e761bc9ae3d52d
|
||||
SHA1 (patch-an) = 17b4e17b3b562c29a050e9bb20447084ce82b8ab
|
||||
SHA1 (patch-ao) = 8c6a156b0f0c2a6d319658477fff348e6a0c3603
|
||||
SHA1 (patch-ap) = 5ad6f248027be369bd27f69210ff3c7b97a297a2
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-am,v 1.23 2014/04/13 14:56:56 bsiegert Exp $
|
||||
$NetBSD: patch-am,v 1.24 2014/05/21 00:35:50 obache Exp $
|
||||
|
||||
Disabled modules for normal build:
|
||||
bsddb
|
||||
|
@ -79,7 +79,7 @@ support building the "nis" and "crypt" modules.
|
|||
|
||||
# Add paths specified in the environment variables LDFLAGS and
|
||||
# CPPFLAGS for header and library files.
|
||||
@@ -691,10 +721,9 @@ class PyBuildExt(build_ext):
|
||||
@@ -691,11 +721,10 @@ class PyBuildExt(build_ext):
|
||||
depends = ['socketmodule.h']) )
|
||||
# Detect SSL support for the socket module (via _ssl)
|
||||
search_for_ssl_incs_in = [
|
||||
|
@ -88,10 +88,12 @@ support building the "nis" and "crypt" modules.
|
|||
+ '@SSLBASE@/include'
|
||||
]
|
||||
- ssl_incs = find_file('openssl/ssl.h', inc_dirs,
|
||||
- search_for_ssl_incs_in
|
||||
+ ssl_incs = find_file('openssl/ssl.h', [],
|
||||
search_for_ssl_incs_in
|
||||
+ search_for_ssl_incs_in + inc_dirs
|
||||
)
|
||||
if ssl_incs is not None:
|
||||
krb5_h = find_file('krb5.h', inc_dirs,
|
||||
@@ -703,9 +732,7 @@ class PyBuildExt(build_ext):
|
||||
if krb5_h:
|
||||
ssl_incs += krb5_h
|
||||
|
@ -108,7 +110,7 @@ support building the "nis" and "crypt" modules.
|
|||
# look for the openssl version header on the compiler search path.
|
||||
opensslv_h = find_file('openssl/opensslv.h', [],
|
||||
- inc_dirs + search_for_ssl_incs_in)
|
||||
+ search_for_ssl_incs_in)
|
||||
+ search_for_ssl_incs_in + inc_dirs)
|
||||
if opensslv_h:
|
||||
name = os.path.join(opensslv_h[0], 'openssl/opensslv.h')
|
||||
if sys.platform == 'darwin' and is_macosx_sdk_path(name):
|
||||
|
|
Loading…
Reference in a new issue