Update of mail/nail to 10.4. Changes since 10.3 (as per e-mail

from Gunnar Ritter):

* A missing #ifdef HAVE_ICONV caused build errors on platforms without
  iconv() support (J.A. Neitzel, Jens Schleusener, Lars Kellogg-Stedman,
  Felicia Neff, Chris Pinnock).
* Extraction of parts from header fields with more than 2560 characters
  fixed (Lukasz Sznuk, William Cherry).
* Source archive name in nail.spec corrected (Didar Hussain).
* Fixed segmentation violation when encountering multipart header fields
  that contain no ':' character (William Cherry).
* Respect the 'allnet' variable when comparing strings in message lists.
* IPv6 support (Jun-ichiro itojun Hagino).
This commit is contained in:
cjep 2003-01-19 18:10:11 +00:00
parent 97d2d439b1
commit 66cc2c431a
3 changed files with 5 additions and 24 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/12/09 10:37:17 cjep Exp $
# $NetBSD: Makefile,v 1.2 2003/01/19 18:10:11 cjep Exp $
DISTNAME= nail-10.3
DISTNAME= nail-10.4
CATEGORIES= mail
MASTER_SITES= http://omnibus.ruf.uni-freiburg.de/~gritter/archive/nail/

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2002/12/09 10:37:17 cjep Exp $
$NetBSD: distinfo,v 1.2 2003/01/19 18:10:11 cjep Exp $
SHA1 (nail-10.3.tar.gz) = 5eaa3dfe2c9519d4dea0d3c414581430fc1b9fd8
Size (nail-10.3.tar.gz) = 187462 bytes
SHA1 (nail-10.4.tar.gz) = fff829d9fb44cfa402051604b4bc95eb62381d7b
Size (nail-10.4.tar.gz) = 189380 bytes
SHA1 (patch-aa) = c31048d0994efc5f26d88d07e348ad750aa44a2b
SHA1 (patch-ab) = f9295585fed37e2a33debc49629afa2263ea699a
SHA1 (patch-ac) = 72defa8a22e31244941154b5a7245fb1d698e88a
SHA1 (patch-ad) = 33be3128be74aa0b5b5486300b24a5fa82bfa009

View file

@ -1,18 +0,0 @@
$NetBSD: patch-ad,v 1.1.1.1 2002/12/09 10:37:17 cjep Exp $
--- sendout.c.orig Thu Nov 28 01:01:01 2002
+++ sendout.c
@@ -428,10 +428,13 @@ infix(hp, fi)
#endif
return NULL;
}
+
+#ifdef HAVE_ICONV
if (convhdr && iconvd != (iconv_t)-1) {
iconv_close(iconvd);
iconvd = (iconv_t)-1;
}
+#endif
if (hp->h_attach != NULL) {
if (make_multipart(hp, convert, fi, nfo,
contenttype, charset) != 0) {