include stdlib.h to get a prototype for getenv(). Fixes recently noted

bulk build problems on alpha.
This commit is contained in:
dmcmahill 2003-11-25 23:05:24 +00:00
parent 875982fb7d
commit 66ec3b8e56
2 changed files with 18 additions and 9 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.12 2003/06/09 12:32:45 tron Exp $
$NetBSD: distinfo,v 1.13 2003/11/25 23:05:24 dmcmahill Exp $
SHA1 (qt-x11-2.3.1.tar.gz) = f1403700fe80fbfb125ec84731d0dfe9c576c823
Size (qt-x11-2.3.1.tar.gz) = 8967271 bytes
@ -14,4 +14,4 @@ SHA1 (patch-ai) = 20a61cefe445fdc8cac90da9800d0836ac57caf8
SHA1 (patch-aj) = ed0cd262eca3ff190c221421a62ce2970121a4d4
SHA1 (patch-ak) = 3eac0d921f3535231aab9ff1f6738f9541b8b564
SHA1 (patch-al) = 32f6b13393b115c56a4ca75f62f5916034189174
SHA1 (patch-am) = bc6fc455ca86df1e9b877bbd08ba226145de484f
SHA1 (patch-am) = ebbc184b095e2adcf81461472f4723d515167a9e

View file

@ -1,15 +1,24 @@
$NetBSD: patch-am,v 1.1 2003/06/09 12:32:46 tron Exp $
$NetBSD: patch-am,v 1.2 2003/11/25 23:05:24 dmcmahill Exp $
--- src/kernel/qpsprinter.cpp.orig 2001-06-13 10:53:46.000000000 +0200
+++ src/kernel/qpsprinter.cpp 2003-06-09 14:16:18.000000000 +0200
@@ -2771,10 +2771,6 @@
--- src/kernel/qpsprinter.cpp.orig Wed Jun 13 08:53:46 2001
+++ src/kernel/qpsprinter.cpp
@@ -92,6 +92,8 @@
#include <unistd.h>
#endif
+#include <stdlib.h>
+
#ifdef _WS_X11_
#include "qt_x11.h"
#ifdef None
@@ -2770,10 +2772,6 @@ private:
};
-
-#ifndef _OS_OSF_
-extern "C" char* getenv(char*);
-#endif
-
QPSPrinterFontTTF::QPSPrinterFontTTF(const QFont &f, QByteArray& d)
{
psname = makePSFontName( f );