Rename private strtoi function. Bump revision.

This commit is contained in:
joerg 2015-01-23 15:07:53 +00:00
parent 962855d175
commit 6708bba9df
5 changed files with 72 additions and 3 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.61 2014/09/23 09:08:21 jperkin Exp $
# $NetBSD: Makefile,v 1.62 2015/01/23 15:07:53 joerg Exp $
DISTNAME= pari-2.3.5
PKGREVISION= 14
PKGREVISION= 15
CATEGORIES= math
MASTER_SITES= http://pari.math.u-bordeaux.fr/pub/pari/unix/

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.20 2011/12/10 23:53:34 marino Exp $
$NetBSD: distinfo,v 1.21 2015/01/23 15:07:53 joerg Exp $
SHA1 (pari-2.3.5.tar.gz) = f211ccfe42a4b18dbcde832dfd1ece6f477f4966
RMD160 (pari-2.3.5.tar.gz) = 488adf3af5398d0ab5390eb86b65cd79bd1044c5
@ -20,3 +20,6 @@ SHA1 (patch-an) = 4e1f9c8e0c63e2f1922bb8b181212b3e09c56ce6
SHA1 (patch-ao) = 44bf077f1585e20277dcd42a7c5fd38d12b19af5
SHA1 (patch-ap) = 21a20b68b589f8be3036d1f2f9c4b2a7f43210a8
SHA1 (patch-config_get_fltk) = 2c2aa271fad5880a44b2df70a7143d2aea690ca0
SHA1 (patch-src_headers_paridecl.h) = ee02e487807d8ed1c1a11268965ade76a2f80cf2
SHA1 (patch-src_language_anal.c) = d0028a51e8ef14cae766cb881fcfce82cec0346f
SHA1 (patch-src_modules_mpqs.c) = 3dd164e5c686fd2eb8317569cf05906a4c527721

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_headers_paridecl.h,v 1.1 2015/01/23 15:07:53 joerg Exp $
--- src/headers/paridecl.h.orig 2015-01-22 19:57:35.000000000 +0000
+++ src/headers/paridecl.h
@@ -264,7 +264,7 @@ GEN readseq(char *t);
long manage_var(long n, entree *ep);
void name_var(long n, char *s);
GEN strtoGENstr(const char *s);
-GEN strtoi(char *s);
+GEN pari_strtoi(char *s);
GEN strtor(char *s, long prec);
GEN type0(GEN x);

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_language_anal.c,v 1.1 2015/01/23 15:07:53 joerg Exp $
--- src/language/anal.c.orig 2015-01-22 19:57:33.000000000 +0000
+++ src/language/anal.c
@@ -2520,7 +2520,7 @@ int_read(char **s)
}
GEN
-strtoi(char *s) { return int_read(&s); }
+pari_strtoi(char *s) { return int_read(&s); }
GEN
strtor(char *s, long PREC)

View file

@ -0,0 +1,40 @@
$NetBSD: patch-src_modules_mpqs.c,v 1.1 2015/01/23 15:07:53 joerg Exp $
--- src/modules/mpqs.c.orig 2015-01-22 19:57:31.000000000 +0000
+++ src/modules/mpqs.c
@@ -2345,7 +2345,7 @@ mpqs_combine_large_primes(mpqs_handle_t
*f = gerepileuptoint(av0, inv_q);
return c;
}
- Y1 = strtoi(e[0].Y);
+ Y1 = pari_strtoi(e[0].Y);
av2 = avma; /* preserve inv_q and Y1 */
while (fgets(buf, MPQS_STRING_LENGTH, COMB))
@@ -2371,7 +2371,7 @@ mpqs_combine_large_primes(mpqs_handle_t
*f = gerepileuptoint(av0, inv_q);
return c;
}
- Y1 = strtoi(e[i].Y);
+ Y1 = pari_strtoi(e[i].Y);
i = 1 - i; /* subsequent relations go to other row */
av2 = avma; /* preserve inv_q and Y1 */
continue;
@@ -2381,7 +2381,7 @@ mpqs_combine_large_primes(mpqs_handle_t
memset((void *)ei, 0, ei_size * sizeof(long));
mpqs_set_exponents(ei, e[0].E);
mpqs_set_exponents(ei, e[1].E);
- Y2 = strtoi(e[i].Y);
+ Y2 = pari_strtoi(e[i].Y);
new_Y = modii(mulii(mulii(Y1, Y2), inv_q), h->N);
new_Y1 = subii(h->N, new_Y);
if (absi_cmp(new_Y1, new_Y) < 0) new_Y = new_Y1;
@@ -2692,7 +2692,7 @@ mpqs_add_relation(GEN Y_prod, GEN N, lon
s = strchr(rel, ':') - 1;
*s = '\0';
- res = remii(mulii(Y_prod, strtoi(rel)), N);
+ res = remii(mulii(Y_prod, pari_strtoi(rel)), N);
s = strtok(s + 3, " \n");
while (s != NULL)