Imported camlbz2 0.6.0 as archivers/ocamlbz2. This closes PR pkg/41738.

This Objective Caml library provides easy access to compressed files in
bzip2 format. It provides functions for reading from and writing to compressed
files in these formats.
This commit is contained in:
jaapb 2012-09-16 12:30:46 +00:00
parent dfa8b97d36
commit 6739d9ee74
5 changed files with 68 additions and 0 deletions

View file

@ -0,0 +1,3 @@
This Objective Caml library provides easy access to compressed files in
bzip2 format. It provides functions for reading from and writing to compressed
files in these formats.

View file

@ -0,0 +1,29 @@
# $NetBSD: Makefile,v 1.1 2012/09/16 12:30:46 jaapb Exp $
PKGNAME= ocaml-bz2-${VERSION}
DISTNAME= camlbz2-${VERSION}
VERSION= 0.6.0
CATEGORIES= archivers
MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/72/
MAINTAINER= jaapb@NetBSD.org
COMMENT= OCaml library to manipulate bz2 archives
HOMEPAGE= http://camlbz2.forge.ocamlcore.org/
LICENSE= gnu-lgpl-v2.1
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
USE_TOOLS+= gmake
MAKE_JOBS_SAFE= no
PLIST_VARS+= opt
.if (${MACHINE_ARCH} == "i386") || (${MACHINE_ARCH} == "powerpc") || \
(${MACHINE_ARCH} == "sparc") || (${MACHINE_ARCH} == "x86_64") || \
(${MACHINE_ARCH} == "arm")
PLIST.opt= yes
.endif
.include "../../lang/ocaml/buildlink3.mk"
.include "../../devel/ocaml-findlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

12
archivers/ocaml-bz2/PLIST Normal file
View file

@ -0,0 +1,12 @@
@comment $NetBSD: PLIST,v 1.1 2012/09/16 12:30:46 jaapb Exp $
@unexec %D/libexec/ocaml-findlib-register del %D/lib/ocaml/site-lib/bz2
lib/ocaml/site-lib/bz2/META
${PLIST.opt}lib/ocaml/site-lib/bz2/bz2.a
lib/ocaml/site-lib/bz2/bz2.cma
${PLIST.opt}lib/ocaml/site-lib/bz2/bz2.cmx
${PLIST.opt}lib/ocaml/site-lib/bz2/bz2.cmxa
lib/ocaml/site-lib/bz2/bz2.cmi
lib/ocaml/site-lib/bz2/bz2.mli
lib/ocaml/site-lib/bz2/dllcamlbz2.so
lib/ocaml/site-lib/bz2/libcamlbz2.a
@exec %D/libexec/ocaml-findlib-register add %D/lib/ocaml/site-lib/bz2

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2012/09/16 12:30:46 jaapb Exp $
SHA1 (camlbz2-0.6.0.tar.gz) = c2bbff429b36eb60f5d410d7a6dbba2f0001a245
RMD160 (camlbz2-0.6.0.tar.gz) = 544cf2b105c44dcc3eee6495e25c7b516e2fff7a
Size (camlbz2-0.6.0.tar.gz) = 57771 bytes
SHA1 (patch-Makefile.in) = 461eaf03de4bafca9d174d7ad242b8c496b07742

View file

@ -0,0 +1,18 @@
$NetBSD: patch-Makefile.in,v 1.1 2012/09/16 12:30:46 jaapb Exp $
Install into the right DESTDIR
--- Makefile.in.orig 2008-11-08 11:19:40.000000000 +0000
+++ Makefile.in
@@ -43,10 +43,10 @@ install : findlib-install
ifeq ($(DESTDIR),)
DESTDIR_FLAGS =
else
-DESTDIR_FLAGS = -destdir $(DESTDIR)
+DESTDIR_FLAGS = -destdir $(DESTDIR)$(PREFIX)/lib/ocaml/site-lib/
findlib-install : install-mkdir
install-mkdir :
- test -d $(DESTDIR) || mkdir -p $(DESTDIR)
+ test -d $(DESTDIR)$(PREFIX)/lib/ocaml/site-lib/ || mkdir -p $(DESTDIR)$(PREFIX)/lib/ocaml/site-lib/
endif
else
install : normal-install