* Fix the really annoying bug where the video window doesn't attach to

the controller window even when you have it configured to do so.
* Look for DejaVu fonts in LOCALBASE not X11BASE, so the OSD works with
  native Xorg; explicitly depend on the dejavu-ttf package.
* Bump PKGREVISION
This commit is contained in:
jmcneill 2009-01-28 12:28:25 +00:00
parent 11c929eca1
commit 6748a4b320
3 changed files with 19 additions and 4 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.70 2008/12/19 23:28:40 jmcneill Exp $
# $NetBSD: Makefile,v 1.71 2009/01/28 12:28:25 jmcneill Exp $
#
DISTNAME= vlc-${VLC_VERSION}
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= http://download.videolan.org/pub/videolan/vlc/${VLC_VERSION}/
EXTRACT_SUFX= .tar.bz2
@ -95,7 +95,8 @@ pre-install:
# Let's use dejavu-ttf as it has nice unicode support
#
ORIGFNT= /usr/share/fonts/truetype/freefont/FreeSerifBold.ttf
DEFAULT_FONT?= ${X11BASE}/lib/X11/fonts/TTF/DejaVuSans.ttf
DEFAULT_FONT?= ${LOCALBASE}/lib/X11/fonts/TTF/DejaVuSans.ttf
DEPENDS+= dejavu-fonts-ttf>=2.26:../../fonts/dejavu-ttf
SUBST_CLASSES+= oss
SUBST_STAGE.oss= post-patch

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.24 2008/12/04 14:03:11 ahoka Exp $
$NetBSD: distinfo,v 1.25 2009/01/28 12:28:25 jmcneill Exp $
SHA1 (vlc-0.9.8a.tar.bz2) = 1d68f4e4ef77ffc9cb63de70a610a3969bffd873
RMD160 (vlc-0.9.8a.tar.bz2) = a9b57d9c6d99c5e3384914003afec974d1996f59
Size (vlc-0.9.8a.tar.bz2) = 17032727 bytes
SHA1 (patch-configure) = 0b69157981409067b42385ee5c81fc422f3842a2
SHA1 (patch-embedded-video) = 82c59d4bc62c22015cb6923fd1202a598525575d
SHA1 (patch-v4l2) = 54504b7e3bc41522db5c90983319c0c1ce1f3c8f

View file

@ -0,0 +1,13 @@
$NetBSD: patch-embedded-video,v 1.1 2009/01/28 12:28:25 jmcneill Exp $
--- modules/gui/qt4/qt4.cpp.orig 2008-11-09 13:11:18.000000000 -0500
+++ modules/gui/qt4/qt4.cpp
@@ -213,7 +213,7 @@ vlc_module_begin();
set_callbacks( OpenDialogs, Close );
-#if 0
+#if !defined(Q_QS_X11) || HAS_QT43
add_submodule();
set_capability( "vout window", 50 );
set_callbacks( WindowOpen, WindowClose );