mail/roundcube: update to 1.4.2

Update roundcube ot 1.4.2.
pkgsrc change:

* Use "complete" distfile and avoid downloading each JavaScript libraries.
* Use common patches/distinfo directory.
* Use REPLACE_PHP.

Here is release 1.4.0 announce (2019/11/09):

It's a big honor for me to announce the final release of the long awaited
major version 1.4 of Roundcube webmail.
After more than two years of hard work by Alec and other volunteer
contributors, Roundcube finally gets the responsive skin with full mobile
device support - the Elastic.

In addition to the new UI we introduce these new features:

* Email Resent (Bounce) feature
* Improved [Mailvelope](https://www.mailvelope.com) integration
* Support for Redis and Memcached cache
* Support for SMTPUTF8 and GSSAPI

Plus numerous improvements and bug fixes collected from your precious
feedback as well as updates to recent versions of 3rd party libraries like
jQuery and TinyMCE. See the full changelog in the release notes on the
Github download page [1].

The new Elastic theme, which is the new default skin, is built with LESS
and of course the sources are included. They allow a certain degree of
customization by adjusting some colors and variables using the
`_styles.less` and `_variables.less` files. Please consider customizing
your Roundcube installation in order to make phishing [2] harder. You'll
find guidance in the README.md file inside the skin folder.

This release is considered stable and we encourage you to update your
productive installations after carefully testing the upgrade scenario and
preparing your users to the significant changes in their webmail UI.
Download it from https://roundcube.net/download.

With the release of Roundcube 1.4.0, the previous stable release branches
1.3.x and 1.2.x will change into LTS low maintenance mode which means they
will only receive important security updates but no longer any regular
improvement updates. The 1.1.x series is no longer supported and maintained.

RELEASE 1.4.1 (2019/11/22)
-------------
- Elastic: Change HTML editor widget to improve form flow (#6992)
- Elastic: Fix position of mobile floating action button (#7038)
- Managesieve: Fix locked UI after opening filter frame (#7007)
- Fix PHP warning: "array_merge(): Expected parameter 2 to be an array, null given in sendmail.inc (#7003)
- Fix bug where cache keys could exceed length limit specified in db schema (#7004)
- Fix invalid Signature button state after escaping Mailvelope mode (#7015)
- Fix so 401 error is returned only on failed logon requests (#7010)
- Fix db_prefix handling in queries with `TRUNCATE TABLE <name>` and `UNIQUE <name>` (#7013)
- Fix so update.sh script warns about changed defaults (#7011)
- Fix tables listing routine when DSN contained a database with unsupported suffix (#7034)
- Fix so Elastic is also a default in jqueryui plugin (#7039)
- Fix bug where the Installer would not warn about required schema upgrade (#7042)

RELEASE 1.4.2 (2020/01/01)
-------------
- Plugin API: Make actionbefore, before<action>, actionafter and after<action> events working with plugin actions (#7106)
- Managesieve: Replace "Filter disabled" with "Filter enabled" (#7028)
- Managesieve: Fix so modifier type select wasn't hidden after hiding modifier select on header change
- Managesieve: Fix filter selection after removing a first filter (#7079)
- Markasjunk: Fix marking more than one message as spam/ham with email_learn driver (#7121)
- Installer: Fix DB Write test on SQLite database ("database is locked" error) (#7064)
- Installer: Fix so SQLite DSN with a relative path to the database file works in Installer
- Elastic: Fix contrast of warning toasts (#7058)
- Elastic: Simple search in pretty selects (#7072)
- Elastic: Fix hidden list widget on mobile/tablet when selecting folder while search menu is open (#7120)
- Fix so type attribute on script tags is not used on HTML5 pages (#6975)
- Fix unread count after purge on a folder that is not currently selected (#7051)
- Fix bug where Enter key didn't work on messages list in "List" layout (#7052)
- Fix bug where deleting a saved search in addressbook caused display issue on sources/groups list (#7061)
- Fix bug where a new saved search added after removing all searches wasn't added to the list (#7061)
- Fix bug where a new contact group added after removing all groups from addressbook wasn't added to the list
- Fix bug where Ctype extension wasn't required in Installer and INSTALL file (#7049)
- Fix so install-jsdeps.sh removes Bootstrap's sourceMappingURL (#7035)
- Fix so use of Ctrl+A does not scroll the list (#7020)
- Fix/remove useless keyup event handler on username input in logon form (#6970)
- Fix bug where cancelling switching from HTML to plain text didn't set the flag properly (#7077)
- Fix bug where HTML reply could add an empty line with extra indentation above the original message (#7088)
- Fix matching multiple X-Forwarded-For addresses with 'proxy_whitelist' (#7107)
- Fix so displayed maximum attachment size depends also on 'max_message_size' (#7105)
- Fix bug where 'skins_allowed' option didn't enforce user skin preference (#7080)
- Fix so contact's organization field accepts up to 128 characters (it was 50)
- Fix bug where listing tables in PostgreSQL database with db_prefix didn't work (#7093)
- Fix bug where 'text' attribute on body tag was ignored when displaying HTML message (#7109)
- Fix bug where next message wasn't displayed after delete in List mode (#7096)
- Fix so number of contacts in a group is not limited to 200 when redirecting to mail composer from Contacts (#6972)
- Fix malformed characters in HTML message with charset meta tag not in head (#7116)
This commit is contained in:
taca 2020-01-14 14:30:00 +00:00
parent 2cd23a9d64
commit 674a080a2c
7 changed files with 363 additions and 273 deletions

View file

@ -1,22 +1,12 @@
# $NetBSD: Makefile,v 1.91 2019/11/19 05:26:21 wiz Exp $
# $NetBSD: Makefile,v 1.92 2020/01/14 14:30:00 taca Exp $
DISTNAME= roundcubemail-${RC_VERS}
PKGNAME= ${PHP_PKG_PREFIX}-${DISTNAME:S/mail-/-/}
PKGREVISION= 1
PKGNAME= ${PHP_PKG_PREFIX}-${DISTNAME:S/mail-/-/:S/-complete//}
MAINTAINER= taca@NetBSD.org
COMMENT= Browser-based multilingual IMAP client
LICENSE= gnu-gpl-v3 AND mit AND gnu-lgpl-v2.1
# JavaScript dependencies from bin/install-jsdeps.sh
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
DISTFILES+= jquery-3.2.1.min.js
DISTFILES+= jstz.min.js
DISTFILES+= publickey.js
DISTFILES+= tinymce_4.5.8.zip
DISTFILES+= tinymce_languages.zip
DISTFILES+= codemirror-5.21.0.zip
DEPENDS+= ${PHP_PKG_PREFIX}-mbstring>=${PHP_BASE_VERS}:../../converters/php-mbstring
DEPENDS+= ${PHP_PKG_PREFIX}-exif>=${PHP_BASE_VERS}:../../graphics/php-exif
DEPENDS+= ${PHP_PKG_PREFIX}-intl>=${PHP_BASE_VERS}:../../textproc/php-intl
@ -30,22 +20,10 @@ DEPENDS+= ${PHP_PKG_PREFIX}-pear-Mail_Mime>=1.10.0:../../mail/pear-Mail_Mime
DEPENDS+= ${PHP_PKG_PREFIX}-pear-Auth_SASL>=1.0.6:../../mail/pear-Auth_SASL
RC_SUBDIRS= SQL bin installer plugins program skins
TMCE_SUBDIRS= langs plugins skins themes
CM_SUBDIRS= lib mode/sieve addon/selection
CONF_PLUGINS= acl additional_message_headers database_attachments \
emoticons help http_authentication jqueryui \
krb_authentication managesieve new_user_identity \
newmail_notifier redundant_attachments squirrelmail_usercopy
.for d in ${RC_SUBDIRS}
INSTALLATION_DIRS+= ${RCDIR}/${d}
.endfor
.for d in ${TMCE_SUBDIRS}
INSTALLATION_DIRS+= ${RCDIR}/program/js/tinymce/${d}
.endfor
.for d in ${CM_SUBDIRS}
INSTALLATION_DIRS+= ${RCDIR}/plugins/managesieve/codemirror/${d}
.endfor
INSTALLATION_DIRS+= ${DOCDIR} ${EGDIR}
@ -80,12 +58,18 @@ SUBST_SED.files+= -e "s|@PKG_EXAMPLES@|${PREFIX}/share/examples/roundcube|g"
SUBST_VARS.files+= PKG_SYSCONFBASE
SUBST_VARS.files+= PKG_SYSCONFDIR
REPLACE_INTERPRETER+= php
REPLACE.php.old= /usr/bin/env php
REPLACE.php.new= ${PREFIX}/bin/php
REPLACE_FILES.php= bin/*.sh
CONF_PLUGINS= acl additional_message_headers database_attachments \
emoticons help http_authentication jqueryui \
krb_authentication managesieve markasjunk \
new_user_identity newmail_notifier \
redundant_attachments squirrelmail_usercopy
RC_DOCS= CHANGELOG INSTALL LICENSE README.md UPGRADING
REPLACE_PHP= cleandb.sh decrypt.sh deluser.sh gc.sh \
indexcontacts.sh initdb.sh installto.sh \
moduserprefs.sh msgexport.sh msgimport.sh \
update.sh updatecss.sh updatedb.sh
post-extract:
pre-configure:
${CP} ${FILESDIR}/apache.conf ${WRKSRC}/apache.conf
${CP} ${FILESDIR}/lighttpd.conf ${WRKSRC}/lighttpd.conf
${CP} ${FILESDIR}/nginx.conf ${WRKSRC}/nginx.conf
@ -94,10 +78,9 @@ pre-install:
cd ${WRKSRC}/plugins && ${RM} -fr enigma password zipdownload
do-install:
${INSTALL_DATA} ${WRKSRC}/INSTALL ${DESTDIR}${PREFIX}/${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/LICENSE ${DESTDIR}${PREFIX}/${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${DESTDIR}${PREFIX}/${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/UPGRADING ${DESTDIR}${PREFIX}/${DOCDIR}
.for i in ${RC_DOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DESTDIR}${PREFIX}/${DOCDIR}
.endfor
${INSTALL_DATA} ${WRKSRC}/.htaccess ${DESTDIR}${PREFIX}/${RCDIR}
${INSTALL_DATA} ${WRKSRC}/index.php ${DESTDIR}${PREFIX}/${RCDIR}
.for i in ${RC_SUBDIRS}
@ -121,39 +104,6 @@ do-install:
${DESTDIR}${PREFIX}/${EGDIR}/config.inc.php
${INSTALL_DATA} ${WRKSRC}/config/defaults.inc.php \
${DESTDIR}${PREFIX}/${EGDIR}/defaults.inc.php
${INSTALL_DATA} ${WRKDIR}/jquery-3.2.1.min.js \
${DESTDIR}${PREFIX}/${RCDIR}/program/js/jquery.min.js
${INSTALL_DATA} ${WRKDIR}/jstz.min.js \
${DESTDIR}${PREFIX}/${RCDIR}/program/js/jstz.min.js
${INSTALL_DATA} ${WRKDIR}/publickey.js \
${DESTDIR}${PREFIX}/${RCDIR}/program/js/publickey.js
.for i in ${TMCE_SUBDIRS}
cd ${WRKDIR}/tinymce/js/tinymce/${i} && ${FIND} . -type f -print | \
pax -rw ${DESTDIR}${PREFIX}/${RCDIR}/program/js/tinymce/${i}
${FIND} ${DESTDIR}${PREFIX}/${RCDIR}/program/js/tinymce/${i} -type f | \
${XARGS} ${CHMOD} ${SHAREMODE}
${FIND} ${DESTDIR}${PREFIX}/${RCDIR}/program/js/tinymce/${i} -type d | \
${XARGS} ${CHMOD} ${PKGDIRMODE}
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DESTDIR}${PREFIX}/${RCDIR}/program/js/tinymce/${i}
.endfor
${INSTALL_DATA} ${WRKDIR}/tinymce/js/tinymce/tinymce.min.js \
${DESTDIR}${PREFIX}/${RCDIR}/program/js/tinymce/tinymce.min.js
cd ${WRKDIR}/langs && ${FIND} . -type f -print | \
pax -rw ${DESTDIR}${PREFIX}/${RCDIR}/program/js/tinymce/langs
${FIND} ${DESTDIR}${PREFIX}/${RCDIR}/program/js/tinymce/langs -type f | \
${XARGS} ${CHMOD} ${SHAREMODE}
${FIND} ${DESTDIR}${PREFIX}/${RCDIR}/program/js/tinymce/langs -type d | \
${XARGS} ${CHMOD} ${PKGDIRMODE}
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DESTDIR}${PREFIX}/${RCDIR}/program/js/tinymce/langs
.for i in ${CM_SUBDIRS}
cd ${WRKDIR}/codemirror-5.21.0/${i} && ${FIND} . -type f -print | \
pax -rw ${DESTDIR}${PREFIX}/${RCDIR}/plugins/managesieve/codemirror/${i}
${FIND} ${DESTDIR}${PREFIX}/${RCDIR}/plugins/managesieve/codemirror/${i} -type f | \
${XARGS} ${CHMOD} ${SHAREMODE}
${FIND} ${DESTDIR}${PREFIX}/${RCDIR}/plugins/managesieve/codemirror/${i} -type d | \
${XARGS} ${CHMOD} ${PKGDIRMODE}
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DESTDIR}${PREFIX}/${RCDIR}/plugins/managesieve/codemirror/${i}
.endfor
.include "Makefile.common"
.include "../../lang/php/phpversion.mk"

View file

@ -1,22 +1,25 @@
# $NetBSD: Makefile.common,v 1.15 2019/11/09 11:30:06 nia Exp $
# $NetBSD: Makefile.common,v 1.16 2020/01/14 14:30:00 taca Exp $
#
# used by mail/roundcube/Makefile
# used by mail/roundcube/plugins.mk
DISTNAME= roundcubemail-${RC_VERS}
DISTNAME= roundcubemail-${RC_VERS}-complete
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_GITHUB:=roundcube/}
GITHUB_PROJECT= roundcubemail
GITHUB_RELEASE= ${RC_VERS}
HOMEPAGE= https://roundcube.net/
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX}
DIST_SUBDIR= roundcube
RC_VERS= 1.3.10
RC_VERS= 1.4.2
USE_LANGUAGES= # none
USE_TOOLS+= pax
EXTRACT_USING= gtar
EXTRACT_USING= bsdtar
NO_BUILD= yes
WRKNAME= ${DISTNAME:S/-complete//}
WRKSRC= ${WRKDIR}/${WRKNAME}
DISTINFO_FILE?= ${PKGDIR}/../../mail/roundcube/distinfo
PKG_SYSCONFSUBDIR?= roundcube

File diff suppressed because it is too large Load diff

View file

@ -1,34 +1,10 @@
$NetBSD: distinfo,v 1.65 2019/09/01 13:08:09 taca Exp $
$NetBSD: distinfo,v 1.66 2020/01/14 14:30:00 taca Exp $
SHA1 (roundcube/codemirror-5.21.0.zip) = 3b767c2e3acd6796e54ed19ed2ac0755fcf87984
RMD160 (roundcube/codemirror-5.21.0.zip) = 3c629362a2a6c31aee099811b4598ba22e2fd763
SHA512 (roundcube/codemirror-5.21.0.zip) = e80bc2f66e49acc9c618237ceec5fe526a4bcb91acfd3035e82cef1a9313531a8dda5d8caec00ffe4e507266e2846e44e0562e8fe567415ef650cfcca7b9c659
Size (roundcube/codemirror-5.21.0.zip) = 1356111 bytes
SHA1 (roundcube/jquery-3.2.1.min.js) = 1055018c28ab41087ef9ccefe411606893dabea2
RMD160 (roundcube/jquery-3.2.1.min.js) = 3e2258f10b8d26c43b80b378db356dccb13f1e01
SHA512 (roundcube/jquery-3.2.1.min.js) = dcff2b5c2b8625d3593a7531ff4ddcd633939cc9f7acfeb79c18a9e6038fdaa99487960075502f159d44f902d965b0b5aed32b41bfa66a1dc07d85b5d5152b58
Size (roundcube/jquery-3.2.1.min.js) = 86659 bytes
SHA1 (roundcube/jstz.min.js) = 4291cd3b259d2060460c2a6ab99f428d3c0c9537
RMD160 (roundcube/jstz.min.js) = 7e1561a667d51e879eb79d57e6e69971c7e27bd8
SHA512 (roundcube/jstz.min.js) = 5de18a936d531d252ce82c3dc55661e5e8595ea39506a26f3d47ee625bf3de101194bfa681da43f1103e9e96dd4047858a2b4228ce67ad1eecc13cebfa09188a
Size (roundcube/jstz.min.js) = 12076 bytes
SHA1 (roundcube/publickey.js) = d0920e190754e024c4be76ad5bbc7e76b2e37a4d
RMD160 (roundcube/publickey.js) = 40ae054af69c621c77a24e7a77f6280b1c630c23
SHA512 (roundcube/publickey.js) = 443bb71b2e374e2c392ea2fba61ea1c5a78523aa9cf03846dc184ac937d967cf2f87f27529aaf82f0c982cb26b3d6423b202f6424eaf8d10c7478928b6efaa42
Size (roundcube/publickey.js) = 19078 bytes
SHA1 (roundcube/roundcubemail-1.3.10.tar.gz) = e47db672bedd8413837dbca073f81f4b17c2f131
RMD160 (roundcube/roundcubemail-1.3.10.tar.gz) = 88b33acaa6a01e053bcc5c8d061eb1b76a0c6b2a
SHA512 (roundcube/roundcubemail-1.3.10.tar.gz) = 3f7be9c0f41b8e551a4863e06928a073aacf5368ffa8b1d0acd8c26224a957e806b986f7bc5b88ac4c853f9c4eff3112cc66b1c90386660e4eab7fa747c3a5cc
Size (roundcube/roundcubemail-1.3.10.tar.gz) = 3127446 bytes
SHA1 (roundcube/tinymce_4.5.8.zip) = 08b0757264adb86066940bbafb7aa9ec0c7c6685
RMD160 (roundcube/tinymce_4.5.8.zip) = 68217fd86a7b359f2a3f233fd64f6d24ca0e6d53
SHA512 (roundcube/tinymce_4.5.8.zip) = 5d0d9315f226730394e5fb13f2ed19edcc974adb34533437d4fb2b35ec5a77368d37a3c60b39afd5e30beff90f26feb7713d027f1ab0fa708e6a6b597edd4be6
Size (roundcube/tinymce_4.5.8.zip) = 387375 bytes
SHA1 (roundcube/tinymce_languages.zip) = 4726119c65c3fcbe7ac1d0d2b3b0cac8f580ad76
RMD160 (roundcube/tinymce_languages.zip) = 372facd0ca877ad709278cf09b0a72d04556e55a
SHA512 (roundcube/tinymce_languages.zip) = 5d20984675cbe97e8a0300c9a10c566ad51f712ef6cb1fdb7a019b4e5df19446f2f615f4501bd21ce256b99c7c57a0e80d4e112f553b99e997aec64eb4a95984
Size (roundcube/tinymce_languages.zip) = 287381 bytes
SHA1 (patch-af) = 1f95a7005569207469563aa37ff48da0383b7668
SHA1 (patch-config_config.inc.php.sample) = 1c9751ba36394d592e7d3cdcc705010e0a4adda9
SHA1 (roundcubemail-1.4.2-complete.tar.gz) = d53fcd7f1109a63364d5d4a43f879c6f47d34a89
RMD160 (roundcubemail-1.4.2-complete.tar.gz) = f043c3e55156625a9f4a8f95aeab704502be9b9d
SHA512 (roundcubemail-1.4.2-complete.tar.gz) = 3f705bc38b44a0b7ea3241b0222f607b040ec01c8ea400b6b6222fbe346570c5f3450e5a188bab99ea171481453eb3f5b1e7457070ace1144558ec662a4273bb
Size (roundcubemail-1.4.2-complete.tar.gz) = 7006013 bytes
SHA1 (patch-af) = 7f29b0310a2a6b2e71858787e08b025e30d8bd12
SHA1 (patch-config_config.inc.php.sample) = 92a48a97b16fe3f5f4b9441fce762a559d8daca7
SHA1 (patch-plugins_password_helpers_passwd-expect) = 9e0082f23e37bbab26e8bb1439668132d5aacca2
SHA1 (patch-rcube_mime_default) = b1e9479d575b7fd61c413e2b76ee36c06ece7a5c

View file

@ -1,15 +1,15 @@
$NetBSD: patch-af,v 1.7 2013/06/16 22:04:07 taca Exp $
$NetBSD: patch-af,v 1.8 2020/01/14 14:30:00 taca Exp $
Honor PKG_SYSCONFDIR.
--- program/include/iniset.php.orig 2013-06-16 15:12:21.000000000 +0000
--- program/include/iniset.php.orig 2020-01-01 19:58:53.000000000 +0000
+++ program/include/iniset.php
@@ -29,7 +29,7 @@ if (!defined('INSTALL_PATH')) {
@@ -28,7 +28,7 @@ if (!defined('INSTALL_PATH')) {
}
if (!defined('RCMAIL_CONFIG_DIR')) {
- define('RCMAIL_CONFIG_DIR', INSTALL_PATH . 'config');
+ define('RCMAIL_CONFIG_DIR', '@PKG_SYSCONFDIR@');
- define('RCMAIL_CONFIG_DIR', getenv('ROUNDCUBE_CONFIG_DIR') ?: (INSTALL_PATH . 'config'));
+ define('RCMAIL_CONFIG_DIR', getenv('ROUNDCUBE_CONFIG_DIR') ?: '@PKG_SYSCONFDIR@');
}
if (!defined('RCUBE_LOCALIZATION_DIR')) {

View file

@ -1,13 +1,13 @@
$NetBSD: patch-config_config.inc.php.sample,v 1.1 2016/09/13 15:56:01 taca Exp $
$NetBSD: patch-config_config.inc.php.sample,v 1.2 2020/01/14 14:30:00 taca Exp $
Add default paths for log, tmp and MIME types.
--- config/config.inc.php.sample.orig 2016-04-17 16:22:20.000000000 +0000
--- config/config.inc.php.sample.orig 2020-01-01 19:58:53.000000000 +0000
+++ config/config.inc.php.sample
@@ -83,3 +83,10 @@ $config['plugins'] = array(
@@ -84,3 +84,10 @@ $config['plugins'] = array(
// skin name: folder from skins/
$config['skin'] = 'larry';
$config['skin'] = 'elastic';
+
+// use this folder to store log files (must be writeable for apache user)
+// This is used by the 'file' log driver.

View file

@ -1,4 +1,4 @@
# $NetBSD: plugins.mk,v 1.2 2018/04/30 06:44:11 taca Exp $
# $NetBSD: plugins.mk,v 1.3 2020/01/14 14:30:00 taca Exp $
#
# plugin's PKGNAME
@ -8,7 +8,7 @@ DEPENDS+= ${PHP_PKG_PREFIX}-roundcube>=${RC_VERS}:../../mail/roundcube
#
# a few parameters
EXTRACT_ELEMENTS?= ${DISTNAME}/${PLUGIN_DIR}
EXTRACT_ELEMENTS?= ${WRKNAME}/${PLUGIN_DIR}
PLUGIN_DIR?= plugins/${PLUGIN}
CONF_PLUGINS?= ${PLUGIN}
@ -23,7 +23,7 @@ CONF_FILES_PERMS+= ${EGDIR}/plugins/${f}/config.inc.php \
${WWW_USER} ${WWW_GROUP} 0640
.endfor
plugin-install:
do-install:
.for i in ${PLUGIN_DIR}
cd ${WRKSRC}/${i} && ${FIND} . -type f \! -name "*.orig" -print | \
${PAX} -rw ${DESTDIR}${PREFIX}/${RCDIR}/${i}