PR 45258 strikes again. Really fix build this time.
This commit is contained in:
parent
f48fe263dc
commit
676bca8428
6 changed files with 64 additions and 21 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.8 2011/10/09 06:40:38 dholland Exp $
|
||||
$NetBSD: distinfo,v 1.9 2011/10/11 00:29:41 dholland Exp $
|
||||
|
||||
SHA1 (efltk-2.0.5.tar.bz2) = 26f7124b384d0bfe3d28a73cbdf0111432b08d99
|
||||
RMD160 (efltk-2.0.5.tar.bz2) = 7efa711d0df8a01ee402e1866286265d294778e8
|
||||
|
@ -13,13 +13,13 @@ SHA1 (patch-ag) = 29799b2b0aeffbca82dbc98cb1e06eb62a7e595a
|
|||
SHA1 (patch-ah) = 32768bef3acc3e19b151fbfb87ad63d34cd2ec09
|
||||
SHA1 (patch-configure_in) = 4d5fad7b0b89e80f6a4e4958a3bdc3c6de572bd5
|
||||
SHA1 (patch-efltk_Fl__Flags_h) = 589ea469042b1271cc9591680f55db6858025db2
|
||||
SHA1 (patch-efltk_Fl__Int__List_h) = 766ae82ee67a90def27e0882b815e918b8cc6ca3
|
||||
SHA1 (patch-efltk_Fl__Int__List_h) = 8883eb41310736fae2a4a7d90119284d14ebe2fe
|
||||
SHA1 (patch-efltk_Fl__Text__Buffer.h) = 16eb6b48d0f06ac0f2074a0b61a782db7757663e
|
||||
SHA1 (patch-efltk_Fl__Widget_h) = a35acb6f3af14bd2fabbe1c67b92e80fe561a366
|
||||
SHA1 (patch-efltk_Fl__Window.h) = b97f04435b88e05ec4f642b0615575cf8d279dd7
|
||||
SHA1 (patch-efltk_db_Fl__Params_h) = 3e16bd8ddf1b700cc9ba516e312dc797f26e6546
|
||||
SHA1 (patch-efltk_db_Fl__Params_h) = 9bb8574d1558f6ca753e0d9845b6fdaebeac38b4
|
||||
SHA1 (patch-src_core_fl__draw__pixmap_cpp) = cd31ac6d730b257bb3e76c9525ad92f9ea0fa3aa
|
||||
SHA1 (patch-src_images_Fl__Png.cpp) = 0c2d3bf30a5542274048784aaf32256cc5466dea
|
||||
SHA1 (patch-src_widgets_Fl__Calendar_cpp) = fc0f83c5f64c074b0e33783cac5aaa072b21c999
|
||||
SHA1 (patch-src_widgets_Fl__Input_cpp) = 33c0eb6c582aeae66a40bd993ac7e5616a6fdf72
|
||||
SHA1 (patch-src_widgets_Fl__Text__Editor_cpp) = fff83662ee1efe9370e366aa12bf34cb7d26e165
|
||||
SHA1 (patch-src_widgets_Fl__Calendar_cpp) = fb44e30fbed6a48ccd0d07348440df503a7e945e
|
||||
SHA1 (patch-src_widgets_Fl__Input_cpp) = d1f30bf63ef2000a6b676d5a6205d93ddf1347f3
|
||||
SHA1 (patch-src_widgets_Fl__Text__Editor_cpp) = 6dc9f71019612cbac0fe5fffe0388069d8d23e3b
|
||||
|
|
|
@ -1,10 +1,19 @@
|
|||
$NetBSD: patch-efltk_Fl__Int__List_h,v 1.1 2011/10/02 03:44:10 dholland Exp $
|
||||
$NetBSD: patch-efltk_Fl__Int__List_h,v 1.2 2011/10/11 00:29:41 dholland Exp $
|
||||
|
||||
- fix LP64 build
|
||||
|
||||
--- efltk/Fl_Int_List.h~ 2003-07-03 20:36:35.000000000 +0000
|
||||
--- efltk/Fl_Int_List.h.orig 2003-07-03 20:36:35.000000000 +0000
|
||||
+++ efltk/Fl_Int_List.h
|
||||
@@ -43,7 +43,7 @@ public:
|
||||
@@ -22,6 +22,8 @@
|
||||
#ifndef _FL_INT_LIST_H_
|
||||
#define _FL_INT_LIST_H_
|
||||
|
||||
+#include <stdint.h>
|
||||
+
|
||||
#include "Fl_Ptr_List.h"
|
||||
|
||||
/** Fl_Int_List */
|
||||
@@ -43,7 +45,7 @@ public:
|
||||
char *to_string(const char *separator=",");
|
||||
void from_string(const char * s, const char * separator=",");
|
||||
|
||||
|
|
|
@ -1,10 +1,19 @@
|
|||
$NetBSD: patch-efltk_db_Fl__Params_h,v 1.1 2011/10/02 03:44:10 dholland Exp $
|
||||
$NetBSD: patch-efltk_db_Fl__Params_h,v 1.2 2011/10/11 00:29:41 dholland Exp $
|
||||
|
||||
- fix LP64 build
|
||||
|
||||
--- efltk/db/Fl_Params.h~ 2003-04-23 17:56:23.000000000 +0000
|
||||
--- efltk/db/Fl_Params.h.orig 2003-04-23 17:56:23.000000000 +0000
|
||||
+++ efltk/db/Fl_Params.h
|
||||
@@ -45,7 +45,7 @@ public:
|
||||
@@ -18,6 +18,8 @@
|
||||
#ifndef _FL_PARAMS_H_
|
||||
#define _FL_PARAMS_H_
|
||||
|
||||
+#include <stdint.h>
|
||||
+
|
||||
#include "../Fl_String.h"
|
||||
#include "../Fl_Variant.h"
|
||||
#include "../Fl_Ptr_List.h"
|
||||
@@ -45,7 +47,7 @@ public:
|
||||
void bind_clear() { m_bindParamIndexes.clear(); }
|
||||
void bind_add(unsigned bindIndex);
|
||||
unsigned bind_count() { return m_bindParamIndexes.count(); }
|
||||
|
|
|
@ -1,10 +1,19 @@
|
|||
$NetBSD: patch-src_widgets_Fl__Calendar_cpp,v 1.1 2011/10/02 03:44:10 dholland Exp $
|
||||
$NetBSD: patch-src_widgets_Fl__Calendar_cpp,v 1.2 2011/10/11 00:29:41 dholland Exp $
|
||||
|
||||
- fix LP64 build
|
||||
|
||||
--- src/widgets/Fl_Calendar.cpp~ 2003-05-30 08:46:58.000000000 +0000
|
||||
--- src/widgets/Fl_Calendar.cpp.orig 2003-05-30 08:46:58.000000000 +0000
|
||||
+++ src/widgets/Fl_Calendar.cpp
|
||||
@@ -43,13 +43,13 @@ static const int monthChanges[4] = {
|
||||
@@ -15,6 +15,8 @@
|
||||
* *
|
||||
***************************************************************************/
|
||||
|
||||
+#include <stdint.h>
|
||||
+
|
||||
#include <efltk/Fl_Calendar.h>
|
||||
#include <efltk/Fl.h>
|
||||
|
||||
@@ -43,13 +45,13 @@ static const int monthChanges[4] = {
|
||||
// Callback function for day buttons
|
||||
void Fl_Calendar::cbDayButtonClicked(Fl_Widget *button, void *param) {
|
||||
Fl_Calendar *c = (Fl_Calendar *)button->parent()->parent();
|
||||
|
|
|
@ -1,10 +1,18 @@
|
|||
$NetBSD: patch-src_widgets_Fl__Input_cpp,v 1.1 2011/10/02 03:44:10 dholland Exp $
|
||||
$NetBSD: patch-src_widgets_Fl__Input_cpp,v 1.2 2011/10/11 00:29:41 dholland Exp $
|
||||
|
||||
- fix LP64 build
|
||||
|
||||
--- src/widgets/Fl_Input.cpp~ 2003-06-22 21:36:13.000000000 +0000
|
||||
--- src/widgets/Fl_Input.cpp.orig 2003-06-22 21:36:13.000000000 +0000
|
||||
+++ src/widgets/Fl_Input.cpp
|
||||
@@ -59,7 +59,7 @@ static Fl_Menu_ *menu_ = &menu;
|
||||
@@ -40,6 +40,7 @@
|
||||
// For NLS stuff
|
||||
#include "../core/fl_internal.h"
|
||||
|
||||
+#include <stdint.h>
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#include <ctype.h>
|
||||
@@ -59,7 +60,7 @@ static Fl_Menu_ *menu_ = &menu;
|
||||
static void cb_menu(Fl_Widget *w, void *d)
|
||||
{
|
||||
if(!menu_widget) return;
|
||||
|
|
|
@ -1,10 +1,18 @@
|
|||
$NetBSD: patch-src_widgets_Fl__Text__Editor_cpp,v 1.1 2011/10/02 03:44:10 dholland Exp $
|
||||
$NetBSD: patch-src_widgets_Fl__Text__Editor_cpp,v 1.2 2011/10/11 00:29:41 dholland Exp $
|
||||
|
||||
- fix LP64 build
|
||||
|
||||
--- src/widgets/Fl_Text_Editor.cpp~ 2003-06-16 19:41:23.000000000 +0000
|
||||
--- src/widgets/Fl_Text_Editor.cpp.orig 2003-06-16 19:41:23.000000000 +0000
|
||||
+++ src/widgets/Fl_Text_Editor.cpp
|
||||
@@ -45,7 +45,7 @@ static void cb_menu(Fl_Widget *w, void *
|
||||
@@ -26,6 +26,7 @@
|
||||
#include <efltk/Fl.h>
|
||||
#include <efltk/Fl_Text_Editor.h>
|
||||
#include <efltk/Fl_Style.h>
|
||||
+#include <stdint.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
@@ -45,7 +46,7 @@ static void cb_menu(Fl_Widget *w, void *
|
||||
{
|
||||
if(!menu_widget) return;
|
||||
char *selection = 0;
|
||||
|
|
Loading…
Reference in a new issue