Initial import of FreeBSD's "xneko" port.

This commit is contained in:
tron 1998-02-17 23:26:49 +00:00
parent 5baa5aeaad
commit 676f8927c5
6 changed files with 67 additions and 0 deletions

20
x11/xneko/Makefile Normal file
View file

@ -0,0 +1,20 @@
# New ports collection makefile for: xneko
# Version required: 4.4BSD-Lite
# Date created: 22 December 1995
# Whom: markm
#
# $FreeBSD Id: Makefile,v 1.6 1997/03/12 08:21:35 asami Exp
#
DISTNAME= xneko
PKGNAME= xneko-4.4
CATEGORIES= x11 games
MASTER_SITES= ftp://ftp.cdrom.com/pub/bsd-sources/4.4BSD-Lite/usr/src/games/
MAINTAINER= markm@FreeBSD.ORG
USE_X11= yes
IGNOREFILES= ${DISTFILES}
WRKSRC= ${WRKDIR}/pub/bsd-sources/4.4BSD-Lite/usr/src/games/xneko
.include <bsd.port.mk>

1
x11/xneko/files/md5 Normal file
View file

@ -0,0 +1 @@
MD5 (xneko.tar.gz) = IGNORE

View file

@ -0,0 +1,37 @@
diff -udr ../xneko.BSD/Makefile ./Makefile
--- ../xneko.BSD/Makefile Tue Jun 1 03:46:11 1993
+++ ./Makefile Fri Dec 22 19:16:13 1995
@@ -1,8 +1,17 @@
# @(#)Makefile 8.1 (Berkeley) 5/31/93
PROG= xneko
-MAN6= xneko.0
-DPADD= ${LIBX} ${LIBM}
-LDADD= -lX11/X11 -lm
+MAN6= xneko.6
+
+DPADD+= ${X11BASE}/lib/libX11.a ${LIBM}
+CFLAGS+= -I${X11BASE}/include
+LDDESTDIR+= -L${X11BASE}/lib
+LDADD+= -lX11 -lm
+
+MANDIR= ${X11BASE}/man/man
+
+BINOWN= bin
+BINDIR= ${X11BASE}/bin
+BINMODE= 755
.include <bsd.prog.mk>
diff -udr ../xneko.BSD/xneko.c ./xneko.c
--- ../xneko.BSD/xneko.c Tue Jun 1 03:46:10 1993
+++ ./xneko.c Fri Dec 22 19:10:44 1995
@@ -139,6 +139,9 @@
#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+
#include <signal.h>
#include <math.h>
#include <sys/time.h>

1
x11/xneko/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
The classic BSD4.4 cat-and-mouse.

6
x11/xneko/pkg/DESCR Normal file
View file

@ -0,0 +1,6 @@
Xneko displays a window in which a cat chases your ``mouse''
cursor.
The word ``neko'' means ``cat'' in Japanese.
Masayuki Koba, 1990

2
x11/xneko/pkg/PLIST Normal file
View file

@ -0,0 +1,2 @@
bin/xneko
man/man6/xneko.6.gz