Initial import of NDTPD 2.1.1, a server for accessing CD-ROM books /

dictionaries with NDTP protocol.
This commit is contained in:
uebayasi 2002-03-15 07:19:58 +00:00
parent 58c0212d2f
commit 677723e078
8 changed files with 212 additions and 0 deletions

9
textproc/ndtpd/DESCR Normal file
View file

@ -0,0 +1,9 @@
NDTPD is a server for accessing CD-ROM books with NDTP (Network
Dictionary Transfer Protocol) on TCP. You can replace dserver with
NDTPD. NDTPD can run on UNIX derived systems. It supports to access
CD-ROM books of EB, EBG, EBXA and EPWING formats. CD-ROM books of
those formats are popular in Japan. Since CD-ROM books themseves are
stands on the ISO 9660 format, you can mount the discs by the same way
as other ISO 9660 discs.
-- Motoyuki Kasahara <m-kasahr@sra.co.jp>

10
textproc/ndtpd/MESSAGE Normal file
View file

@ -0,0 +1,10 @@
=============================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2002/03/15 07:19:58 uebayasi Exp $
You need to add a port entry to run NDTP. The default port is 2010 and
the entry in /etc/services will look like
ndtp 2010/tcp
Please read (well written) Info manuals for more details.
=============================================================================

45
textproc/ndtpd/Makefile Normal file
View file

@ -0,0 +1,45 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/03/15 07:19:58 uebayasi Exp $
DISTNAME= ndtpd-3.1.1
CATEGORIES= textproc japanese
MASTER_SITES= ftp://ftp.sra.co.jp/pub/net/ndtp/ndtpd/
PATCHFILES= ${DISTNAME}+.diff
PATCH_SITES= ${MASTER_SITES}
MAINTAINER= uebayasi@soum.co.jp
HOMEPAGE= http://www.sra.co.jp/people/m-kasahr/ndtpd/
COMMENT= Server for accessing CD-ROM books with NDTP
USE_BUILDLINK_ONLY= # Defined
USE_LIBTOOL= # Defined
GNU_CONFIGURE= # Defined
CONFIGURE_ARGS+=--localstatedir=${NDTPD_RUNDIR}
CONFIGURE_ARGS+=--with-logdir=${NDTPD_LOGDIR}
CONFIGURE_ARGS+=--with-eb
CONFIGURE_ARGS+=--with-eb-includes=${PREFIX}/include
CONFIGURE_ARGS+=--with-eb-libraries=${PREFIX}/lib
CONFIGURE_ARGS+=--with-zlib
MAKE_FLAGS+= INSTALL_INFO=${INSTALL_INFO}
# For INSTALL/DEINSTALL scripts.
CONF_FILES= ${NDTPD_CONFDIR}/ndtpd.conf.sample ${NDTPD_CONFDIR}/ndtpd.conf
OWN_DIRS= ${NDTPD_RUNDIR}/ndtpd
RCD_SCRIPT= ndtpd.sh
# Will be used not only for INSTALL but also ndtpd.sh.
FILES_SUBST+= NDTPD_RUNDIR=${NDTPD_RUNDIR:Q}
NDTPD_CONFDIR= ${PREFIX}/etc
NDTPD_LOGDIR= ${DESTDIR}/var/log
NDTPD_RUNDIR= ${DESTDIR}/var/run
post-build:
@${SED} ${FILES_SUBST_SED} ${FILESDIR}/ndtpd.sh >${WRKDIR}/ndtpd.sh
post-install:
@${INSTALL_DATA} ${WRKDIR}/ndtpd.sh ${PREFIX}/etc/rc.d/ndtpd.sh
.include "../../devel/gettext-lib/buildlink.mk"
.include "../../textproc/eb/buildlink.mk"
.include "../../mk/texinfo.mk"
.include "../../mk/bsd.pkg.install.mk"
.include "../../mk/bsd.pkg.mk"

19
textproc/ndtpd/PLIST Normal file
View file

@ -0,0 +1,19 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/03/15 07:19:58 uebayasi Exp $
etc/ndtpd.conf.sample
etc/rc.d/ndtpd.sh
@unexec install-info --delete %D/info/ndtpd-ja.info %D/info/dir
@unexec install-info --delete %D/info/ndtpd.info %D/info/dir
info/ndtpd-ja.info
info/ndtpd-ja.info-1
info/ndtpd-ja.info-2
info/ndtpd.info
info/ndtpd.info-1
info/ndtpd.info-2
@exec install-info %D/info/ndtpd-ja.info %D/info/dir
@exec install-info %D/info/ndtpd.info %D/info/dir
libexec/ndtpstat
sbin/ndtpd
sbin/ndtpcheck
sbin/ndtpcontrol
sbin/ndtpdaily
sbin/ndtpupgrade

8
textproc/ndtpd/distinfo Normal file
View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2002/03/15 07:19:58 uebayasi Exp $
SHA1 (ndtpd-3.1.1.tar.gz) = f5874d718abad3918584e3c4f34e762d8daed260
Size (ndtpd-3.1.1.tar.gz) = 541526 bytes
SHA1 (ndtpd-3.1.1+.diff) = 44df42112deeb6205bd1e4c753546168842630c7
Size (ndtpd-3.1.1+.diff) = 600 bytes
SHA1 (patch-aa) = a271f7debee44169e186e064538ea07451aa33eb
SHA1 (patch-ab) = 15334fa0332c5dc038b51451a2f99c822aac9199

View file

@ -0,0 +1,45 @@
#!/bin/sh
#
# $NetBSD: ndtpd.sh,v 1.1.1.1 2002/03/15 07:19:58 uebayasi Exp $
#
# PROVIDE: ndtpd
# REQUIRE: DAEMON
# KEYWORD: shutdown
#
# To start ndtpd at startup, copy this script to /etc/rc.d and set
# ndtpd=YES in /etc/rc.conf.
if [ -f /etc/rc.subr ]; then
. /etc/rc.subr
fi
name="ndtpd"
rcvar=$name
prog="@PREFIX@/sbin/ndtpd"
pidfile=@NDTPD_RUNDIR@/ndtpd/ndtpd.pid
case $1 in
start)
{ @ECHO@ "Starting ${name}."; ${prog} >/dev/null 2>&1; } || {
@ECHO@ "Configuration error?" >&2
@ECHO@ "Try @PREFIX@/sbin/ndtpdcheck" >&2
exit 1
}
;;
stop)
if [ -f ${pidfile} ]; then
pid=`@HEAD@ -1 ${pidfile}`
@ECHO@ "Stopping ${name}."
kill -s TERM ${pid}
else
@ECHO@ "${name} not running?"
exit 1
fi
;;
*)
@ECHO@ "Usage: $0 [start|stop]" 1>&2
exit 1
;;
esac
exit 0

View file

@ -0,0 +1,38 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/03/15 07:19:58 uebayasi Exp $
--- doc/Makefile.in.orig Wed Feb 13 23:39:03 2002
+++ doc/Makefile.in Fri Mar 15 01:05:22 2002
@@ -177,12 +177,12 @@
uninstall-info-am:
$(PRE_UNINSTALL)
- @if (install-info --version && \
- install-info --version | fgrep -i -v debian) >/dev/null 2>&1; then \
+ @if (${INSTALL_INFO} --version && \
+ ${INSTALL_INFO} --version | fgrep -i -v debian) >/dev/null 2>&1; then \
list='$(INFO_DEPS)'; \
for file in $$list; do \
- echo " install-info --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file"; \
- install-info --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file; \
+ echo " ${INSTALL_INFO} --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file"; \
+ ${INSTALL_INFO} --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file; \
done; \
else :; fi
@$(NORMAL_UNINSTALL)
@@ -311,12 +311,12 @@
done; \
done
@$(POST_INSTALL)
- @if (install-info --version && \
- install-info --version | fgrep -i -v debian) >/dev/null 2>&1; then \
+ @if (${INSTALL_INFO} --version && \
+ ${INSTALL_INFO} --version | fgrep -i -v debian) >/dev/null 2>&1; then \
list='$(INFO_DEPS)'; \
for file in $$list; do \
- echo " install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file";\
- install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file || :;\
+ echo " ${INSTALL_INFO} --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file";\
+ ${INSTALL_INFO} --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file || :;\
done; \
else : ; fi
install-man:

View file

@ -0,0 +1,38 @@
$NetBSD: patch-ab,v 1.1.1.1 2002/03/15 07:19:58 uebayasi Exp $
--- doc-ja/Makefile.in.orig Wed Feb 13 23:39:03 2002
+++ doc-ja/Makefile.in Fri Mar 15 01:05:22 2002
@@ -179,12 +179,12 @@
uninstall-info-am:
$(PRE_UNINSTALL)
- @if (install-info --version && \
- install-info --version | fgrep -i -v debian) >/dev/null 2>&1; then \
+ @if (${INSTALL_INFO} --version && \
+ ${INSTALL_INFO} --version | fgrep -i -v debian) >/dev/null 2>&1; then \
list='$(INFO_DEPS)'; \
for file in $$list; do \
- echo " install-info --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file"; \
- install-info --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file; \
+ echo " ${INSTALL_INFO} --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file"; \
+ ${INSTALL_INFO} --info-dir=$(DESTDIR)$(infodir) --remove $(DESTDIR)$(infodir)/$$file; \
done; \
else :; fi
@$(NORMAL_UNINSTALL)
@@ -314,12 +314,12 @@
done; \
done
@$(POST_INSTALL)
- @if (install-info --version && \
- install-info --version | fgrep -i -v debian) >/dev/null 2>&1; then \
+ @if (${INSTALL_INFO} --version && \
+ ${INSTALL_INFO} --version | fgrep -i -v debian) >/dev/null 2>&1; then \
list='$(INFO_DEPS)'; \
for file in $$list; do \
- echo " install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file";\
- install-info --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file || :;\
+ echo " ${INSTALL_INFO} --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file";\
+ ${INSTALL_INFO} --info-dir=$(DESTDIR)$(infodir) $(DESTDIR)$(infodir)/$$file || :;\
done; \
else : ; fi
install-man: