devel/php4-sysvshm: PHP4 extension for SysV shared memory support
This version is from the php-4.0.6 distribution.
This commit is contained in:
parent
b41383946e
commit
67ac44f25e
4 changed files with 33 additions and 0 deletions
13
devel/php4-sysvshm/Makefile
Normal file
13
devel/php4-sysvshm/Makefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2001/10/16 06:36:38 jlam Exp $
|
||||
|
||||
.include "../php4/Makefile.module"
|
||||
|
||||
MODNAME= sysvshm
|
||||
CATEGORIES+= devel
|
||||
PHP_PKG_VERS= # empty
|
||||
COMMENT= PHP4 extension for SysV shared memory support
|
||||
|
||||
USE_BUILDLINK_ONLY= YES
|
||||
CONFIGURE_ARGS+= --enable-${MODNAME}=shared,${BUILDLINK_DIR}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
5
devel/php4-sysvshm/distinfo
Normal file
5
devel/php4-sysvshm/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2001/10/16 06:36:38 jlam Exp $
|
||||
|
||||
SHA1 (php-4.0.6.tar.gz) = 6544eb1085b916541af914a11074e9bb8a037a03
|
||||
Size (php-4.0.6.tar.gz) = 3157346 bytes
|
||||
SHA1 (patch-aa) = 52d55439ab6184bf9bdcf181528d877ccbc46c15
|
13
devel/php4-sysvshm/patches/patch-aa
Normal file
13
devel/php4-sysvshm/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2001/10/16 06:36:38 jlam Exp $
|
||||
|
||||
--- sysvshm.c.orig Thu May 24 08:42:09 2001
|
||||
+++ sysvshm.c
|
||||
@@ -33,7 +33,7 @@
|
||||
#include <errno.h>
|
||||
|
||||
#include "php_sysvshm.h"
|
||||
-#include "../standard/php_var.h"
|
||||
+#include "ext/standard/php_var.h"
|
||||
|
||||
function_entry sysvshm_functions[] = {
|
||||
PHP_FE(shm_attach, NULL)
|
2
devel/php4-sysvshm/pkg/DESCR
Normal file
2
devel/php4-sysvshm/pkg/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
PHP is a programming language designed to be embedded into web pages.
|
||||
This module provides support for SysV shared memory in PHP4.
|
Loading…
Reference in a new issue