Include <machine/endian.h> on Darwin, and supply a fake <malloc.h>

if the system lacks one (trick borrowed from multimedia/smpeg).
Fixes build on Darwin.
This commit is contained in:
schmonz 2007-06-30 14:19:52 +00:00
parent f622125847
commit 67e138c0ba
3 changed files with 22 additions and 10 deletions

View file

@ -1,11 +1,11 @@
# $NetBSD: Makefile,v 1.5 2007/04/16 14:48:31 joerg Exp $
# $NetBSD: Makefile,v 1.6 2007/06/30 14:19:52 schmonz Exp $
#
DISTNAME= xfrac310
PKGNAME= xfractint-3.10
PKGREVISION= 1
CATEGORIES= math
MASTER_SITES= http://spanky.triumf.ca/pub/fractals/programs/unix/
MASTER_SITES= ${HOMEPAGE}
EXTRACT_SUFX= .zip
MAINTAINER= rillig@NetBSD.org
@ -25,6 +25,15 @@ INSTALLATION_DIRS= share/xfractint
MAKE_ENV+= X11_LDFLAGS=${X11_LDFLAGS:Q}
# xfractint sources assume <malloc.h> exists.
# Create a fake one for platforms that don't have it.
#
post-wrapper:
if ${TEST} ! -f /usr/include/malloc.h; then \
${ECHO} "#include <stdlib.h>" \
> ${BUILDLINK_DIR}/include/malloc.h; \
fi
.include "../../mk/curses.buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2007/04/16 14:48:31 joerg Exp $
$NetBSD: distinfo,v 1.6 2007/06/30 14:19:52 schmonz Exp $
SHA1 (xfrac310.zip) = 420de4ca20623b4fe6b6367a269e5525b6bff3af
RMD160 (xfrac310.zip) = ede481d77f8f5b71a6cef9d7ec4b2e09d9662f5b
@ -14,6 +14,6 @@ SHA1 (patch-ak) = 2d128d7575070d3452702f219aa51c468928f38a
SHA1 (patch-al) = 1954f3243be20ceb03c0e9d6dba86c2fd101ce89
SHA1 (patch-am) = ae214e36ff64009d18724e80638f1fa55544d19e
SHA1 (patch-an) = 5c4728b4d4ffa4ddd1ff904943af1484d75308f1
SHA1 (patch-ao) = c4c7f6d73f04a8a31503d84ca4ab4a2a64b7a9cd
SHA1 (patch-ao) = c9fb472e44bbc4d939fe00725be9b06fd8cecb26
SHA1 (patch-ap) = 87f6bc9db67554f600428e3369f83849b81d23fa
SHA1 (patch-aq) = 8202b8a7adc3e3badee6de0b395d912910aa6710

View file

@ -1,17 +1,20 @@
$NetBSD: patch-ao,v 1.2 2006/06/14 14:34:10 joerg Exp $
$NetBSD: patch-ao,v 1.3 2007/06/30 14:19:52 schmonz Exp $
--- port.h.orig 1999-09-06 17:38:10.000000000 +0200
+++ port.h 2006-06-15 08:52:47.000000000 +0200
@@ -42,7 +42,7 @@
--- port.h.orig 1999-09-06 11:38:10.000000000 -0400
+++ port.h
@@ -42,8 +42,10 @@
/* If endian.h is not present, it can be handled in the code below, */
/* but if you have this file, it can make it more fool proof. */
#if (defined(XFRACT) && !defined(__sun))
-#if defined(sgi)
+#if defined(sgi) || defined(__NetBSD__) || defined(__DragonFly__)
#include <sys/endian.h>
+#elif defined (__APPLE__)
+#include <machine/endian.h>
#else
#include <endian.h>
@@ -290,6 +290,9 @@ typedef int sigfunc(int);
#endif
@@ -290,6 +292,9 @@ typedef int sigfunc(int);
#ifdef sun
#define DO_NOT_USE_LONG_DOUBLE
#endif
@ -21,7 +24,7 @@ $NetBSD: patch-ao,v 1.2 2006/06/14 14:34:10 joerg Exp $
#ifndef DO_NOT_USE_LONG_DOUBLE
#ifdef LDBL_DIG
@@ -353,6 +356,7 @@ typedef int sigfunc(int);
@@ -353,6 +358,7 @@ typedef int sigfunc(int);
#define fabsl fabs
#define sinl sin
#define cosl cos