Don't try to use CE, just call clrtoeol() instead. Fixes build problems
against a libcurses from December 22, 2000 -current or later. Reported by Matt Green.
This commit is contained in:
parent
952fa0ef9f
commit
6834b177ab
2 changed files with 33 additions and 2 deletions
|
@ -1,4 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2001/04/17 11:30:15 agc Exp $
|
||||
$NetBSD: distinfo,v 1.2 2001/04/18 12:20:38 simonb Exp $
|
||||
|
||||
MD5 (zombies-1.0.tar.gz) = b7b185af6c89d5d3a8b9f9ee132218f4
|
||||
SHA1 (zombies-1.0.tar.gz) = 5bc4c87211b5aa29edffb7df74ee12c0bbdc408a
|
||||
Size (zombies-1.0.tar.gz) = 9482 bytes
|
||||
SHA1 (patch-aa) = 64fc0de367cf31fe93970932b94d7c26ce3a73d0
|
||||
SHA1 (patch-ab) = c17689d0b97e48e8d75c696809a77cf9664bcc4e
|
||||
|
|
29
games/zombies/patches/patch-ab
Normal file
29
games/zombies/patches/patch-ab
Normal file
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-ab,v 1.1 2001/04/18 12:20:38 simonb Exp $
|
||||
|
||||
--- main.c.orig Sat Jun 26 23:48:39 1999
|
||||
+++ main.c Wed Apr 18 22:11:45 2001
|
||||
@@ -212,21 +212,11 @@
|
||||
#ifndef _putchar
|
||||
extern int _putchar();
|
||||
#endif
|
||||
- extern char *CE;
|
||||
|
||||
mvcur(0, COLS - 1, LINES - 1, 0);
|
||||
-#ifndef SYSV
|
||||
- if (CE) { /* try to clear to end of line */
|
||||
- _puts(CE);
|
||||
- endwin();
|
||||
- }
|
||||
- else { /* otherwise move done a line */
|
||||
-#endif
|
||||
- endwin();
|
||||
- putchar('\n');
|
||||
-#ifndef SYSV
|
||||
- }
|
||||
-#endif
|
||||
+ clrtoeol();
|
||||
+ endwin();
|
||||
+ putchar('\n');
|
||||
exit(0);
|
||||
/* NOTREACHED */
|
||||
}
|
Loading…
Reference in a new issue