Adjust for changes done in the pkgsrc infrastructure to make this

package build again.
This commit is contained in:
kristerw 2005-04-15 21:58:32 +00:00
parent aebe5711b6
commit 684686b004
2 changed files with 98 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.12 2005/02/24 09:03:09 agc Exp $
$NetBSD: distinfo,v 1.13 2005/04/15 21:58:32 kristerw Exp $
SHA1 (nhc98src-1.16.tar.gz) = 7ca27c190d06462cab5d642726b7e5e73b61a7e4
RMD160 (nhc98src-1.16.tar.gz) = 52afba3e5c1190d4586d3125cca07083fbc4cb80
@ -10,3 +10,4 @@ SHA1 (patch-ad) = 53ff3bf9b71810c024df1ed04103964f0d65848f
SHA1 (patch-ae) = b3cebbf940f03cfb250743991f52b2b7999f923f
SHA1 (patch-af) = 0036a99ddd54f86679faa2d564fab1297aa00273
SHA1 (patch-ag) = 613b06d92328ff649ea8d3cd198b058f0354654a
SHA1 (patch-ah) = 72ea669ae55695b0377e647174e16dfc531b1a2e

View file

@ -0,0 +1,96 @@
$NetBSD: patch-ah,v 1.1 2005/04/15 21:58:32 kristerw Exp $
--- Makefile.orig Fri Apr 15 23:07:16 2005
+++ Makefile Fri Apr 15 23:10:52 2005
@@ -132,13 +132,13 @@
TARGDIR= targets
TARGETS= runtime prelude libraries greencard hp2graph \
- profruntime profprelude profprelude-$(CC) \
- timeruntime timeprelude timeprelude-$(CC) \
+ profruntime profprelude profprelude-${BUILDCOMP} \
+ timeruntime timeprelude timeprelude-${BUILDCOMP} \
timetraceruntime timetraceprelude \
- compiler-nhc compiler-hbc compiler-ghc compiler-$(CC) \
- hmake-nhc hmake-hbc hmake-ghc hmake-$(CC) \
- greencard-nhc greencard-hbc greencard-ghc greencard-$(CC) \
- prelude-$(CC) pragma-$(CC) libraries-$(CC)
+ compiler-nhc compiler-hbc compiler-ghc compiler-${BUILDCOMP} \
+ hmake-nhc hmake-hbc hmake-ghc hmake-${BUILDCOMP} \
+ greencard-nhc greencard-hbc greencard-ghc greencard-${BUILDCOMP} \
+ prelude-${BUILDCOMP} pragma-${BUILDCOMP} libraries-${BUILDCOMP}
.PHONY: default basic all compiler help config install
@@ -173,10 +173,10 @@
libraries
basic-ghc: $(PRAGMA) runtime hmake-ghc greencard-ghc compiler-ghc prelude \
libraries
-basic-$(CC): runtime prelude-$(CC) pragma-$(CC) compiler-$(CC) \
- greencard-$(CC) hmake-$(CC) libraries-$(CC)
+basic-${BUILDCOMP}: runtime prelude-${BUILDCOMP} pragma-${BUILDCOMP} compiler-${BUILDCOMP} \
+ greencard-${BUILDCOMP} hmake-${BUILDCOMP} libraries-${BUILDCOMP}
-all-$(BUILDCOMP): basic-$(BUILDCOMP) heapprofile timeprofile #hoodui
+all-${BUILDCOMP}: basic-$(BUILDCOMP) heapprofile timeprofile #hoodui
heapprofile: compiler profruntime profprelude-$(BUILDCOMP) hp2graph
timeprofile: compiler timeruntime timeprelude-$(BUILDCOMP)
@@ -275,41 +275,41 @@
touch $(TARGDIR)/$(MACHINE)/timeprelude
-$(TARGDIR)/$(MACHINE)/prelude-$(CC): $(PRELUDEC)
+$(TARGDIR)/$(MACHINE)/prelude-${BUILDCOMP}: $(PRELUDEC)
cd src/prelude; $(MAKE) fromC relink
- touch $(TARGDIR)/$(MACHINE)/prelude-$(CC)
+ touch $(TARGDIR)/$(MACHINE)/prelude-${BUILDCOMP}
touch $(TARGDIR)/$(MACHINE)/prelude
-$(TARGDIR)/$(MACHINE)/timeprelude-$(CC): $(PRELUDEC)
+$(TARGDIR)/$(MACHINE)/timeprelude-${BUILDCOMP}: $(PRELUDEC)
cd src/prelude; $(MAKE) CFG=z fromC
cd src/prelude/$(MACHINE)/NHC; $(MAKE) CFG=z clean all
cd src/prelude; $(MAKE) CFG=z relink
- touch $(TARGDIR)/$(MACHINE)/timeprelude-$(CC)
+ touch $(TARGDIR)/$(MACHINE)/timeprelude-${BUILDCOMP}
touch $(TARGDIR)/$(MACHINE)/timeprelude
-$(TARGDIR)/$(MACHINE)/profprelude-$(CC): $(PRELUDEC)
+$(TARGDIR)/$(MACHINE)/profprelude-${BUILDCOMP}: $(PRELUDEC)
cd src/prelude; $(MAKE) CFG=p fromC
cd src/prelude/$(MACHINE)/NHC; $(MAKE) CFG=p clean all
cd src/prelude; $(MAKE) CFG=p relink
- touch $(TARGDIR)/$(MACHINE)/profprelude-$(CC)
+ touch $(TARGDIR)/$(MACHINE)/profprelude-${BUILDCOMP}
touch $(TARGDIR)/$(MACHINE)/profprelude
-$(TARGDIR)/$(MACHINE)/compiler-$(CC): $(COMPILERC)
+$(TARGDIR)/$(MACHINE)/compiler-${BUILDCOMP}: $(COMPILERC)
cd src/compiler98; $(MAKE) fromC
cd src/prelude/$(MACHINE)/NHC; $(MAKE) clean all # Patch machine-specific parts.
cd src/prelude; $(MAKE) relink
cd src/compiler98; $(MAKE) relink
- touch $(TARGDIR)/$(MACHINE)/compiler-$(CC)
-$(TARGDIR)/$(MACHINE)/greencard-$(CC): $(GREENCARDC)
+ touch $(TARGDIR)/$(MACHINE)/compiler-${BUILDCOMP}
+$(TARGDIR)/$(MACHINE)/greencard-${BUILDCOMP}: $(GREENCARDC)
cd src/greencard; $(MAKE) fromC
- touch $(TARGDIR)/$(MACHINE)/greencard $(TARGDIR)/$(MACHINE)/greencard-$(CC)
-$(TARGDIR)/$(MACHINE)/pragma-$(CC): script/hmake-PRAGMA.hc
+ touch $(TARGDIR)/$(MACHINE)/greencard $(TARGDIR)/$(MACHINE)/greencard-${BUILDCOMP}
+$(TARGDIR)/$(MACHINE)/pragma-${BUILDCOMP}: script/hmake-PRAGMA.hc
script/nhc98 -o $(PRAGMA) script/hmake-PRAGMA.hc
- touch $(TARGDIR)/$(MACHINE)/pragma-$(CC)
-$(TARGDIR)/$(MACHINE)/hmake-$(CC): $(HMAKEC)
+ touch $(TARGDIR)/$(MACHINE)/pragma-${BUILDCOMP}
+$(TARGDIR)/$(MACHINE)/hmake-${BUILDCOMP}: $(HMAKEC)
cd src/hmake; $(MAKE) fromC config
cd src/interpreter; $(MAKE) fromC
- touch $(TARGDIR)/$(MACHINE)/hmake-$(CC)
-$(TARGDIR)/$(MACHINE)/libraries-$(CC): $(LIBRARIES)
+ touch $(TARGDIR)/$(MACHINE)/hmake-${BUILDCOMP}
+$(TARGDIR)/$(MACHINE)/libraries-${BUILDCOMP}: $(LIBRARIES)
cd src/libraries/base; $(MAKE) -f Makefile.nhc98 fromC
- touch $(TARGDIR)/$(MACHINE)/libraries-$(CC)
+ touch $(TARGDIR)/$(MACHINE)/libraries-${BUILDCOMP}
script/errnogen.c: script/GenerateErrNo.hs