Viking is a free/open source program to manage GPS data. You can import and
plot tracks and waypoints, show Open Street Maps and/or Terraserver maps under it, download geocaches for an area on the map, make new tracks and waypoints, see real-time GPS position, etc.
This commit is contained in:
parent
b9feab6335
commit
68501c8a22
5 changed files with 87 additions and 0 deletions
4
geography/viking/DESCR
Normal file
4
geography/viking/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Viking is a free/open source program to manage GPS data. You can import and
|
||||
plot tracks and waypoints, show Open Street Maps and/or Terraserver maps under
|
||||
it, download geocaches for an area on the map, make new tracks and waypoints,
|
||||
see real-time GPS position, etc.
|
31
geography/viking/Makefile
Normal file
31
geography/viking/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/03/11 14:18:30 gdt Exp $
|
||||
#
|
||||
|
||||
DISTNAME= viking-0.9.8
|
||||
CATEGORIES= geography
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=viking/}
|
||||
|
||||
MAINTAINER= gdt@NetBSD.org
|
||||
HOMEPAGE= http://viking.sourceforge.net/
|
||||
COMMENT= Viking manages GPS data, supports Open Street Map and geocaching
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
DEPENDS+= gpsbabel-[0-9]*:../../geography/gpsbabel
|
||||
REPLACE_PERL= viking-remote
|
||||
|
||||
USE_TOOLS+= intltool
|
||||
USE_TOOLS+= gmake
|
||||
USE_TOOLS+= msgfmt
|
||||
|
||||
USE_DIRS+= xdg-1.4
|
||||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../geography/gpsd/buildlink3.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../lang/perl5/buildlink3.mk"
|
||||
.include "../../www/curl/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
27
geography/viking/PLIST
Normal file
27
geography/viking/PLIST
Normal file
|
@ -0,0 +1,27 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/03/11 14:18:30 gdt Exp $
|
||||
bin/viking
|
||||
bin/viking-remote
|
||||
share/applications/viking.desktop
|
||||
share/icons/hicolor/48x48/apps/viking.png
|
||||
share/locale/cs/LC_MESSAGES/viking.mo
|
||||
share/locale/da/LC_MESSAGES/viking.mo
|
||||
share/locale/de/LC_MESSAGES/viking.mo
|
||||
share/locale/el/LC_MESSAGES/viking.mo
|
||||
share/locale/es/LC_MESSAGES/viking.mo
|
||||
share/locale/fr/LC_MESSAGES/viking.mo
|
||||
share/locale/he/LC_MESSAGES/viking.mo
|
||||
share/locale/it/LC_MESSAGES/viking.mo
|
||||
share/locale/ja/LC_MESSAGES/viking.mo
|
||||
share/locale/lt/LC_MESSAGES/viking.mo
|
||||
share/locale/nb/LC_MESSAGES/viking.mo
|
||||
share/locale/nl/LC_MESSAGES/viking.mo
|
||||
share/locale/pl/LC_MESSAGES/viking.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/viking.mo
|
||||
share/locale/ru/LC_MESSAGES/viking.mo
|
||||
share/locale/sl/LC_MESSAGES/viking.mo
|
||||
share/locale/sv/LC_MESSAGES/viking.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/viking.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/viking.mo
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/48x48/apps
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor
|
||||
@comment in xdg-dirs: @dirrm share/applications
|
6
geography/viking/distinfo
Normal file
6
geography/viking/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/03/11 14:18:30 gdt Exp $
|
||||
|
||||
SHA1 (viking-0.9.8.tar.gz) = fa36293c6e926a20c6d209cbe6e1e0657e83e11d
|
||||
RMD160 (viking-0.9.8.tar.gz) = 01484eaf1453b9cb8302a14161290d1c2714dbc0
|
||||
Size (viking-0.9.8.tar.gz) = 778565 bytes
|
||||
SHA1 (patch-aa) = 24dba675c4aeacef6541f474edd90b7457d98d02
|
19
geography/viking/patches/patch-aa
Normal file
19
geography/viking/patches/patch-aa
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/03/11 14:18:30 gdt Exp $
|
||||
|
||||
--- src/gpspoint.c.orig 2009-02-08 14:47:01.000000000 +0100
|
||||
+++ src/gpspoint.c
|
||||
@@ -81,8 +81,14 @@ static gdouble line_altitude = VIK_DEFAU
|
||||
static gboolean line_visible = TRUE;
|
||||
|
||||
static gboolean line_extended = FALSE;
|
||||
+/* Work around a bug in NetBSD. See PR standards/40695 */
|
||||
+#if defined(__NetBSD__) && __GNUC_PREREQ__(3,3)
|
||||
+static gdouble line_speed = __builtin_nanf("");
|
||||
+static gdouble line_course = __builtin_nanf("");
|
||||
+#else /* NetBSD */
|
||||
static gdouble line_speed = NAN;
|
||||
static gdouble line_course = NAN;
|
||||
+#endif /* NetBSD */
|
||||
static gint line_sat = 0;
|
||||
static gint line_fix = 0;
|
||||
/* other possible properties go here */
|
Loading…
Reference in a new issue