Make the disk krells use and display the correct names. Pointed out by
xtraeme@.
This commit is contained in:
parent
65ee24230e
commit
689624bd1e
2 changed files with 5 additions and 7 deletions
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.25 2004/06/07 17:01:50 cube Exp $
|
||||
$NetBSD: distinfo,v 1.26 2004/06/07 17:28:44 cube Exp $
|
||||
|
||||
SHA1 (gkrellm-2.2.1.tar.bz2) = 4a4d296a61307b3a0b93da035c07e301ed474dbc
|
||||
Size (gkrellm-2.2.1.tar.bz2) = 663952 bytes
|
||||
SHA1 (patch-aa) = e7d7dc8f3189632a8a0855c3fc39479482407cc4
|
||||
SHA1 (patch-ab) = 90359656530804804bf231cbde3d1c38dab559a7
|
||||
SHA1 (patch-ab) = 9688dc53a784d808e79d04bbccd382305e6e2276
|
||||
SHA1 (patch-ac) = 8890d5a5e8eaf21508a1bf91de788183fd6f7a75
|
||||
SHA1 (patch-ad) = c33319783a40ad64f43015200047656efc1bcdb3
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: patch-ab,v 1.11 2004/06/07 17:01:50 cube Exp $
|
||||
$NetBSD: patch-ab,v 1.12 2004/06/07 17:28:44 cube Exp $
|
||||
|
||||
--- src/sysdeps/netbsd.c.orig 2004-05-01 19:46:38.000000000 +0200
|
||||
+++ src/sysdeps/netbsd.c
|
||||
|
@ -171,7 +171,7 @@ $NetBSD: patch-ab,v 1.11 2004/06/07 17:01:50 cube Exp $
|
|||
gboolean found_sensors = FALSE;
|
||||
|
||||
/* check if some sensor is configured */
|
||||
@@ -336,3 +421,70 @@ gkrellm_sys_sensors_init(void)
|
||||
@@ -336,3 +421,68 @@ gkrellm_sys_sensors_init(void)
|
||||
return found_sensors;
|
||||
}
|
||||
|
||||
|
@ -200,7 +200,6 @@ $NetBSD: patch-ab,v 1.11 2004/06/07 17:01:50 cube Exp $
|
|||
+{
|
||||
+ int i, n_disks, mib[3] = { CTL_HW, HW_DISKSTATS, sizeof(struct disk_sysctl) };
|
||||
+ size_t size;
|
||||
+ char buf[20];
|
||||
+ guint64 rbytes, wbytes;
|
||||
+ struct disk_sysctl *dk_drives;
|
||||
+
|
||||
|
@ -223,8 +222,7 @@ $NetBSD: patch-ab,v 1.11 2004/06/07 17:01:50 cube Exp $
|
|||
+ wbytes = 0;
|
||||
+#endif
|
||||
+
|
||||
+ snprintf(buf, sizeof(buf), "%s%c", _("Disk"), 'A' + i);
|
||||
+ gkrellm_disk_assign_data_by_name(buf, rbytes, wbytes);
|
||||
+ gkrellm_disk_assign_data_by_name(dk_drives[i].dk_name, rbytes, wbytes);
|
||||
+ }
|
||||
+
|
||||
+ free(dk_drives);
|
||||
|
|
Loading…
Reference in a new issue