gcc5: don't try to make references to stack_chk_fail_local on netbsd/sun
sun was added as joyent is patching for the same. this code is only reached if compiling for i386 (or some variation of ppc) netbsd's stack_chk_fail_local won't work for this. PR pkg/53436
This commit is contained in:
parent
4bee1dfcc9
commit
689977ef54
4 changed files with 23 additions and 5 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.12 2017/10/20 23:50:19 maya Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2018/07/18 22:42:57 maya Exp $
|
||||
|
||||
GCC_PKGNAME= gcc5
|
||||
.include "../../lang/${GCC_PKGNAME}/version.mk"
|
||||
|
@ -9,7 +9,7 @@ PKGNAME= ${GCC_PKGNAME}-libs-${GCC5_DIST_VERSION}
|
|||
## The PKGREVISION of this package needs to be at least 1 more than the
|
||||
## PKGREVISION of the lang/gcc5 package so that with the dependence pattern
|
||||
## '{gcc5,gcc5-libs}>=5.1.*' pkg_add will choose gcc5-libs over gcc5.
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= # empty
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.28 2018/07/18 00:06:20 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.29 2018/07/18 22:42:57 maya Exp $
|
||||
|
||||
GCC_PKGNAME= gcc5
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
.include "version.mk"
|
||||
|
||||
DISTNAME= gcc-${GCC5_DIST_VERSION}
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.18 2017/10/20 23:49:47 maya Exp $
|
||||
$NetBSD: distinfo,v 1.19 2018/07/18 22:42:57 maya Exp $
|
||||
|
||||
SHA1 (gcc-5.5.0.tar.xz) = 0d985aaf6d63598916933a690cb902d47d385bea
|
||||
RMD160 (gcc-5.5.0.tar.xz) = 63fdc006c2289f81df664d1fd9b4124f71732e7b
|
||||
|
@ -25,6 +25,7 @@ SHA1 (patch-gcc_configure) = d6cc6a0bd257829ca2fd077a852fc447acaa63a0
|
|||
SHA1 (patch-gcc_ggc-common.c) = a5d2dba635859f5d680c3f80d7c30b42461c752b
|
||||
SHA1 (patch-gcc_lto_lto.c) = 825b632e2a7ff5777d4fbfdcf6f0ea3f64c4742b
|
||||
SHA1 (patch-gcc_system.h) = 4c959a6b1c4d524cbdf44cfb80f0e5758ec20783
|
||||
SHA1 (patch-gcc_targhooks.c) = b4389cc6e2490e8ee3d4dd60d84e32dee8473648
|
||||
SHA1 (patch-libcilkrts_configure) = d52de4f104bd4c7c9f200d7ce45d782cccfe73bf
|
||||
SHA1 (patch-libcilkrts_runtime_os-unix.c) = 653c5e3486d09bddae6a384edc2a3b3f2c95f74b
|
||||
SHA1 (patch-libdecnumber_decNumber.c) = cec90e49c829bfc6ba1ec605d2fac7daaad62762
|
||||
|
|
17
lang/gcc5/patches/patch-gcc_targhooks.c
Normal file
17
lang/gcc5/patches/patch-gcc_targhooks.c
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-gcc_targhooks.c,v 1.1 2018/07/18 22:42:57 maya Exp $
|
||||
|
||||
PR pkg/53436
|
||||
netbsd can't handle hidden reference to stack_chk_fail_local.
|
||||
(note: this code is only happening if targeting i386)
|
||||
|
||||
--- gcc/targhooks.c.orig 2016-03-03 13:52:57.000000000 +0000
|
||||
+++ gcc/targhooks.c
|
||||
@@ -772,7 +772,7 @@ default_external_stack_protect_fail (voi
|
||||
tree
|
||||
default_hidden_stack_protect_fail (void)
|
||||
{
|
||||
-#ifndef HAVE_GAS_HIDDEN
|
||||
+#if !defined(HAVE_GAS_HIDDEN) || defined(__NetBSD__) || defined(__sun)
|
||||
return default_external_stack_protect_fail ();
|
||||
#else
|
||||
tree t = stack_chk_fail_decl;
|
Loading…
Reference in a new issue