Match return types and return usage.
This commit is contained in:
parent
d39cfec15d
commit
68a7697f3b
3 changed files with 45 additions and 1 deletions
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.2 2006/03/25 20:00:34 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.3 2013/03/28 21:39:32 joerg Exp $
|
||||
|
||||
SHA1 (pcmanfm-0.1.8.9.tar.gz) = 12415788dfa93cb767329c45caef32b23e9ab9e6
|
||||
RMD160 (pcmanfm-0.1.8.9.tar.gz) = b75784afa73509de6aa0de33ba3e65cc78296773
|
||||
Size (pcmanfm-0.1.8.9.tar.gz) = 261303 bytes
|
||||
SHA1 (patch-aa) = d97b81fa583de90973e6339eadf7570931f8d53e
|
||||
SHA1 (patch-src_filebrowser.c) = 58ac8013594f610f613833455e15245080cf6eef
|
||||
SHA1 (patch-src_fileoperation.c) = 340d7c1c0cea6d68b9dba69b7f284095f6b1f8ee
|
||||
|
|
29
sysutils/pcmanfm/patches/patch-src_filebrowser.c
Normal file
29
sysutils/pcmanfm/patches/patch-src_filebrowser.c
Normal file
|
@ -0,0 +1,29 @@
|
|||
$NetBSD: patch-src_filebrowser.c,v 1.1 2013/03/28 21:39:32 joerg Exp $
|
||||
|
||||
--- src/filebrowser.c.orig 2013-03-28 20:32:19.000000000 +0000
|
||||
+++ src/filebrowser.c
|
||||
@@ -1193,13 +1193,13 @@ gboolean update_folder_view_visible_regi
|
||||
if( data->view_mode == FBVM_ICON_VIEW ) {
|
||||
if( !ptk_icon_view_get_visible_range ( PTK_ICON_VIEW(folder_view),
|
||||
&start_path, &end_path ) )
|
||||
- return;
|
||||
+ return FALSE;
|
||||
model = ptk_icon_view_get_model( PTK_ICON_VIEW(folder_view) );
|
||||
}
|
||||
else if( data->view_mode == FBVM_LIST_VIEW ) {
|
||||
if( !gtk_tree_view_get_visible_range ( GTK_TREE_VIEW(folder_view),
|
||||
&start_path, &end_path ) )
|
||||
- return;
|
||||
+ return FALSE;
|
||||
model = gtk_tree_view_get_model( GTK_TREE_VIEW(folder_view) );
|
||||
}
|
||||
|
||||
@@ -1216,7 +1216,7 @@ gboolean update_folder_view_visible_regi
|
||||
gtk_tree_path_free( start_path );
|
||||
if( end_path )
|
||||
gtk_tree_path_free( end_path );
|
||||
- return;
|
||||
+ return FALSE;
|
||||
}
|
||||
|
||||
model_sorter = PTK_TREE_MODEL_SORT( gtk_tree_model_filter_get_model(
|
13
sysutils/pcmanfm/patches/patch-src_fileoperation.c
Normal file
13
sysutils/pcmanfm/patches/patch-src_fileoperation.c
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-src_fileoperation.c,v 1.1 2013/03/28 21:39:32 joerg Exp $
|
||||
|
||||
--- src/fileoperation.c.orig 2013-03-28 20:33:04.000000000 +0000
|
||||
+++ src/fileoperation.c
|
||||
@@ -347,7 +347,7 @@ file_operation_copy_do ( const char* src
|
||||
|
||||
check_cancel( file_operation );
|
||||
if( file_operation->state == FOS_CANCELLED ) {
|
||||
- return NULL;
|
||||
+ return;
|
||||
}
|
||||
|
||||
file_operation->current_file = src_file;
|
Loading…
Reference in a new issue