-to avoid a different set of applets to be built if py-gnome2-desktop
is installed, require it and build invest-applet properly -patch bashisms in makefiles so that .svg icons are installed properly -bump PKGREVISION
This commit is contained in:
parent
6d80e7cf48
commit
68c669d67d
5 changed files with 81 additions and 6 deletions
|
@ -1,7 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.76 2007/04/11 18:28:13 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.77 2007/04/17 17:59:06 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gnome-applets-2.18.0
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= x11 gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-applets/2.18/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -72,6 +73,10 @@ BUILDLINK_API_DEPENDS.gnome-vfs2+= gnome-vfs2>=2.16.0
|
|||
BUILDLINK_API_DEPENDS.gnome-panel+= gnome-panel>=2.13.4
|
||||
BUILDLINK_API_DEPENDS.gtk2+= gtk2+>=2.6.0
|
||||
|
||||
PY_PATCHPLIST= yes
|
||||
PYTHON_PATCH_SCRIPTS+= invest-applet/invest/invest-applet.py
|
||||
PYTHON_PATCH_SCRIPTS+= invest-applet/invest/invest-chart
|
||||
|
||||
.include "../../devel/gail/buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
|
@ -95,7 +100,10 @@ BUILDLINK_API_DEPENDS.gtk2+= gtk2+>=2.6.0
|
|||
.include "../../x11/gnome-desktop/buildlink3.mk"
|
||||
.include "../../x11/gnome-panel/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../x11/py-gnome2/buildlink3.mk"
|
||||
.include "../../x11/py-gnome2-desktop/buildlink3.mk"
|
||||
|
||||
.include "../../mk/oss.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.21 2007/04/11 18:28:13 drochner Exp $
|
||||
${BATTSTAT}etc/sound/events/battstat_applet.soundlist
|
||||
@comment $NetBSD: PLIST,v 1.22 2007/04/17 17:59:07 drochner Exp $
|
||||
bin/invest-chart
|
||||
include/libgweather/gweather-gconf.h
|
||||
include/libgweather/gweather-prefs.h
|
||||
include/libgweather/weather.h
|
||||
|
@ -10,6 +10,7 @@ lib/bonobo/servers/GNOME_CharpickerApplet.server
|
|||
lib/bonobo/servers/GNOME_DriveMountApplet.server
|
||||
lib/bonobo/servers/GNOME_GWeatherApplet_Factory.server
|
||||
lib/bonobo/servers/GNOME_GeyesApplet.server
|
||||
lib/bonobo/servers/GNOME_GtikApplet.server
|
||||
lib/bonobo/servers/GNOME_MailcheckApplet_Factory.server
|
||||
lib/bonobo/servers/GNOME_MiniCommanderApplet.server
|
||||
lib/bonobo/servers/GNOME_MixerApplet.server
|
||||
|
@ -18,19 +19,46 @@ lib/bonobo/servers/GNOME_NullApplet_Factory.server
|
|||
lib/bonobo/servers/GNOME_Panel_TrashApplet.server
|
||||
lib/bonobo/servers/GNOME_Panel_WirelessApplet.server
|
||||
lib/bonobo/servers/GNOME_StickyNotesApplet.server
|
||||
lib/bonobo/servers/Invest_Applet.server
|
||||
lib/libgweather.la
|
||||
lib/pkgconfig/gweather.pc
|
||||
${PYSITELIB}/invest/__init__.py
|
||||
${PYSITELIB}/invest/__init__.pyc
|
||||
${PYSITELIB}/invest/__init__.pyo
|
||||
${PYSITELIB}/invest/about.py
|
||||
${PYSITELIB}/invest/about.pyc
|
||||
${PYSITELIB}/invest/about.pyo
|
||||
${PYSITELIB}/invest/applet.py
|
||||
${PYSITELIB}/invest/applet.pyc
|
||||
${PYSITELIB}/invest/applet.pyo
|
||||
${PYSITELIB}/invest/chart.py
|
||||
${PYSITELIB}/invest/chart.pyc
|
||||
${PYSITELIB}/invest/chart.pyo
|
||||
${PYSITELIB}/invest/defs.py
|
||||
${PYSITELIB}/invest/defs.pyc
|
||||
${PYSITELIB}/invest/defs.pyo
|
||||
${PYSITELIB}/invest/preferences.py
|
||||
${PYSITELIB}/invest/preferences.pyc
|
||||
${PYSITELIB}/invest/preferences.pyo
|
||||
${PYSITELIB}/invest/quotes.py
|
||||
${PYSITELIB}/invest/quotes.pyc
|
||||
${PYSITELIB}/invest/quotes.pyo
|
||||
${PYSITELIB}/invest/widgets.py
|
||||
${PYSITELIB}/invest/widgets.pyc
|
||||
${PYSITELIB}/invest/widgets.pyo
|
||||
libexec/accessx-status-applet
|
||||
${BATTSTAT}libexec/battstat-applet-2
|
||||
libexec/charpick_applet2
|
||||
libexec/drivemount_applet2
|
||||
libexec/geyes_applet2
|
||||
libexec/gweather-applet-2
|
||||
libexec/invest-applet
|
||||
libexec/mixer_applet2
|
||||
libexec/multiload-applet-2
|
||||
libexec/null_applet
|
||||
libexec/stickynotes_applet
|
||||
libexec/trashapplet
|
||||
share/applications/invest-chart.desktop
|
||||
${BATTSTAT}share/examples/gnome-applets/sound/events/battstat_applet.soundlist
|
||||
${BATTSTAT}share/gconf/schemas/battstat.schemas
|
||||
share/gconf/schemas/charpick.schemas
|
||||
|
@ -50,6 +78,7 @@ share/gnome-2.0/ui/GNOME_MixerApplet.xml
|
|||
share/gnome-2.0/ui/GNOME_MultiloadApplet.xml
|
||||
share/gnome-2.0/ui/GNOME_Panel_TrashApplet.xml
|
||||
share/gnome-2.0/ui/GNOME_StickyNotesApplet.xml
|
||||
share/gnome-2.0/ui/Invest_Applet.xml
|
||||
share/gnome-applets/geyes/Bizarre/Bizarre-eye.png
|
||||
share/gnome-applets/geyes/Bizarre/Bizarre-pupil.png
|
||||
share/gnome-applets/geyes/Bizarre/config
|
||||
|
@ -69,10 +98,15 @@ share/gnome-applets/geyes/Tango/config
|
|||
share/gnome-applets/geyes/Tango/tango-eye.png
|
||||
share/gnome-applets/geyes/Tango/tango-pupil.png
|
||||
${BATTSTAT}share/gnome-applets/glade/battstat_applet.glade
|
||||
share/gnome-applets/glade/financialchart.glade
|
||||
share/gnome-applets/glade/prefs-dialog.glade
|
||||
share/gnome-applets/glade/stickynotes.glade
|
||||
share/gnome-applets/glade/trashapplet.glade
|
||||
share/gnome-applets/gweather/Locations.xml
|
||||
share/gnome-applets/gweather/locations.dtd
|
||||
share/gnome-applets/invest-applet/invest-16.png
|
||||
share/gnome-applets/invest-applet/invest-button.png
|
||||
share/gnome-applets/invest-applet/invest.svg
|
||||
share/gnome/help/accessx-status/C/accessx-status.xml
|
||||
share/gnome/help/accessx-status/C/figures/accessx-status-applet.png
|
||||
share/gnome/help/accessx-status/C/figures/accessx-status-disabled.png
|
||||
|
@ -609,8 +643,8 @@ share/icons/hicolor/32x32/apps/gnome-eyes-applet.png
|
|||
share/icons/hicolor/32x32/apps/gnome-sticky-notes-applet.png
|
||||
share/icons/hicolor/48x48/apps/ax-applet.png
|
||||
share/icons/hicolor/48x48/apps/charpick.png
|
||||
share/icons/hicolor/svgxsvg/apps/gnome-eyes-applet
|
||||
share/icons/hicolor/svgxsvg/apps/gnome-sticky-notes-applet
|
||||
share/icons/hicolor/scalable/apps/gnome-eyes-applet.svg
|
||||
share/icons/hicolor/scalable/apps/gnome-sticky-notes-applet.svg
|
||||
share/locale/am/LC_MESSAGES/gnome-applets-2.0.mo
|
||||
share/locale/ar/LC_MESSAGES/gnome-applets-2.0.mo
|
||||
share/locale/az/LC_MESSAGES/gnome-applets-2.0.mo
|
||||
|
@ -828,6 +862,7 @@ share/pixmaps/accessx-status-applet/sticky-shift-none.png
|
|||
share/pixmaps/accessx-status-applet/sticky-super-latched.png
|
||||
share/pixmaps/accessx-status-applet/sticky-super-locked.png
|
||||
share/pixmaps/accessx-status-applet/sticky-super-none.png
|
||||
share/pixmaps/invest-big.png
|
||||
share/pixmaps/stickynotes/close.png
|
||||
share/pixmaps/stickynotes/locked.png
|
||||
share/pixmaps/stickynotes/resize_se.png
|
||||
|
@ -934,6 +969,7 @@ share/xmodmap/xmodmap.yu
|
|||
${BATTSTAT}@dirrm share/omf/battstat
|
||||
@dirrm share/omf/accessx-status
|
||||
@comment in scrollkeeper: @dirrm share/omf
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/scalable/apps
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/48x48/apps
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/32x32/apps
|
||||
@comment in hicolor-icon-theme: @dirrm share/icons/hicolor/24x24/apps
|
||||
|
@ -1127,6 +1163,7 @@ ${BATTSTAT}@dirrm share/gnome/help/battstat
|
|||
@dirrm share/gnome/help/accessx-status/C
|
||||
@dirrm share/gnome/help/accessx-status
|
||||
@comment in gnome2-dirs: @dirrm share/gnome/help
|
||||
@dirrm share/gnome-applets/invest-applet
|
||||
@dirrm share/gnome-applets/gweather
|
||||
@dirrm share/gnome-applets/glade
|
||||
@dirrm share/gnome-applets/geyes/Tango
|
||||
|
@ -1142,5 +1179,7 @@ ${BATTSTAT}@dirrm share/gnome/help/battstat
|
|||
${BATTSTAT}@dirrm share/examples/gnome-applets/sound/events
|
||||
${BATTSTAT}@dirrm share/examples/gnome-applets/sound
|
||||
${BATTSTAT}@dirrm share/examples/gnome-applets
|
||||
@comment in xdg-dirs: @dirrm share/applications
|
||||
@dirrm ${PYSITELIB}/invest
|
||||
@comment in libbonobo: @dirrm lib/bonobo/servers
|
||||
@dirrm include/libgweather
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.23 2007/04/11 18:28:14 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.24 2007/04/17 17:59:07 drochner Exp $
|
||||
|
||||
SHA1 (gnome-applets-2.18.0.tar.bz2) = 7bec1f642e827634f74859e81e1502799d3c05a2
|
||||
RMD160 (gnome-applets-2.18.0.tar.bz2) = c9a18c717fd01ede9476a70784a8522968e52211
|
||||
|
@ -7,3 +7,5 @@ SHA1 (patch-aa) = d4683f2d1273c4202ee336be436b9fd237610b7b
|
|||
SHA1 (patch-ab) = f880abec6df2254b6541d4e5a894559763ef674b
|
||||
SHA1 (patch-ac) = 8244d73dd62973fdc022947a62e9ce6211a3561b
|
||||
SHA1 (patch-ad) = 42fb64b30a031a1ea8f57f47cabdf63475b7987e
|
||||
SHA1 (patch-ae) = 16f66d3012a7ef7cfb5b72fdaa0f3e7719eea8f4
|
||||
SHA1 (patch-af) = e938bbc263cb9d70f613893ab414b13e8a1eaafd
|
||||
|
|
13
x11/gnome2-applets/patches/patch-ae
Normal file
13
x11/gnome2-applets/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.5 2007/04/17 17:59:07 drochner Exp $
|
||||
|
||||
--- geyes/Makefile.in.orig 2007-03-12 14:04:23.000000000 +0100
|
||||
+++ geyes/Makefile.in
|
||||
@@ -867,7 +867,7 @@ install-data-local:
|
||||
for icon in $(icons); do \
|
||||
SIZE=`echo $$icon | cut -d. -f2`; \
|
||||
FILE=`echo $$icon | cut -d. -f1,3`; \
|
||||
- if [ "$$SIZE" == "svg" ]; then \
|
||||
+ if [ "$$SIZE" = "svg" ]; then \
|
||||
SIZE="scalable"; \
|
||||
FILE="$$FILE.svg"; \
|
||||
else \
|
13
x11/gnome2-applets/patches/patch-af
Normal file
13
x11/gnome2-applets/patches/patch-af
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-af,v 1.3 2007/04/17 17:59:07 drochner Exp $
|
||||
|
||||
--- ./stickynotes/pixmaps/Makefile.in.orig 2007-04-17 18:13:05.000000000 +0200
|
||||
+++ ./stickynotes/pixmaps/Makefile.in
|
||||
@@ -563,7 +563,7 @@ install-data-local:
|
||||
for icon in $(icons); do \
|
||||
SIZE=`echo $$icon | cut -d. -f2`; \
|
||||
FILE=`echo $$icon | cut -d. -f1,3`; \
|
||||
- if [ "$$SIZE" == "svg" ]; then \
|
||||
+ if [ "$$SIZE" = "svg" ]; then \
|
||||
SIZE="scalable"; \
|
||||
FILE="$$FILE.svg"; \
|
||||
else \
|
Loading…
Reference in a new issue