A group of updates from Khorben, correcting some mangled paths.

Thank you Khorben!
This commit is contained in:
schnoebe 2015-11-03 15:08:50 +00:00
parent 533c94cd6d
commit 68d05b1f5c
4 changed files with 31 additions and 6 deletions

View file

@ -1,12 +1,14 @@
$NetBSD: distinfo,v 1.19 2015/08/27 23:53:24 khorben Exp $
$NetBSD: distinfo,v 1.20 2015/11/03 15:08:50 schnoebe Exp $
SHA1 (hplip-3.15.7.tar.gz) = f84e33b749ef34939c11b253767686c00ca2c30c
RMD160 (hplip-3.15.7.tar.gz) = b8f5b9be838ed9261cb208df46b5aa7ef6680e31
SHA512 (hplip-3.15.7.tar.gz) = 45458b74ec496816292c40a9c1d5aed4a288f84be62e79378e701fff5fb1cb55cc77e8415884b824602ec6af8d1155b7dc288ef7382a2e4d96b337520d541a1c
Size (hplip-3.15.7.tar.gz) = 21979938 bytes
SHA1 (patch-aa) = 8eb162708a48e9b1720245f65f01177418a4ed85
SHA1 (patch-ab) = 82b8ab80f778a6a31c1031688d9a16dbd4c55462
SHA1 (patch-ae) = c4bae69fce7d9061d4c7dc53f1f8c5404577c605
SHA1 (patch-installer_dcheck.py) = e381086ccdfbdcd84d3ffe29995d5d3643709be6
SHA1 (patch-diagnose_queues.py) = aa3e544dc131accf4f799d26924b50f511c8c69f
SHA1 (patch-installer_dcheck.py) = c37121080a605b35de04af13f8ce284b0c1e7784
SHA1 (patch-io_hpmud_musb.h) = ad634f5a1f426877e1c88916b6468fcdb7598555
SHA1 (patch-prnt_hpijs_context2.cpp) = f81148c1c334a9074453b27ac055833cd1669bd0
SHA1 (patch-prnt_hpijs_foomatic-rip-hplip) = a94c7bbdc90dd68d001ce0325b7aabcd470233eb

View file

@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.6 2015/04/26 13:29:12 joerg Exp $
# $NetBSD: options.mk,v 1.7 2015/11/03 15:08:50 schnoebe Exp $
#
# HPLIP dependencies are detailed in the following page:
# http://hplipopensource.com/hplip-web/install/manual/distros/other.html
@ -33,8 +33,12 @@ MESSAGE_SRC+= MESSAGE.scan
MESSAGE_SUBST+= EGDIR=${EGDIR}
.include "../../graphics/sane-backends/buildlink3.mk"
# XXX: a dependency installs py-Pillow, which conflicts
.include "../../graphics/py-imaging/buildlink3.mk"
PYTHON_VERSIONS_INCOMPATIBLE= 33 34 # py-imaging
# .include "../../graphics/py-imaging/buildlink3.mk"
# DEPENDS+= ${PYPKGPREFIX}-Pillow-[0-9]*:../../print/py-Pillow
# version depends on if py-reportlab was installed before we called
# out an imaging library.
DEPENDS+= {${PYPKGPREFIX}-imaging-[0-9]*,${PYPKGPREFIX}-Pillow-[0-9]*}:../../graphics/py-imaging
# PYTHON_VERSIONS_INCOMPATIBLE= 33 34 # py-imaging
.else
CONFIGURE_ARGS+= --disable-scan-build
.endif

View file

@ -0,0 +1,13 @@
$NetBSD: patch-diagnose_queues.py,v 1.1 2015/11/03 15:08:50 schnoebe Exp $
--- diagnose_queues.py.orig 2015-08-19 13:25:37.000000000 +0000
+++ diagnose_queues.py
@@ -22,7 +22,7 @@
from __future__ import print_function
__version__ = '1.1'
__title__ = 'AutoConfig Utility to check queues configuration'
-__mod__ = 'hp-daignose-queues'
+__mod__ = 'hp-diagnose-queues'
__doc__ = """Auto config utility for HPLIP supported multifunction Devices to diagnose queues configuration."""
# Std Lib

View file

@ -1,4 +1,4 @@
$NetBSD: patch-installer_dcheck.py,v 1.1 2015/08/27 23:53:24 khorben Exp $
$NetBSD: patch-installer_dcheck.py,v 1.2 2015/11/03 15:08:50 schnoebe Exp $
Locate libraries on systems without ldconfig(8)
@ -6,6 +6,12 @@ This only looks for libraries in pkgsrc's own library folder.
--- installer/dcheck.py.orig 2015-06-07 19:25:11.000000000 +0000
+++ installer/dcheck.py
@@ -1,4 +1,4 @@
-#!/usr/bin/env python
+#!/usr/pkg/bin/python2.7
# -*- coding: utf-8 -*-
#
# (c) Copyright 2003-2007 Hewlett-Packard Development Company, L.P.
@@ -99,6 +99,8 @@ def check_lib(lib, min_ver=0):
# pass
#else: