CVSup built from sources via lang/ezm3, if you want to use the binary
install devel/cvsup-bin instead.
This commit is contained in:
parent
d46006fe28
commit
68d0b92ecd
8 changed files with 78 additions and 139 deletions
|
@ -1,4 +1 @@
|
|||
cvsup server and non-GUI client.
|
||||
|
||||
the binary is for NetBSD 1.5/i386/ELF systems, and compiled by
|
||||
Markus Kurek <Markus.Kurek@t-online.de>.
|
||||
CVSup: CVS-optimized general-purpose network file distribution system.
|
||||
|
|
|
@ -1,39 +1,11 @@
|
|||
# $NetBSD: Makefile,v 1.12 2004/01/05 04:41:20 xtraeme Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2004/01/06 00:08:06 xtraeme Exp $
|
||||
|
||||
DISTNAME= cvsup-static-16.1.h
|
||||
PKGNAME= ${DISTNAME:C/-static//}
|
||||
WRKSRC= ${WRKDIR}
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://motoyuki.bsdclub.org/data/NetBSD/CVSup/i386/
|
||||
EXTRACT_SUFX= .tgz
|
||||
.include "${.CURDIR}/../../devel/cvsup/Makefile.common"
|
||||
|
||||
MAINTAINER= tech-pkg@NetBSD.org
|
||||
HOMEPAGE= http://people.freebsd.org/~jdp/
|
||||
COMMENT= cvsup daemon and client
|
||||
PKGNAME= cvsup-16.1.h
|
||||
|
||||
NO_CONFIGURE= yes
|
||||
NO_BUILD= yes
|
||||
ONLY_FOR_PLATFORM= NetBSD-1.[5-9]*-i386
|
||||
DIST_SUBDIR= cvsup-${MACHINE_ARCH}-${OS_VERSION:C/(...).*/\1/}
|
||||
M3FLAGS+= -DNOGUI
|
||||
|
||||
do-install:
|
||||
for i in cvpasswd cvsup ; do \
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/$$i ${PREFIX}/bin; \
|
||||
done
|
||||
for i in cvsupd; do \
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/sbin/$$i ${PREFIX}/sbin; \
|
||||
done
|
||||
for i in cvpasswd.1 cvsup.1; do \
|
||||
${INSTALL_MAN} ${WRKSRC}/man/man1/$$i ${PREFIX}/man/man1; \
|
||||
done
|
||||
for i in cvsupd.8; do \
|
||||
${INSTALL_MAN} ${WRKSRC}/man/man8/$$i ${PREFIX}/man/man8; \
|
||||
done
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/cvsup
|
||||
${INSTALL_DATA} ${WRKSRC}/share/doc/cvsup/License \
|
||||
${PREFIX}/share/doc/cvsup
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/cvsup
|
||||
${INSTALL_DATA} ${FILESDIR}/supfile* \
|
||||
${PREFIX}/share/examples/cvsup
|
||||
CONFLICTS= cvsup-{bin,gui}-[0-9]*
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
51
devel/cvsup/Makefile.common
Normal file
51
devel/cvsup/Makefile.common
Normal file
|
@ -0,0 +1,51 @@
|
|||
# $NetBSD: Makefile.common,v 1.1 2004/01/06 00:08:06 xtraeme Exp $
|
||||
|
||||
DISTNAME= cvsup-snap-16.1h
|
||||
CATEGORIES= devel net
|
||||
MASTER_SITES= ftp://ftp.freebsd.org/pub/FreeBSD/development/CVSup/snapshots/
|
||||
|
||||
MAINTAINER= motoyuki@bsdclub.org
|
||||
HOMEPAGE= http://www.polstra.com/projects/freeware/CVSup/
|
||||
COMMENT= cvsup daemon and client
|
||||
|
||||
ONLY_FOR_PLATFORM= FreeBSD-*-i386 NetBSD-*-i386
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
BUILD_DEPENDS= ezm3-*:../../lang/ezm3-${OPSYS}-${MACHINE_ARCH}
|
||||
|
||||
CONFLICTS= cvsup-*
|
||||
MAKE_FLAGS+= PREFIX=${PREFIX} M3FLAGS="${M3FLAGS}"
|
||||
|
||||
M3BIN= ${PREFIX}/ezm3/bin/m3build
|
||||
|
||||
DESCR_SRC= ${.CURDIR}/../../devel/cvsup/DESCR
|
||||
DISTINFO_FILE= ${.CURDIR}/../../devel/cvsup/distinfo
|
||||
PLIST_SRC= ${.CURDIR}/../../devel/cvsup/PLIST
|
||||
PATCHDIR= ${.CURDIR}/../../devel/cvsup/patches
|
||||
FILESDIR= ${.CURDIR}/../../devel/cvsup/files
|
||||
|
||||
post-extract:
|
||||
@${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.in
|
||||
|
||||
pre-configure:
|
||||
@${SED} -e "s,@M3BIN@,${M3BIN},g" ${WRKSRC}/Makefile.in > \
|
||||
${WRKSRC}/Makefile
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
BUILD_DEFS+= CVSUP_STATIC
|
||||
CVSUP_STATIC?= NO
|
||||
|
||||
.if defined(CVSUP_STATIC) && !empty(CVSUP_STATIC:M[Yy][Ee][Ss])
|
||||
M3FLAGS+= -DSTATIC
|
||||
STATIC= -static
|
||||
.endif
|
||||
|
||||
EGDIR= ${PREFIX}/share/examples/cvsup
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/cvsup ${EGDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/License ${PREFIX}/share/doc/cvsup
|
||||
${INSTALL_DATA} ${FILESDIR}/*cvsup* \
|
||||
${EGDIR}
|
|
@ -1,12 +1,11 @@
|
|||
@comment $NetBSD: PLIST,v 1.3 2004/01/05 04:41:20 xtraeme Exp $
|
||||
@comment $NetBSD: PLIST,v 1.4 2004/01/06 00:08:06 xtraeme Exp $
|
||||
bin/cvpasswd
|
||||
bin/cvsup
|
||||
sbin/cvsupd
|
||||
share/doc/cvsup/License
|
||||
share/examples/cvsup/supfile-cvsup.jp.netbsd.org
|
||||
share/examples/cvsup/supfile-cvsup.no.netbsd.org
|
||||
man/man1/cvpasswd.1
|
||||
man/man1/cvsup.1
|
||||
man/man8/cvsupd.8
|
||||
share/examples/cvsup/supfile-cvsup.no.netbsd.org
|
||||
share/examples/cvsup/supfile-cvsup.jp.netbsd.org
|
||||
share/doc/cvsup/License
|
||||
@dirrm share/examples/cvsup
|
||||
@dirrm share/doc/cvsup
|
||||
|
|
|
@ -1,4 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.6 2004/01/05 04:41:20 xtraeme Exp $
|
||||
$NetBSD: distinfo,v 1.7 2004/01/06 00:08:06 xtraeme Exp $
|
||||
|
||||
SHA1 (cvsup-i386-1.6/cvsup-static-16.1.h.tgz) = 8a9cfd3e5e24e8bdc7c174c5bab0eb728aad1837
|
||||
Size (cvsup-i386-1.6/cvsup-static-16.1.h.tgz) = 1291666 bytes
|
||||
SHA1 (cvsup-snap-16.1h.tar.gz) = 976439eb09c9e929d3bb2837b5e4db14719393b2
|
||||
Size (cvsup-snap-16.1h.tar.gz) = 430951 bytes
|
||||
SHA1 (patch-aa) = 21e66792dfb53c592577710ade53ae4bd2d425bc
|
||||
|
|
|
@ -1,60 +0,0 @@
|
|||
#
|
||||
# Example cvsup config file provided by
|
||||
# Motoyuki Konno <motoyuki@bsdclub.org> (cvsup.jp.netbsd.org maintainer)
|
||||
#
|
||||
|
||||
# This file can be used to obtain the checked-out NetBSD source files
|
||||
|
||||
#*default tag=. # Comment out this line to obtain
|
||||
# the checkout-out NetBSD source files.
|
||||
# Replace the ``.'' with a cvs tag
|
||||
# to get other NetBSD releases.
|
||||
*default release=cvs
|
||||
*default delete use-rel-suffix
|
||||
*default umask=022
|
||||
*default host=cvsup.jp.NetBSD.org # Machine to connect to
|
||||
*default base=/var/cvsup/ # Location to put the sources
|
||||
*default prefix=/usr/cvsup # Where to put the sup subdirectory
|
||||
|
||||
*default compress # Use this unless your network link
|
||||
# is a T1 or faster
|
||||
|
||||
# You can get everything using the ``netbsd'' collection.
|
||||
netbsd
|
||||
|
||||
# Alternatively, use following collections to get one or more
|
||||
# of the partial collections by uncommenting them below.
|
||||
|
||||
#netbsd-base # CVSROOT and misc
|
||||
#
|
||||
#netbsd-src # All of src tree
|
||||
#netbsd-src-base # src/[A-Z]* and misc.
|
||||
#netbsd-src-bin # src/bin
|
||||
#netbsd-src-crypto # src/crypto
|
||||
#netbsd-src-dist # src/dist
|
||||
#netbsd-src-distrib # src/distrib
|
||||
#netbsd-src-doc # src/doc
|
||||
#netbsd-src-etc # src/etc
|
||||
#netbsd-src-games # src/games
|
||||
#netbsd-src-gnu # src/gnu
|
||||
#netbsd-src-include # src/include
|
||||
#netbsd-src-lib # src/lib
|
||||
#netbsd-src-libexec # src/libexec
|
||||
#netbsd-src-regress # src/regress
|
||||
#netbsd-src-rescue # src/rescue
|
||||
#netbsd-src-sbin # src/sbin
|
||||
#netbsd-src-share # src/share
|
||||
#netbsd-src-sys # src/sys
|
||||
#netbsd-src-tools # src/tools
|
||||
#netbsd-src-usrbin # src/usr.bin
|
||||
#netbsd-src-usrsbin # src/usr.sbin
|
||||
#
|
||||
#netbsd-htdocs # htdocs
|
||||
#netbsd-othersrc # othersrc
|
||||
#netbsd-pkgsrc # pkgsrc
|
||||
#netbsd-xsrc # All of xsrc tree
|
||||
#netbsd-xsrc-3 # xsrc tree for XFree86 3.X
|
||||
#netbsd-xsrc-4 # xsrc tree for XFree86 4.X
|
||||
#
|
||||
#netbsd-distrib release=self # server's own config files
|
||||
#
|
|
@ -1,34 +0,0 @@
|
|||
#
|
||||
# Example cvsup config file provided by
|
||||
# Onno van der Linden <o.vd.linden@quicknet.nl>
|
||||
#
|
||||
|
||||
|
||||
# This file can be used to obtain the checked-out NetBSD source files
|
||||
|
||||
*default tag=. # Get the current files. Replace the
|
||||
# ``.'' with a cvs tag to get other
|
||||
# NetBSD releases.
|
||||
*default release=cvs
|
||||
*default delete use-rel-suffix
|
||||
*default umask=022
|
||||
*default host=cvsup.no.NetBSD.org # Machine to connect to
|
||||
*default base=/var/cvsup/ # Location to put the sources
|
||||
*default prefix=/usr/cvsup # Where to put the sup subdirectory
|
||||
|
||||
*default compress # Use this unless your network link
|
||||
# is a T1 or faster
|
||||
|
||||
# You can get everything using the ``netbsd'' collection.
|
||||
# netbsd-doc
|
||||
|
||||
# Alternatively, comment out the ``netbsd'' collection and just get one or
|
||||
# more of the partial collections by uncommenting them below.
|
||||
|
||||
netbsd-basesrc
|
||||
netbsd-doc prefix=/var/cvsup
|
||||
netbsd-gnusrc
|
||||
netbsd-sharesrc
|
||||
netbsd-syssrc
|
||||
netbsd-pkgsrc
|
||||
# netbsd-xsrc
|
13
devel/cvsup/patches/patch-aa
Normal file
13
devel/cvsup/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1 2004/01/06 00:08:06 xtraeme Exp $
|
||||
|
||||
--- Makefile.in.orig 2004-01-05 22:04:40.000000000 +0100
|
||||
+++ Makefile.in 2004-01-05 22:05:02.000000000 +0100
|
||||
@@ -37,7 +37,7 @@
|
||||
|
||||
# Modula-3 compiler. For the SRC and PM3 compilers it is "m3build". For
|
||||
# the Critical Mass compiler use "cm3".
|
||||
-M3= m3build
|
||||
+M3= @M3BIN@
|
||||
|
||||
# Extra flags to pass to the Modula-3 compiler.
|
||||
M3FLAGS=
|
Loading…
Reference in a new issue