Fix Solaris issues by linking socket libraries where required.

OKed schmonz.
This commit is contained in:
markd 2006-12-29 22:00:17 +00:00
parent 3cff6d1109
commit 68f0f6eced
3 changed files with 27 additions and 4 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.19 2006/12/28 03:20:32 schmonz Exp $
$NetBSD: distinfo,v 1.20 2006/12/29 22:00:17 markd Exp $
SHA1 (bglibs-1.102.tar.gz) = 45d0df13d35d5b162378314f354dde76aa704977
RMD160 (bglibs-1.102.tar.gz) = 5e8e1c37f5c153cb04f4451f130013676bc655bf
Size (bglibs-1.102.tar.gz) = 421136 bytes
SHA1 (patch-ab) = 05876883e44e5a388e36fb1d14330ab24d6c2458
SHA1 (patch-ab) = 86bc70d8fb3fbe2c29431eb32bbd7f269b1d5258
SHA1 (patch-ac) = 9a43872412b39057828e6d3b95d9c9ba5d35de29

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ab,v 1.2 2006/12/28 03:20:32 schmonz Exp $
$NetBSD: patch-ab,v 1.3 2006/12/29 22:00:17 markd Exp $
--- Makefile.orig 2006-10-30 16:11:21.000000000 -0500
--- Makefile.orig 2006-10-31 10:11:21.000000000 +1300
+++ Makefile
@@ -126,7 +126,7 @@ adt/hashs.lo: libcompile adt/hashs.c adt
adt/hashs.o: compile adt/hashs.c adt/common.h
@ -11,6 +11,15 @@ $NetBSD: patch-ab,v 1.2 2006/12/28 03:20:32 schmonz Exp $
base64/asc2bin.lo: libcompile base64/asc2bin.c base64/base64.h str/str.h
./libcompile base64/asc2bin.c
@@ -1033,7 +1033,7 @@ makeshlib: conf-ld conf-lib LIBVERSION M
echo '#!/bin/sh'; \
echo 'lib="$$1"; shift';\
echo 'rm -f "$$lib"';\
- echo libtool --mode=link --silent $$tag `head -n 1 conf-ld` '-o "$$lib" -rpath' `head -n 1 conf-lib` -version-info `head -n 1 LIBVERSION` '$${1+"$$@"}';\
+ echo libtool --mode=link --silent $$tag `head -n 1 conf-ld` '-o "$$lib" -rpath' `head -n 1 conf-lib` -version-info `head -n 1 LIBVERSION` '$${1+"$$@"}' `cat socket.lib`;\
) >makeshlib
chmod 755 makeshlib
@@ -1505,9 +1505,7 @@ path/mktemp.o: compile path/mktemp.c sys
./compile path/mktemp.c

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.1 2006/12/29 22:00:17 markd Exp $
--- selftests.sh.orig 2006-12-30 10:00:53.471026000 +1300
+++ selftests.sh
@@ -20,7 +20,7 @@ do_test() {
return 1
}
- ./load $t/test .libs/libbg.a .libs/libbg-sysdeps.a || {
+ ./load $t/test .libs/libbg.a .libs/libbg-sysdeps.a `cat socket.lib` || {
echo "=====> Load failed! <====="
return 1
}