Add missing prototypes.

This commit is contained in:
joerg 2012-10-20 22:14:05 +00:00
parent a517c1747a
commit 6926f8fa4b
3 changed files with 55 additions and 12 deletions

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.7 2008/06/20 01:09:25 joerg Exp $
$NetBSD: distinfo,v 1.8 2012/10/20 22:14:05 joerg Exp $
SHA1 (buffer-1.17.tar.gz) = 88201f677485880cd508430015b7ce7d9663b6e7
RMD160 (buffer-1.17.tar.gz) = c7f87873f8f74b900609ef495ebabc8596729fb8
Size (buffer-1.17.tar.gz) = 17131 bytes
SHA1 (patch-aa) = 3fd94e382e9444fd88a17bcef348800767f8a8d0
SHA1 (patch-ab) = 70c28daab40f6c5ab2fae5d19fc0e98fdefbdf69
SHA1 (patch-ac) = 2edead52c6a79a04e11ddabef1e140ac24d7d379
SHA1 (patch-ab) = c17afef3231afe48476273183c0f1365fa8cd86f
SHA1 (patch-ac) = c899209c54933756f5ce97b083fa43daa69a8ffc

View file

@ -1,8 +1,14 @@
$NetBSD: patch-ab,v 1.3 2005/11/10 17:31:48 joerg Exp $
$NetBSD: patch-ab,v 1.4 2012/10/20 22:14:05 joerg Exp $
--- sem.c.orig 1994-10-04 16:44:53.000000000 +0000
+++ sem.c
@@ -32,8 +32,10 @@
@@ -27,13 +27,16 @@
* semaphores */
#include <stdio.h>
+#include <unistd.h>
#include <sys/types.h>
#include <sys/stat.h>
#include <sys/ipc.h>
#include <sys/sem.h>
#include <errno.h>
@ -14,7 +20,7 @@ $NetBSD: patch-ab,v 1.3 2005/11/10 17:31:48 joerg Exp $
union semun {
int val;
struct semid_ds *buf;
@@ -60,7 +62,6 @@ sem_set( sem_id, semn, val )
@@ -60,7 +63,6 @@ sem_set( sem_id, semn, val )
int val;
{
union semun arg;
@ -22,7 +28,16 @@ $NetBSD: patch-ab,v 1.3 2005/11/10 17:31:48 joerg Exp $
arg.val = val;
@@ -148,10 +149,17 @@ void
@@ -94,7 +96,7 @@ new_sems( nsems )
return sem;
}
-static
+static void
do_sem( sem_id, pbuf, err )
int sem_id;
struct sembuf *pbuf;
@@ -148,10 +150,17 @@ void
remove_sems( sem_id )
int sem_id;
{

View file

@ -1,23 +1,51 @@
$NetBSD: patch-ac,v 1.3 2005/12/05 20:50:38 rillig Exp $
$NetBSD: patch-ac,v 1.4 2012/10/20 22:14:05 joerg Exp $
--- buffer.c.orig 1994-10-04 09:44:53.000000000 -0700
--- buffer.c.orig 1994-10-04 16:44:53.000000000 +0000
+++ buffer.c
@@ -118,6 +118,4 @@
@@ -103,4 +103,6 @@
*
*/
+#include <stdlib.h>
+#include <string.h>
#include <unistd.h>
#include <stdio.h>
@@ -118,6 +120,4 @@ static char *rcsid = "$Header: /a/swan/h
#endif
-extern char *shmat();
-
/* General macros */
#define TRUE 1
@@ -385,4 +383,5 @@ parse_args( argc, argv )
@@ -385,4 +385,5 @@ parse_args( argc, argv )
/* The interrupt handler */
+void
shutdown()
{
@@ -401,4 +400,5 @@ shutdown()
@@ -401,4 +402,5 @@ shutdown()
/* Shutdown because the child has ended */
+void
child_shutdown()
{
@@ -461,5 +463,5 @@ buffer_allocate()
if( debug )
- fprintf( stderr, "%s pbuffer is 0x%08x, buffer_size is %d [%d x %d]\n",
+ fprintf( stderr, "%s pbuffer is %p, buffer_size is %d [%d x %d]\n",
proc_string,
(char *)pbuffer, buffer_size, blocks, blocksize );
@@ -489,5 +491,5 @@ buffer_allocate()
}
-buffer_remove()
+void buffer_remove(void)
{
static char removing = FALSE;
@@ -728,5 +730,5 @@ write_block_to_stdout()
if( next_k == 0 && showevery ){
if( debug > 3 )
- fprintf( stderr, "W: next_k = %lu showevery = %lu\n", next_k, showevery );
+ fprintf( stderr, "W: next_k = %lu showevery = %d\n", next_k, showevery );
showevery = showevery / 1024;
next_k = showevery;