patch-ai: Fix a compile problem with the asio headers on NetBSD.

Upstream bug: https://svn.boost.org/trac/boost/ticket/6098

Bump revision of boost-headers.
This commit is contained in:
tnn 2011-11-06 21:54:32 +00:00
parent 3e3ee3d754
commit 69661684ef
3 changed files with 34 additions and 2 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.15 2011/10/11 10:02:08 adam Exp $
# $NetBSD: Makefile,v 1.16 2011/11/06 21:54:32 tnn Exp $
BOOST_PACKAGE= headers
BOOST_COMMENT= (build-time headers)
BOOST_CONFIG= generate
PKGREVISION= 1
PKG_DESTDIR_SUPPORT= user-destdir

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.36 2011/10/14 01:12:06 jmmv Exp $
$NetBSD: distinfo,v 1.37 2011/11/06 21:54:32 tnn Exp $
SHA1 (boost_1_47_0.tar.bz2) = 6e3eb548b9d955c0bc6f71c51042b713b678136a
RMD160 (boost_1_47_0.tar.bz2) = 511144eb5ade340115971c372a3c849bd55181f1
@ -11,5 +11,6 @@ SHA1 (patch-ae) = 2fb49c90bbb3fd797ccdfaaf44c93494a5988f52
SHA1 (patch-af) = 560157e198b416be700f15fe816e0196134fe414
SHA1 (patch-ag) = b19bf29b0c08ede6470e0a697f99d4ea796ab987
SHA1 (patch-ah) = c32b43bdbbe3cecc15ad56172083ee6ed926b45b
SHA1 (patch-ai) = 2565d3ca95641104ebbfd5e96d5c56df67e06719
SHA1 (patch-aq) = e5c7b72ffa2942ce401f3d9bf05498fd761df17a
SHA1 (patch-ar) = 91981e2edb93666de78c203a6cef3d5011b2b26a

View file

@ -0,0 +1,30 @@
$NetBSD: patch-ai,v 1.3 2011/11/06 21:54:32 tnn Exp $
https://svn.boost.org/trac/boost/ticket/6098
--- boost/asio/detail/impl/kqueue_reactor.ipp.orig 2011-11-06 17:01:14.000000000 +0000
+++ boost/asio/detail/impl/kqueue_reactor.ipp
@@ -289,9 +289,9 @@ void kqueue_reactor::deregister_descript
{
struct kevent events[2];
BOOST_ASIO_KQUEUE_EV_SET(&events[0], descriptor,
- EVFILT_READ, EV_DELETE, 0, 0, 0);
+ EVFILT_READ, EV_DELETE, 0, 0, (void*)0);
BOOST_ASIO_KQUEUE_EV_SET(&events[1], descriptor,
- EVFILT_WRITE, EV_DELETE, 0, 0, 0);
+ EVFILT_WRITE, EV_DELETE, 0, 0, (void*)0);
::kevent(kqueue_fd_, events, 2, 0, 0, 0);
}
@@ -333,9 +333,9 @@ void kqueue_reactor::deregister_internal
{
struct kevent events[2];
BOOST_ASIO_KQUEUE_EV_SET(&events[0], descriptor,
- EVFILT_READ, EV_DELETE, 0, 0, 0);
+ EVFILT_READ, EV_DELETE, 0, 0, (void*)0);
BOOST_ASIO_KQUEUE_EV_SET(&events[1], descriptor,
- EVFILT_WRITE, EV_DELETE, 0, 0, 0);
+ EVFILT_WRITE, EV_DELETE, 0, 0, (void*)0);
::kevent(kqueue_fd_, events, 2, 0, 0, 0);
op_queue<operation> ops;