Update to bind9.0.0 beta2. Changes:

Many more config file options
  implemented (see doc/misc/options for a
  summary of the current implementation
  status), portability improvements, (works
  much better than beta 1 on FreeBSD 3.4),
  and bugfixes (almost all bugs reported
  against beta 1 have been fixed).
This commit is contained in:
hubertf 2000-03-31 11:15:23 +00:00
parent 9c3bd33489
commit 6976776735
11 changed files with 221 additions and 249 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.4 2000/02/29 01:28:44 hubertf Exp $
# $NetBSD: Makefile,v 1.5 2000/03/31 11:15:23 hubertf Exp $
#
DISTNAME= bind-9.0.0b1
DISTNAME= bind-9.0.0b2
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/bind9/9.0.0b1/
MASTER_SITES= ftp://ftp.isc.org/isc/bind9/9.0.0b2/
MAINTAINER= hubertf@NetBSD.org
HOMEPAGE= http://www.isc.org/products/BIND/
@ -14,11 +14,12 @@ ONLY_FOR_PLATFORM= NetBSD-*-i386 NetBSD-*-arm32 NetBSD-*-m68k
DEPENDS+= unproven-pthreads-0.*:../../devel/unproven-pthreads
# No need to set USE_INET6, will auto-detect.
DIST_SUBDIR= bind/9.0.0b1
DIST_SUBDIR= bind/9.0.0b2
GNU_CONFIGURE= yes
PLIST_SRC= ${WRKDIR}/newPLIST
CONFIGURE_ARGS+=--with-mit-pthreads \
--with-libtool=yes
--with-libtool=yes \
--sysconfdir=/etc \
--localstatedir=/var
CONFIGURE_ENV+= CC=${LOCALBASE}/pthreads/bin/pgcc \
CXX=${LOCALBASE}/pthreads/bin/pg++
@ -35,12 +36,5 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/rfc/* ${PREFIX}/share/doc/bind9/rfc
${INSTALL_SCRIPT} ${WRKSRC}/bin/rndc/rndc ${PREFIX}/sbin
${INSTALL_SCRIPT} ${WRKSRC}/bin/lwresd/lwresd ${PREFIX}/sbin
${CP} ${PKGDIR}/PLIST ${PLIST_SRC}
(cd ${PREFIX}; \
${FIND} share/doc/bind9 \( -type f -or -type l \) | \
sort >> ${PLIST_SRC}; \
for DIR in `${FIND} share/doc/bind9 -type d | sort -r`; do \
${ECHO} "@dirrm $$DIR" >> ${PLIST_SRC}; \
done)
.include "../../mk/bsd.pkg.mk"

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.1.1.1 2000/02/22 03:50:58 hubertf Exp $
$NetBSD: md5,v 1.2 2000/03/31 11:15:24 hubertf Exp $
MD5 (bind/9.0.0b1/bind-9.0.0b1.tar.gz) = 492c8338907a8d1e7dae0048f5e7f5e3
MD5 (bind/9.0.0b2/bind-9.0.0b2.tar.gz) = 499c56d1604368a95bfa19e4ffb50e80

View file

@ -1,10 +1,5 @@
$NetBSD: patch-sum,v 1.1.1.1 2000/02/22 03:50:58 hubertf Exp $
$NetBSD: patch-sum,v 1.2 2000/03/31 11:15:24 hubertf Exp $
MD5 (patch-aa) = 5b90996dd1307aa9de7e2ff70908f5bb
MD5 (patch-ab) = 853a75fde831241da45447be1602f51d
MD5 (patch-ac) = 43a26fecd75c77b64ea1fe7c36c18283
MD5 (patch-ad) = 676f6462a48cb45bdae7c813d2ad9d4e
MD5 (patch-ae) = acd0f87fc8e9f26c78ceeea589b6081d
MD5 (patch-af) = 0b80afe1845ab2d3b44144a6def77a20
MD5 (patch-ag) = f5453b83c85ac5462a5781a97d27d1c1
MD5 (patch-aa) = d7892e5486b17f1974ad4bcf534f1dc8
MD5 (patch-af) = 69a05a8e9ee331444826f062b01cb218
MD5 (patch-ah) = 25192ddf483840734fa4e6b6e6df2a32

View file

@ -1,13 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2000/02/22 03:50:59 hubertf Exp $
$NetBSD: patch-aa,v 1.2 2000/03/31 11:15:24 hubertf Exp $
--- lib/dns/Makefile.in.orig Mon Feb 21 04:28:14 2000
+++ lib/dns/Makefile.in Mon Feb 21 04:28:30 2000
@@ -156,7 +156,7 @@
-DLIBAGE=${LIBAGE} \
-c ${srcdir}/version.c
-libdns.@A@: ${OBJS}
+libdns.a: ${OBJS}
${AR} ${ARFLAGS} $@ ${OBJS}
${RANLIB} $@
--- lib/isc/unix/include/isc/Makefile.in.orig Fri Mar 31 01:23:39 2000
+++ lib/isc/unix/include/isc/Makefile.in Fri Mar 31 01:23:56 2000
@@ -30,7 +30,7 @@
if [ ! -d ${DESTDIR}${includedir} ]; then \
mkdir ${DESTDIR}${includedir} ; \
fi
- if [ ! -d ${DESTDIR)${includedir}/isc ]; then \
+ if [ ! -d ${DESTDIR}${includedir}/isc ]; then \
mkdir ${DESTDIR}${includedir}/isc ; \
fi

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 2000/02/22 03:50:59 hubertf Exp $
--- lib/isc/Makefile.in.orig Mon Feb 21 04:39:23 2000
+++ lib/isc/Makefile.in Mon Feb 21 04:40:43 2000
@@ -78,7 +78,7 @@
-DLIBAGE=${LIBAGE} \
-c ${srcdir}/version.c
-libisc.@A@: ${OBJS}
+libisc.a: ${OBJS}
${AR} ${ARFLAGS} $@ ${OBJS}
${RANLIB} $@

View file

@ -1,22 +0,0 @@
$NetBSD: patch-ac,v 1.1.1.1 2000/02/22 03:51:00 hubertf Exp $
--- lib/lwres/Makefile.in.orig Fri Feb 4 07:02:49 2000
+++ lib/lwres/Makefile.in Mon Feb 21 05:08:46 2000
@@ -19,6 +19,8 @@
@BIND9_VERSION@
+@LIBDNS_API@
+
@BIND9_INCLUDES@
CINCLUDES = -I. -I./include -I${srcdir}/include ${ISC_INCLUDES}
@@ -53,7 +55,7 @@
-DLIBAGE=${LIBAGE} \
-c ${srcdir}/version.c
-liblwres.@A@: ${OBJS}
+liblwres.a: ${OBJS}
${AR} ${ARFLAGS} $@ ${OBJS}
${RANLIB} $@

View file

@ -1,20 +0,0 @@
$NetBSD: patch-ad,v 1.1.1.1 2000/02/22 03:51:00 hubertf Exp $
--- lib/omapi/Makefile.in.orig Fri Feb 4 02:58:37 2000
+++ lib/omapi/Makefile.in Mon Feb 21 05:11:56 2000
@@ -55,13 +55,13 @@
-DLIBAGE=${LIBAGE} \
-c ${srcdir}/version.c
-libomapi.@A@: ${OBJS}
+libomapi.a: ${OBJS}
${AR} ${ARFLAGS} $@ ${OBJS}
${RANLIB} $@
libomapi.la: ${OBJS}
${LIBTOOL} --mode=link \
- ${CC} ${ALL_CFLAGS} -o libisc.la -rpath ${libdir} \
+ ${CC} ${ALL_CFLAGS} -o libomapi.la -rpath ${libdir} \
-version-info ${LIBINTERFACE}:${LIBREVISION}:${LIBAGE} \
${OBJS} ${LIBS}

View file

@ -1,34 +0,0 @@
$NetBSD: patch-ae,v 1.1.1.1 2000/02/22 03:51:00 hubertf Exp $
--- lib/tests/Makefile.in.orig Fri Feb 4 00:15:53 2000
+++ lib/tests/Makefile.in Mon Feb 21 05:59:53 2000
@@ -17,6 +17,12 @@
VPATH = @srcdir@
top_srcdir = @top_srcdir@
+@BIND9_VERSION@
+
+@LIBDNS_API@
+
+@BIND9_INCLUDES@
+
CINCLUDES = -I../../lib/isc/unix/include \
-I${srcdir}/../../lib/isc/unix/include \
-I${srcdir}/../../lib/isc/pthreads/include \
@@ -39,9 +45,15 @@
@BIND9_MAKE_RULES@
-libt_api.@A@: ${OBJS}
+libt_api.a: ${OBJS}
${AR} ${ARFLAGS} $@ ${OBJS}
${RANLIB} $@
+
+libt_api.la: ${OBJS}
+ ${LIBTOOL} --mode=link \
+ ${CC} ${ALL_CFLAGS} -o libt_api.la -rpath ${libdir} \
+ -version-info ${LIBINTERFACE}:${LIBREVISION}:${LIBAGE} \
+ ${OBJS} ${LIBS}
timestamp: libt_api.@A@
touch timestamp

View file

@ -1,15 +1,8 @@
$NetBSD: patch-af,v 1.1.1.1 2000/02/22 03:50:59 hubertf Exp $
$NetBSD: patch-af,v 1.2 2000/03/31 11:15:25 hubertf Exp $
--- configure.BAK Mon Feb 21 06:09:34 2000
+++ configure Mon Feb 21 06:10:18 2000
@@ -931,12 +931,13 @@
case "$use_mit_pthreads+$use_ptl2" in
yes+no)
echo "$ac_t""mit-pthreads" 1>&6
- pkg="/usr/pkg/pthreads"
+ pkg="${LOCALBASE}/pthreads"
lib1="-L$pkg/lib -Wl,-R$pkg/lib"
lib2="-lpthread -lm -lgcc -lpthread"
--- configure.orig Fri Mar 31 01:09:27 2000
+++ configure Fri Mar 31 01:10:12 2000
@@ -1063,6 +1063,7 @@
LIBS="$lib1 $lib2 $LIBS"
CPPFLAGS="-I$pkg/include $CPPFLAGS"
STD_CINCLUDES="-I$pkg/include"

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ag,v 1.1.1.1 2000/02/22 03:50:59 hubertf Exp $
--- lib/isc/unix/ifiter_ioctl.c.orig Mon Feb 21 15:16:05 2000
+++ lib/isc/unix/ifiter_ioctl.c Mon Feb 21 15:16:38 2000
@@ -15,6 +15,9 @@
* SOFTWARE.
*/
+#include <errno.h>
+
+
/*
* Obtain the list of network interfaces using the SIOCGLIFCONF ioctl.
* See netintro(4).

View file

@ -1,62 +1,4 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2000/02/22 03:51:01 hubertf Exp $
sbin/named
sbin/lwresd
sbin/rndc
include/isc/assertions.h
include/isc/base64.h
include/isc/bitstring.h
include/isc/boolean.h
include/isc/buffer.h
include/isc/bufferlist.h
include/isc/commandline.h
include/isc/error.h
include/isc/event.h
include/isc/eventclass.h
include/isc/heap.h
include/isc/interfaceiter.h
include/isc/lang.h
include/isc/lex.h
include/isc/lfsr.h
include/isc/lib.h
include/isc/list.h
include/isc/magic.h
include/isc/mem.h
include/isc/mktemplate.h
include/isc/msgcat.h
include/isc/mutexblock.h
include/isc/netaddr.h
include/isc/platform.h
include/isc/print.h
include/isc/quota.h
include/isc/random.h
include/isc/ratelimiter.h
include/isc/rbtgen.h
include/isc/region.h
include/isc/result.h
include/isc/resultclass.h
include/isc/rwlock.h
include/isc/serial.h
include/isc/sockaddr.h
include/isc/socket.h
include/isc/str.h
include/isc/symtab.h
include/isc/task.h
include/isc/taskpool.h
include/isc/timer.h
include/isc/types.h
include/isc/ufile.h
include/isc/util.h
include/isc/app.h
include/isc/dir.h
include/isc/int.h
include/isc/net.h
include/isc/netdb.h
include/isc/stdtime.h
include/isc/time.h
include/isc/condition.h
include/isc/mutex.h
include/isc/once.h
include/isc/thread.h
@comment $NetBSD: PLIST,v 1.2 2000/03/31 11:15:25 hubertf Exp $
include/dns/a6.h
include/dns/acl.h
include/dns/aclconf.h
@ -86,10 +28,13 @@ include/dns/dbiterator.h
include/dns/dbtable.h
include/dns/dispatch.h
include/dns/dnssec.h
include/dns/enumclass.h
include/dns/enumtype.h
include/dns/events.h
include/dns/fixedname.h
include/dns/journal.h
include/dns/keyflags.h
include/dns/keytable.h
include/dns/keyvalues.h
include/dns/lib.h
include/dns/log.h
@ -108,12 +53,15 @@ include/dns/rdatalist.h
include/dns/rdataset.h
include/dns/rdatasetiter.h
include/dns/rdataslab.h
include/dns/rdatastruct.h
include/dns/rdatatype.h
include/dns/request.h
include/dns/resolver.h
include/dns/result.h
include/dns/rootns.h
include/dns/secalg.h
include/dns/secproto.h
include/dns/ssu.h
include/dns/tcpmsg.h
include/dns/time.h
include/dns/tkey.h
@ -121,72 +69,217 @@ include/dns/tkeyconf.h
include/dns/tsig.h
include/dns/ttl.h
include/dns/types.h
include/dns/validator.h
include/dns/view.h
include/dns/xfrin.h
include/dns/zone.h
include/dns/zoneconf.h
include/dns/zt.h
include/dns/enumclass.h
include/dns/enumtype.h
include/dns/rdatastruct.h
include/dst/dst.h
include/dst/lib.h
include/dst/result.h
include/dst/bio.h
include/dst/bn.h
include/dst/buffer.h
include/dst/crypto.h
include/dst/dh.h
include/dst/dsa.h
include/dst/e_os.h
include/dst/e_os2.h
include/dst/err.h
include/dst/lhash.h
include/dst/md5.h
include/dst/opensslconf.h
include/dst/opensslv.h
include/dst/rand.h
include/dst/sha.h
include/dst/stack.h
include/isc/app.h
include/isc/assertions.h
include/isc/base64.h
include/isc/bitstring.h
include/isc/boolean.h
include/isc/buffer.h
include/isc/bufferlist.h
include/isc/commandline.h
include/isc/condition.h
include/isc/dir.h
include/isc/error.h
include/isc/event.h
include/isc/eventclass.h
include/isc/heap.h
include/isc/int.h
include/isc/interfaceiter.h
include/isc/lang.h
include/isc/lex.h
include/isc/lfsr.h
include/isc/lib.h
include/isc/list.h
include/isc/magic.h
include/isc/mem.h
include/isc/mktemplate.h
include/isc/msgcat.h
include/isc/mutex.h
include/isc/mutexblock.h
include/isc/net.h
include/isc/netaddr.h
include/isc/netdb.h
include/isc/once.h
include/isc/platform.h
include/isc/print.h
include/isc/quota.h
include/isc/random.h
include/isc/ratelimiter.h
include/isc/rbtgen.h
include/isc/region.h
include/isc/result.h
include/isc/resultclass.h
include/isc/rwlock.h
include/isc/serial.h
include/isc/sockaddr.h
include/isc/socket.h
include/isc/stdtime.h
include/isc/str.h
include/isc/symtab.h
include/isc/task.h
include/isc/taskpool.h
include/isc/thread.h
include/isc/time.h
include/isc/timer.h
include/isc/types.h
include/isc/ufile.h
include/isc/util.h
include/lwres/context.h
include/lwres/int.h
include/lwres/ipv6.h
include/lwres/lang.h
include/lwres/list.h
include/lwres/lwbuffer.h
include/lwres/lwpacket.h
include/lwres/lwres.h
include/lwres/netdb.h
include/lwres/result.h
include/lwres/int.h
include/lwres/lang.h
include/lwres/net.h
include/lwres/ipv6.h
include/lwres/netdb.h
include/lwres/platform.h
include/lwres/result.h
include/omapi/compatibility.h
include/omapi/lib.h
include/omapi/omapi.h
include/omapi/private.h
include/omapi/result.h
include/omapi/types.h
lib/libisc.so.0.0
lib/libisc.so.0
lib/libisc.so
lib/libisc.la
lib/libisc.a
lib/libdns.so.0.0
lib/libdns.so.0
lib/libdns.so
lib/libdns.la
lib/libdns.a
lib/liblwres.so.0.0
lib/liblwres.so.0
lib/liblwres.so
lib/liblwres.la
lib/libdns.la
lib/libdns.so
lib/libdns.so.0
lib/libdns.so.0.0
lib/libisc.a
lib/libisc.la
lib/libisc.so
lib/libisc.so.0
lib/libisc.so.0.0
lib/liblwres.a
lib/libomapi.so.0.0
lib/libomapi.so.0
lib/libomapi.so
lib/libomapi.la
lib/liblwres.la
lib/liblwres.so
lib/liblwres.so.0
lib/liblwres.so.0.0
lib/libomapi.a
lib/libomapi.la
lib/libomapi.so
lib/libomapi.so.0
lib/libomapi.so.0.0
sbin/lwresd
sbin/named
sbin/rndc
share/doc/bind9/README
share/doc/bind9/arm/BV9ARM.1.html
share/doc/bind9/arm/BV9ARM.2.html
share/doc/bind9/arm/BV9ARM.3.html
share/doc/bind9/arm/BV9ARM.4.html
share/doc/bind9/arm/BV9ARM.5.html
share/doc/bind9/arm/BV9ARM.6.html
share/doc/bind9/arm/BV9ARM.7.html
share/doc/bind9/arm/BV9ARM.8.html
share/doc/bind9/arm/BV9ARM.PDF
share/doc/bind9/arm/BV9ARM.css
share/doc/bind9/arm/BV9ARM.html
share/doc/bind9/arm/isc.color.gif
share/doc/bind9/draft/draft-duerst-dns-i18n-02.txt
share/doc/bind9/draft/draft-dunlap-dns-duxfr-00.txt
share/doc/bind9/draft/draft-ietf-dhc-dhcp-dns-12.txt
share/doc/bind9/draft/draft-ietf-dnsext-apl-rr-00.txt
share/doc/bind9/draft/draft-ietf-dnsext-edns0dot5-00.txt
share/doc/bind9/draft/draft-ietf-dnsext-iana-dns-00.txt
share/doc/bind9/draft/draft-ietf-dnsext-sig-zero-00.txt
share/doc/bind9/draft/draft-ietf-dnsext-signing-auth-00.txt
share/doc/bind9/draft/draft-ietf-dnsext-simple-secure-update-00.txt
share/doc/bind9/draft/draft-ietf-dnsext-tkey-01.txt
share/doc/bind9/draft/draft-ietf-dnsext-tsig-00.txt
share/doc/bind9/draft/draft-ietf-dnsext-zone-status-00.txt
share/doc/bind9/draft/draft-ietf-dnsind-dddd-01.txt
share/doc/bind9/draft/draft-ietf-dnsind-dhcp-rr-00.txt
share/doc/bind9/draft/draft-ietf-dnsind-edns1-03.txt
share/doc/bind9/draft/draft-ietf-dnsind-indirect-key-01.txt
share/doc/bind9/draft/draft-ietf-dnsind-keyreferral-00.txt
share/doc/bind9/draft/draft-ietf-dnsind-kitchen-sink-02.txt
share/doc/bind9/draft/draft-ietf-dnsind-local-compression-05.txt
share/doc/bind9/draft/draft-ietf-dnsind-local-names-08.txt
share/doc/bind9/draft/draft-ietf-dnsind-rfc2052bis-02.txt
share/doc/bind9/draft/draft-ietf-dnsind-rollover-00.txt
share/doc/bind9/draft/draft-ietf-dnsind-sec-rr-00.txt
share/doc/bind9/draft/draft-ietf-dnsind-sigalgopt-00.txt
share/doc/bind9/draft/draft-ietf-dnsind-test-tlds-13.txt
share/doc/bind9/draft/draft-ietf-dnsind-verify-01.txt
share/doc/bind9/draft/draft-ietf-dnssec-ar-00.txt
share/doc/bind9/draft/draft-ietf-dnssec-as-map-06.txt
share/doc/bind9/draft/draft-ietf-dnssec-key-handling-00.txt
share/doc/bind9/draft/draft-ietf-dnssec-secfail-00.txt
share/doc/bind9/draft/draft-ietf-dnssec-update2-00.txt
share/doc/bind9/draft/draft-ietf-enum-rqmts-00.txt
share/doc/bind9/draft/draft-ietf-idn-requirment-00.txt
share/doc/bind9/draft/draft-ietf-ipngwg-2292bis-00.txt
share/doc/bind9/draft/draft-ietf-ipngwg-default-addr-select-00.txt
share/doc/bind9/draft/draft-ietf-ipngwg-dns-lookups-05.txt
share/doc/bind9/draft/draft-schroeppel-dnsind-ecc-00.txt
share/doc/bind9/draft/draft-skwan-gss-tsig-05.txt
share/doc/bind9/draft/draft-skwan-utf8-dns-03.txt
share/doc/bind9/misc/options
share/doc/bind9/rfc/rfc1032.txt
share/doc/bind9/rfc/rfc1033.txt
share/doc/bind9/rfc/rfc1034.txt
share/doc/bind9/rfc/rfc1035.txt
share/doc/bind9/rfc/rfc1101.txt
share/doc/bind9/rfc/rfc1122.txt
share/doc/bind9/rfc/rfc1123.txt
share/doc/bind9/rfc/rfc1183.txt
share/doc/bind9/rfc/rfc1348.txt
share/doc/bind9/rfc/rfc1535.txt
share/doc/bind9/rfc/rfc1536.txt
share/doc/bind9/rfc/rfc1537.txt
share/doc/bind9/rfc/rfc1591.txt
share/doc/bind9/rfc/rfc1706.txt
share/doc/bind9/rfc/rfc1712.txt
share/doc/bind9/rfc/rfc1750.txt
share/doc/bind9/rfc/rfc1876.txt
share/doc/bind9/rfc/rfc1982.txt
share/doc/bind9/rfc/rfc1995.txt
share/doc/bind9/rfc/rfc1996.txt
share/doc/bind9/rfc/rfc2052.txt
share/doc/bind9/rfc/rfc2104.txt
share/doc/bind9/rfc/rfc2119.txt
share/doc/bind9/rfc/rfc2136.txt
share/doc/bind9/rfc/rfc2137.txt
share/doc/bind9/rfc/rfc2163.txt
share/doc/bind9/rfc/rfc2168.txt
share/doc/bind9/rfc/rfc2181.txt
share/doc/bind9/rfc/rfc2230.txt
share/doc/bind9/rfc/rfc2308.txt
share/doc/bind9/rfc/rfc2373.txt
share/doc/bind9/rfc/rfc2374.txt
share/doc/bind9/rfc/rfc2375.txt
share/doc/bind9/rfc/rfc2418.txt
share/doc/bind9/rfc/rfc2535.txt
share/doc/bind9/rfc/rfc2536.txt
share/doc/bind9/rfc/rfc2537.txt
share/doc/bind9/rfc/rfc2538.txt
share/doc/bind9/rfc/rfc2539.txt
share/doc/bind9/rfc/rfc2540.txt
share/doc/bind9/rfc/rfc2541.txt
share/doc/bind9/rfc/rfc2553.txt
share/doc/bind9/rfc/rfc2671.txt
share/doc/bind9/rfc/rfc2672.txt
share/doc/bind9/rfc/rfc2673.txt
share/doc/bind9/rfc/rfc2782.txt
@dirrm share/doc/bind9/rfc
@dirrm share/doc/bind9/misc
@dirrm share/doc/bind9/draft
@dirrm share/doc/bind9/arm
@dirrm share/doc/bind9
@dirrm include/omapi
@dirrm include/lwres
@dirrm include/isc
@dirrm include/dst
@dirrm include/dns
@dirrm include/isc