Bump PKGREVISION to 1.
This commit is contained in:
snj 2015-03-03 17:19:58 +00:00
parent 812ab404d1
commit 697ef80037
4 changed files with 49 additions and 2 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.47 2014/12/16 07:40:58 chopps Exp $
# $NetBSD: Makefile,v 1.48 2015/03/03 17:19:58 snj Exp $
.include "dist.mk"
PKGNAME= python27-${PY_DISTVERSION}
PKGREVISION= 1
CATEGORIES= lang python
MAINTAINER= pkgsrc-users@NetBSD.org

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.48 2014/12/16 07:07:32 chopps Exp $
$NetBSD: distinfo,v 1.49 2015/03/03 17:19:58 snj Exp $
SHA1 (Python-2.7.9.tar.xz) = 3172f6e957713c2d9fca462cc16068222fd1b9d3
RMD160 (Python-2.7.9.tar.xz) = 2b047c3b56987b473c3ca957ad87f5582c37d6f6
@ -6,7 +6,9 @@ Size (Python-2.7.9.tar.xz) = 12164712 bytes
SHA1 (patch-Include_pyerrors.h) = 3eba043c83b1d1df4918524f7b53047a6ed372ae
SHA1 (patch-Include_pyport.h) = 971c7c548b92595712d0d70a0917a0ccc83b6c7e
SHA1 (patch-Lib_distutils_unixccompiler.py) = 39b967dc2ae648143d5841f22602a21063b4d5ea
SHA1 (patch-Lib_dumbdb.py) = b4b154f511c8852e2f869653eccd7d9a1c21e734
SHA1 (patch-Lib_multiprocessing_process.py) = b47ad4cbeddbcfb4342c08c84d0d515a793815d4
SHA1 (patch-Lib_test_test__dumbdbm.py) = f59f0d8bbf910bac369528129b564597a77379ba
SHA1 (patch-Modules_getaddrinfo.c) = 696c58c4c4bbb710fb1508d7d88864d0b08cfc79
SHA1 (patch-Modules_getpath.c) = aa8a54717a85f831e3ceaad19d96c43bc38aef10
SHA1 (patch-Modules_mmapmodule.c) = 87ea76e6d8263045c1ca794ff5c75ed631a74b6d

View file

@ -0,0 +1,23 @@
$NetBSD: patch-Lib_dumbdb.py,v 1.1 2015/03/03 17:19:58 snj Exp $
http://bugs.python.org/issue22885
--- Lib/dumbdbm.py.orig 2015-03-03 09:05:52.000000000 -0800
+++ Lib/dumbdbm.py 2015-03-03 09:10:02.000000000 -0800
@@ -21,6 +21,7 @@ is read when the database is opened, and
"""
+import ast as _ast
import os as _os
import __builtin__
import UserDict
@@ -85,7 +86,7 @@ class _Database(UserDict.DictMixin):
with f:
for line in f:
line = line.rstrip()
- key, pos_and_siz_pair = eval(line)
+ key, pos_and_siz_pair = _ast.literal_eval(line)
self._index[key] = pos_and_siz_pair
# Write the index dict to the directory file. The original directory

View file

@ -0,0 +1,21 @@
$NetBSD: patch-Lib_test_test__dumbdbm.py,v 1.1 2015/03/03 17:19:58 snj Exp $
http://bugs.python.org/issue22885
--- Lib/test/test_dumbdbm.py.orig 2015-03-03 09:05:53.000000000 -0800
+++ Lib/test/test_dumbdbm.py 2015-03-03 09:10:02.000000000 -0800
@@ -160,6 +160,14 @@ class DumbDBMTestCase(unittest.TestCase)
self.assertEqual(expected, got)
f.close()
+ def test_eval(self):
+ with open(_fname + '.dir', 'w') as stream:
+ stream.write("str(__import__('sys').stdout.write('Hacked!')), 0\n")
+ with test_support.captured_stdout() as stdout:
+ with self.assertRaises(ValueError):
+ dumbdbm.open(_fname).close()
+ self.assertEqual(stdout.getvalue(), '')
+
def tearDown(self):
_delete_files()