Remove ffplay, ffmpeg; add ffplay1, ffmpeg1 to Makefile.

This commit is contained in:
wiz 2014-08-11 23:10:51 +00:00
parent 5bce7a8784
commit 698273f94b
15 changed files with 3 additions and 656 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.226 2014/08/09 20:26:40 wiz Exp $
# $NetBSD: Makefile,v 1.227 2014/08/11 23:10:51 wiz Exp $
#
COMMENT= Multimedia utilities
@ -27,13 +27,13 @@ SUBDIR+= dvdrip
SUBDIR+= dvdstyler
SUBDIR+= dvdview
SUBDIR+= farsight2
SUBDIR+= ffmpeg
SUBDIR+= ffmpeg010
SUBDIR+= ffmpeg1
SUBDIR+= ffmpeg2
SUBDIR+= ffmpeg2theora
SUBDIR+= ffmpegthumbnailer
SUBDIR+= ffmpegthumbs
SUBDIR+= ffplay
SUBDIR+= ffplay1
SUBDIR+= ffplay2
SUBDIR+= flashplayer
SUBDIR+= fuppes

View file

@ -1,3 +0,0 @@
FFmpeg is a complete, cross-platform solution to record, convert
and stream audio and video. It includes libavcodec - the leading
audio/video codec library.

View file

@ -1,60 +0,0 @@
# $NetBSD: Makefile,v 1.123 2014/07/04 10:34:52 adam Exp $
PKGNAME= ffmpeg-20140623.${DISTVERSION}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://ffmpeg.mplayerhq.hu/
COMMENT= Decoding, encoding and streaming software
CONFIGURE_ARGS+= --enable-avfilter
#CONFIGURE_ARGS+= --enable-avfilter-lavf
CONFIGURE_ARGS+= --enable-postproc
INSTALLATION_DIRS= lib share/examples/ffmpeg share/doc/ffmpeg
CONF_FILES+= ${PREFIX}/share/examples/ffmpeg/ffserver.conf \
${PKG_SYSCONFDIR}/ffserver.conf
# Needs to come before bsd.prefs.mk or compiler.mk, USE_LIBTOOL is set too late.
USE_GCC_RUNTIME= yes
.include "../../mk/bsd.prefs.mk"
.if !empty(USE_CROSS_COMPILE:M[yY][eE][sS])
CONFIGURE_ARGS+= --enable-cross-compile
CONFIGURE_ARGS+= --target-os=${LOWER_OPSYS}
CONFIGURE_ARGS+= --arch=${MACHINE_ARCH}
CONFIGURE_ARGS+= --host-cc=${NATIVE_CC:Q}
CONFIGURE_ARGS+= --host-ld=${NATIVE_CC:Q}
.endif
TEST_TARGET= check
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/*.txt \
${DESTDIR}${PREFIX}/share/doc/ffmpeg
${INSTALL_DATA} ${WRKSRC}/doc/ffserver.conf \
${DESTDIR}${PREFIX}/share/examples/ffmpeg
.include "options.mk"
.include "../../mk/compiler.mk"
# disable asm on i386 for non-gcc and gcc < 4.2
# no alignment options needed for gcc >= 4.6 on i386
.if ${MACHINE_ARCH} == "i386"
. if !empty(MACHINE_PLATFORM:MDarwin-*-i386) \
|| !empty(MACHINE_PLATFORM:MSunOS-*-i386) \
|| !empty(CC_VERSION:Mgcc-[123]*) \
|| !empty(CC_VERSION:Mgcc-4.[01]*) \
|| empty(CC_VERSION:Mgcc*)
CONFIGURE_ARGS+= --disable-asm
. elif !empty(CC_VERSION:Mgcc-4.[2345]*)
CFLAGS+= -mstackrealign -mpreferred-stack-boundary=4
. endif
.endif
.if !empty(PKGSRC_COMPILER:Mclang)
CFLAGS+= -no-integrated-as
.endif
.include "../../multimedia/ffmpeg/Makefile.common"

View file

@ -1,80 +0,0 @@
# $NetBSD: Makefile.common,v 1.39 2014/07/04 10:33:41 adam Exp $
# used by multimedia/ffplay/Makefile
# used by multimedia/ffmpeg/Makefile
DISTNAME= ffmpeg-${DISTVERSION:S/-//g}
CATEGORIES= multimedia
MASTER_SITES= http://www.ffmpeg.org/releases/
EXTRACT_SUFX= .tar.bz2
LICENSE= gnu-lgpl-v2.1 AND gnu-gpl-v2
DISTVERSION= 1.2.7
PREV_PKGPATH= multimedia/ffmpeg-devel
PATCHDIR= ${.CURDIR}/../../multimedia/ffmpeg/patches
USE_LANGUAGES= c99
USE_LIBTOOL= yes
USE_TOOLS+= gmake texi2html pod2man
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --mandir=${PREFIX}/${PKGMANDIR}
CONFIGURE_ARGS+= --cc=${CC:Q}
CONFIGURE_ARGS+= --prefix=${PREFIX}
CONFIGURE_ARGS+= --disable-debug
CONFIGURE_ARGS+= --disable-optimizations
CONFIGURE_ARGS+= --disable-stripping
CONFIGURE_ARGS+= --enable-shared
CONFIGURE_ARGS+= --enable-pthreads
CONFIGURE_ARGS+= --enable-gpl
.if ${OPSYS} == "SunOS"
CONFIGURE_ARGS+= --disable-asm
.else
CONFIGURE_ARGS+= --enable-runtime-cpudetect
.endif
# No posix_memalign() in NetBSD 4.0 and earlier
.if !empty(MACHINE_PLATFORM:MNetBSD-[1-4].*-*)
CONFIGURE_ARGS+= --enable-memalign-hack
.endif
# Let's not put garbage into /tmp
CONFIGURE_ENV+= TMPDIR=${WRKSRC}/tmp
.include "../../mk/compiler.mk"
.if ${OPSYS} == "SunOS" && empty(CC_VERSION:Mgcc*)
SUBST_CLASSES+= sunwspro
SUBST_MESSAGE.sunwspro= Fixing compiler options for SunStudio C compiler.
SUBST_STAGE.sunwspro= post-configure
SUBST_FILES.sunwspro= config.mak
SUBST_SED.sunwspro= -e "s/-O /-KPIC -DPIC /"
SUBST_SED.sunwspro+= -e "s/-O3/-xO2/g"
SUBST_SED.sunwspro+= -e "s/-std=c99/-xc99=all/"
SUBST_SED.sunwspro+= -e "s/-Wl,-rpath-link,/-L /g"
.endif
BUILD_DEPENDS+= yasm>=0.7.2:../../devel/yasm
REPLACE_PERL+= doc/texi2pod.pl
REPLACE_SH+= configure version.sh
SUBST_CLASSES+= conf
SUBST_STAGE.conf= post-patch
SUBST_FILES.conf= ffserver.c
SUBST_SED.conf= -e 's,/etc/ffserver.conf,${PKG_SYSCONFDIR}/ffserver.conf,g'
SUBST_MESSAGE.conf= Fixing configuration path.
PLIST_SRC+= ${PKGDIR}/PLIST
MAKE_ENV+= EXTRA_LIBS=${LIBGETOPT:Q}
# LOCALBASE=${LOCALBASE:Q}
pre-configure:
mkdir ${WRKSRC}/tmp
.include "../../mk/pthread.buildlink3.mk"
.include "../../archivers/bzip2/buildlink3.mk"
.include "../../devel/libgetopt/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,154 +0,0 @@
@comment $NetBSD: PLIST,v 1.21 2013/03/17 15:18:11 wiz Exp $
bin/ffmpeg
bin/ffprobe
bin/ffserver
include/libavcodec/avcodec.h
include/libavcodec/avfft.h
include/libavcodec/dxva2.h
include/libavcodec/old_codec_ids.h
include/libavcodec/vaapi.h
include/libavcodec/vda.h
include/libavcodec/vdpau.h
include/libavcodec/version.h
include/libavcodec/xvmc.h
include/libavdevice/avdevice.h
include/libavdevice/version.h
include/libavfilter/asrc_abuffer.h
include/libavfilter/avcodec.h
include/libavfilter/avfilter.h
include/libavfilter/avfiltergraph.h
include/libavfilter/buffersink.h
include/libavfilter/buffersrc.h
include/libavfilter/version.h
include/libavformat/avformat.h
include/libavformat/avio.h
include/libavformat/version.h
include/libavutil/adler32.h
include/libavutil/aes.h
include/libavutil/attributes.h
include/libavutil/audio_fifo.h
include/libavutil/audioconvert.h
include/libavutil/avassert.h
include/libavutil/avconfig.h
include/libavutil/avstring.h
include/libavutil/avutil.h
include/libavutil/base64.h
include/libavutil/blowfish.h
include/libavutil/bprint.h
include/libavutil/bswap.h
include/libavutil/channel_layout.h
include/libavutil/common.h
include/libavutil/cpu.h
include/libavutil/crc.h
include/libavutil/dict.h
include/libavutil/error.h
include/libavutil/eval.h
include/libavutil/fifo.h
include/libavutil/file.h
include/libavutil/hmac.h
include/libavutil/imgutils.h
include/libavutil/intfloat.h
include/libavutil/intfloat_readwrite.h
include/libavutil/intreadwrite.h
include/libavutil/lfg.h
include/libavutil/log.h
include/libavutil/lzo.h
include/libavutil/mathematics.h
include/libavutil/md5.h
include/libavutil/mem.h
include/libavutil/old_pix_fmts.h
include/libavutil/opt.h
include/libavutil/parseutils.h
include/libavutil/pixdesc.h
include/libavutil/pixfmt.h
include/libavutil/random_seed.h
include/libavutil/rational.h
include/libavutil/samplefmt.h
include/libavutil/sha.h
include/libavutil/time.h
include/libavutil/timecode.h
include/libavutil/timestamp.h
include/libavutil/version.h
include/libavutil/xtea.h
include/libpostproc/postprocess.h
include/libpostproc/version.h
include/libswresample/swresample.h
include/libswresample/version.h
include/libswscale/swscale.h
include/libswscale/version.h
lib/libavcodec.a
lib/libavcodec.so
lib/libavcodec.so.54
lib/libavcodec.so.54.92.100
lib/libavdevice.a
lib/libavdevice.so
lib/libavdevice.so.54
lib/libavdevice.so.54.3.103
lib/libavfilter.a
lib/libavfilter.so
lib/libavfilter.so.3
lib/libavfilter.so.3.42.103
lib/libavformat.a
lib/libavformat.so
lib/libavformat.so.54
lib/libavformat.so.54.63.104
lib/libavutil.a
lib/libavutil.so
lib/libavutil.so.52
lib/libavutil.so.52.18.100
lib/libpostproc.a
lib/libpostproc.so
lib/libpostproc.so.52
lib/libpostproc.so.52.2.100
lib/libswresample.a
lib/libswresample.so
lib/libswresample.so.0
lib/libswresample.so.0.17.102
lib/libswscale.a
lib/libswscale.so
lib/libswscale.so.2
lib/libswscale.so.2.2.100
lib/pkgconfig/libavcodec.pc
lib/pkgconfig/libavdevice.pc
lib/pkgconfig/libavfilter.pc
lib/pkgconfig/libavformat.pc
lib/pkgconfig/libavutil.pc
lib/pkgconfig/libpostproc.pc
lib/pkgconfig/libswresample.pc
lib/pkgconfig/libswscale.pc
share/doc/ffmpeg/avutil.txt
share/doc/ffmpeg/build_system.txt
share/doc/ffmpeg/errno.txt
share/doc/ffmpeg/ffmpeg.txt
share/doc/ffmpeg/filter_design.txt
share/doc/ffmpeg/git-howto.txt
share/doc/ffmpeg/issue_tracker.txt
share/doc/ffmpeg/mips.txt
share/doc/ffmpeg/multithreading.txt
share/doc/ffmpeg/optimization.txt
share/doc/ffmpeg/rate_distortion.txt
share/doc/ffmpeg/snow.txt
share/doc/ffmpeg/soc.txt
share/doc/ffmpeg/swresample.txt
share/doc/ffmpeg/swscale.txt
share/doc/ffmpeg/tablegen.txt
share/doc/ffmpeg/viterbi.txt
share/examples/ffmpeg/ffserver.conf
share/ffmpeg/examples/Makefile
share/ffmpeg/examples/README
share/ffmpeg/examples/decoding_encoding.c
share/ffmpeg/examples/demuxing.c
share/ffmpeg/examples/filtering_audio.c
share/ffmpeg/examples/filtering_video.c
share/ffmpeg/examples/metadata.c
share/ffmpeg/examples/muxing.c
share/ffmpeg/examples/resampling_audio.c
share/ffmpeg/examples/scaling_video.c
share/ffmpeg/ffprobe.xsd
share/ffmpeg/libvpx-1080p.ffpreset
share/ffmpeg/libvpx-1080p50_60.ffpreset
share/ffmpeg/libvpx-360p.ffpreset
share/ffmpeg/libvpx-720p.ffpreset
share/ffmpeg/libvpx-720p50_60.ffpreset
share/ffmpeg/libx264-ipod320.ffpreset
share/ffmpeg/libx264-ipod640.ffpreset

View file

@ -1,42 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.24 2014/04/10 05:39:14 obache Exp $
BUILDLINK_TREE+= ffmpeg
.if !defined(FFMPEG_BUILDLINK3_MK)
FFMPEG_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.ffmpeg+= ffmpeg>=20120919.0.10.5
BUILDLINK_ABI_DEPENDS.ffmpeg+= ffmpeg>=20140305.1.2.6nb1
BUILDLINK_PKGSRCDIR.ffmpeg?= ../../multimedia/ffmpeg
pkgbase := ffmpeg
. include "../../mk/pkg-build-options.mk"
.include "../../mk/bsd.fast.prefs.mk"
.if !empty(PKG_BUILD_OPTIONS.ffmpeg:Mtheora)
. include "../../multimedia/libtheora/buildlink3.mk"
.endif
.if !empty(PKG_BUILD_OPTIONS.ffmpeg:Mxvid)
. include "../../multimedia/xvidcore/buildlink3.mk"
.endif
.if !empty(PKG_BUILD_OPTIONS.ffmpeg:Mx264)
. include "../../multimedia/x264-devel/buildlink3.mk"
.endif
.if !empty(PKG_BUILD_OPTIONS.ffmpeg:Mfaac)
. include "../../audio/faac/buildlink3.mk"
.endif
.if !empty(PKG_BUILD_OPTIONS.ffmpeg:Mlibvpx)
. include "../../multimedia/libvpx/buildlink3.mk"
.endif
.include "../../archivers/bzip2/buildlink3.mk"
.include "../../devel/libgetopt/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.endif # FFMPEG_BUILDLINK3_MK
BUILDLINK_TREE+= -ffmpeg

View file

@ -1,10 +0,0 @@
$NetBSD: distinfo,v 1.75 2014/07/04 10:33:41 adam Exp $
SHA1 (ffmpeg-1.2.7.tar.bz2) = ff49a6b28e174f9f8072638d8251e1e447666ef6
RMD160 (ffmpeg-1.2.7.tar.bz2) = ac1df042ebb63f815292f48d899bd8cb70098112
Size (ffmpeg-1.2.7.tar.bz2) = 5969563 bytes
SHA1 (patch-CVE-2014-4610) = dc77f6f37760c0e34f730f241af1ba3ce72ef5b1
SHA1 (patch-aa) = 14006874aee07e7e41803269040f0ae0157d931d
SHA1 (patch-ac) = ff8a7a5fdfd4987ef2835bd7360a78efd4310253
SHA1 (patch-ap) = ebbd0c169f228af37ae2dd54b27d5dba11a34c5e
SHA1 (patch-configure) = a04493172f7600cc9ebbda6c140915b1169f5f14

View file

@ -1,148 +0,0 @@
# $NetBSD: options.mk,v 1.28 2013/04/14 01:36:44 cheusov Exp $
# Global and legacy options
PKG_OPTIONS_VAR= PKG_OPTIONS.ffmpeg
PKG_SUPPORTED_OPTIONS= faac lame ass libvpx theora vorbis x264 xvid \
opencore-amr
PKG_SUGGESTED_OPTIONS= lame ass libvpx theora vorbis x264 xvid
#PKG_OPTIONS_OPTIONAL_GROUPS= aac-decoder
#PKG_OPTIONS_GROUP.aac-decoder= faac
### Add VDPAU if it is available
.include "../../multimedia/libvdpau/available.mk"
.if ${VDPAU_AVAILABLE} == "yes"
PKG_SUPPORTED_OPTIONS+= vdpau
PKG_SUGGESTED_OPTIONS+= vdpau
.endif
### Add VAAPI if it is available
.include "../../multimedia/libva/available.mk"
.if ${VAAPI_AVAILABLE} == "yes"
PKG_SUPPORTED_OPTIONS+= vaapi
PKG_SUGGESTED_OPTIONS+= vaapi
.endif
###
.include "../../mk/bsd.options.mk"
###
### ass option
###
.if !empty(PKG_OPTIONS:Mass)
USE_TOOLS+= pkg-config
CONFIGURE_ARGS+= --enable-libass
.include "../../multimedia/libass/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-libass
.endif
###
### faac option
###
.if !empty(PKG_OPTIONS:Mfaac)
RESTRICTED= This software may require the payment of patent royalties
NO_BIN_ON_CDROM= ${RESTRICTED}
NO_BIN_ON_FTP= ${RESTRICTED}
CONFIGURE_ARGS+= --enable-libfaac
CONFIGURE_ARGS+= --enable-nonfree
.include "../../audio/faac/buildlink3.mk"
.endif
###
### opencore-amr option
###
.if !empty(PKG_OPTIONS:Mopencore-amr)
CONFIGURE_ARGS+= --enable-libopencore-amrnb
CONFIGURE_ARGS+= --enable-libopencore-amrwb
# "The OpenCORE external libraries are under the Apache License
# 2.0. That license is incompatible with the LGPL v2.1 and the GPL
# v2, but not with version 3 of those licenses. So to combine the
# OpenCORE libraries with FFmpeg, the license version needs to be
# upgraded by passing --enable-version3 to configure."
CONFIGURE_ARGS+= --enable-version3
# TODO: LICENSE
.include "../../audio/opencore-amr/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-libopencore-amrnb
CONFIGURE_ARGS+= --disable-libopencore-amrwb
.endif
###
### OGG Theora support
###
.if !empty(PKG_OPTIONS:Mtheora)
CONFIGURE_ARGS+= --enable-libtheora
.include "../../multimedia/libtheora/buildlink3.mk"
.endif
###
### OGG Vorbis support
###
.if !empty(PKG_OPTIONS:Mvorbis)
CONFIGURE_ARGS+= --enable-libvorbis
.include "../../audio/libvorbis/buildlink3.mk"
.endif
###
### LAME MP3 encoder
###
.if !empty(PKG_OPTIONS:Mlame)
# "lame-3.98" isn't compatible with "ffmpeg" which breaks audio encoding.
BUILDLINK_ABI_DEPENDS.lame+= lame>=3.98.2nb1
CONFIGURE_ARGS+= --enable-libmp3lame
.include "../../audio/lame/buildlink3.mk"
.endif
###
### XviD support
###
.if !empty(PKG_OPTIONS:Mxvid)
CONFIGURE_ARGS+= --enable-libxvid
.include "../../multimedia/xvidcore/buildlink3.mk"
.endif
###
### x264 support
###
.if !empty(PKG_OPTIONS:Mx264)
# ABI change between 20090326 and 20100201
BUILDLINK_API_DEPENDS.x264-devel+= x264-devel>=20111207
#BUILDLINK_API_DEPENDS.x264-devel+= x264-devel<20110102
CONFIGURE_ARGS+= --enable-libx264
.include "../../multimedia/x264-devel/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-libx264
.endif
###
### VDPAU support
###
.if !empty(PKG_OPTIONS:Mvdpau)
CONFIGURE_ARGS+= --enable-vdpau
.include "../../multimedia/libvdpau/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-vdpau
.endif
###
### VAAPI support
###
.if !empty(PKG_OPTIONS:Mvaapi)
CONFIGURE_ARGS+= --enable-vaapi
.include "../../multimedia/libva/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-vaapi
.endif
###
### VPX support
###
.if !empty(PKG_OPTIONS:Mlibvpx)
CONFIGURE_ARGS+= --enable-libvpx
.include "../../multimedia/libvpx/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-libvpx
.endif

View file

@ -1,20 +0,0 @@
$NetBSD: patch-aa,v 1.13 2013/01/16 20:55:47 adam Exp $
--- libavutil/x86/cpu.c.orig 2013-01-06 21:53:29.000000000 +0000
+++ libavutil/x86/cpu.c
@@ -115,6 +115,7 @@ int ff_get_cpu_flags_x86(void)
#if HAVE_SSE
if (std_caps & (1 << 25))
rval |= AV_CPU_FLAG_SSE;
+#if !defined(__GNUC__) || (__GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 2))
if (std_caps & (1 << 26))
rval |= AV_CPU_FLAG_SSE2;
if (ecx & 1)
@@ -134,6 +135,7 @@ int ff_get_cpu_flags_x86(void)
rval |= AV_CPU_FLAG_AVX;
}
#endif /* HAVE_AVX */
+#endif /* gcc >= 4.2 */
#endif /* HAVE_SSE */
}

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ac,v 1.14 2013/01/16 20:55:47 adam Exp $
--- Makefile.orig 2012-09-28 01:37:35.000000000 +0000
+++ Makefile
@@ -139,8 +139,8 @@ install-progs: install-progs-yes $(PROGS
install-data: $(DATA_FILES) $(EXAMPLES_FILES)
$(Q)mkdir -p "$(DATADIR)/examples"
- $(INSTALL) -m 644 $(DATA_FILES) "$(DATADIR)"
- $(INSTALL) -m 644 $(EXAMPLES_FILES) "$(DATADIR)/examples"
+ $(INSTALL) -c -m 644 $(DATA_FILES) "$(DATADIR)"
+ $(INSTALL) -c -m 644 $(EXAMPLES_FILES) "$(DATADIR)/examples"
uninstall: uninstall-libs uninstall-headers uninstall-progs uninstall-data

View file

@ -1,27 +0,0 @@
$NetBSD: patch-ap,v 1.6 2013/01/16 20:55:47 adam Exp $
--- libavutil/common.h.orig 2013-01-06 21:53:29.000000000 +0000
+++ libavutil/common.h
@@ -39,6 +39,22 @@
#include "version.h"
#include "libavutil/avconfig.h"
+#if defined(__cplusplus)
+#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__linux__)
+#undef _STDINT_H_
+#undef _SYS_STDINT_H_
+#undef _STDINT_H
+#undef _GCC_WRAP_STDINT_H
+#ifndef __STDC_CONSTANT_MACROS
+#define __STDC_CONSTANT_MACROS
+#endif
+#include <stdint.h>
+#endif /* FreeBSD | OpenBSD | linux */
+#if defined(__DragonFly__) || defined(__NetBSD__)
+#include <machine/int_const.h>
+#endif /* DragonFly | NetBSD */
+#endif /* __cplusplus */
+
#if AV_HAVE_BIGENDIAN
# define AV_NE(be, le) (be)
#else

View file

@ -1,58 +0,0 @@
$NetBSD: patch-configure,v 1.19 2013/08/02 18:24:18 adam Exp $
--- configure.orig 2013-07-27 23:49:20.000000000 +0000
+++ configure
@@ -3225,6 +3225,11 @@ case $target_os in
;;
netbsd)
disable symver
+ # NetBSD/macppc *really* needs PIC enabled. ffmpeg has repeatedly
+ # broken time and time again because PIC support has been removed
+ # from architectures that need it. So, if you touch this, please
+ # be careful and make sure that your changes work.
+ test "${subarch}" != "x86_32" && enable pic
oss_indev_extralibs="-lossaudio"
oss_outdev_extralibs="-lossaudio"
enabled gcc || check_ldflags -Wl,-zmuldefs
@@ -3555,10 +3560,13 @@ check_cc <<EOF && enable attribute_may_a
union { int x; } __attribute__((may_alias)) x;
EOF
-check_cc <<EOF || die "endian test failed"
-unsigned int endian = 'B' << 24 | 'I' << 16 | 'G' << 8 | 'E';
+check_exec <<EOF || enable bigendian
+int main()
+{
+ long one = 1;
+ return !(*((char *)(&one)));
+}
EOF
-od -t x1 $TMPO | grep -q '42 *49 *47 *45' && enable bigendian
if enabled alpha; then
@@ -4092,6 +4100,7 @@ enabled xmm_clobber_test &&
-Wl,--wrap,sws_scale ||
disable xmm_clobber_test
+if false; then
echo "X{};" > $TMPV
if test_ldflags -Wl,--version-script,$TMPV; then
append SHFLAGS '-Wl,--version-script,\$(SUBDIR)lib\$(NAME).ver'
@@ -4104,6 +4113,7 @@ __asm__(".symver ff_foo,av_foo@VERSION")
void ff_foo(void) {}
EOF
fi
+fi
if [ -z "$optflags" ]; then
if enabled small; then
@@ -4560,7 +4570,7 @@ Version: $version
Requires: $(enabled shared || echo $requires)
Requires.private: $(enabled shared && echo $requires)
Conflicts:
-Libs: -L\${libdir} -l${shortname} $(enabled shared || echo $libs)
+Libs: -L\${libdir} -Wl,-R\${libdir} -l${shortname} $(enabled shared || echo $libs)
Libs.private: $(enabled shared && echo $libs)
Cflags: -I\${includedir}
EOF

View file

@ -1,3 +0,0 @@
FFplay is a very simple and portable media player using the FFmpeg
libraries and the SDL library. It is mostly used as a testbed for
the various FFmpeg APIs.

View file

@ -1,31 +0,0 @@
# $NetBSD: Makefile,v 1.14 2014/08/11 23:09:45 wiz Exp $
PKGNAME= ${DISTNAME:S/ffmpeg/ffplay/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://ffmpeg.mplayerhq.hu/
COMMENT= Simple SDL frontend for FFmpeg
DISTINFO_FILE= ${.CURDIR}/../ffmpeg/distinfo
CONFIGURE_ARGS+= --disable-ffmpeg
CONFIGURE_ARGS+= --disable-ffserver
CONFIGURE_ARGS+= --disable-encoders
CONFIGURE_ARGS+= --disable-decoders
CONFIGURE_ARGS+= --disable-hwaccels
CONFIGURE_ARGS+= --disable-muxers
CONFIGURE_ARGS+= --disable-demuxers
CONFIGURE_ARGS+= --disable-parsers
CONFIGURE_ARGS+= --disable-bsfs
CONFIGURE_ARGS+= --disable-protocols
CONFIGURE_ARGS+= --disable-devices
#CONFIGURE_ARGS+= --disable-filters
CONFIGURE_ARGS+= --enable-ffplay
INSTALLATION_DIRS+= bin ${PKGMANDIR}/man1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ffplay ${DESTDIR}${PREFIX}/bin
.include "../../devel/SDL/buildlink3.mk"
.include "../../multimedia/ffmpeg1/buildlink3.mk"
.include "../../multimedia/ffmpeg/Makefile.common"

View file

@ -1,2 +0,0 @@
@comment $NetBSD: PLIST,v 1.2 2012/11/08 19:57:29 adam Exp $
bin/ffplay