tmate 2.4.0
New Features: Add support for named sessions. Run tmate with tmate -k api_key -n session_name -r session_name_ro to name sessions. See https://tmate.io/#named_sessions Add a foreground mode with tmate -F. This is useful when tmate is used only for remote access. See https://tmate.io/#remote_access Add SSH key access control. Run tmate with -a authorized_keys or set tmate-authorized-keys in the tmate configuration file. This will allow access to tmate to only SSH clients with keys contained in the authorized keys file. See https://tmate.io/#access_control SSH keys are no longer needed to use tmate Bug fixes: Fix reconnection bug due to misconfigured keepalives Existing feature changes: Tmux configuration file ~/.tmux.conf is no longer loaded.. You may add source-file ~/.tmux.conf in ~/.tmate.conf to retain the older behavior. Discussion can be found in #108 Initial connection strings are now shown in a separate window at start time --- tmate 2.3.0 tmate is now compatible with libssh 0.9.
This commit is contained in:
parent
64ade8241e
commit
699dfd1235
6 changed files with 26 additions and 48 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.4 2020/01/18 21:50:04 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2021/01/09 12:53:45 rxg Exp $
|
||||
|
||||
DISTNAME= tmate-2.2.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= tmate-2.4.0
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=tmate-io/}
|
||||
GITHUB_TAG= ${PKGVERSION_NOREV}
|
||||
|
|
|
@ -1,10 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.3 2019/12/19 22:21:01 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.4 2021/01/09 12:53:45 rxg Exp $
|
||||
|
||||
SHA1 (tmate-2.2.1.tar.gz) = 8ef6999f7bf2511738650421e40b6a639e782d36
|
||||
RMD160 (tmate-2.2.1.tar.gz) = fd72920b91041905a218f59ba25eb1d58d4bfc6c
|
||||
SHA512 (tmate-2.2.1.tar.gz) = 3d4ce7510cd8da39bc4fe63f2a64179846a813bb3560ca811d9e1e2a28b06d95a9033047a900d76bda069c249d7ebbe1143daa082b23212c5d32a50bf1819d2d
|
||||
Size (tmate-2.2.1.tar.gz) = 610745 bytes
|
||||
SHA1 (patch-configure.ac) = dba0fdd160797e3884533d99686efdf9b0af9e7a
|
||||
SHA1 (patch-tmate-session.c) = 9a3b31787dd86f4eb9528a4cb0e6708da31e75e9
|
||||
SHA1 (patch-tmate-ssh-client.c) = d797fb9d770999447859ce4f204fa853a2f63cb9
|
||||
SHA1 (tmate-2.4.0.tar.gz) = 27c08f321e75716dfe0f037d18fa907b9dfe1319
|
||||
RMD160 (tmate-2.4.0.tar.gz) = b377abc68071506ac5b05a067fc5c13985cfd7ab
|
||||
SHA512 (tmate-2.4.0.tar.gz) = 92d2ca354b295678bfc2747ca83a45ebafeaec40ebac94bd94c4926af4f820b3f3a087f365147f41c80d1c8ad032f52c697a2421839c39315d84f98f7eccada6
|
||||
Size (tmate-2.4.0.tar.gz) = 614179 bytes
|
||||
SHA1 (patch-Makefile.am) = 34eeac2f32d09bbde1ae5eda6158881891feb2f2
|
||||
SHA1 (patch-tmux.h) = 8c26d6ca70b1a8d51e7c920ea54f59d2023968fe
|
||||
|
|
18
misc/tmate/patches/patch-Makefile.am
Normal file
18
misc/tmate/patches/patch-Makefile.am
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-Makefile.am,v 1.1 2021/01/09 12:53:45 rxg Exp $
|
||||
|
||||
Compatible with NetBSD.
|
||||
|
||||
--- Makefile.am.orig 2021-01-07 13:42:30.818799315 +0000
|
||||
+++ Makefile.am
|
||||
@@ -47,6 +47,11 @@ endif
|
||||
CFLAGS += -Wno-unused-parameter -Wno-unused-variable -Wno-null-pointer-arithmetic
|
||||
CFLAGS += -Wno-deprecated-declarations -Wno-format-nonliteral
|
||||
|
||||
+# Set flags for NetBSD.
|
||||
+if IS_NETBSD
|
||||
+CPPFLAGS += -D_OPENBSD_SOURCE
|
||||
+endif
|
||||
+
|
||||
# Set flags for Solaris.
|
||||
if IS_SUNOS
|
||||
if IS_GCC
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-configure.ac,v 1.1 2017/09/12 08:31:20 dholland Exp $
|
||||
|
||||
Remove bashism in configure script.
|
||||
|
||||
--- configure.ac~ 2016-03-29 03:30:07.000000000 +0000
|
||||
+++ configure.ac
|
||||
@@ -465,7 +465,7 @@ if test "x$found_static" = xyes; then
|
||||
LIBS="compat/memcpy.o -Wl,--wrap=memcpy $LIBS"
|
||||
fi
|
||||
LIBS="compat/clock_gettime.o libc/fdelt_chk.o $LIBS"
|
||||
- LIBS="-Wl,-Bstatic ${LIBS/-ldl/} -Wl,-Bdynamic -ldl"
|
||||
+ LIBS="-Wl,-Bstatic $(echo ${LIBS} | sed -e s/-ldl//) -Wl,-Bdynamic -ldl"
|
||||
fi
|
||||
|
||||
# Check for BSD-style integer types.
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-tmate-session.c,v 1.1 2019/12/19 22:21:01 joerg Exp $
|
||||
|
||||
--- tmate-session.c.orig 2019-12-19 18:49:04.116108537 +0000
|
||||
+++ tmate-session.c
|
||||
@@ -3,6 +3,7 @@
|
||||
#include <event2/event.h>
|
||||
|
||||
#include <sys/socket.h>
|
||||
+#include <netinet/in.h>
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
|
@ -1,10 +0,0 @@
|
|||
$NetBSD: patch-tmate-ssh-client.c,v 1.1 2019/12/19 22:21:01 joerg Exp $
|
||||
|
||||
--- tmate-ssh-client.c.orig 2019-12-19 18:48:37.085517987 +0000
|
||||
+++ tmate-ssh-client.c
|
||||
@@ -1,4 +1,5 @@
|
||||
#include <sys/socket.h>
|
||||
+#include <netinet/in.h>
|
||||
#include <netinet/tcp.h>
|
||||
#include <stdio.h>
|
||||
#include <event.h>
|
Loading…
Reference in a new issue