Add a cast to appease gcc4.

This commit is contained in:
agc 2007-05-13 16:13:10 +00:00
parent e30760a745
commit 69b5ceb206
2 changed files with 15 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.3 2006/10/21 11:53:13 agc Exp $
$NetBSD: distinfo,v 1.4 2007/05/13 16:13:10 agc Exp $
SHA1 (sfs-0.7.2.tar.gz) = 3619afc9b785e4aa41f7cdf202c5b233a6b5fe08
RMD160 (sfs-0.7.2.tar.gz) = 30cd5e21c4f63292ef0f5671720f6036d08e5ff1
@ -49,3 +49,4 @@ SHA1 (patch-bq) = df81507b2e2fd5d40a6759bf063229ef3e0fa301
SHA1 (patch-br) = 411b894e043d105402ab7d0622fc843703457639
SHA1 (patch-bs) = a426787d1b2a74a92a091046c1c9fdf7696a87f4
SHA1 (patch-bt) = 41b1359d716493aadd861818c9a377247191ecec
SHA1 (patch-bu) = 42924f5d59315b99d3d397eedde977366ec0ad96

View file

@ -0,0 +1,13 @@
$NetBSD: patch-bu,v 1.1 2007/05/13 16:13:10 agc Exp $
--- async/myaddrs.C 2007/05/13 15:39:24 1.1
+++ async/myaddrs.C 2007/05/13 15:40:12
@@ -74,7 +74,7 @@
res->clear ();
bhash<in_addr> addrs;
- p = ifc.ifc_buf;
+ p = (char *) ifc.ifc_buf;
e = p + ifc.ifc_len;
while (p < e) {
struct ifreq *ifrp = (struct ifreq *) p;