Update to 2.1.4, provided by Christopher Richards in PR 21191.

Extract of changes:
    - a fix in the Gzip stream reader, it couldn't read certain .gz files
      properly due to a small typo. In certain cases, FreeType could also
      loop endlessly when trying to load tiny gzipped files.
    - certain fonts couldn't be loaded by 2.1.3 because they lacked a
      Unicode charmap (e.g. SYMBOL.TTF). FreeType erroneously rejected
      them.
    - the CFF loader was modified to accept fonts which only
      contain a subset of their reference charset. This prevented the
      correct use of PDF-embedded fonts.
    - the logic to detect Unicode charmaps has been modified. this is required
      to support fonts which include both 16-bit and 32-bit charmaps (like
      very recent asian ones) using the new 10 and 12 SFNT formats.
    - the TrueType loader now limits the depth of composite glyphs. This is
      necessary to prevent broken fonts to break the engine by blowing the
      stack with recursive glyph definitions.
    - the CMap cache is now capable of managing UCS-4 character codes that
      are mapped through extended charmaps in recent TrueType/OpenType fonts
    - the cache sub-system now properly manages out-of-memory conditions,
      instead of blindly reporting them to the caller. This means that it
      will try to empty the cache before restarting its allocations to see
      if that can help.
    - the PFR driver didn't return the list of available embedded bitmaps
      properly.

    - David Chester contributed some enhancements to the auto-hinter that
      significantly increase the quality of its output. The Postscript hinter
      was also improved in several ways..
    - the FT_RENDER_MODE_LIGHT render mode was implemented
    - a new API, called FT_Get_BDF_Property has been added to FT_BDF_H to
      retrieve BDF properties from BDF _and_ PCF font files. THIS IS STILL
      EXPERIMENTAL, since it hasn't been properly tested yet.
    - a Windows FNT specific API has been added, mostly to access font
      headers. This is used by Wine
    - TrueType tables without a "hmtx" table are now tolerated when an
      incremental interface is used. This happens for certain Type42 fonts
      passed from Ghostscript to FreeType.
    - the PFR font driver is now capable of returning the font family and
      style names when they're available (instead of the sole "FontID"). This
      is performed by parsing an *undocumented* portion of the font file !!
This commit is contained in:
wiz 2003-04-16 08:53:45 +00:00
parent 7cebd4b325
commit 69ef771841
5 changed files with 20 additions and 19 deletions

View file

@ -1,9 +1,8 @@
# $NetBSD: Makefile,v 1.15 2003/03/21 22:25:50 dillo Exp $
# $NetBSD: Makefile,v 1.16 2003/04/16 08:53:45 wiz Exp $
#
DISTNAME= freetype-2.1.3
PKGNAME= freetype2-2.1.3
PKGREVISION= 1
DISTNAME= freetype-2.1.4
PKGNAME= freetype2-2.1.4
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=freetype/} \
ftp://ftp.freetype.org/freetype/freetype2/ \
@ -30,4 +29,5 @@ LIBTOOL_OVERRIDE= ${WRKSRC}/builds/unix/libtool
post-configure:
cd ${WRKSRC} && ${LN} -s builds/unix/unix.mk config.mk
.include "../../devel/zlib/buildlink2.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.3 2002/12/24 00:04:16 wiz Exp $
@comment $NetBSD: PLIST,v 1.4 2003/04/16 08:53:46 wiz Exp $
bin/freetype-config
include/freetype2/freetype/cache/ftccache.h
include/freetype2/freetype/cache/ftccmap.h
@ -40,6 +40,7 @@ include/freetype2/freetype/ftsysmem.h
include/freetype2/freetype/ftsystem.h
include/freetype2/freetype/fttrigon.h
include/freetype2/freetype/fttypes.h
include/freetype2/freetype/ftwinfnt.h
include/freetype2/freetype/ftxf86.h
include/freetype2/freetype/internal/autohint.h
include/freetype2/freetype/internal/bdftypes.h
@ -76,7 +77,7 @@ lib/libfreetype.a
lib/libfreetype.la
lib/libfreetype.so
lib/libfreetype.so.9
lib/libfreetype.so.9.2
lib/libfreetype.so.9.3
share/aclocal/freetype2.m4
@unexec ${RMDIR} %D/share/aclocal 2>/dev/null || ${TRUE}
@dirrm include/freetype2/freetype/internal

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.6 2003/03/21 22:25:50 dillo Exp $
$NetBSD: distinfo,v 1.7 2003/04/16 08:53:47 wiz Exp $
SHA1 (freetype-2.1.3.tar.bz2) = 7b101c9220c1a64061eec8f007301fb249a52737
Size (freetype-2.1.3.tar.bz2) = 790213 bytes
SHA1 (patch-aa) = e95285428ba58ce9ceeeec89d6f3fef04099488c
SHA1 (patch-ab) = 62ce099789f031845fcf71506302b4cdb1672066
SHA1 (freetype-2.1.4.tar.bz2) = 87779a895757fe7bf45f80cffbd412282115227a
Size (freetype-2.1.4.tar.bz2) = 806635 bytes
SHA1 (patch-aa) = bdfc47360ca1952ce6cb540e795a69523ca8a665
SHA1 (patch-ab) = 93449315852a2c868d5e3b09a9ae32d005141b14

View file

@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.1 2003/03/21 22:25:51 dillo Exp $
$NetBSD: patch-aa,v 1.2 2003/04/16 08:53:48 wiz Exp $
--- builds/unix/freetype-config.in.orig Sat Feb 2 16:05:38 2002
--- builds/unix/freetype-config.in.orig Mon Dec 16 16:51:23 2002
+++ builds/unix/freetype-config.in
@@ -81,7 +81,7 @@ fi
if test "$echo_cflags" = "yes" ; then
@ -13,7 +13,7 @@ $NetBSD: patch-aa,v 1.1 2003/03/21 22:25:51 dillo Exp $
fi
@@ -90,7 +90,7 @@ fi
if test "$echo_libs" = "yes" ; then
libs="-lfreetype"
libs="-lfreetype @LIBZ@"
if test "@libdir@" != "/usr/lib" ; then
- echo -L@libdir@ $libs
+ echo -L@libdir@ -Wl,@RPATH_FLAG@@libdir@ $libs

View file

@ -1,11 +1,11 @@
$NetBSD: patch-ab,v 1.1 2003/03/21 22:25:51 dillo Exp $
$NetBSD: patch-ab,v 1.2 2003/04/16 08:53:49 wiz Exp $
--- builds/unix/configure.orig Fri Mar 21 23:12:07 2003
--- builds/unix/configure.orig Sat Jan 18 11:39:18 2003
+++ builds/unix/configure
@@ -9259,6 +9259,7 @@ s,@ac_ct_RANLIB@,$ac_ct_RANLIB,;t t
s,@STRIP@,$STRIP,;t t
s,@ac_ct_STRIP@,$ac_ct_STRIP,;t t
@@ -9374,6 +9374,7 @@ s,@ac_ct_STRIP@,$ac_ct_STRIP,;t t
s,@LIBTOOL@,$LIBTOOL,;t t
s,@LIBOBJS@,$LIBOBJS,;t t
s,@LTLIBOBJS@,$LTLIBOBJS,;t t
+s,@RPATH_FLAG@,$RPATH_FLAG,;t t
CEOF