Add patch and bump revision.

This is for PR 37610 to fix internationalized text bug.

This fix was already in XFree86 and Xorg libXaw versions since at
least Nov. 2004 and in Fedora for Xaw3d since 2002.
This commit is contained in:
reed 2007-12-27 14:14:24 +00:00
parent b992f36697
commit 69f205360c
4 changed files with 22 additions and 4 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: CHANGES-2007,v 1.2707 2007/12/27 12:28:09 obache Exp $
$NetBSD: CHANGES-2007,v 1.2708 2007/12/27 14:14:25 reed Exp $
Changes to the packages collection and infrastructure in 2007:
@ -4910,3 +4910,4 @@ Changes to the packages collection and infrastructure in 2007:
Updated sysutils/osname to 1.1nb1 [obache 2007-12-27]
Updated net/srsh to 1.2nb1 [obache 2007-12-27]
Updated print/gimp-print-cups to 4.2.7nb4 [obache 2007-12-27]
Updated x11/Xaw3d to 1.5Enb4 [reed 2007-12-27]

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.53 2007/09/29 12:28:36 obache Exp $
# $NetBSD: Makefile,v 1.54 2007/12/27 14:14:24 reed Exp $
#
DISTNAME= Xaw3d-1.5E
PKGREVISION= 3
PKGREVISION= 4
CATEGORIES= x11
MASTER_SITES= ftp://ftp.visi.com/users/hawkeyd/X/

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.11 2007/09/12 11:29:36 xtraeme Exp $
$NetBSD: distinfo,v 1.12 2007/12/27 14:14:24 reed Exp $
SHA1 (Xaw3d-1.5E.tar.gz) = efc5b923feda52866c859c59a5b553cb675a69d1
RMD160 (Xaw3d-1.5E.tar.gz) = 086cbabaa45ce5c110815aea24eebcbb54613118
@ -7,3 +7,4 @@ SHA1 (patch-aa) = 7729cfe83671f482670350ead9ccf1bfe3e932e3
SHA1 (patch-ab) = 9bbe44041708b2d01b728638ac07e32addc01cff
SHA1 (patch-ac) = cce339b75bdfe407608f004eaf1f22fca26ecd5e
SHA1 (patch-ad) = e9c599fd237feabe9b3311f41da96455263a1a28
SHA1 (patch-ae) = 6f6ffdd9ed4b60afb5518ed1d0245aa7fb515ac6

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ae,v 1.1 2007/12/27 14:14:24 reed Exp $
Already in XFree86 and X.org versions since at least Nov. 2004.
Also in Fedora version since Aug 09 2002.
http://rpmfind.net//linux/RPM/fedora/7/x86_64/Xaw3d-1.5E-10.1.i386.html
--- MultiSrc.c.orig Tue Aug 6 22:51:08 2002
+++ MultiSrc.c Tue Aug 6 22:51:16 2002
@@ -735,6 +735,7 @@
if ( string_set || (old_src->multi_src.type != src->multi_src.type) ) {
RemoveOldStringOrFile(old_src, string_set);
+ src->multi_src.allocated_string = old_src->multi_src.allocated_string;
file = InitStringOrFile(src, string_set);
/* Load pieces does this logic for us, but it shouldn't. Its messy.*/