Fix pointer vs value confusion. Bump revision.
This commit is contained in:
parent
b9e64f1014
commit
6a06bf3300
4 changed files with 153 additions and 3 deletions
|
@ -1,8 +1,8 @@
|
||||||
# $NetBSD: Makefile,v 1.20 2012/10/23 10:24:09 wiz Exp $
|
# $NetBSD: Makefile,v 1.21 2013/08/31 14:52:50 joerg Exp $
|
||||||
|
|
||||||
DISTNAME= xanim2920
|
DISTNAME= xanim2920
|
||||||
PKGNAME= xanim-2.92.0
|
PKGNAME= xanim-2.92.0
|
||||||
PKGREVISION= 2
|
PKGREVISION= 3
|
||||||
CATEGORIES= multimedia x11
|
CATEGORIES= multimedia x11
|
||||||
MASTER_SITES= ftp://ftp.informatik.uni-hamburg.de/pub/soft/graphics/xanim/ \
|
MASTER_SITES= ftp://ftp.informatik.uni-hamburg.de/pub/soft/graphics/xanim/ \
|
||||||
ftp://ftp.informatik.uni-hamburg.de/pub/soft/graphics/xanim/modules/ \
|
ftp://ftp.informatik.uni-hamburg.de/pub/soft/graphics/xanim/modules/ \
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.6 2007/08/05 15:37:34 joerg Exp $
|
$NetBSD: distinfo,v 1.7 2013/08/31 14:52:50 joerg Exp $
|
||||||
|
|
||||||
SHA1 (xanim2920.tar.gz) = 8adb5948cc6fd9bba5417aee4d319b5f041830e8
|
SHA1 (xanim2920.tar.gz) = 8adb5948cc6fd9bba5417aee4d319b5f041830e8
|
||||||
RMD160 (xanim2920.tar.gz) = dae33cdbd9f20388a067df8269b625f2594cdfb9
|
RMD160 (xanim2920.tar.gz) = dae33cdbd9f20388a067df8269b625f2594cdfb9
|
||||||
|
@ -57,3 +57,5 @@ Size (xa1.0_cyuv_linuxPPC.o.gz) = 1287 bytes
|
||||||
SHA1 (patch-aa) = 4d2f360bca128e979951227b3ff1b645a82ce7f3
|
SHA1 (patch-aa) = 4d2f360bca128e979951227b3ff1b645a82ce7f3
|
||||||
SHA1 (patch-ab) = c9fd497ee20efc699a84367ee36d34f5aff6da66
|
SHA1 (patch-ab) = c9fd497ee20efc699a84367ee36d34f5aff6da66
|
||||||
SHA1 (patch-ae) = 6023e76bc0471a0810b0789cd24355c06eac02b8
|
SHA1 (patch-ae) = 6023e76bc0471a0810b0789cd24355c06eac02b8
|
||||||
|
SHA1 (patch-xa__input.c) = 2033ce6c68b5a87911011b6917705f08482060a2
|
||||||
|
SHA1 (patch-xa__x11.c) = d51fea74991e9453c29bf82a7e41bf1b74a98f32
|
||||||
|
|
59
multimedia/xanim/patches/patch-xa__input.c
Normal file
59
multimedia/xanim/patches/patch-xa__input.c
Normal file
|
@ -0,0 +1,59 @@
|
||||||
|
$NetBSD: patch-xa__input.c,v 1.1 2013/08/31 14:52:50 joerg Exp $
|
||||||
|
|
||||||
|
--- xa_input.c.orig 2013-08-31 14:16:57.000000000 +0000
|
||||||
|
+++ xa_input.c
|
||||||
|
@@ -1025,28 +1025,28 @@ char *machine, *user_cmd, *passwd_cmd, *
|
||||||
|
memset(&data,0,sizeof(data));
|
||||||
|
memset(&from,0,sizeof(from));
|
||||||
|
if (gethostname(hostname, sizeof(hostname)) < 0)
|
||||||
|
- return(xa_ftp_abort(xin));
|
||||||
|
+ return(xa_ftp_abort(*xin));
|
||||||
|
if ((host= (struct hostent *)gethostbyname(hostname)) == 0)
|
||||||
|
- return(xa_ftp_abort(xin));
|
||||||
|
+ return(xa_ftp_abort(*xin));
|
||||||
|
data.sin_family = host->h_addrtype;
|
||||||
|
memcpy( (char *)&data.sin_addr, (char *)host->h_addr_list[0], host->h_length);
|
||||||
|
if ((tmp_sock = socket ( AF_INET , SOCK_STREAM , 0 )) < 0)
|
||||||
|
- return(xa_ftp_abort(xin));
|
||||||
|
+ return(xa_ftp_abort(*xin));
|
||||||
|
len = 1;
|
||||||
|
if (setsockopt(tmp_sock, SOL_SOCKET, SO_REUSEADDR,
|
||||||
|
(char *)(&len), sizeof(len)) < 0)
|
||||||
|
- { close(tmp_sock); return(xa_ftp_abort(xin)); }
|
||||||
|
+ { close(tmp_sock); return(xa_ftp_abort(*xin)); }
|
||||||
|
|
||||||
|
data.sin_port = 0;
|
||||||
|
if ( bind(tmp_sock, (struct sockaddr *)&data, sizeof(data)) < 0 )
|
||||||
|
- { close(tmp_sock); return(xa_ftp_abort(xin)); }
|
||||||
|
+ { close(tmp_sock); return(xa_ftp_abort(*xin)); }
|
||||||
|
|
||||||
|
len = sizeof(data);
|
||||||
|
if (getsockname(tmp_sock, (struct sockaddr *)&data, &len) < 0 )
|
||||||
|
- { close(tmp_sock); return(xa_ftp_abort(xin)); }
|
||||||
|
+ { close(tmp_sock); return(xa_ftp_abort(*xin)); }
|
||||||
|
|
||||||
|
if (listen(tmp_sock, 4) < 0 )
|
||||||
|
- { close(tmp_sock); return(xa_ftp_abort(xin)); }
|
||||||
|
+ { close(tmp_sock); return(xa_ftp_abort(*xin)); }
|
||||||
|
|
||||||
|
/* POD add support for PORT command? */
|
||||||
|
addr = (xaUBYTE *) (&data.sin_addr);
|
||||||
|
@@ -1059,15 +1059,15 @@ char *machine, *user_cmd, *passwd_cmd, *
|
||||||
|
|
||||||
|
if (xa_ftp_send_cmd(xin, port_cmd, &retcode) == xaFALSE)
|
||||||
|
{ fprintf(stderr,"FTP: send cmd err\n");
|
||||||
|
- close(tmp_sock); return(xa_ftp_abort(xin)); }
|
||||||
|
+ close(tmp_sock); return(xa_ftp_abort(*xin)); }
|
||||||
|
|
||||||
|
if (xa_ftp_send_cmd(xin, file_cmd, &retcode) == xaFALSE)
|
||||||
|
{ fprintf(stderr,"FTP: send cmd err\n");
|
||||||
|
- close(tmp_sock); return(xa_ftp_abort(xin)); }
|
||||||
|
+ close(tmp_sock); return(xa_ftp_abort(*xin)); }
|
||||||
|
|
||||||
|
len = sizeof(from);
|
||||||
|
xin->dsock = accept((int)tmp_sock, (struct sockaddr *) &from, (int *)&len);
|
||||||
|
- if (xin->dsock < 0) { close(tmp_sock); return(xa_ftp_abort(xin)); }
|
||||||
|
+ if (xin->dsock < 0) { close(tmp_sock); return(xa_ftp_abort(*xin)); }
|
||||||
|
close(tmp_sock);
|
||||||
|
return(xaTRUE);
|
||||||
|
}
|
89
multimedia/xanim/patches/patch-xa__x11.c
Normal file
89
multimedia/xanim/patches/patch-xa__x11.c
Normal file
|
@ -0,0 +1,89 @@
|
||||||
|
$NetBSD: patch-xa__x11.c,v 1.1 2013/08/31 14:52:50 joerg Exp $
|
||||||
|
|
||||||
|
--- xa_x11.c.orig 2013-08-31 14:15:35.000000000 +0000
|
||||||
|
+++ xa_x11.c
|
||||||
|
@@ -1464,7 +1464,7 @@ void xanim_events()
|
||||||
|
XChangeProperty(theDisp, mainW, window_atom, XA_STRING, 8,
|
||||||
|
PropModeReplace, (unsigned char *)command, 1);
|
||||||
|
if (xa_window_prepare_flag == xaFALSE)
|
||||||
|
- xanim_expose(theWG, event, NULL, 0);
|
||||||
|
+ xanim_expose(theWG, &event, NULL, 0);
|
||||||
|
while (1)
|
||||||
|
{
|
||||||
|
XtAppNextEvent(theContext, &event);
|
||||||
|
@@ -1504,50 +1504,50 @@ void xanim_events()
|
||||||
|
break;
|
||||||
|
case ' ':
|
||||||
|
if (xa_anim_status == XA_UNSTARTED)
|
||||||
|
- xanim_expose(theWG, event, NULL, 0);
|
||||||
|
- else xanim_toggle_action(theWG, event, NULL, 0);
|
||||||
|
+ xanim_expose(theWG, &event, NULL, 0);
|
||||||
|
+ else xanim_toggle_action(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case ',':
|
||||||
|
- xanim_step_prev_action(theWG, event, NULL, 0);
|
||||||
|
+ xanim_step_prev_action(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '.':
|
||||||
|
- xanim_step_next_action(theWG, event, NULL, 0);
|
||||||
|
+ xanim_step_next_action(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case 'm':
|
||||||
|
- xanim_step_prev_int_action(theWG, event, NULL, 0);
|
||||||
|
+ xanim_step_prev_int_action(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '/':
|
||||||
|
- xanim_step_next_int_action(theWG, event, NULL, 0);
|
||||||
|
+ xanim_step_next_int_action(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '-':
|
||||||
|
- xanim_faster_action(theWG, event, NULL, 0);
|
||||||
|
+ xanim_faster_action(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '=':
|
||||||
|
- xanim_slower_action(theWG, event, NULL, 0);
|
||||||
|
+ xanim_slower_action(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '0':
|
||||||
|
- xanim_speed_reset_action(theWG, event, NULL, 0);
|
||||||
|
+ xanim_speed_reset_action(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '1':
|
||||||
|
- xanim_dec_audio_5(theWG, event, NULL, 0);
|
||||||
|
+ xanim_dec_audio_5(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '2':
|
||||||
|
- xanim_dec_audio_1(theWG, event, NULL, 0);
|
||||||
|
+ xanim_dec_audio_1(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '3':
|
||||||
|
- xanim_inc_audio_1(theWG, event, NULL, 0);
|
||||||
|
+ xanim_inc_audio_1(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '4':
|
||||||
|
- xanim_inc_audio_5(theWG, event, NULL, 0);
|
||||||
|
+ xanim_inc_audio_5(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case 's':
|
||||||
|
- xanim_mute_audio(theWG, event, NULL, 0);
|
||||||
|
+ xanim_mute_audio(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '8':
|
||||||
|
- xanim_speaker_tog(theWG, event, NULL, 0);
|
||||||
|
+ xanim_speaker_tog(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case '9':
|
||||||
|
- xanim_headphone_tog(theWG, event, NULL, 0);
|
||||||
|
+ xanim_headphone_tog(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case 'v':
|
||||||
|
vaudiof->volume = atoi( &command[1] );
|
||||||
|
@@ -1559,7 +1559,7 @@ void xanim_events()
|
||||||
|
XA_AUDIO_SET_VOLUME(vaudiof->volume);
|
||||||
|
break;
|
||||||
|
case 'z':
|
||||||
|
- xanim_realize_remote(theWG, event, NULL, 0);
|
||||||
|
+ xanim_realize_remote(theWG, &event, NULL, 0);
|
||||||
|
break;
|
||||||
|
case 'e':
|
||||||
|
x11_expose_flag = xaTRUE;
|
Loading…
Reference in a new issue