Build fixes for new glib2.
This commit is contained in:
parent
95f51a2f22
commit
6a1b98d5f7
7 changed files with 82 additions and 2 deletions
|
@ -1,5 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.2 2012/01/19 19:22:35 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.3 2012/05/06 19:06:21 dholland Exp $
|
||||
|
||||
SHA1 (ario-1.5.1.tar.gz) = 99c1ae6318a596cd27ac3c38ad25bc716527a94d
|
||||
RMD160 (ario-1.5.1.tar.gz) = dfc819cf46a80e822aa3b654c334d8cbaddb3b9d
|
||||
Size (ario-1.5.1.tar.gz) = 1135444 bytes
|
||||
SHA1 (patch-src_ario-profiles_h) = 5610730865e843beeba09257ce5db1db3160359f
|
||||
SHA1 (patch-src_ario-util_h) = d376e424d948c0545e2238466e3fbd229cde3325
|
||||
SHA1 (patch-src_plugins_ario-plugin-info_c) = 06db2d0df1ebb3f626d92ed3f0126ebc5735c11e
|
||||
|
|
15
audio/ario/patches/patch-src_ario-profiles_h
Normal file
15
audio/ario/patches/patch-src_ario-profiles_h
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_ario-profiles_h,v 1.1 2012/05/06 19:06:21 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- src/ario-profiles.h~ 2011-05-17 17:54:49.000000000 +0000
|
||||
+++ src/ario-profiles.h
|
||||
@@ -20,7 +20,7 @@
|
||||
#ifndef __ARIO_PROFILES_H
|
||||
#define __ARIO_PROFILES_H
|
||||
|
||||
-#include <glib/gslist.h>
|
||||
+#include <glib.h>
|
||||
#include "servers/ario-server.h"
|
||||
|
||||
G_BEGIN_DECLS
|
15
audio/ario/patches/patch-src_ario-util_h
Normal file
15
audio/ario/patches/patch-src_ario-util_h
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_ario-util_h,v 1.1 2012/05/06 19:06:21 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- src/ario-util.h~ 2011-02-27 15:07:31.000000000 +0000
|
||||
+++ src/ario-util.h
|
||||
@@ -18,7 +18,7 @@
|
||||
*/
|
||||
|
||||
#include "servers/ario-server.h"
|
||||
-#include "glib/gslist.h"
|
||||
+#include "glib.h"
|
||||
#include "gdk/gdkpixbuf.h"
|
||||
|
||||
/* Number of covers used to generate the drag & drop image */
|
15
audio/ario/patches/patch-src_plugins_ario-plugin-info_c
Normal file
15
audio/ario/patches/patch-src_plugins_ario-plugin-info_c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_plugins_ario-plugin-info_c,v 1.1 2012/05/06 19:06:21 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- src/plugins/ario-plugin-info.c~ 2011-02-27 15:07:28.000000000 +0000
|
||||
+++ src/plugins/ario-plugin-info.c
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
#include <string.h>
|
||||
#include <glib/gi18n.h>
|
||||
-#include <glib/gkeyfile.h>
|
||||
+#include <glib.h>
|
||||
|
||||
#include "plugins/ario-plugin-info-priv.h"
|
||||
#include "ario-debug.h"
|
|
@ -1,6 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.4 2011/04/21 20:01:03 hans Exp $
|
||||
$NetBSD: distinfo,v 1.5 2012/05/06 19:12:22 dholland Exp $
|
||||
|
||||
SHA1 (audacious-1.5.1.tbz2) = 571ed77333c4d85dab901770f6640501930a748c
|
||||
RMD160 (audacious-1.5.1.tbz2) = 1748b7075cef3fd0d41fb74c44109e294433d03b
|
||||
Size (audacious-1.5.1.tbz2) = 1374028 bytes
|
||||
SHA1 (patch-aa) = a95588e0f2c27f1f520cb687421f5d33e01e5155
|
||||
SHA1 (patch-src_audacious_i18n_h) = a0524ed265fb1298cf741f5c3af2f9893bde3bfe
|
||||
SHA1 (patch-src_audacious_ui__skinned__window_c) = 1aa195373ee7a2542a8d4e2b71b611a533c00483
|
||||
|
|
15
audio/audacious/patches/patch-src_audacious_i18n_h
Normal file
15
audio/audacious/patches/patch-src_audacious_i18n_h
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_audacious_i18n_h,v 1.1 2012/05/06 19:12:22 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- src/audacious/i18n.h~ 2008-05-23 22:00:34.000000000 +0000
|
||||
+++ src/audacious/i18n.h
|
||||
@@ -20,7 +20,7 @@
|
||||
#ifndef AUDACIOUS_I18N_H
|
||||
#define AUDACIOUS_I18N_H
|
||||
|
||||
-#include <glib/gstrfuncs.h>
|
||||
+#include <glib.h>
|
||||
#include <libintl.h>
|
||||
|
||||
#define _(String) dgettext (PACKAGE, String)
|
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_audacious_ui__skinned__window_c,v 1.1 2012/05/06 19:12:22 dholland Exp $
|
||||
|
||||
Fix build with latest glib2.
|
||||
|
||||
--- src/audacious/ui_skinned_window.c~ 2008-05-23 22:00:34.000000000 +0000
|
||||
+++ src/audacious/ui_skinned_window.c
|
||||
@@ -23,7 +23,7 @@
|
||||
|
||||
#include <gtk/gtkmain.h>
|
||||
#include <glib-object.h>
|
||||
-#include <glib/gmacros.h>
|
||||
+#include <glib.h>
|
||||
#include <gtk/gtkmarshal.h>
|
||||
#include <gtk/gtkwindow.h>
|
||||
#include <string.h>
|
Loading…
Reference in a new issue