xgalaga: Update to 2.1.1.0
Version 2.1.01.0 (HR 2008/03/05) - Updated configure.in and Makefile.in for building an new configure script and Makefile with BSD support (autoconf -o configure configure.in). The goal is to build on supported platforms 'out of the box'. If there is anything to do, please let me know at tshe_hermann remove_this at web dot de - Added scrolling credits in the title screen. Therefore increased the third paragraph of the version number. Version 2.1.00.2 (HR 2008/02/11) - Changed numbering scheme to a dotted style to become better compatibility with distro's numbering scheme. - Fixed broken sound. xgal.sndsrv.linux opens /dev/dsp now with O_WRONLY. This makes simultaneously playing oggs working. - Added man page (content and build handling). Added <s> and <Q> key. Version 2.1.00-1 (HR 2008/02/07) - added ifdefs in score.c for compiling with no sound support - added file mkinstalldirs. Needed by make install Version 2.1.00-0 (HR 2008/02/06) - This release is mainly a bugfix relase. Some of them are years old. See hints below. - added the xgalaga_2.0.34-44.diff from debian. Thanks to Joey Hess for collecting all these stuff over the years. Main changes are: compiling xgalaga-hyperspace, full screen mode, security fixes for HOME-Variable and global score file, joystick support, improvements of sound server, new weapons machine gun and spread shot, .... - Bugs as reported at sourceforge Request ID 1394882 "make error on fc4 64-bit" and 1167157 "make error on FC3" are supposed to be fixed. Changed the order of header files in several .c files. I have no 64 bit system to test this, but I got the same error on ubuntu 7.10 - Debian bug report #149743: "xgalaga starts when i want to turn sounds off" is fixed. In fact, it started on any key except <q> or <Q>. Now starts only on the keys <k> and <m> as stated in the last line on the title screen. Turning sound off works during the game and at the title screen. For clarity there is now a 'Q' (=quiet) right from the level, which appears, when sound is switched off. - Debian bug report #60266: "Too slow when sounds are not available" is probably fixed. I could not exactly reproduce the bug. On my box, xgalaga crashes totally. Maybe it depends on the sound system. I added the evaluation of the returncode on writing to /dev/dsp. The crash was gone away. - Debian bug report #399987 "xgalaga -level accepts ""impossible to loose"" levels" is partially fixed. The -level parameter value is cut to 15. Higher levels are still avalable by playing (good luck). - Added a couple of additional key codes. The <p> (pause) and <s> (toggle sound) did not work, because they produce key codes increased with 256. Editing the high score name also didn't work on the same reason. - Added bugfix for "[1837041] Fix seg fault" as reported on sourceforge - Changed order of libs in configure.in. This (and some other improvements) makes xgalaga compile under Cygwin/X
This commit is contained in:
parent
5bbd2c2591
commit
6a1c9e2533
18 changed files with 143 additions and 282 deletions
|
@ -1,21 +1,17 @@
|
|||
# $NetBSD: Makefile,v 1.36 2018/01/14 15:26:49 rillig Exp $
|
||||
# $NetBSD: Makefile,v 1.37 2020/11/20 13:50:23 nia Exp $
|
||||
|
||||
DISTNAME= xgalaga-2.0.34
|
||||
PKGREVISION= 4
|
||||
DISTNAME= xgalaga-2.1.1.0
|
||||
CATEGORIES= games x11
|
||||
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xgalaga/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= https://sourceforge.net/projects/xgalaga/
|
||||
COMMENT= Very fast true-to-the-original port of galaga for X11
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
NO_SRC_ON_FTP= "already in MASTER_SITE_LOCAL"
|
||||
|
||||
USE_TOOLS+= gmake
|
||||
GNU_CONFIGURE= YES
|
||||
GNU_CONFIGURE_PREFIX= ${PREFIX}/share/xgalaga
|
||||
CONFIGURE_ARGS+= --exec-prefix=${PREFIX}/bin
|
||||
SETGIDGAME= yes
|
||||
MAKE_ENV+= GAMEOWN=${GAMEOWN:Q} GAMEGRP=${GAMEGRP:Q} \
|
||||
GAMEMODE=${GAMEMODE} GAMEDATAMODE=${GAMEDATAMODE}
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
|
@ -24,10 +20,12 @@ CONFIGURE_ARGS+= --x-includes=${PREFIX}/include
|
|||
CONFIGURE_ARGS+= --x-libraries=${PREFIX}/lib
|
||||
.endif
|
||||
|
||||
INSTALLATION_DIRS= libexec
|
||||
INSTALLATION_DIRS+= libexec
|
||||
INSTALLATION_DIRS+= share/xgalaga
|
||||
INSTALLATION_DIRS+= ${PKGMANDIR}/man6
|
||||
|
||||
post-install:
|
||||
${INSTALL_MAN} ${WRKSRC}/README ${DESTDIR}${PREFIX}/share/xgalaga/README
|
||||
${INSTALL_MAN} ${WRKSRC}/README ${DESTDIR}${PREFIX}/share/doc/xgalaga/README
|
||||
|
||||
.include "../../x11/libXmu/buildlink3.mk"
|
||||
.include "../../x11/libXpm/buildlink3.mk"
|
||||
|
|
|
@ -1,7 +1,10 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2018/01/01 22:29:35 rillig Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2020/11/20 13:50:23 nia Exp $
|
||||
bin/xgalaga
|
||||
libexec/xgalaga.sndsrv
|
||||
share/xgalaga/README
|
||||
bin/xgalaga-hyperspace
|
||||
libexec/xgal.sndsrv
|
||||
man/man6/xgalaga.6x
|
||||
share/doc/xgalaga/CREDITS
|
||||
share/doc/xgalaga/README
|
||||
share/xgalaga/levels/level1.xgl
|
||||
share/xgalaga/levels/level10.xgl
|
||||
share/xgalaga/levels/level11.xgl
|
||||
|
@ -17,7 +20,6 @@ share/xgalaga/levels/level6.xgl
|
|||
share/xgalaga/levels/level7.xgl
|
||||
share/xgalaga/levels/level8.xgl
|
||||
share/xgalaga/levels/level9.xgl
|
||||
share/xgalaga/scores
|
||||
share/xgalaga/sounds/ddloo.raw
|
||||
share/xgalaga/sounds/explode.raw
|
||||
share/xgalaga/sounds/explode_big.raw
|
||||
|
@ -26,4 +28,3 @@ share/xgalaga/sounds/shield.raw
|
|||
share/xgalaga/sounds/smart.raw
|
||||
share/xgalaga/sounds/torphit.raw
|
||||
share/xgalaga/sounds/warp.raw
|
||||
@unexec ${RM} -f %D/share/xgalaga/scores
|
||||
|
|
|
@ -1,17 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.13 2017/03/23 17:06:52 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.14 2020/11/20 13:50:23 nia Exp $
|
||||
|
||||
SHA1 (xgalaga-2.0.34.tar.gz) = 82dcb328af0d9e779c566f4225d7f072b1c17b7d
|
||||
RMD160 (xgalaga-2.0.34.tar.gz) = bf2cc91820c1cdb8e02bd35347b309cac27b3ba4
|
||||
SHA512 (xgalaga-2.0.34.tar.gz) = 90cdc8a911e7de1d15af65ab100273d39c26a15761e7c3bc977eb3d55920f1a5b962a69d0a494d5c29ea28b724f8c69856955431de420f205fc638e88c3d62b0
|
||||
Size (xgalaga-2.0.34.tar.gz) = 314189 bytes
|
||||
SHA1 (patch-aa) = 63dc49d79e33ba4eaf596e600cdfaa1d00d70bce
|
||||
SHA1 (patch-ab) = 97bd43c07f76278245730bbc9724497ab87e552d
|
||||
SHA1 (patch-ac) = ca85bafaa637fc03d1c53a527c7804a95c146fe3
|
||||
SHA1 (patch-ad) = 22b946b261c4d0969e48bf5de1ba0d55c3649bb8
|
||||
SHA1 (patch-ae) = 2e9f31a279aa5ecd14a0843dc18d151e7990aed0
|
||||
SHA1 (patch-af) = 83856e8718bcbe6f40b4c156199c4db56cdf8777
|
||||
SHA1 (patch-ag) = 0e4270a29bac33ae21e5a837feb7fe87fa650173
|
||||
SHA1 (patch-ah) = 88bb0385cc1091eae83475fa26296419095f10a6
|
||||
SHA1 (patch-ai) = 21dc08a4d6d04fca2a374034b79de8ab9c953793
|
||||
SHA1 (patch-aj) = d1577211627e280aef977ff7c1cf2b48c02f1c3f
|
||||
SHA1 (patch-ak) = ef0077094fb3814c0b83f8dd274dc620e8e34f61
|
||||
SHA1 (xgalaga-2.1.1.0.tar.gz) = ef40ad833d2434b0643d4c00202bd75ec14b94ac
|
||||
RMD160 (xgalaga-2.1.1.0.tar.gz) = b55a97187b61ffe7c072ecd784cf9a16fe568c26
|
||||
SHA512 (xgalaga-2.1.1.0.tar.gz) = 087db9e0501cedb042bb673a217f9de32640d3e4f4f529a29fd25ed682a1aece9ae1beacdc2ee77fc93ac931411a1051e2cd19873578ccffe5f03a083bffe513
|
||||
Size (xgalaga-2.1.1.0.tar.gz) = 331621 bytes
|
||||
SHA1 (patch-Makefile.in) = f8eacc067c760dd5071fc9799a4587c6ee2b0a2c
|
||||
SHA1 (patch-configure) = 695098c4ea95139496d2dfb76dcf7164943c3f64
|
||||
SHA1 (patch-main.c) = a2743012bd84882c728f90990a1ec586273724ba
|
||||
SHA1 (patch-title.c) = cd94537f8ebcedf737af4208686f80bb42da00e7
|
||||
|
|
61
games/xgalaga/patches/patch-Makefile.in
Normal file
61
games/xgalaga/patches/patch-Makefile.in
Normal file
|
@ -0,0 +1,61 @@
|
|||
$NetBSD: patch-Makefile.in,v 1.1 2020/11/20 13:50:23 nia Exp $
|
||||
|
||||
Correct installation paths.
|
||||
|
||||
--- Makefile.in.orig 2008-03-05 21:58:16.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -11,12 +11,13 @@ VPATH = @srcdir@
|
||||
.SUFFIXES: .c .o
|
||||
|
||||
prefix = @prefix@
|
||||
+datadir = @datadir@/xgalaga
|
||||
+docdir = @docdir@/xgalaga
|
||||
exec_prefix = @exec_prefix@
|
||||
bindir = $(exec_prefix)
|
||||
libdir = $(prefix)/lib
|
||||
infodir = $(prefix)/info
|
||||
-#mandir = @mandir@
|
||||
-mandir = /usr/share/man
|
||||
+mandir = @mandir@
|
||||
creditsfile = @CREDITSFILE@
|
||||
distversion = 2.1.1.0
|
||||
|
||||
@@ -27,11 +28,11 @@ SOUNDSRVDIR = @SOUNDSRVDIR@
|
||||
SOUNDOBJS = xgal.sndsrv.linux.o
|
||||
SOUNDSRCS = xgal.sndsrv.linux.c
|
||||
|
||||
-SOUNDDEFS = -DSOUNDSERVER=\"$(prefix)$(SOUNDSRVDIR)/@SOUNDSERVER@\"
|
||||
+SOUNDDEFS = -DSOUNDSERVER=\"$(prefix)$(SOUNDSRVDIR)/xgal.sndsrv\"
|
||||
|
||||
RM = rm -f
|
||||
CC = @CC@
|
||||
-CFLAGS = -I. @CFLAGS@ @DEFS@ @X_CFLAGS@ -DXGALAGADIR=\"@prefix@/\" $(SOUNDDEFS)
|
||||
+CFLAGS = -I. @CFLAGS@ @DEFS@ @X_CFLAGS@ -DXGALAGADIR=\"@datadir@/xgalaga/levels\" $(SOUNDDEFS)
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBS = libsprite/libsprite.a @LIBS@ @X_LIBS@
|
||||
INSTALL = @INSTALL@
|
||||
@@ -58,15 +59,16 @@ install: all
|
||||
$(INSTALL) $(TARGET) $(DESTDIR)$(bindir)/$(TARGET)
|
||||
$(INSTALL) $(TARGET2) $(DESTDIR)$(bindir)/$(TARGET2)
|
||||
if test ! "$(SOUNDSRV)" = ""; then \
|
||||
- $(INSTALL) $(SOUNDSRV) $(DESTDIR)$(prefix)$(SOUNDSRVDIR)/$(SOUNDSRV); \
|
||||
+ $(INSTALL) $(SOUNDSRV) $(DESTDIR)$(prefix)$(SOUNDSRVDIR)/xgal.sndsrv; \
|
||||
fi
|
||||
- ./mkinstalldirs $(DESTDIR)$(prefix)/sounds
|
||||
- ./mkinstalldirs $(DESTDIR)$(prefix)/levels
|
||||
- for i in levels/*.xgl; do $(INSTALL) $$i $(DESTDIR)$(prefix)/$$i ; done
|
||||
- for i in sounds/*.raw; do $(INSTALL) $$i $(DESTDIR)$(prefix)/$$i ; done
|
||||
- $(INSTALL) CREDITS $(DESTDIR)$(creditsfile)
|
||||
- $(INSTALL) xgalaga.6x.gz $(mandir)/man6/xgalaga.6x.gz
|
||||
- chmod 644 $(mandir)/man6/xgalaga.6x.gz
|
||||
+ ./mkinstalldirs $(DESTDIR)$(datadir)/sounds
|
||||
+ ./mkinstalldirs $(DESTDIR)$(datadir)/levels
|
||||
+ for i in levels/*.xgl; do $(INSTALL) $$i $(DESTDIR)$(datadir)/$$i ; done
|
||||
+ for i in sounds/*.raw; do $(INSTALL) $$i $(DESTDIR)$(datadir)/$$i ; done
|
||||
+ ./mkinstalldirs $(DESTDIR)$(docdir)
|
||||
+ $(INSTALL) CREDITS $(DESTDIR)$(docdir)/CREDITS
|
||||
+ $(INSTALL) xgalaga.6x $(DESTDIR)$(mandir)/man6/xgalaga.6x
|
||||
+ chmod 644 $(DESTDIR)$(mandir)/man6/xgalaga.6x
|
||||
# touch $(prefix)/scores
|
||||
# chmod 666 $(prefix)/scores
|
||||
# chown ${GAMEOWN}:${GAMEGRP} $(prefix)/scores
|
|
@ -1,55 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.7 2009/11/15 01:29:34 dholland Exp $
|
||||
|
||||
Patch installation paths. DESTDIR support.
|
||||
|
||||
--- Makefile.in.orig 1998-05-11 02:52:59.000000000 -0400
|
||||
+++ Makefile.in 2009-11-14 20:26:16.000000000 -0500
|
||||
@@ -20,12 +20,12 @@ SOUNDSRV = @SOUNDSERVER@
|
||||
SOUNDOBJS = @SOUNDSERVER@.o
|
||||
SOUNDSRCS = @SOUNDSERVER@.c
|
||||
|
||||
-SOUNDDEFS = -DSOUNDSERVER=\"@prefix@/@SOUNDSERVER@\"
|
||||
+SOUNDDEFS = -DSOUNDSERVER=\"${PREFIX}/libexec/xgalaga.sndsrv\"
|
||||
|
||||
RM = rm -f
|
||||
CC = @CC@
|
||||
CFLAGS = -I. @CFLAGS@ @DEFS@ @X_CFLAGS@ -DXGALAGADIR=\"@prefix@/\" $(SOUNDDEFS)
|
||||
-LDFLAGS = @LDFLAGS@
|
||||
+
|
||||
LIBS = @LIBS@ libsprite/libsprite.a @X_LIBS@
|
||||
INSTALL = @INSTALL@
|
||||
|
||||
@@ -40,19 +40,22 @@ SUBDIRS = libsprite
|
||||
all: $(TARGET) $(SOUNDSRV)
|
||||
|
||||
$(SOUNDSRV): $(SOUNDOBJS)
|
||||
- $(CC) $(LDFLAGS) -o $(SOUNDSRV) $(SOUNDOBJS) $(SOUNDLIBS)
|
||||
+ $(CC) $(LDFLAGS) -o $(SOUNDSRV) $(SOUNDOBJS) $(SOUNDLIBS) $(LIBOSSAUDIO)
|
||||
|
||||
install: all
|
||||
- ./mkinstalldirs $(bindir)
|
||||
- ./mkinstalldirs $(prefix)
|
||||
- $(INSTALL) $(TARGET) $(bindir)/$(TARGET)
|
||||
- $(INSTALL) $(SOUNDSRV) $(prefix)/$(SOUNDSRV)
|
||||
- ./mkinstalldirs $(prefix)/sounds
|
||||
- ./mkinstalldirs $(prefix)/levels
|
||||
- for i in levels/*.xgl; do $(INSTALL) $$i $(prefix)/$$i ; done
|
||||
- for i in sounds/*.raw; do $(INSTALL) $$i $(prefix)/$$i ; done
|
||||
- touch $(prefix)/scores
|
||||
- chmod 666 $(prefix)/scores
|
||||
+ ./mkinstalldirs $(DESTDIR)$(bindir)
|
||||
+ ./mkinstalldirs $(DESTDIR)$(prefix)
|
||||
+ $(INSTALL) $(TARGET) $(DESTDIR)$(bindir)/$(TARGET)
|
||||
+ $(INSTALL) $(SOUNDSRV) $(DESTDIR)${PREFIX}/libexec/xgalaga.sndsrv
|
||||
+ ./mkinstalldirs $(DESTDIR)$(prefix)/sounds
|
||||
+ ./mkinstalldirs $(DESTDIR)$(prefix)/levels
|
||||
+ for i in levels/*.xgl; do $(INSTALL) $$i $(DESTDIR)$(prefix)/$$i ; done
|
||||
+ for i in sounds/*.raw; do $(INSTALL) $$i $(DESTDIR)$(prefix)/$$i ; done
|
||||
+ touch $(DESTDIR)$(prefix)/scores
|
||||
+ chown ${GAMEOWN}:${GAMEGRP} $(DESTDIR)$(prefix)/scores
|
||||
+ chown ${GAMEOWN}:${GAMEGRP} $(DESTDIR)$(bindir)/$(TARGET)
|
||||
+ chmod ${GAMEMODE} $(DESTDIR)$(bindir)/$(TARGET)
|
||||
+ chmod ${GAMEDATAMODE} $(DESTDIR)$(prefix)/scores
|
||||
|
||||
subdirs:
|
||||
for i in $(SUBDIRS); do cd $$i ; make ; done
|
|
@ -1,58 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2009/01/03 12:37:08 obache Exp $
|
||||
|
||||
--- configure.orig 1998-05-11 07:02:12.000000000 +0000
|
||||
+++ configure
|
||||
@@ -1810,9 +1810,15 @@ if test -n "$sound-type"; then
|
||||
*linux*)
|
||||
sound_type=native
|
||||
;;
|
||||
+ *dragonfly*)
|
||||
+ sound_type=native
|
||||
+ ;;
|
||||
*freebsd*)
|
||||
sound_type=native
|
||||
;;
|
||||
+ *netbsd*)
|
||||
+ sound_type=native
|
||||
+ ;;
|
||||
*sunos*)
|
||||
sound_type=native
|
||||
;;
|
||||
@@ -1839,7 +1845,7 @@ EOF
|
||||
EOF
|
||||
|
||||
;;
|
||||
- *freebsd*)
|
||||
+ *freebsd* | *dragonfly*)
|
||||
SOUNDSERVER=xgal.sndsrv.freebsd
|
||||
cat >> confdefs.h <<\EOF
|
||||
#define SOUNDDEV "/dev/dsp"
|
||||
@@ -1850,8 +1856,18 @@ EOF
|
||||
EOF
|
||||
|
||||
;;
|
||||
+ *netbsd*)
|
||||
+ SOUNDSERVER=xgal.sndsrv.linux
|
||||
+ cat >> confdefs.h <<\EOF
|
||||
+#define SOUNDDEV "/dev/audio"
|
||||
+EOF
|
||||
+ cat >> confdefs.h <<\EOF
|
||||
+#define SOUND 1
|
||||
+EOF
|
||||
+
|
||||
+ ;;
|
||||
*sunos*)
|
||||
- SOUNDSERVER=xgal.sndsrv.sun.c
|
||||
+ SOUNDSERVER=xgal.sndsrv.sun
|
||||
cat >> confdefs.h <<\EOF
|
||||
#define SOUNDDEV "/dev/audio"
|
||||
EOF
|
||||
@@ -1862,7 +1878,7 @@ EOF
|
||||
|
||||
;;
|
||||
*solaris*)
|
||||
- SOUNDSERVER=xgal.sndsrv.sun.c
|
||||
+ SOUNDSERVER=xgal.sndsrv.sun
|
||||
cat >> confdefs.h <<\EOF
|
||||
#define SOUNDDEV "/dev/audio"
|
||||
EOF
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2001/09/10 01:03:28 hubertf Exp $
|
||||
|
||||
--- xgal.sndsrv.linux.c.orig Fri Sep 7 14:33:57 2001
|
||||
+++ xgal.sndsrv.linux.c
|
||||
@@ -15,8 +15,12 @@
|
||||
#include <unistd.h>
|
||||
#include <fcntl.h>
|
||||
#include <sys/ioctl.h>
|
||||
+#ifdef __NetBSD__
|
||||
+#include <soundcard.h>
|
||||
+#else
|
||||
#include <linux/soundcard.h>
|
||||
/*#include "linux_pcsp.h" /* /usr/include/linux/pcsp.h */
|
||||
+#endif
|
||||
#include <sys/time.h>
|
||||
#include <signal.h>
|
||||
#include <string.h>
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2005/06/14 17:32:37 jmmv Exp $
|
||||
|
||||
--- libsprite/data.c.orig 1998-04-12 08:03:22.000000000 +0200
|
||||
+++ libsprite/data.c
|
||||
@@ -79,7 +79,6 @@ W_Font W_HighlightFont = (W_Font) & two
|
||||
W_Color W_White = WHITE, W_Black = BLACK, W_Red = RED, W_Green = GREEN;
|
||||
W_Color W_Yellow = YELLOW, W_Cyan = CYAN, W_Grey = LIGHT_GREY, W_DarkGrey = DARK_GREY;
|
||||
int W_Textwidth, W_Textheight, W_BigTextwidth, W_BigTextheight;
|
||||
-char *strdup();
|
||||
|
||||
int W_in_message = 0; /* jfy -- for Jerry's warp message hack */
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- libsprite/data.h.orig 1998-04-12 07:03:22.000000000 +0100
|
||||
+++ libsprite/data.h 2006-07-02 15:26:28.000000000 +0100
|
||||
@@ -10,6 +10,8 @@
|
||||
#include <assert.h>
|
||||
#include <string.h>
|
||||
|
||||
+#include "struct.h"
|
||||
+
|
||||
#ifdef XPM
|
||||
#ifdef HACKED_XPMLIB
|
||||
#include "xpmlib-3.4b/xpm.h"
|
|
@ -1,24 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- main.c.orig 1998-05-11 07:52:59.000000000 +0100
|
||||
+++ main.c 2006-07-02 15:28:05.000000000 +0100
|
||||
@@ -7,6 +7,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#ifdef HAVE_SYS_TIME_H
|
||||
#include <sys/time.h>
|
||||
#endif
|
||||
@@ -14,10 +15,10 @@
|
||||
# include <unistd.h>
|
||||
#endif
|
||||
#include "libsprite/Wlib.h"
|
||||
+#include "struct.h"
|
||||
#include "data.h"
|
||||
#include "images.h"
|
||||
#include "defs.h"
|
||||
-#include "struct.h"
|
||||
#include "paths.h"
|
||||
#include "proto.h"
|
||||
#include "sound.h"
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ag,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- data.c.orig 1998-05-11 07:37:19.000000000 +0100
|
||||
+++ data.c 2006-07-02 15:30:36.000000000 +0100
|
||||
@@ -5,8 +5,8 @@
|
||||
#include "Wlib.h"
|
||||
#include "images.h"
|
||||
#include "defs.h"
|
||||
-#include "data.h"
|
||||
#include "struct.h"
|
||||
+#include "data.h"
|
||||
|
||||
int buttonDown = 0;
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ah,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- pathfile.c.orig 1998-04-30 06:11:56.000000000 +0100
|
||||
+++ pathfile.c 2006-07-02 15:31:23.000000000 +0100
|
||||
@@ -15,6 +15,7 @@
|
||||
|
||||
#include "paths.h"
|
||||
#include "pathfile.h"
|
||||
+#include "struct.h"
|
||||
#include "data.h"
|
||||
#include "defs.h"
|
||||
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-ai,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- title.c.orig 1998-05-11 07:52:59.000000000 +0100
|
||||
+++ title.c 2006-07-02 15:32:19.000000000 +0100
|
||||
@@ -7,8 +7,8 @@
|
||||
#include "Wlib.h"
|
||||
#include "defs.h"
|
||||
#include "images.h"
|
||||
-#include "data.h"
|
||||
#include "struct.h"
|
||||
+#include "data.h"
|
||||
#include "proto.h"
|
||||
|
||||
W_Image *pauseImage, *titleImage;
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-aj,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- score.c.orig 1998-04-30 06:11:58.000000000 +0100
|
||||
+++ score.c 2006-07-02 15:33:07.000000000 +0100
|
||||
@@ -4,11 +4,12 @@
|
||||
|
||||
#include <config.h>
|
||||
#include <stdio.h>
|
||||
+#include <string.h>
|
||||
#include "Wlib.h"
|
||||
#include "images.h"
|
||||
+#include "struct.h"
|
||||
#include "data.h"
|
||||
#include "defs.h"
|
||||
-#include "struct.h"
|
||||
#include "proto.h"
|
||||
|
||||
char scorestr[40] = "Score: 0000000", shipstr[4] ="";
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-ak,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- sound.c.orig 1998-04-12 07:03:21.000000000 +0100
|
||||
+++ sound.c 2006-07-02 15:33:52.000000000 +0100
|
||||
@@ -24,6 +24,7 @@
|
||||
#endif
|
||||
#include <signal.h>
|
||||
#include <sys/stat.h>
|
||||
+#include "struct.h"
|
||||
#include "data.h"
|
||||
|
||||
|
28
games/xgalaga/patches/patch-configure
Normal file
28
games/xgalaga/patches/patch-configure
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-configure,v 1.1 2020/11/20 13:50:23 nia Exp $
|
||||
|
||||
Correct installation paths.
|
||||
|
||||
--- configure.orig 2008-03-05 21:58:16.000000000 +0000
|
||||
+++ configure
|
||||
@@ -4664,10 +4664,10 @@ cat >>confdefs.h <<_ACEOF
|
||||
_ACEOF
|
||||
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
-#define SOUNDDIR "$prefix/sounds/"
|
||||
+#define SOUNDDIR "$prefix/share/xgalaga/sounds/"
|
||||
_ACEOF
|
||||
|
||||
-CREDITSFILE="$prefix/CREDITS"
|
||||
+CREDITSFILE="$prefix/share/doc/xgalaga/CREDITS"
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
#define CREDITSFILE "$CREDITSFILE"
|
||||
_ACEOF
|
||||
@@ -4677,7 +4677,7 @@ cat >>confdefs.h <<\_ACEOF
|
||||
_ACEOF
|
||||
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
-#define LEVELDIR "$prefix/levels/"
|
||||
+#define LEVELDIR "$prefix/share/xgalaga/levels/"
|
||||
_ACEOF
|
||||
|
||||
|
15
games/xgalaga/patches/patch-main.c
Normal file
15
games/xgalaga/patches/patch-main.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-main.c,v 1.1 2020/11/20 13:50:23 nia Exp $
|
||||
|
||||
Don't start fullscreen, appears to be buggy...
|
||||
|
||||
--- main.c.orig 2008-03-05 21:58:16.000000000 +0000
|
||||
+++ main.c
|
||||
@@ -1277,7 +1277,7 @@ char **argv;
|
||||
int ac;
|
||||
char *dpyname = 0;
|
||||
int mx, my, but;
|
||||
- int start_fullscreen = 1;
|
||||
+ int start_fullscreen = 0;
|
||||
|
||||
for(ac = 1; ac < argc; ac++) {
|
||||
if(*argv[ac] == '-') {
|
14
games/xgalaga/patches/patch-title.c
Normal file
14
games/xgalaga/patches/patch-title.c
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-title.c,v 1.1 2020/11/20 13:50:23 nia Exp $
|
||||
|
||||
Include unistd.h for close().
|
||||
|
||||
--- title.c.orig 2008-03-05 21:58:16.000000000 +0000
|
||||
+++ title.c
|
||||
@@ -5,6 +5,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <unistd.h>
|
||||
#ifdef HAVE_FCNTL_H
|
||||
# include <fcntl.h>
|
||||
#endif
|
Loading…
Reference in a new issue