Fix build under NetBSD with upstream patch

This commit is contained in:
ryoon 2018-05-12 12:16:00 +00:00
parent b8b6c67354
commit 6a1ff836b1
2 changed files with 34 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.19 2016/11/17 08:06:52 wiz Exp $
$NetBSD: distinfo,v 1.20 2018/05/12 12:16:00 ryoon Exp $
SHA1 (xf86-input-mouse-1.9.2.tar.bz2) = d3a0839ad5a33665bb261a4fba33e3a6271817dc
RMD160 (xf86-input-mouse-1.9.2.tar.bz2) = c7d68c0de19787ceda4e4307b113b6d74e0cb62d
SHA512 (xf86-input-mouse-1.9.2.tar.bz2) = 30fdc4f699d434e2fb4a9f8d2f4f980538d646a6e4d2d572737fc5498c0bce0fb1ba080173ea0aa3480f574dde3f58d5a7ac837afdb29640ccb092b3f18ff209
Size (xf86-input-mouse-1.9.2.tar.bz2) = 377685 bytes
SHA1 (patch-src_mouse.c) = 0e593e5c805af8d0be04925a8e0af97961fa4dd3
SHA1 (patch-src_sun__mouse.c) = e23157bc9bdb5840ac008648d1c9a894e7a900cc

View file

@ -0,0 +1,32 @@
$NetBSD: patch-src_mouse.c,v 1.3 2018/05/12 12:16:00 ryoon Exp $
From: https://cgit.freedesktop.org/xorg/driver/xf86-input-mouse/commit/?id=3c8f243b750a92d5837a449d344ff884dbd02b57
Adapt to removal of xf86GetOS
--- src/mouse.c.orig 2016-09-06 03:53:31.000000000 +0000
+++ src/mouse.c
@@ -794,7 +794,6 @@ InitProtocols(void)
{
int classes;
int i;
- const char *osname = NULL;
if (osInfo)
return TRUE;
@@ -821,11 +820,11 @@ InitProtocols(void)
mouseProtocols[i].id = PROT_UNSUP;
/* NetBSD uses PROT_BM for "PS/2". */
- xf86GetOS(&osname, NULL, NULL, NULL);
- if (osname && xf86NameCmp(osname, "netbsd") == 0)
- for (i = 0; mouseProtocols[i].name; i++)
- if (mouseProtocols[i].id == PROT_PS2)
- mouseProtocols[i].id = PROT_BM;
+#if defined(__NetBSD__)
+ for (i = 0; mouseProtocols[i].name; i++)
+ if (mouseProtocols[i].id == PROT_PS2)
+ mouseProtocols[i].id = PROT_BM;
+#endif
return TRUE;
}