Update "squid31" package to version 3.1.0.9. Changes since version 3.1.0.8:

- Bug 2682: Add ftp_epsv control to disable EPSV support.
- Bug 2665: Detach automake system from using -I.
- Bug 2395: FTP auth errors not displayed
- ... also several changes and bugs closed in 3.0.STABLE16
- Port from 2.7: Show local address on listening sockets
- Add "tag" type acl matching tags set by external acl helpers.
- Adds Language alias linker/installer/upgrade scripts
- Support for GCC 4.4
- Fix false NAT lookup errors on Linux
- Fix many Windows port issues
- Fix squid_kerb_auth helepr install location
- Better detection of IPv6 stack types
- Updates Licensing information for Squid 3.1
- ... and many packaging portability build and install issues
This commit is contained in:
tron 2009-07-07 18:25:13 +00:00
parent 46c823cbde
commit 6a4f868b86
3 changed files with 30 additions and 14 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.7 2009/07/01 02:17:46 taca Exp $
# $NetBSD: Makefile,v 1.8 2009/07/07 18:25:13 tron Exp $
DISTNAME= squid-3.1.0.8
DISTNAME= squid-3.1.0.9
PKGNAME= ${DISTNAME} # Necessary for "pkgsrc/www/squid/options.mk"
CATEGORIES= www
MASTER_SITES= ${SQUID_MASTER_SITES} \
@ -17,6 +17,8 @@ USE_TOOLS+= perl gmake
GNU_CONFIGURE= yes
PKG_DESTDIR_SUPPORT= destdir
POST_INSTALL_EXTRA= install-error-pages
.include "../../www/squid/Makefile.squid"
CONFIGURE_ARGS+= --with-default-user=${SQUID_USER}
@ -33,4 +35,17 @@ post-build:
${CP} -pf ${WRKSRC}/src/squid.conf.documented \
${WRKSRC}/src/squid.conf.default
install-error-pages:
cd ${WRKSRC}/errors && \
for DIR in *; do \
if [ -d $$DIR ]; then \
ERROR_DIR=${PREFIX}/share/squid/errors/$$DIR; \
${INSTALL_DATA_DIR} $$ERROR_DIR; \
for FILE in $$DIR/ERR_*; do \
${INSTALL_DATA} $$FILE $$ERROR_DIR; \
done; \
fi; \
done
${LN} -s en ${PREFIX}/share/squid/errors/templates
.include "../../mk/bsd.pkg.mk"

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.4 2009/06/07 08:36:36 tron Exp $
$NetBSD: distinfo,v 1.5 2009/07/07 18:25:13 tron Exp $
SHA1 (squid-3.1.0.8.tar.bz2) = 23c582d7fa11fc63cf388f00d01611398453aab1
RMD160 (squid-3.1.0.8.tar.bz2) = f6069174f118d79470f35bf7c11184e014984674
Size (squid-3.1.0.8.tar.bz2) = 2345063 bytes
SHA1 (squid-3.1.0.9.tar.bz2) = 221cc189c1c69e61819540ceb798ded728c2579a
RMD160 (squid-3.1.0.9.tar.bz2) = 208ec13315ba73e16f3f4051e41aa7a539d7ba45
Size (squid-3.1.0.9.tar.bz2) = 2360740 bytes
SHA1 (patch-ad) = 031e5de714610917ac0c575b42add980c0933c72
SHA1 (patch-ae) = b1833170580e93248af867f003c37ce8afbb5e6f
SHA1 (patch-ae) = a512f1d521f3019e2136b5d0ad2199182e2aaabb
SHA1 (patch-ah) = e20f7b76d6d48041efbfe1a07dce756a818e6642
SHA1 (patch-aj) = 349b5d49dec49430cff2a170ad53d3a16f2a4c76
SHA1 (patch-al) = 6dd09cf75ed53a92616f4eed9f3e290232ff54a5

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ae,v 1.1 2009/05/17 14:17:42 tron Exp $
$NetBSD: patch-ae,v 1.2 2009/07/07 18:25:13 tron Exp $
--- errors/Makefile.in.orig 2009-04-08 11:51:20.000000000 +0100
+++ errors/Makefile.in 2009-05-17 14:32:03.000000000 +0100
@@ -509,13 +509,13 @@
--- errors/Makefile.in.orig 2009-06-26 11:35:52.000000000 +0100
+++ errors/Makefile.in 2009-06-30 18:58:13.000000000 +0100
@@ -408,13 +408,13 @@
done; \
fi \
done; \
@ -12,14 +12,15 @@ $NetBSD: patch-ae,v 1.1 2009/05/17 14:17:42 tron Exp $
- else \
- echo "$(INSTALL_DATA) $(srcdir)/errorpage.css $(DESTDIR)$(DEFAULT_STYLESHEET)"; \
- $(INSTALL_DATA) $(srcdir)/errorpage.css $(DESTDIR)$(DEFAULT_STYLESHEET); \
- fi
- fi ; \
+# $(INSTALL_DATA) $(srcdir)/errorpage.css $(DESTDIR)$(DEFAULT_STYLESHEET).default; \
+# if test -f $(DESTDIR)$(DEFAULT_STYLESHEET) ; then \
+# echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_STYLESHEET)" ; \
+# else \
+# echo "$(INSTALL_DATA) $(srcdir)/errorpage.css $(DESTDIR)$(DEFAULT_STYLESHEET)"; \
+# $(INSTALL_DATA) $(srcdir)/errorpage.css $(DESTDIR)$(DEFAULT_STYLESHEET); \
+# fi
+# fi ; \
$(SHELL) $(srcdir)/alias-link.sh "$(LN)" "$(RM)" "$(DESTDIR)$(DEFAULT_ERROR_DIR)" "$(srcdir)/aliases" || exit 1 ;
uninstall-local:
@ for l in $(LANGUAGES) templates; do \
for l in $(TRANSLATIONS); do \