* Updated to 0.96.3.
* Added GUI option "headless". * Removed dbus dependency. It's just a gimmick, not worth it. * Added patch-ab to avoid picking up stuff from /usr/local for example.
This commit is contained in:
parent
99a67ac141
commit
6a5f9caaa4
6 changed files with 74 additions and 13 deletions
|
@ -5,7 +5,7 @@ things.
|
|||
|
||||
Gnutella is a peer-based file-sharing protocol that allows a
|
||||
user running a Gnutella client to search for and download files from
|
||||
other Gnutella users, as well as share some files of his/her own.
|
||||
other Gnutella users, as well as share some files of their own.
|
||||
|
||||
Gtk-Gnutella offers all the extra features you expect from a modern
|
||||
client: persistent downloads, searches and filters, intuitive interface,
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.56 2006/08/23 09:49:36 jmmv Exp $
|
||||
# $NetBSD: Makefile,v 1.57 2007/01/20 14:50:03 cbiere Exp $
|
||||
|
||||
DISTNAME= gtk-gnutella-0.96.1
|
||||
PKGREVISION= 1
|
||||
DISTNAME= gtk-gnutella-0.96.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gtk-gnutella/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
@ -29,7 +28,5 @@ CONFIGURE_ARGS+= -U optimize
|
|||
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../security/gnutls/buildlink3.mk"
|
||||
.include "../../sysutils/dbus/buildlink3.mk"
|
||||
.include "../../textproc/libxml2/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.12 2006/04/17 07:07:31 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.13 2007/01/20 14:50:03 cbiere Exp $
|
||||
bin/gtk-gnutella
|
||||
share/applications/gtk-gnutella.desktop
|
||||
share/gtk-gnutella/bogons.txt
|
||||
|
@ -29,6 +29,9 @@ share/gtk-gnutella/pixmaps/freeze.xpm
|
|||
share/gtk-gnutella/pixmaps/icon.xpm
|
||||
share/gtk-gnutella/pixmaps/leaf.xpm
|
||||
share/gtk-gnutella/pixmaps/legacy.xpm
|
||||
share/gtk-gnutella/pixmaps/magnet.16x16.png
|
||||
share/gtk-gnutella/pixmaps/magnet.32x32.png
|
||||
share/gtk-gnutella/pixmaps/magnet.64x64.png
|
||||
share/gtk-gnutella/pixmaps/no_firewall.xpm
|
||||
share/gtk-gnutella/pixmaps/offline.xpm
|
||||
share/gtk-gnutella/pixmaps/online.xpm
|
||||
|
@ -45,9 +48,11 @@ share/locale/el/LC_MESSAGES/gtk-gnutella.mo
|
|||
share/locale/es/LC_MESSAGES/gtk-gnutella.mo
|
||||
share/locale/fr/LC_MESSAGES/gtk-gnutella.mo
|
||||
share/locale/hu/LC_MESSAGES/gtk-gnutella.mo
|
||||
share/locale/it/LC_MESSAGES/gtk-gnutella.mo
|
||||
share/locale/ja/LC_MESSAGES/gtk-gnutella.mo
|
||||
share/locale/nb/LC_MESSAGES/gtk-gnutella.mo
|
||||
share/locale/nl/LC_MESSAGES/gtk-gnutella.mo
|
||||
share/locale/tr/LC_MESSAGES/gtk-gnutella.mo
|
||||
share/locale/uk/LC_MESSAGES/gtk-gnutella.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/gtk-gnutella.mo
|
||||
share/pixmaps/gtk-gnutella.png
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.23 2006/05/12 20:43:54 adam Exp $
|
||||
$NetBSD: distinfo,v 1.24 2007/01/20 14:50:03 cbiere Exp $
|
||||
|
||||
SHA1 (gtk-gnutella-0.96.1.tar.bz2) = 28540c4e78f4c3513ac15b95228a98d17ace2091
|
||||
RMD160 (gtk-gnutella-0.96.1.tar.bz2) = 58fc8eb3aea991e81d96435f11665d6f50ccc1de
|
||||
Size (gtk-gnutella-0.96.1.tar.bz2) = 2661487 bytes
|
||||
SHA1 (gtk-gnutella-0.96.3.tar.bz2) = 7469d4ea685c387f38e927efeb8b9947a9ec72e3
|
||||
RMD160 (gtk-gnutella-0.96.3.tar.bz2) = fd5f04d22349a584e9b26cefbbbef41a2dbef7b2
|
||||
Size (gtk-gnutella-0.96.3.tar.bz2) = 2845172 bytes
|
||||
SHA1 (patch-aa) = 16cc12d99624677d81fd1a7746b2afb80db0b570
|
||||
SHA1 (patch-ab) = 9ffbe8d12c7e4747a2110cd825bf957e2f3f393a
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: options.mk,v 1.1 2006/05/12 20:43:54 adam Exp $
|
||||
# $NetBSD: options.mk,v 1.2 2007/01/20 14:50:03 cbiere Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.gtk-gnutella
|
||||
PKG_SUPPORTED_OPTIONS= # empty
|
||||
PKG_OPTIONS_OPTIONAL_GROUPS= gui
|
||||
PKG_OPTIONS_GROUP.gui= gtk1 gtk2
|
||||
PKG_OPTIONS_GROUP.gui= gtk1 gtk2 headless
|
||||
PKG_SUGGESTED_OPTIONS= gtk2
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
@ -17,3 +17,8 @@ CONFIGURE_ARGS+= -D gtkversion=1
|
|||
CONFIGURE_ARGS+= -D gtkversion=2
|
||||
. include "../../x11/gtk2/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mheadless)
|
||||
CONFIGURE_ARGS+= -D d_headless
|
||||
. include "../../devel/glib2/buildlink3.mk"
|
||||
.endif
|
||||
|
|
53
net/gtk-gnutella/patches/patch-ab
Normal file
53
net/gtk-gnutella/patches/patch-ab
Normal file
|
@ -0,0 +1,53 @@
|
|||
$NetBSD: patch-ab,v 1.5 2007/01/20 14:50:03 cbiere Exp $
|
||||
|
||||
--- Configure 2007-01-05 01:02:13.000000000 +0100
|
||||
+++ Configure 2007-01-05 01:01:24.000000000 +0100
|
||||
@@ -69,28 +69,6 @@
|
||||
fi
|
||||
fi
|
||||
|
||||
-: Proper PATH setting
|
||||
-paths='/bin /usr/bin /usr/local/bin /usr/ucb /usr/local /usr/lbin'
|
||||
-paths="$paths /opt/bin /opt/local/bin /opt/local /opt/lbin"
|
||||
-paths="$paths /usr/5bin /etc /usr/gnu/bin /usr/new /usr/new/bin /usr/nbin"
|
||||
-paths="$paths /opt/gnu/bin /opt/new /opt/new/bin /opt/nbin"
|
||||
-paths="$paths /sys5.3/bin /sys5.3/usr/bin /bsd4.3/bin /bsd4.3/usr/ucb"
|
||||
-paths="$paths /bsd4.3/usr/bin /usr/bsd /bsd43/bin /usr/ccs/bin"
|
||||
-paths="$paths /etc /usr/lib /usr/ucblib /lib /usr/ccs/lib"
|
||||
-paths="$paths /sbin /usr/sbin /usr/libexec"
|
||||
-paths="$paths /system/gnu_library/bin"
|
||||
-
|
||||
-for p in $paths
|
||||
-do
|
||||
- case "$p_$PATH$p_" in
|
||||
- *$p_$p$p_*) ;;
|
||||
- *) test -d $p && PATH=$PATH$p_$p ;;
|
||||
- esac
|
||||
-done
|
||||
-
|
||||
-PATH=.$p_$PATH
|
||||
-export PATH
|
||||
-
|
||||
: shall we be using ksh?
|
||||
inksh=''
|
||||
needksh=''
|
||||
@@ -569,8 +547,7 @@
|
||||
archobjs=''
|
||||
: Possible local include directories to search.
|
||||
: Set locincpth to "" in a hint file to defeat local include searches.
|
||||
-locincpth="/usr/local/include /opt/local/include /usr/gnu/include"
|
||||
-locincpth="$locincpth /opt/gnu/include /usr/GNU/include /opt/GNU/include"
|
||||
+locincpth=""
|
||||
:
|
||||
: no include file wanted by default
|
||||
inclwanted=''
|
||||
@@ -581,8 +558,7 @@
|
||||
: change the next line if compiling for Xenix/286 on Xenix/386
|
||||
xlibpth='/usr/lib/386 /lib/386'
|
||||
: Possible local library directories to search.
|
||||
-loclibpth="/usr/local/lib /opt/local/lib /usr/gnu/lib"
|
||||
-loclibpth="$loclibpth /opt/gnu/lib /usr/GNU/lib /opt/GNU/lib"
|
||||
+loclibpth=""
|
||||
|
||||
: general looking path for locating libraries
|
||||
glibpth="/lib /usr/lib $xlibpth"
|
Loading…
Reference in a new issue