xf86-video-s3: update to 0.7.0.

This is a maintenance release of S3 DDX for X.Org X Server.
The DDX compiles cleanly without compilation warnings on X Server 1.19.6.

Kevin Brace
Brace Computer Laboratory blog
https://bracecomputerlab.com

--
Alan Coopersmith (7):
      When checking malloc for success, it helps to use == NULL, instead of =
      s3_bios.c: Simplify code for choosing between 16000 & 16000 for RefClock
      Remove unused BIOS size & address macros
      configure: Drop AM_MAINTAINER_MODE
      autogen.sh: Honor NOCONFIGURE=1
      Update README for gitlab migration
      Update configure.ac bug URL for gitlab migration

Emil Velikov (1):
      autogen.sh: use quoted string variables

Eric S. Raymond (1):
      Fix malformed list syntax.

Gaetan Nadon (1):
      Remove mibstore.h

Kevin Brace (5):
      Discontinue the use of xf86PciInfo.h
      Use const char for xf86GetOptValString return type
      Eliminate set but not used variable compilation warnings
      Eliminate unused variable compilation warning
      Version bumped to 0.7.0

Mihail Konev (1):
      autogen: add default patch prefix

Peter Hutterer (1):
      autogen.sh: use exec instead of waiting for configure to finish
This commit is contained in:
wiz 2019-11-14 11:07:12 +00:00
parent d2b22de940
commit 6a6d2c032d
3 changed files with 7 additions and 41 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.19 2018/03/07 11:57:44 wiz Exp $
# $NetBSD: Makefile,v 1.20 2019/11/14 11:07:12 wiz Exp $
DISTNAME= xf86-video-s3-0.6.5
PKGREVISION= 5
DISTNAME= xf86-video-s3-0.7.0
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XORG:=driver/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.7 2015/11/04 03:29:03 agc Exp $
$NetBSD: distinfo,v 1.8 2019/11/14 11:07:12 wiz Exp $
SHA1 (xf86-video-s3-0.6.5.tar.bz2) = e9d715fbcddd7bef32b0216e1b7fd976c7538be2
RMD160 (xf86-video-s3-0.6.5.tar.bz2) = 8dfe48f967666c55fe54abd22ca132ce3695f534
SHA512 (xf86-video-s3-0.6.5.tar.bz2) = bd7d93008dae33b0b7943b2c81de5f39b1d8224ccebd0cdb9e8d22e7ea7fb0981adf6afd44e24162fa8a076d3e250f93316fd3a25cada2d65166a6bc4d13c267
Size (xf86-video-s3-0.6.5.tar.bz2) = 325582 bytes
SHA1 (patch-src_s3__driver.c) = 2c3a6a74c27305c097464f36627e7176ad63b9b8
SHA1 (xf86-video-s3-0.7.0.tar.bz2) = ddcd103a8e955b30f09c0336623fe1341f92ff12
RMD160 (xf86-video-s3-0.7.0.tar.bz2) = e0d867a0bfab79633e0591a686b75a479b03aeb1
SHA512 (xf86-video-s3-0.7.0.tar.bz2) = 6158e3f7dba8b4770758fa43c686a316c11f70966f80e015ae0087d90a036062237adeb7ad0f6aa21cc46b9d08ad38c964940ff503b58b502e87cf11be60cdd4
Size (xf86-video-s3-0.7.0.tar.bz2) = 348923 bytes

View file

@ -1,32 +0,0 @@
$NetBSD: patch-src_s3__driver.c,v 1.1 2015/04/02 22:16:47 tnn Exp $
From ed0fbfd27609e897c42d7ab316481a9504746233 Mon Sep 17 00:00:00 2001
From: Gaetan Nadon <memsize@videotron.ca>
Date: Tue, 7 Jan 2014 16:28:58 -0500
Subject: Remove mibstore.h
As it was done in numerous other drivers. Fixes compile error.
Tested-by: Trevor Woerner <trevor.woerner@linaro.org>
Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
diff --git a/src/s3_driver.c b/src/s3_driver.c
index 61242ad..85763ba 100644
--- src/s3_driver.c
+++ src/s3_driver.c
@@ -52,7 +52,6 @@
#include "compiler.h"
#include "mipointer.h"
#include "micmap.h"
-#include "mibstore.h"
#include "fb.h"
#include "inputstr.h"
#include "shadowfb.h"
@@ -822,7 +821,6 @@ static Bool S3ScreenInit(SCREEN_INIT_ARGS_DECL)
fbPictureInit (pScreen, 0, 0);
S3DGAInit(pScreen);
- miInitializeBackingStore(pScreen);
xf86SetBackingStore(pScreen);
/* framebuffer manager setup */