rawtherappe: fix man page installation

Ride update
This commit is contained in:
wiz 2023-11-21 16:26:36 +00:00
parent 1f25719c19
commit 6a77310b5d
4 changed files with 15 additions and 29 deletions

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.32 2023/11/21 16:09:25 wiz Exp $
# $NetBSD: Makefile,v 1.33 2023/11/21 16:26:36 wiz Exp $
DISTNAME= rawtherapee-5.9
CATEGORIES= graphics
@ -14,12 +14,9 @@ USE_CMAKE= yes
USE_LANGUAGES= c c++
USE_TOOLS+= pkg-config
# for patch-CMakeLists.txt
CMAKE_ARGS+= -DPKGMANDIR=${PKGMANDIR}
# ReleaseInfo.cmake must exist or it will try to use git(1) to regen it.
pre-configure:
touch ${WRKSRC}/ReleaseInfo.cmake
.include "../../audio/libcanberra/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../graphics/lcms2/buildlink3.mk"

View File

@ -1,6 +1,7 @@
@comment $NetBSD: PLIST,v 1.4 2023/11/21 16:09:25 wiz Exp $
@comment $NetBSD: PLIST,v 1.5 2023/11/21 16:26:36 wiz Exp $
bin/rawtherapee
bin/rawtherapee-cli
man/man1/rawtherapee.1
share/applications/rawtherapee.desktop
share/doc/rawtherapee/AUTHORS.txt
share/doc/rawtherapee/AboutThisBuild.txt
@ -563,7 +564,6 @@ share/rawtherapee/languages/Serbian (Cyrilic Characters)
share/rawtherapee/languages/Slovenian
share/rawtherapee/languages/Swedish
share/rawtherapee/languages/default
share/rawtherapee/man/man1/rawtherapee.1
share/rawtherapee/options
share/rawtherapee/profiles/Auto-Matched Curve - ISO High.pp3
share/rawtherapee/profiles/Auto-Matched Curve - ISO Low.pp3

View File

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.7 2023/11/21 16:09:25 wiz Exp $
$NetBSD: distinfo,v 1.8 2023/11/21 16:26:36 wiz Exp $
BLAKE2s (rawtherapee-5.9.tar.xz) = 7c1c20e6504d34752b70f597df97b37eb1be68803528eb3e00343d58fa3ff692
SHA512 (rawtherapee-5.9.tar.xz) = 0d848a36293eb5cac3212910eaf1d011315269c6bbe780c4c2e5f91719721e25a7d1678a7e4453fa4a9694618978b04828612dc03e1d50cb9c11ad4d238e7ca8
Size (rawtherapee-5.9.tar.xz) = 16219076 bytes
SHA1 (patch-CMakeLists.txt) = fcbfca37cbf5c1952aea44376a5d5e8a556acc87
SHA1 (patch-CMakeLists.txt) = f96c3edf8dd61f595f4e447dfb8c843ab132bcd6
SHA1 (patch-rtgui_CMakeLists.txt) = 563c3fa1efcbe9767fbecbd8c866fa7362dd3e8b

View File

@ -1,26 +1,15 @@
$NetBSD: patch-CMakeLists.txt,v 1.2 2023/11/21 16:09:25 wiz Exp $
$NetBSD: patch-CMakeLists.txt,v 1.3 2023/11/21 16:26:36 wiz Exp $
Adapt man path.
Fix man page installation path.
--- CMakeLists.txt.orig 2022-11-27 18:04:23.000000000 +0000
--- CMakeLists.txt.orig 2023-11-21 16:16:22.166786047 +0000
+++ CMakeLists.txt
@@ -757,18 +757,8 @@ install(
# The standard location for man pages in Linux is /usr/share/man Use "manpath"
# to see the search paths for man pages on your system.
-if(BUILD_BUNDLE)
- if(APPLE)
- install(FILES "${PROJECT_SOURCE_DIR}/doc/manpage/rawtherapee.1"
+install(FILES "${PROJECT_SOURCE_DIR}/doc/manpage/rawtherapee.1"
DESTINATION "${DATADIR}/man/man1")
- else()
- install(FILES "${PROJECT_SOURCE_DIR}/doc/manpage/rawtherapee.1"
- DESTINATION "${DATADIR}/share/man/man1")
- endif()
-else()
- install(FILES "${PROJECT_SOURCE_DIR}/doc/manpage/rawtherapee.1"
@@ -767,7 +767,7 @@ if(BUILD_BUNDLE)
endif()
else()
install(FILES "${PROJECT_SOURCE_DIR}/doc/manpage/rawtherapee.1"
- DESTINATION "${CMAKE_INSTALL_PREFIX}/share/man/man1")
-endif()
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/${PKGMANDIR}/man1")
endif()
if(WIN32)
install(DIRECTORY "licenses" DESTINATION "${LICENCEDIR}")