Fix PR pkg/45795.

Fix build error on some systems.

Upstream patch:
http://git.chromium.org/gitweb/?p=webm/libvpx.git;a=commitdiff;h=17c754fc00881a78e71488e7c544d05cf2f6927f
This commit is contained in:
ryoon 2012-01-07 12:18:47 +00:00
parent 8b5cd5cf62
commit 6a7f5f4f28
2 changed files with 28 additions and 5 deletions

View file

@ -1,10 +1,10 @@
$NetBSD: distinfo,v 1.8 2011/10/28 14:09:44 ryoon Exp $
$NetBSD: distinfo,v 1.9 2012/01/07 12:18:47 ryoon Exp $
SHA1 (libvpx-v0.9.7-p1.tar.bz2) = dacfefaf3363f781de43858f09cdd0b0d469e6fc
RMD160 (libvpx-v0.9.7-p1.tar.bz2) = 8a9e011d1039fee132ecd9f6feb1055815b7b777
Size (libvpx-v0.9.7-p1.tar.bz2) = 1244783 bytes
SHA1 (patch-aa) = 77f98144d28166ac26f76bb349303c0766633a99
SHA1 (patch-ab) = ee50d164938f4225dee83d5c4d65314ba331e2cf
SHA1 (patch-ab) = d2932c6e3a1039315f9e0361456ab8037de7aa08
SHA1 (patch-ac) = 9c7ed134d8b85734dc81ed1eb2e3ada2b753c802
SHA1 (patch-ad) = f1963d5997afb486f53bb94ab6b60c6eb3edc626
SHA1 (patch-ae) = 15cc4d0a043bd66c48ebe43612a8619533afca04

View file

@ -1,8 +1,10 @@
$NetBSD: patch-ab,v 1.2 2011/08/07 17:20:09 ryoon Exp $
$NetBSD: patch-ab,v 1.3 2012/01/07 12:18:47 ryoon Exp $
--- libs.mk.orig 2011-08-04 17:30:15.000000000 +0000
http://git.chromium.org/gitweb/?p=webm/libvpx.git;a=commitdiff;h=17c754fc00881a78e71488e7c544d05cf2f6927f
--- libs.mk.orig 2011-08-15 21:02:45.000000000 +0000
+++ libs.mk
@@ -180,8 +180,8 @@ endif
@@ -188,8 +188,8 @@ endif
else
LIBVPX_OBJS=$(call objs,$(CODEC_SRCS))
OBJS-$(BUILD_LIBVPX) += $(LIBVPX_OBJS)
@ -13,3 +15,24 @@ $NetBSD: patch-ab,v 1.2 2011/08/07 17:20:09 ryoon Exp $
BUILD_LIBVPX_SO := $(if $(BUILD_LIBVPX),$(CONFIG_SHARED))
LIBVPX_SO := libvpx.so.$(VERSION_MAJOR).$(VERSION_MINOR).$(VERSION_PATCH)
@@ -281,17 +281,17 @@ $(filter %$(ASM).o,$(OBJS-yes)): $(BUILD
ifeq ($(filter icc gcc,$(TGT_CC)), $(TGT_CC))
$(BUILD_PFX)asm_com_offsets.asm: $(BUILD_PFX)$(VP8_PREFIX)common/asm_com_offsets.c.S
- grep EQU $< | tr -d '$$\#' $(ADS2GAS) > $@
+ grep -w EQU $< | tr -d '$$\#' $(ADS2GAS) > $@
$(BUILD_PFX)$(VP8_PREFIX)common/asm_com_offsets.c.S: $(VP8_PREFIX)common/asm_com_offsets.c
CLEAN-OBJS += $(BUILD_PFX)asm_com_offsets.asm $(BUILD_PFX)$(VP8_PREFIX)common/asm_com_offsets.c.S
$(BUILD_PFX)asm_enc_offsets.asm: $(BUILD_PFX)$(VP8_PREFIX)encoder/asm_enc_offsets.c.S
- grep EQU $< | tr -d '$$\#' $(ADS2GAS) > $@
+ grep -w EQU $< | tr -d '$$\#' $(ADS2GAS) > $@
$(BUILD_PFX)$(VP8_PREFIX)encoder/asm_enc_offsets.c.S: $(VP8_PREFIX)encoder/asm_enc_offsets.c
CLEAN-OBJS += $(BUILD_PFX)asm_enc_offsets.asm $(BUILD_PFX)$(VP8_PREFIX)encoder/asm_enc_offsets.c.S
$(BUILD_PFX)asm_dec_offsets.asm: $(BUILD_PFX)$(VP8_PREFIX)decoder/asm_dec_offsets.c.S
- grep EQU $< | tr -d '$$\#' $(ADS2GAS) > $@
+ grep -w EQU $< | tr -d '$$\#' $(ADS2GAS) > $@
$(BUILD_PFX)$(VP8_PREFIX)decoder/asm_dec_offsets.c.S: $(VP8_PREFIX)decoder/asm_dec_offsets.c
CLEAN-OBJS += $(BUILD_PFX)asm_dec_offsets.asm $(BUILD_PFX)$(VP8_PREFIX)decoder/asm_dec_offsets.c.S
else