Changes 1.51.0:

New Libraries
* Context: Context switching library, from Oliver Kowalke.
Updated Libraries
* Algorithm:
- Fixed is_sorted_until ; now matches the c++11 standard behavior on ranges with
  duplicate values.
- Added range support for the rest of the search algorithms.
- unhex now uses Boost.Exception to signal bad input.
* Asio:
- Fixed an incompatibility between ip::tcp::iostream and C++11.
- Decorated GCC attribute names with underscores to prevent interaction with
  user-defined macros.
- Added missing #include <cctype>, needed for some versions of MinGW.
- Changed to use gcc's atomic builtins on ARM CPUs, when available.
- Changed strand destruction to be a no-op, to allow strand objects to be
  destroyed after their associated io_service has been destroyed.
- Added support for some newer versions of glibc which provide the
  epoll_create1() function but always fail with ENOSYS.
- Changed the SSL implementation to throw an exception if SSL engine
  initialisation fails.
- Fixed another regression in buffered_write_stream.
- Implemented various minor performance improvements, primarily targeted at
  Linux x86 and x86-64 platforms.
* Config:
- Deprecated a whole bunch of macros that were c++11 specific, but not named to
  show that they were c++11 specific. Made new macros with better names, and
  paired the old macros with the new ones. Updated the documentation to list
  the deprecated macros.
[more..]
This commit is contained in:
adam 2012-08-27 08:49:08 +00:00
parent f1d9c72593
commit 6ab41c0425
13 changed files with 87 additions and 69 deletions

View file

@ -1,11 +1,11 @@
# $NetBSD: buildlink3.mk,v 1.22 2012/07/02 07:02:25 adam Exp $
# $NetBSD: buildlink3.mk,v 1.23 2012/08/27 08:49:09 adam Exp $
BUILDLINK_TREE+= boost-build
.if !defined(BOOST_BUILD_BUILDLINK3_MK)
BOOST_BUILD_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.boost-build+= boost-build-1.50.*
BUILDLINK_API_DEPENDS.boost-build+= boost-build-1.51.*
BUILDLINK_DEPMETHOD.boost-build?= build
BUILDLINK_PKGSRCDIR.boost-build?= ../../devel/boost-build
.endif # BOOST_BUILD_BUILDLINK3_MK

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.20 2012/07/02 07:02:25 adam Exp $
@comment $NetBSD: PLIST,v 1.21 2012/08/27 08:49:09 adam Exp $
include/boost/accumulators/accumulators.hpp
include/boost/accumulators/accumulators_fwd.hpp
include/boost/accumulators/framework/accumulator_base.hpp
@ -378,6 +378,7 @@ include/boost/asio/detail/impl/win_thread.ipp
include/boost/asio/detail/impl/win_tss_ptr.ipp
include/boost/asio/detail/impl/winsock_init.ipp
include/boost/asio/detail/io_control.hpp
include/boost/asio/detail/keyword_tss_ptr.hpp
include/boost/asio/detail/kqueue_reactor.hpp
include/boost/asio/detail/kqueue_reactor_fwd.hpp
include/boost/asio/detail/local_free_on_block_exit.hpp
@ -938,11 +939,24 @@ include/boost/container/flat_set.hpp
include/boost/container/list.hpp
include/boost/container/map.hpp
include/boost/container/scoped_allocator.hpp
include/boost/container/scoped_allocator_fwd.hpp
include/boost/container/set.hpp
include/boost/container/slist.hpp
include/boost/container/stable_vector.hpp
include/boost/container/string.hpp
include/boost/container/vector.hpp
include/boost/context/all.hpp
include/boost/context/detail/config.hpp
include/boost/context/detail/fcontext_arm.hpp
include/boost/context/detail/fcontext_i386.hpp
include/boost/context/detail/fcontext_i386_win.hpp
include/boost/context/detail/fcontext_mips.hpp
include/boost/context/detail/fcontext_ppc.hpp
include/boost/context/detail/fcontext_x86_64.hpp
include/boost/context/detail/fcontext_x86_64_win.hpp
include/boost/context/fcontext.hpp
include/boost/context/stack_allocator.hpp
include/boost/context/stack_utils.hpp
include/boost/crc.hpp
include/boost/cregex.hpp
include/boost/cstdint.hpp
@ -1407,11 +1421,13 @@ include/boost/fusion/adapted/struct/adapt_struct.hpp
include/boost/fusion/adapted/struct/adapt_struct_named.hpp
include/boost/fusion/adapted/struct/define_assoc_struct.hpp
include/boost/fusion/adapted/struct/define_struct.hpp
include/boost/fusion/adapted/struct/define_struct_inline.hpp
include/boost/fusion/adapted/struct/detail/adapt_base.hpp
include/boost/fusion/adapted/struct/detail/at_impl.hpp
include/boost/fusion/adapted/struct/detail/begin_impl.hpp
include/boost/fusion/adapted/struct/detail/category_of_impl.hpp
include/boost/fusion/adapted/struct/detail/define_struct.hpp
include/boost/fusion/adapted/struct/detail/define_struct_inline.hpp
include/boost/fusion/adapted/struct/detail/deref_data_impl.hpp
include/boost/fusion/adapted/struct/detail/deref_impl.hpp
include/boost/fusion/adapted/struct/detail/end_impl.hpp
@ -1511,7 +1527,6 @@ include/boost/fusion/container/deque/detail/cpp03_deque_keyed_values.hpp
include/boost/fusion/container/deque/detail/cpp11_deque_keyed_values.hpp
include/boost/fusion/container/deque/detail/deque_forward_ctor.hpp
include/boost/fusion/container/deque/detail/deque_initial_size.hpp
include/boost/fusion/container/deque/detail/deque_keyed_values.hpp
include/boost/fusion/container/deque/detail/deque_keyed_values_call.hpp
include/boost/fusion/container/deque/detail/end_impl.hpp
include/boost/fusion/container/deque/detail/is_sequence_impl.hpp
@ -1858,6 +1873,7 @@ include/boost/fusion/include/deduce.hpp
include/boost/fusion/include/deduce_sequence.hpp
include/boost/fusion/include/define_assoc_struct.hpp
include/boost/fusion/include/define_struct.hpp
include/boost/fusion/include/define_struct_inline.hpp
include/boost/fusion/include/deque.hpp
include/boost/fusion/include/deque_fwd.hpp
include/boost/fusion/include/deque_tie.hpp
@ -1945,7 +1961,7 @@ include/boost/fusion/include/push_front.hpp
include/boost/fusion/include/query.hpp
include/boost/fusion/include/remove.hpp
include/boost/fusion/include/remove_if.hpp
include/boost/fusion/include/repetetive_view.hpp
include/boost/fusion/include/repetitive_view.hpp
include/boost/fusion/include/replace.hpp
include/boost/fusion/include/replace_if.hpp
include/boost/fusion/include/reverse.hpp
@ -2083,6 +2099,7 @@ include/boost/fusion/sequence/io/in.hpp
include/boost/fusion/sequence/io/out.hpp
include/boost/fusion/sequence/sequence_facade.hpp
include/boost/fusion/support.hpp
include/boost/fusion/support/as_const.hpp
include/boost/fusion/support/category_of.hpp
include/boost/fusion/support/deduce.hpp
include/boost/fusion/support/deduce_sequence.hpp
@ -2548,6 +2565,7 @@ include/boost/geometry/strategies/transform/map_transformer.hpp
include/boost/geometry/strategies/transform/matrix_transformers.hpp
include/boost/geometry/strategies/within.hpp
include/boost/geometry/util/add_const_if_c.hpp
include/boost/geometry/util/bare_type.hpp
include/boost/geometry/util/calculation_type.hpp
include/boost/geometry/util/closure_as_bool.hpp
include/boost/geometry/util/coordinate_cast.hpp
@ -2837,6 +2855,7 @@ include/boost/graph/transitive_reduction.hpp
include/boost/graph/transpose_graph.hpp
include/boost/graph/tree_traits.hpp
include/boost/graph/two_bit_color_map.hpp
include/boost/graph/two_graphs_common_spanning_trees.hpp
include/boost/graph/undirected_dfs.hpp
include/boost/graph/undirected_graph.hpp
include/boost/graph/use_mpi.hpp
@ -4892,6 +4911,7 @@ include/boost/msm/back/queue_container_deque.hpp
include/boost/msm/back/state_machine.hpp
include/boost/msm/back/tools.hpp
include/boost/msm/common.hpp
include/boost/msm/event_traits.hpp
include/boost/msm/front/common_states.hpp
include/boost/msm/front/completion_event.hpp
include/boost/msm/front/detail/common_states.hpp
@ -5847,6 +5867,7 @@ include/boost/program_options/variables_map.hpp
include/boost/program_options/version.hpp
include/boost/progress.hpp
include/boost/property_map/dynamic_property_map.hpp
include/boost/property_map/function_property_map.hpp
include/boost/property_map/parallel/caching_property_map.hpp
include/boost/property_map/parallel/distributed_property_map.hpp
include/boost/property_map/parallel/global_index_map.hpp
@ -5855,6 +5876,7 @@ include/boost/property_map/parallel/local_property_map.hpp
include/boost/property_map/property_map.hpp
include/boost/property_map/property_map_iterator.hpp
include/boost/property_map/shared_array_property_map.hpp
include/boost/property_map/transform_value_property_map.hpp
include/boost/property_map/vector_property_map.hpp
include/boost/property_tree/detail/exception_implementation.hpp
include/boost/property_tree/detail/file_parser_error.hpp
@ -5997,19 +6019,24 @@ include/boost/proto/transform/detail/call.hpp
include/boost/proto/transform/detail/construct_funop.hpp
include/boost/proto/transform/detail/construct_pod_funop.hpp
include/boost/proto/transform/detail/default_function_impl.hpp
include/boost/proto/transform/detail/expand_pack.hpp
include/boost/proto/transform/detail/fold_impl.hpp
include/boost/proto/transform/detail/lazy.hpp
include/boost/proto/transform/detail/make.hpp
include/boost/proto/transform/detail/make_gcc_workaround.hpp
include/boost/proto/transform/detail/pack.hpp
include/boost/proto/transform/detail/pack_impl.hpp
include/boost/proto/transform/detail/pass_through_impl.hpp
include/boost/proto/transform/detail/preprocessed/call.hpp
include/boost/proto/transform/detail/preprocessed/construct_funop.hpp
include/boost/proto/transform/detail/preprocessed/construct_pod_funop.hpp
include/boost/proto/transform/detail/preprocessed/default_function_impl.hpp
include/boost/proto/transform/detail/preprocessed/expand_pack.hpp
include/boost/proto/transform/detail/preprocessed/fold_impl.hpp
include/boost/proto/transform/detail/preprocessed/lazy.hpp
include/boost/proto/transform/detail/preprocessed/make.hpp
include/boost/proto/transform/detail/preprocessed/make_gcc_workaround.hpp
include/boost/proto/transform/detail/preprocessed/pack_impl.hpp
include/boost/proto/transform/detail/preprocessed/pass_through_impl.hpp
include/boost/proto/transform/detail/preprocessed/when.hpp
include/boost/proto/transform/detail/when.hpp
@ -8696,9 +8723,8 @@ include/boost/units/systems/temperature/celsius.hpp
include/boost/units/systems/temperature/fahrenheit.hpp
include/boost/units/unit.hpp
include/boost/units/units_fwd.hpp
include/boost/unordered/detail/allocator_helpers.hpp
include/boost/unordered/detail/allocate.hpp
include/boost/unordered/detail/buckets.hpp
include/boost/unordered/detail/emplace_args.hpp
include/boost/unordered/detail/equivalent.hpp
include/boost/unordered/detail/extract_key.hpp
include/boost/unordered/detail/fwd.hpp

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.23 2012/07/02 07:02:25 adam Exp $
# $NetBSD: buildlink3.mk,v 1.24 2012/08/27 08:49:09 adam Exp $
BUILDLINK_TREE+= boost-headers
@ -6,7 +6,7 @@ BUILDLINK_TREE+= boost-headers
BOOST_HEADERS_BUILDLINK3_MK:=
# Use a dependency pattern that guarantees the proper ABI.
BUILDLINK_API_DEPENDS.boost-headers+= boost-headers-1.50.*
BUILDLINK_API_DEPENDS.boost-headers+= boost-headers-1.51.*
BUILDLINK_DEPMETHOD.boost-headers?= build
BUILDLINK_PKGSRCDIR.boost-headers?= ../../devel/boost-headers

View file

@ -1,11 +1,11 @@
# $NetBSD: buildlink3.mk,v 1.18 2012/07/02 07:02:25 adam Exp $
# $NetBSD: buildlink3.mk,v 1.19 2012/08/27 08:49:09 adam Exp $
BUILDLINK_TREE+= boost-jam
.if !defined(BOOST_JAM_BUILDLINK3_MK)
BOOST_JAM_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.boost-jam+= boost-jam-1.50.*
BUILDLINK_API_DEPENDS.boost-jam+= boost-jam-1.51.*
BUILDLINK_DEPMETHOD.boost-jam?= build
BUILDLINK_PKGSRCDIR.boost-jam?= ../../devel/boost-jam
.endif # BOOST_JAM_BUILDLINK3_MK

View file

@ -1,7 +1,10 @@
@comment $NetBSD: PLIST,v 1.14 2012/01/08 11:35:07 adam Exp $
@comment $NetBSD: PLIST,v 1.15 2012/08/27 08:49:09 adam Exp $
lib/libboost_chrono.a
lib/libboost_chrono.so
lib/libboost_chrono.so.${BOOST_VERSION}
lib/libboost_context.a
lib/libboost_context.so
lib/libboost_context.so.${BOOST_VERSION}
lib/libboost_date_time.a
lib/libboost_date_time.so
lib/libboost_date_time.so.${BOOST_VERSION}
@ -15,6 +18,9 @@ lib/libboost_graph.so.${BOOST_VERSION}
lib/libboost_iostreams.a
lib/libboost_iostreams.so
lib/libboost_iostreams.so.${BOOST_VERSION}
lib/libboost_locale.a
lib/libboost_locale.so
lib/libboost_locale.so.${BOOST_VERSION}
lib/libboost_math_c99.a
lib/libboost_math_c99.so
lib/libboost_math_c99.so.${BOOST_VERSION}

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.24 2012/07/02 13:37:36 adam Exp $
# $NetBSD: buildlink3.mk,v 1.25 2012/08/27 08:49:09 adam Exp $
BUILDLINK_TREE+= boost-libs
@ -6,8 +6,8 @@ BUILDLINK_TREE+= boost-libs
BOOST_LIBS_BUILDLINK3_MK:=
# Use a dependency pattern that guarantees the proper ABI.
BUILDLINK_API_DEPENDS.boost-libs+= boost-libs-1.50.*
BUILDLINK_ABI_DEPENDS.boost-libs?= boost-libs>=1.50.0
BUILDLINK_API_DEPENDS.boost-libs+= boost-libs-1.51.*
BUILDLINK_ABI_DEPENDS.boost-libs?= boost-libs>=1.51.0
BUILDLINK_PKGSRCDIR.boost-libs?= ../../devel/boost-libs
.include "../../devel/boost-headers/buildlink3.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.27 2012/07/02 07:02:25 adam Exp $
# $NetBSD: buildlink3.mk,v 1.28 2012/08/27 08:49:09 adam Exp $
BUILDLINK_TREE+= boost-python
@ -6,8 +6,8 @@ BUILDLINK_TREE+= boost-python
BOOST_PYTHON_BUILDLINK3_MK:=
# Use a dependency pattern that guarantees the proper ABI.
BUILDLINK_API_DEPENDS.boost-python+= boost-python-1.50.*
BUILDLINK_ABI_DEPENDS.boost-python+= boost-python-1.50.*
BUILDLINK_API_DEPENDS.boost-python+= boost-python-1.51.*
BUILDLINK_ABI_DEPENDS.boost-python+= boost-python-1.51.*
BUILDLINK_PKGSRCDIR.boost-python?= ../../devel/boost-python
.include "../../devel/boost-headers/buildlink3.mk"

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.35 2012/08/02 09:08:41 fhajny Exp $
# $NetBSD: Makefile.common,v 1.36 2012/08/27 08:49:08 adam Exp $
#
# used by devel/boost-build/Makefile
# used by devel/boost-docs/Makefile
@ -9,7 +9,7 @@
BOOST_PACKAGE?= undefined
BOOST_COMMENT?= undefined
BOOST_VERSION= 1.50.0
BOOST_VERSION= 1.51.0
BOOST_SHORT_VERSION= ${BOOST_VERSION:S/./_/:C/\..*$//}
DISTNAME= boost_${BOOST_VERSION:S/./_/g}

View file

@ -1,12 +1,12 @@
$NetBSD: distinfo,v 1.46 2012/08/02 12:08:41 jperkin Exp $
$NetBSD: distinfo,v 1.47 2012/08/27 08:49:08 adam Exp $
SHA1 (boost_1_50_0.tar.bz2) = ee06f89ed472cf369573f8acf9819fbc7173344e
RMD160 (boost_1_50_0.tar.bz2) = 72e33875d768def47acb5ba8222da4fa56780bab
Size (boost_1_50_0.tar.bz2) = 50786885 bytes
SHA1 (patch-aa) = 62bb260fce3bca6dd5f61dd9b179fd40593d31b4
SHA1 (boost_1_51_0.tar.bz2) = 52ef06895b97cc9981b8abf1997c375ca79f30c5
RMD160 (boost_1_51_0.tar.bz2) = e92733c82785a38049f2d6a8126eadd3f8ac0c40
Size (boost_1_51_0.tar.bz2) = 50811407 bytes
SHA1 (patch-aa) = 408a63a807aaa491130db018cd89bca6a427090d
SHA1 (patch-ab) = f1c95ae229465a4d2da76ce6ff88d76ace52fdd8
SHA1 (patch-ac) = 54d40e6a62cdf40c4155c64d9f02df475fbe111d
SHA1 (patch-ad) = d36799e40e1f7e6f62768e1144859f22ce76a265
SHA1 (patch-ac) = 5ecd12564259e4ad9d439990e198b889762ec733
SHA1 (patch-ad) = 0e5dc31c3425de94444f97a9b7dec97ed5967733
SHA1 (patch-ae) = 2fb49c90bbb3fd797ccdfaaf44c93494a5988f52
SHA1 (patch-ag) = c406e9beb9260db7861b13a6eb4c386f23346eb1
SHA1 (patch-ai) = 231db48819aa563b2082d95bb91d662b5d6cf779
@ -15,4 +15,3 @@ SHA1 (patch-ar) = 2fec2c51272cc4ee376e6538d8f1fd8561a7f0a3
SHA1 (patch-boost_foreach.hpp) = 7cd26c4983873bcac284ad400950e341c559f9a8
SHA1 (patch-boost_foreach_fwd.hpp) = 5accd68d559213a9677f7d1204e72dd082a42a41
SHA1 (patch-libs_filesystem_src_unique_path.cpp) = 3666663305bba85871f2ef291dc117158c678643
SHA1 (patch-libs_signals_src_named_slot_map.cpp) = 42119b98857eb7e96ea29ac85c184eed46965295

View file

@ -1,23 +1,23 @@
$NetBSD: patch-aa,v 1.9 2011/10/11 10:02:08 adam Exp $
$NetBSD: patch-aa,v 1.10 2012/08/27 08:49:09 adam Exp $
--- boostcpp.jam.orig 2011-06-06 20:39:27.000000000 +0000
--- boostcpp.jam.orig 2012-07-27 18:15:55.000000000 +0000
+++ boostcpp.jam
@@ -276,6 +276,7 @@ rule declare_install_and_stage_proper_ta
: <location>$(stage-locate)/lib
<install-dependencies>on <install-type>LIB
<install-no-version-symlinks>on
+ <dll-path>@PREFIX@/lib
;
@@ -249,6 +249,7 @@ rule declare_install_and_stage_proper_ta
: <location>$(stage-locate)/lib
<install-dependencies>on <install-type>LIB
<install-no-version-symlinks>on
+ <dll-path>@PREFIX@/lib
;
$(p).mark-target-as-explicit stage-proper ;
@@ -529,6 +530,10 @@ rule libraries-to-install ( existing-lib
ECHO "error: both --with-<library> and --without-<library> specified" ;
EXIT ;
}
@@ -509,6 +510,10 @@ rule libraries-to-install ( existing-lib
{
EXIT error: both --with-<library> and --without-<library> specified ;
}
+ if $(without-parameter) && $(without-parameter) = "*"
+ {
+ without-parameter = $(existing-libraries) ;
+ without-parameter = $(existing-libs) ;
+ }
local wrong = [ set.difference $(with-parameter) : $(existing-libraries) ] ;
if $(wrong)
local wrong = [ set.difference $(with-parameter) : $(existing-libs) ] ;
if $(wrong)

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ac,v 1.6 2010/11/26 20:47:01 adam Exp $
$NetBSD: patch-ac,v 1.7 2012/08/27 08:49:09 adam Exp $
--- boost/config/suffix.hpp.orig 2010-10-01 09:19:44.000000000 +0000
+++ boost/config/suffix.hpp
@@ -254,7 +254,7 @@
@@ -247,7 +247,7 @@
//
#if (defined(__MT__) || defined(_MT) || defined(_REENTRANT) \
|| defined(_PTHREADS) || defined(__APPLE__) || defined(__DragonFly__)) \

View file

@ -1,6 +1,6 @@
$NetBSD: patch-ad,v 1.11 2011/02/24 11:05:36 adam Exp $
$NetBSD: patch-ad,v 1.12 2012/08/27 08:49:09 adam Exp $
--- boost/archive/basic_archive.hpp.orig 2011-01-19 17:33:55.000000000 +0000
--- boost/archive/basic_archive.hpp.orig 2012-08-27 07:38:03.000000000 +0000
+++ boost/archive/basic_archive.hpp
@@ -115,7 +115,7 @@ public:
explicit class_id_type(const int t_) : t(t_){
@ -11,3 +11,12 @@ $NetBSD: patch-ad,v 1.11 2011/02/24 11:05:36 adam Exp $
// BOOST_ASSERT(t_ <= boost::integer_traits<base_type>::const_max);
}
class_id_type(const class_id_type & t_) :
@@ -151,7 +151,7 @@ private:
public:
object_id_type(): t(0) {};
// note: presumes that size_t >= unsigned int.
- explicit object_id_type(const std::size_t & t_) : t(t_){
+ explicit object_id_type(const size_t & t_) : t(t_){
BOOST_ASSERT(t_ <= boost::integer_traits<base_type>::const_max);
}
object_id_type(const object_id_type & t_) :

View file

@ -1,22 +0,0 @@
$NetBSD: patch-libs_signals_src_named_slot_map.cpp,v 1.2 2012/07/02 07:02:26 adam Exp $
--- libs/signals/src/named_slot_map.cpp.orig 2009-11-08 02:48:37.000000000 +0100
+++ libs/signals/src/named_slot_map.cpp 2011-10-24 16:04:24.749105300 +0200
@@ -102,7 +102,7 @@ void named_slot_map::disconnect(const st
i->first.disconnect();
i = next;
}
- groups.erase(group);
+ groups.erase((const_group_iterator) group);
}
}
@@ -125,7 +125,7 @@ void named_slot_map::remove_disconnected
}
// Clear out empty groups
- if (empty(g)) groups.erase(g++);
+ if (empty(g)) groups.erase((const_group_iterator) g++);
else ++g;
}
}