Update p0f to 1.8.2. Changes:

1. Developer changed s/Micha³ Zalewski/William Stearns/
        2. A lot of new finger prints.
        3. GPL -> LGPL license change
        Full list (not so big) in ChangeLog

Patch contributed by Dawid Szymañski in PR 19896.
This commit is contained in:
hubertf 2003-01-17 23:15:23 +00:00
parent b658f2b53c
commit 6ac99e5ad9
5 changed files with 28 additions and 15 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: CHANGES,v 1.1150 2003/01/17 19:46:48 gson Exp $
$NetBSD: CHANGES,v 1.1151 2003/01/17 23:15:23 hubertf Exp $
Changes to the packages collection and infrastructure in 2003:
@ -315,3 +315,4 @@ Changes to the packages collection and infrastructure in 2003:
Added dvdrecord-0.1.3 [toshii 2003-01-17]
Updated p5-DBD-postgresql to 1.21 [mjl 2003-01-17]
Added py-bsddb3-4.1.1nb1 [gson 2003-01-17]
Updated p0f to 1.8.2 [hubertf 2002-01-18]

View file

@ -1,17 +1,24 @@
# $NetBSD: Makefile,v 1.1.1.2 2001/03/26 11:59:15 hubertf Exp $
# $NetBSD: Makefile,v 1.2 2003/01/17 23:15:24 hubertf Exp $
#
DISTNAME= p0f-1.7
DISTNAME= p0f-1.8.2
CATEGORIES= security net
MASTER_SITES= http://lcamtuf.hack.pl/
MASTER_SITES= http://www.stearns.org/p0f/
EXTRACT_SUFX= .tgz
MAINTAINER= DawS@irc.pl
MAINTAINER= dawszy@arhea.net
COMMENT= passive OS fingerprinting tool
pre-build:
${SED} \
-e 's,@PREFIX@,${LOCALBASE},'\
<${WRKSRC}/p0f.c > ${WRKSRC}/p0f.c.tmp
${MV} ${WRKSRC}/p0f.c.tmp ${WRKSRC}/p0f.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/p0f ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/p0f.fp ${PREFIX}/etc
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/p0f.README
${INSTALL_DATA} ${WRKSRC}/p0frep ${PREFIX}/share/doc/p0frep
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,5 @@
@comment $NetBSD: PLIST,v 1.1 2001/11/01 01:17:07 zuntum Exp $
@comment $NetBSD: PLIST,v 1.2 2003/01/17 23:15:24 hubertf Exp $
bin/p0f
etc/p0f.fp
share/doc/p0f.README
share/doc/p0frep

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.2 2001/04/19 15:40:35 agc Exp $
$NetBSD: distinfo,v 1.3 2003/01/17 23:15:24 hubertf Exp $
SHA1 (p0f-1.7.tgz) = ac2ff4b2fc78c023ffe6a4d135385a0cef4a10c6
Size (p0f-1.7.tgz) = 14694 bytes
SHA1 (patch-aa) = 067e95fa6074248712fd05047d540708d80b86ac
SHA1 (patch-ab) = 8be455cbaeddf152604c97c5e136de487838f298
SHA1 (p0f-1.8.2.tgz) = e0c6cb93f9251a3c9e588290a5426c26c9a9af07
Size (p0f-1.8.2.tgz) = 23969 bytes
SHA1 (patch-aa) = 21d484a2fa8de86fcd33727b4056787bdc6099d5

View file

@ -1,13 +1,18 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/03/26 05:12:56 zuntum Exp $
$NetBSD: patch-aa,v 1.2 2003/01/17 23:15:25 hubertf Exp $
--- p0f.c.orig Tue Jun 13 20:45:06 2000
--- p0f.c.orig Sat Feb 2 08:00:40 2002
+++ p0f.c
@@ -260,7 +260,7 @@
@@ -369,11 +369,8 @@ int main(int argc, char *argv[]) {
/* set a reasonable default fingerprint file */
if (!filename || !*filename)
-#ifdef SYSCONFDIR
- filename = SYSCONFDIR "/p0f.fp";
-#else
- filename = "/etc/p0f.fp";
+ filename = PREFIX "/etc/p0f.fp";
-#endif
+
+ filename = "@PREFIX@/etc/p0f.fp";
/* anything left after getopt'ing is a rule */
if (argv[optind] && *(argv[optind]))