Make modules use automake.mk. Bump PKGREVISION for phpize change.
This commit is contained in:
parent
7fdecd5a35
commit
6aedfe3b0f
4 changed files with 28 additions and 6 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.26 2002/09/04 14:47:39 agc Exp $
|
||||
# $NetBSD: Makefile,v 1.27 2002/10/02 23:48:07 wiz Exp $
|
||||
|
||||
PKGNAME= php-${PHP_BASE_VERS}
|
||||
PKGREVISION= # empty
|
||||
PKGREVISION= 1
|
||||
CATEGORIES+= lang
|
||||
COMMENT= HTML-embedded scripting language
|
||||
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.module,v 1.18 2002/09/04 14:47:40 agc Exp $
|
||||
# $NetBSD: Makefile.module,v 1.19 2002/10/02 23:48:07 wiz Exp $
|
||||
#
|
||||
# This Makefile is provided to ease creating PHP4 packages for the extension
|
||||
# modules distributed in the PHP4 sources.
|
||||
|
@ -12,8 +12,10 @@
|
|||
PKGNAME?= php-${MODNAME}-${PHP_BASE_VERS}
|
||||
PKGREVISION?= # empty
|
||||
|
||||
BUILD_DEPENDS+= automake>=1.4:../../devel/automake
|
||||
DEPENDS+= php>=${PHP_BASE_VERS}:../../www/php4
|
||||
DEPENDS+= php>=${PHP_BASE_VERS}nb1:../../www/php4
|
||||
|
||||
AUTOMAKE_REQD?= 1.4
|
||||
.include "../../mk/automake.mk"
|
||||
|
||||
PKGMODNAME?= ${MODNAME:S/-/_/}
|
||||
MODULESDIR?= ${WRKSRC}/modules
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.12 2002/09/04 14:47:40 agc Exp $
|
||||
$NetBSD: distinfo,v 1.13 2002/10/02 23:48:07 wiz Exp $
|
||||
|
||||
SHA1 (php-4.1.2.tar.gz) = fc4f9685b2b26d6e12af2e746a34fadfe57f0466
|
||||
Size (php-4.1.2.tar.gz) = 3359964 bytes
|
||||
SHA1 (patch-aa) = 09fb15fde09bf866d9be016839f33c889d9cefb9
|
||||
SHA1 (patch-ab) = f385cce407fed6fc1ed705a4507015684bebb1b5
|
||||
SHA1 (patch-ac) = 9478c18dbe18e8c4c05dffce31fa3f923562c832
|
||||
SHA1 (patch-ad) = 4ac02d0e0e5bd612254020d46292534a0e9445b0
|
||||
SHA1 (patch-ae) = e7acc06a63f47053c81ab442b53c68d89d122f78
|
||||
|
|
19
www/php4/patches/patch-ab
Normal file
19
www/php4/patches/patch-ab
Normal file
|
@ -0,0 +1,19 @@
|
|||
$NetBSD: patch-ab,v 1.10 2002/10/02 23:48:07 wiz Exp $
|
||||
|
||||
--- pear/scripts/phpize.in.orig Wed Jan 10 02:01:59 2001
|
||||
+++ pear/scripts/phpize.in
|
||||
@@ -25,7 +25,11 @@ sed \
|
||||
|
||||
touch install-sh mkinstalldirs missing
|
||||
|
||||
-aclocal
|
||||
-autoconf
|
||||
-autoheader
|
||||
+if [ -z "$ACLOCAL" ]; then ACLOCAL=aclocal; fi
|
||||
+if [ -z "$AUTOCONF" ]; then AUTOCONF=autoconf; fi
|
||||
+if [ -z "$AUTOHEADER" ]; then AUTOHEADER=autoheader; fi
|
||||
+
|
||||
+$ACLOCAL
|
||||
+$AUTOCONF
|
||||
+$AUTOHEADER
|
||||
libtoolize -f -c
|
Loading…
Reference in a new issue